Оглавление

Начало работы

Назначение системы IndorInfo/Power
Системные требования
Структура установки системы
Установка системы на клиентских местах
Установка серверной части
Выборочная установка
Полная установка
Использование демонстрационного проекта
Содержимое установочного диска
Обновление версии системы
Защита от несанкционированного копирования
Запуск системы
Демонстрационный режим
Служба технической поддержки
Обзор других решений компании "ИндорСофт"

Руководство пользователя

Основы работы в системе
Работа со слоями
Технология рисования в системе IndorGIS
Рисование электрических схем
Ввод атрибутивных данных
Ввод данных по устройствам релейной защиты и автоматики (УРЗА)
Ввод данных по потребителям
Ввод эксплуатационных данных
Работа с готовым проектом

Справочное руководство

Технические паспорта объектов
Перечень кнопок панелей инструментов
Список "горячих" клавиш

Вперёд Авторское право © 2009 ООО "ИндорСофт"


Начало работы. Назначение системы IndorInfo/Power

Информационная система электрических сетей

Начало работы

Назначение системы IndorInfo/Power

Под термином Информационная система будем понимать специализированную программу, охватывающую основные аспекты деятельности организаций, эксплуатирующих электрические сети. Информационная система предназначена для хранения, обработки и оперативного обмена всеми видами информации по сетям. Основной целью внедрения информационной системы является повышение организованности и управляемости инженерной инфраструктуры электрических сетей. Это достигается путём перехода на единое информационное описание (модель) электрических сетей и электронную технологию документооборота.

Рассмотрим назначение информационной системы и основные функции, которые она выполняет.

  • Ведение всей технической и технологической информации по объектам электрических сетей. Это включает в себя представление объектов и оборудования на схемах, планах сооружений и картах местности; представление технических паспортов объектов и оборудования, а также их составных частей, представление эксплуатационной информации (описаний ремонтов, осмотров, испытаний, работ, неисправностей и т.п.), представление документации по объектам и текущей документации, формируемой в процессе эксплуатации.
  • Решение задач, связанных с точным расположением трасс линий электропередачи и планов подстанций на карте местности. На базе такого представления решаются следующие задачи: совместное представление трасс ЛЭП и прочих инженерных сетей для целей согласования работ, формирования зон отчуждения, обременения и взаимного влияния, точное представление трасс линий в требуемых системах координат для решения задач согласования землепользования и межевого дела.
  • Задачи оперативного получения информации об объектах, а именно: поиск по наименованию, по расположению, по адресу (на карте), получение информации по объекту, указанному на схеме, карте, плане.
  • Планирование текущих и капитальных ремонтов, осмотров и испытаний на основе нормативных периодов, анализ неисправностей оборудования и динамики изменения значений измерений, контроль исполнения графиков работ, предупреждение о просроченных работах.
  • Автоматизация работ с оперативными диспетчерскими схемами: отображение состояний коммутаторов, выделение цветом подключенных объектов, выделение цветом фидеров, ведение журналов дат и причин переключений.
  • Выполнение инженерных расчётов с помощью интегрированной системы электрических расчётов IndorElectra. Эта возможность позволяет автоматизировать процесс расчёта текущего режима сети на основе актуальных данных, получаемых из информационной системы.

Также в этом разделе:

Системные требования

Структура установки системы

Установка системы на клиентских местах

Установка серверной части

Выборочная установка

Полная установка

Использование демонстрационного проекта

Содержимое установочного диска

Обновление версии системы

Защита от несанкционированного копирования

Запуск системы

Демонстрационный режим

Служба технической поддержки

Обзор других решений компании "ИндорСофт"

Наверх [image] Назад [image] Вперёд Авторское право © 2009 ООО "ИндорСофт"


Начало работы. Системные требования

Начало работы

Системные требования

Информационная система электрических сетей IndorInfo/Power предназначена для использования на IBM/PC-совместимых персональных компьютерах, работающих под управлением операционной системы Windows 2000/XP/Vista. Для работы серверной части системы необходима СУБД Microsoft SQL Server 2000/2005/2009, Oracle Database 9/10 или PostgreSQL 8.

Минимальная конфигурация компьютера для установки и работы клиентской части IndorInfo/Power:

  • процессор Pentium III;
  • оперативная память 128 Мб;
  • видеокарта с поддержкой разрешения 1024х768 пикселей и 16-битовым цветом;
  • 40 Мб на жестком диске;
  • привод CD-ROM;
  • монитор 15 дюймов (1024х768).

При работе с большими объёмами графической информации (сети с количеством подстанций более 100) рекомендуемой конфигурацией будет:

  • процессор Pentium IV;
  • оперативная память 256 Мб (и более);
  • AGP-видеокарта с поддержкой разрешения более 1024х768;
  • 100-200 Мб на жестком диске (для больших временных файлов);
  • привод CD-ROM;
  • монитор 17 дюймов (и более) с поддержкой разрешения более 1024х768.

Минимальная конфигурация компьютера для установки и работы серверной части IndorInfo/Power:

  • процессор Pentium III;
  • оперативная память 256 Мб;
  • около 50 Мб на жёстком диске для базы данных средней величины;
  • привод CD-ROM.

При работе с большими объёмами графической и атрибутивной информации (сети с количеством подстанций более 100, большим числом абонентов и интенсивной эксплуатационной деятельностью) рекомендуемой конфигурацией будет:

  • процессор Pentium IV Xeon (для атрибутивного сервера можно рекомендовать многопроцессорную систему);
  • оперативная память 512 Мб (и более);
  • 200-500 Мб на жёстком диске (для больших баз данных рекомендуется применение RAID-массивов и дисков SCSI).

Для повышения производительности можно размещать графическую и атрибутивную базы данных на разных серверах.

При работе в режиме клиент-сервер желательно иметь локальную сеть со скоростью 100 Мбит/с. При интенсивной работе и большом количестве клиентов может потребоваться высокопроизводительный маршрутизатор и сеть 1 Гбит/с в сегменте серверов.

Также в этом разделе:

Назначение системы IndorInfo/Power

Структура установки системы

Установка системы на клиентских местах

Установка серверной части

Выборочная установка

Полная установка

Использование демонстрационного проекта

Содержимое установочного диска

Обновление версии системы

Защита от несанкционированного копирования

Запуск системы

Демонстрационный режим

Служба технической поддержки

Обзор других решений компании "ИндорСофт"


Начало работы. Структура установки системы

Начало работы

Структура установки системы

Информационная система IndorInfo/Power предназначена как для работы многих пользователей в режиме клиент-сервер, так и для работы на отдельном компьютере. Некоторые варианты установки приведены на ниже рисунках.

На одном компьютере устанавливается АБД - атрибутивная БД и ГРБД - графическая БД | На клиентских местах устанавливаются клиентские программы, на одном сервере - АБД и ГРБД
БД и ГРБД устанавливаются на разных серверах (для повышения производительности) | Основные базы данных располагаются на серверах, у клиентов могут устанавливаться собственные варианты ГРБД или АБД

Информационная система разворачивается на нескольких взаимно удалённых серверах, актуальность поддерживается путём репликации

Также в этом разделе:

Назначение системы IndorInfo/Power

Системные требования

Установка системы на клиентских местах

Установка серверной части

Выборочная установка

Полная установка

Использование демонстрационного проекта

Содержимое установочного диска

Обновление версии системы

Защита от несанкционированного копирования

Запуск системы

Демонстрационный режим

Служба технической поддержки

Обзор других решений компании "ИндорСофт"


Начало работы. Установка системы на клиентских местах

Начало работы

Установка системы на клиентских местах

Комплект поставки системы IndorPower содержит компакт-диск с дистрибутивом, документацией, обучающими роликами, демонстрационными проектами и другой полезной информацией.

Также в этом разделе:

Процедура установки

Создаваемая структура папок


Установка системы на клиентских местах. Процедура установки

Установка системы на клиентских местах

Процедура установки

При запуске установочного диска появляется список, в котором можно выбрать выполняемое действие:

  • IndorPower 3.3 - при выборе этого пункта начинается установка информационного комплекса электрических сетей IndorPower 3.3; в состав комплекса включено геоинформационное ядро IndorGIS 5.1, информационная подсистема электрических сетей IndorInfo/Power 3.3 и система электрических расчётов IndorElectra 2.3.
  • Документация - при выборе этого пункта в проводнике Windows открывается папка с документацией по системам IndorGIS, IndorInfo/Power и IndorElectra в форматах pdf и chm.
  • Обучающие ролики - при выборе этого пункта в проводнике Windows открывается папка с обучающими роликами по системам IndorInfo/Power и IndorElectra.
  • Дополнительные программы - при выборе этого пункта в проводнике Windows открывается папка с дистрибутивами драйвера ключа HASP и менеджера лицензий, а также дополнительных программ, необходимых для просмотра документации в формате pdf и обучающих flash-роликов.

Запуск установочного диска

При выборе на установочном диске пункта IndorPower запускается мастер установки системы IndorPower.

Начало установки

После начала установки и приветствия мастер предлагает ознакомиться с лицензионным соглашением. Для продолжения установки нужно принять условия соглашения, нажав кнопку Да. Это будет означать, что Вы ознакомились с условиями соглашения, обязуетесь выполнять их и извещены о последствиях нарушения данного соглашения.

Лицензионное соглашение

Далее укажите, в какую папку будут установлены компоненты системы. По умолчанию они устанавливаются на системный том, в стандартную папку для программ, в подпапку IndorSoft.

Выбор папки размещения файлов системы

В следующем окне предлагается выбрать один из четырёх вариантов установки системы. Для установки клиентской части системы выберите вариант Клиентская.

Выбор вида установки системы

В процессе установки появляется ещё одно окно, где предлагается установить две дополнительные программы Adobe Reader 8.12 и Adobe Flash Player для просмотра документации и обучающих flash-роликов. Поставьте галочки рядом с теми программами, которые следует установить на компьютер.

Установка дополнительных программ

После успешного завершения установки выдаётся сообщение о готовности системы к использованию.

Сообщение об успешной установке

Также в этом разделе:

Создаваемая структура папок


Установка системы на клиентских местах. Создаваемая структура папок

Установка системы на клиентских местах

Создаваемая структура папок

После установки системы на клиентском месте в выбранном каталоге создаётся следующая структура папок:

  • ExFonts. В данной папке размещаются EX-шрифты, используемые системой, в том числе шрифты для рисования электрических схем.
  • Hasp. В данной папке размещается драйвер электронного ключа HASP.
  • IndorElectra. Эта папка содержит исполняемые файлы системы электрических расчётов IndorElectra, а также документацию по системе, обучающие видеоролики и демонстрационные проекты.
  • IndorGIS. Эта папка содержит исполняемые файлы геоинформационной системы IndorGIS, а также документацию по системе.
  • IndorPower.
    • Bin. В данной папке размещаются исполняемые файлы системы IndorInfo/Power.
    • Demo. В этой папке хранится демонстрационный проект, который можно использовать для первоначального ознакомления с системой.
    • Help. Папка с документацией по системе IndorInfo/Power в форматах pdf и chm.
    • Movies. Папка с обучающими видеороликами по системе IndorInfo/Power.
    • Templates. В данной папке размещаются шаблоны, используемые системой при формировании отчётов.
  • Shared. Эта папка содержит общие файлы, используемые системами IndorGIS, IndorInfo/Power и IndorElectra.
  • Themes. В данной папке размещаются темы для создания чертёжных слоёв (схем, разметок).

Также в этом разделе:

Процедура установки


Начало работы. Установка серверной части

Начало работы

Установка серверной части

Серверная установка предназначена для развёртывания средств создания и обновления баз данных системы IndorInfo/Power. Кроме того, она включает установку демонстрационной базы данных, а также драйвера ключа HASP и менеджера лицензий. Последние должны быть установлены на компьютер, который будет использоваться для размещения сетевого ключа HASP.

Также в этом разделе:

Процедура установки

Создаваемая структура папок

Создание новой (или обновление существующей) базы данных системы IndorInfo/Power


Установка серверной части. Процедура установки

Установка серверной части

Процедура установки

Выполните все описанные выше действия по установке системы до шага выбора вида установки. Далее выберите вид установки Серверная.

Выбор серверной установки

В ходе инсталляции будет запущена установка программы Менеджер лицензий. Выполните эту установку, если Ваша организация приобрела сетевой ключ HASP и предполагается использовать данный компьютер для размещения ключа (см. подробнее).

Далее появится вопрос, нужно ли развернуть на сервере базу данных, которую использует демонстрационный проект. Если ознакомление с этим проектом предполагается, укажите опцию Установить базу данных демонстрационного проекта.

Выбор установки базы данных демонстрационного проекта

Если опция установки базы данных демонстрационного проекта выбрана, то после нажатия кнопки Далее появляется окно, где нужно указать параметры установки базы данных (см. подробнее). В поле Имя базы введите название, которое будет иметь демонстрационная база данных. При нажатии кнопки Установить на выбранном сервере создаётся новая база и наполняется данными.

Параметры установки базы данных демонстрационного проекта

Замечание
При работе с демонстрационным проектом на рабочих местах необходимо настроить соединение с демонстрационной базой данных (см. подробнее).

Также в этом разделе:

Создаваемая структура папок

Создание новой (или обновление существующей) базы данных системы IndorInfo/Power


Установка серверной части. Создаваемая структура папок

Установка серверной части

Создаваемая структура папок

После установки серверной части в выбранном каталоге создаётся следующая структура папок:

  • IndorPower.
    • Bin. В данной папке размещаются исполняемые файлы системы IndorInfo/Power.
    • DBSetup. Папка содержит установщик баз данных системы IndorInfo/Power и скрипты для создания и обновления баз данных.
    • Demo. В этой папке хранится база данных демонстрационного проекта.

Также в этом разделе:

Процедура установки

Создание новой (или обновление существующей) базы данных системы IndorInfo/Power


Установка серверной части. Создание новой (или обновление существующей) базы данных системы IndorInfo/Power

Установка серверной части

Создание новой (или обновление существующей) базы данных системы IndorInfo/Power

Замечание
Перед обновлением существующей базы данных обязательно создайте её резервную копию!

В папке DBSetup расположен установщик баз данных RunDBSetup.exe. Кроме того, запустить установщик можно через меню Пуск панели задач Windows, выбрав пункт Программы|IndorSoft|IndorPower| [image] Установка баз данных.

  • Выберите тип используемого сервера баз данных.
  • Введите имя сервера, на котором следует создать новую (или обновить существующую) базу данных.
  • Введите имя новой (или обновляемой) базы данных.

При использовании СУБД Oracle необходимо предварительно её средствами создать пустую базу и настроить права доступа, а затем в этом окне указать имя новой базы данных.

  • Укажите способ проверки аутентификации пользователя, выполняющего установку:
    • Если выбран вариант Авторизация Windows NT, то подключение к серверу БД происходит от имени пользователя, под которым Вы вошли в операционную систему, а проверка пользователя осуществляется средствами Windows.
    • Если выбран вариант Авторизация SQL-сервера, то пользователь подключается к серверу БД под своим уникальным именем, которое было создано для него администратором сервера БД. При подключении пользователя сервер БД проверяет, существует ли пользователь с таким именем, и проверяет его пароль.

Установка новой базы данных

  • Таймаут выполнения команд - это максимальное время, в течение которого сервер БД может выполнять одну команду. При отсутствии ответа сервера о выполнении команды в течение этого времени установка прекращается. В таком случае необходимо удалить только что созданную базу данных/восстановить базу из резервной копии, увеличить таймаут и повторно выполнить установку/обновление.

Значение таймаута, устанавливаемое по умолчанию, считается оптимальным, и менять его не рекомендуется.

  • Если Вы не знаете точно имён сервера и базы данных на сервере, можно воспользоваться Мастером подключения, нажав на соответствующую кнопку.
  • Мастер подключения предложит выбрать тип сервера (провайдера), имя сервера, указать параметры пользователя для входа на сервер. Если эти параметры указаны верно, станет доступен выпадающий список баз данных, имеющихся на сервере.

Для обновления базы данных выберите её название в выпадающем списке.

Для установки новой базы данных введите такое название, которое отсутствует в списке.

Замечание
Если выполняется обновление существующей базы данных, то при нажатии кнопки Проверить подключение (Test Connection) должно появиться сообщение об успешном подключении. А если создаётся новая база данных, то, наоборот, сообщение о том, что соединения с базой нет. Это будет говорить о том, что базы данных с указанным именем ещё нет на сервере.

Выбор провайдера данных

Параметры подключения к базе данных

После того как будут указаны все параметры, можно начать установку. Для этого в главном окне установки базы данных (Установка базы данных) нажмите кнопку Установить. В случае если указана уже существующая база данных, появится предупреждение о том, что данная база будет перезаписана новой.

Ход процесса установки отображается в окне установки. После успешного завершения установки выдаётся сообщение о готовности базы к использованию.

Отображение процесса установки и сообщение об успешной установке

В новой базе данных создаются таблицы информационной системы, наполняются справочники и создаётся единственный объект Сеть электроснабжения.

В случае возникновения ошибок в ходе установки сообщение о них будет выведено на экран.

Пример сообщения об ошибках в процессе установки

Также в этом разделе:

Процедура установки

Создаваемая структура папок


Начало работы. Выборочная установка

Начало работы

Выборочная установка

Чтобы выборочно установить только некоторые компоненты программного комплекса, например менеджер лицензий или демонстрационный проект, воспользуйтесь выборочной установкой. Для этого на шаге выбора вида установки укажите вариант Выборочная. Она позволяет установить любые из следующих компонентов:

Выбор компонентов для установки

  • IndorGIS. Геоинформационная система IndorGIS предназначена для работы с графической составляющей информационной системы (картами, схемами и пр.).
    • Программные модули.
    • Visual Basic For Applications. Средство для программирования внутри IndorGIS.
    • Файлы помощи. Документация и встроенная справка по системе IndorGIS.
    • Условные знаки и темы. EX-шрифты и темы для рисования карт, электрических схем и различных инженерных коммуникаций.
  • IndorInfo/Power. Информационная система электрических сетей IndorInfo/Power.
    • Программные модули.
    • Файлы помощи. Документация и встроенная справка по системе IndorInfo/Power.
    • Шаблоны отчётов. Шаблоны отчётов, формируемых системой построения отчётов IndorInfo/Power.
    • Демо-проект. Демонстрационный проект IndorInfo/Power предназначен для ознакомления с технологией работы в информационной системе. Для полноценной работы необходимо на клиентские места установить набор карт и схем, а на сервере развернуть базу данных демонстрационного проекта.
    • Демо-ролики. Обучающие видеоролики по системе IndorInfo/Power.
  • Установщик баз данных. Программа для установки и обновления баз данных информационного комплекса на сервере.
    • Программные модули.
    • Скрипты для MS SQL Server. Скрипты для установки и обновления баз данных на Microsoft SQL Server 2000/2005/2009.
    • Скрипты для Oracle. Скрипты для установки и обновления баз данных на Oracle Database 9/10.
    • Скрипты для PostgreSQL. Скрипты для установки и обновления баз данных на PostgreSQL 8.
  • IndorElectra. Система электрических расчётов IndorElectra.
    • Программные модули.
    • Справочники. Локальные справочники электрооборудования.
    • Файлы помощи. Документация и встроенная справка по системе IndorElectra.
    • Демо-проект. Демонстрационный проект IndorElectra, позволяющий ознакомиться со всеми возможностями системы.
    • Демо-ролики. Обучающие видеоролики по системе IndorElectra.
  • Лицензирование. Установка лицензий и средств доступа к электронному ключу HASP, необходимых для работы системы в полнофункциональном режиме.
    • Лицензии. Установка файлов лицензий с установочного диска.
    • Драйвер ключа HASP. Устанавливается на компьютер, к которому подключается локальный или сетевой ключ HASP.
    • Менеджер сетевого ключа HASP. Менеджер сетевого ключа HASP устанавливается на компьютер, к которому подключается сетевой ключ HASP.

Также в этом разделе:

Назначение системы IndorInfo/Power

Системные требования

Структура установки системы

Установка системы на клиентских местах

Установка серверной части

Полная установка

Использование демонстрационного проекта

Содержимое установочного диска

Обновление версии системы

Защита от несанкционированного копирования

Запуск системы

Демонстрационный режим

Служба технической поддержки

Обзор других решений компании "ИндорСофт"


Начало работы. Полная установка

Начало работы

Полная установка

Если на шаге выбора типа установки указать вариант Полная, то на одном рабочем месте будут установлены клиентская и серверная части системы IndorPower, вся сопутствующая документация, обучающие видеоролики и демонстрационные проекты. Этот вариант установки удобен в тех случаях, когда система используется на одном рабочем месте.

Также в этом разделе:

Назначение системы IndorInfo/Power

Системные требования

Структура установки системы

Установка системы на клиентских местах

Установка серверной части

Выборочная установка

Использование демонстрационного проекта

Содержимое установочного диска

Обновление версии системы

Защита от несанкционированного копирования

Запуск системы

Демонстрационный режим

Служба технической поддержки

Обзор других решений компании "ИндорСофт"


Начало работы. Использование демонстрационного проекта

Начало работы

Использование демонстрационного проекта

При установке системы на клиентских местах (Клиентская установка) в папке IndorPower создаётся папка с названием Demo, в которую копируется демонстрационный проект (его графическая часть).

Чтобы открыть этот проект на рабочем месте пользователя:

  • В меню Пуск панели задач Windows выберите пункт Программы|IndorSoft|IndorPower| [image] Демо-проект.
  • Запустите систему IndorGIS, выполните команду меню Файл| [image] Открыть проект… и выберите файл проекта Демо-проект.upr в папке IndorPower/Demo.

Для полноценной работы с проектом необходимо настроить подключение к демонстрационной базе данных. Она должна быть развёрнута на сервере (см. подробнее).

  • Откройте одну из карт проекта, дважды щёлкнув на ней мышью.
  • Выполните команду главного меню IndorInfo/Power| [image] Настройка IndorInfo/Power…
  • На закладке Подключение выберите тип используемого сервера, введите его имя и имя демонстрационной базы данных или воспользуйтесь мастером подключения для задания этих параметров.

Настройка подключения к базе данных

Также в этом разделе:

Назначение системы IndorInfo/Power

Системные требования

Структура установки системы

Установка системы на клиентских местах

Установка серверной части

Выборочная установка

Полная установка

Содержимое установочного диска

Обновление версии системы

Защита от несанкционированного копирования

Запуск системы

Демонстрационный режим

Служба технической поддержки

Обзор других решений компании "ИндорСофт"


Начало работы. Содержимое установочного диска

Начало работы

Содержимое установочного диска

Установочный компакт-диск содержит дистрибутивы информационной системы электрических сетей IndorInfo/Power, геоинформационной системы IndorGIS и системы электрических расчётов IndorElectra, документацию, обучающие видеоролики, примеры проектов, а также другую полезную информацию. Данные объединены в папки:

  • IndorPower. Дистрибутив программного комплекса IndorPower.
  • Setup. Программа установки содержимого диска.
  • Документация. В этой папке содержится документация в форматах pdf и chm по системам IndorInfo/Power, IndorElectra и IndorGIS.
  • Дополнительные программы. Папка содержит дистрибутивы программы Adobe Reader 7.0 для просмотра документации в формате PDF, программы Adobe Flash Player для просмотра обучающих flash-роликов, драйвера ключа HASP и менеджера лицензий, а также про-граммы для просмотра подключений к сетевому ключу HASP.
  • Лицензии. В этой папке хранится файл лицензий, сгенерированный для Вашей организации компанией "ИндорСофт".
  • Обучающие ролики. В этой папке расположены демонстрационные видеоролики, обучающие работе с системами IndorInfo/Power и IndorElectra.

Также в этом разделе:

Назначение системы IndorInfo/Power

Системные требования

Структура установки системы

Установка системы на клиентских местах

Установка серверной части

Выборочная установка

Полная установка

Использование демонстрационного проекта

Обновление версии системы

Защита от несанкционированного копирования

Запуск системы

Демонстрационный режим

Служба технической поддержки

Обзор других решений компании "ИндорСофт"


Начало работы. Обновление версии системы

Начало работы

Обновление версии системы

Срок бесплатной технической поддержки для системы IndorInfo/Power составляет 1 год. Бесплатная техническая поддержка означает, что в течение указанного периода с момента покупки программы Вы можете бесплатно обновлять версию системы с сайта компании "ИндорСофт", а также получать консультации в службе технической поддержки.

Дистрибутив последней версии системы всегда доступен на сайте компании.

Для корректной работы системы IndorInfo/Power необходимо, чтобы версия системы на клиентских местах соответствовала версии используемой базы данных. Внесение изменений в программу при переходе к новой версии, как правило, сопровождается изменением конфигурации базы данных. Поэтому при переходе на новую версию нужно, во-первых, обновить клиентскую часть системы на всех рабочих местах, а во-вторых, обновить версию базы данных на сервере.
Замечание
Если версии клиентской части и базы данных не совпадают, то при обращении в ходе работы с проектом к базе данных будет появляться сообщение примерно такого вида:

Несоответствие версии клиентской части и базы данных

Также в этом разделе:

Обновление клиентской части

Обновление базы данных


Обновление версии системы. Обновление клиентской части

Обновление версии системы

Обновление клиентской части

При установке системы на компьютер, на котором ранее уже была инсталлирована система, появляется диалоговое окно, где предлагается настроить параметры установки.

  • Изменить. При выборе этого пункта открывается мастер установки на шаге выбора устанавливаемых компонентов (см. подробнее). В нём галочками отмечены компоненты системы, установленные на компьютере во время предыдущей установки. Новые компоненты, напротив которых Вы поставите галочки, будут установлены, а установленные ранее компоненты, у которых Вы снимите галочки, будут удалены.
  • Исправить. При выборе этого пункта выполняется обновление всех компонентов системы, которые были инсталлированы во время предыдущей установки.
  • Удалить. При выборе этого пункта выполняется удаление всех установленных компонентов системы.

Изменение, исправление или удаление системы

Также в этом разделе:

Обновление базы данных


Обновление версии системы. Обновление базы данных

Обновление версии системы

Обновление базы данных

Обновите версию установщика баз данных. Для этого запустите новый дистрибутив и выберите в появившемся диалоговом окне вариант Исправить или вариант Изменить, если нужно изменить параметры предыдущей установки.

Теперь запустите установщик баз данных (пункт Программы| IndorSoft| IndorPower| [image] Установка баз данных). Укажите тип и имя сервера, параметры пользователя и имя базы данных, которую следует обновить, или воспользуйтесь мастером подключения для задания этих параметров (см. подробнее).

Также в этом разделе:

Обновление клиентской части


Начало работы. Защита от несанкционированного копирования

Начало работы

Защита от несанкционированного копирования

Для предотвращения несанкционированного копирования системы используется программно-аппаратная защита: аппаратный ключ HASP и файл лицензий. Система без аппаратного ключа HASP или файла лицензий будет работать в демонстрационном режиме, в котором недоступна часть функциональных возможностей.

Замечание
На компьютерах, где установлена программа HASP-эмулятор, система IndorInfo/Power работает нестабильно: возможно возникновение ошибок и самопроизвольное закрытие системы.

Также в этом разделе:

Два способа подключения к ключу HASP: локальное и сетевое

Файл лицензий

Настройка соединения с локальным ключом HASP

Установка сетевого ключа HASP. Настройка соединения с сетевым ключом на рабочих местах

Просмотр подключений к сетевому ключу HASP

Просмотр функций, прописанных в файле лицензий


Защита от несанкционированного копирования. Два способа подключения к ключу HASP: локальное и сетевое

Защита от несанкционированного копирования

Два способа подключения к ключу HASP: локальное и сетевое

  • Локальный ключ HASP

При использовании локальных ключей HASP необходимо на каждое рабочее место установить локальный ключ и указать в настройках подключения, что нужно использовать именно этот ключ.

  • Сетевой ключ HASP

Если Вы приобретаете большое количество рабочих мест и при этом не хотите на каждое рабочее место устанавливать локальный ключ HASP, то специально для таких ситуаций предусмотрена поставка программных продуктов с сетевыми ключами на приобретённое количество рабочих мест. В таком случае достаточно установить сетевой ключ на один из компьютеров локальной сети Вашей организации, который постоянно включен, к примеру на сервер. А также установить на этот компьютер программу Менеджер лицензий, реализующую взаимодействие с сетевым ключом HASP. На рабочих местах нужно указать в настройках сетевой адрес компьютера, на котором установлен ключ. При запуске программы на каждом рабочем месте будет происходить обращение с запросом к менеджеру лицензий о возможности запуска и режиме функционирования. Информация о максимально допустимом количестве запущенных копий системы на рабочих местах прописана в сетевом ключе HASP.

Также в этом разделе:

Файл лицензий

Настройка соединения с локальным ключом HASP

Установка сетевого ключа HASP. Настройка соединения с сетевым ключом на рабочих местах

Просмотр подключений к сетевому ключу HASP

Просмотр функций, прописанных в файле лицензий


Защита от несанкционированного копирования. Файл лицензий

Защита от несанкционированного копирования

Файл лицензий

Каждому ключу HASP соответствует свой набор лицензий. Эти лицензии хранятся в файле с расширением LIC, который называется файл лицензий. Он поставляется вместе с системой и записывается на Ваш установочный диск в папку Лицензии. Файл лицензий должен находиться в двух папках:

  • Program Files/IndorSoft/IndorGIS/Bin/Licenses - для доступа к различным функциям системы IndorGIS (выполнение операций с векторными объектами, просмотр и редактирование данных в инспекторе объектов и т.д.).
  • Program Files/IndorSoft/IndorPower/Bin/Licenses - для доступа к функ-циональности системы IndorInfo/Power (работа с эксплуатационными данными, возможность формирования отчётов и т.д.).

При установке системы с установочного диска файл лицензий автоматически копируется в эти папки.

Следует заметить, что система будет работать в полнофункциональном режиме только, если на рабочем месте используются соответствующие друг другу ключ HASP и файл лицензий.

Для примера рассмотрим некоторые варианты поставки ключей HASP:

  • Один локальный ключ HASP

Предположим, Вы приобретаете одно рабочее место системы и, соответственно, один локальный ключ HASP. В таком случае нужно под-ключить к компьютеру локальный ключ и скопировать Ваш файл лицензий в указанные выше папки (при установке с диска копирование выполняется автоматически).

  • Сетевой ключ HASP

Если Вы приобретаете несколько рабочих мест и сетевой ключ HASP, то сетевой ключ нужно установить на один из компьютеров в локальной сети, а файл лицензий (для сетевого ключа он один) скопировать в указанные выше папки на всех рабочих местах, где будет использоваться система.

  • Несколько локальных ключей HASP

В случае приобретения нескольких рабочих мест, возможно с разной функциональностью, в папку Лицензии Вашего установочного диска записываются все файлы лицензий, соответствующие приобретённым ключам. Например, если Вы приобретаете 5 локальных ключей HASP, то на Вашем диске будет 5 файлов лицензий - для каждого ключа свой файл. При установке системы с диска сразу все файлы лицензий автоматически копируются в указанные выше папки. В текущий момент на рабочем месте применяется только тот файл лицензий, который соответствует установленному на данном рабочем месте ключу HASP.

Также в этом разделе:

Два способа подключения к ключу HASP: локальное и сетевое

Настройка соединения с локальным ключом HASP

Установка сетевого ключа HASP. Настройка соединения с сетевым ключом на рабочих местах

Просмотр подключений к сетевому ключу HASP

Просмотр функций, прописанных в файле лицензий


Защита от несанкционированного копирования. Настройка соединения с локальным ключом HASP

Защита от несанкционированного копирования

Настройка соединения с локальным ключом HASP

Чтобы получить возможность работы в полнофункциональном режиме при использовании локального ключа HASP, необходимо выполнить следующие действия на компьютере, на который устанавливается система:

  1. Подключите аппаратный ключ HASP к USB-порту компьютера.
Замечание
Для корректной работы с ключом HASP необходимо, чтобы на компьютере был установлен драйвер ключа. При установке системы с диска он инсталлируется автоматически.
Если оказалось, что драйвер ключа на компьютере не установлен, то можно воспользоваться выборочной установкой, где указать пункт Драйвер ключа HASP (см. подробнее). Кроме того, дистрибутив драйвера находится на установочном диске в папке Дополнительные программы. Последняя версия дистрибутива всегда доступна на сайте компании.
  2. Убедитесь, что в папках Program Files/IndorSoft/IndorGIS/Bin/Licenses и Program Files/IndorSoft/IndorPower/Bin/Licenses находится файл лицензий. И если по каким-то причинам файла лицензий там нет, то скопируйте его в эти папки.
  3. Запустите систему IndorGIS. Если при этом появится диалоговое окно, в котором сообщается о том, что ключ не найден, то:

Ключ HASP не найден

  4. Нажмите кнопку Настроить HASP и повторить… При этом открывается диалоговое окно настройки подключения к ключу HASP.
  5. Установите флаг Использовать локальные ключи HASP и нажмите кнопку ОК.

Настройка подключения к локальному ключу HASP

Окно настройки подключения к ключу HASP открывается также из системы IndorGIS при выполнении команды меню Сервис| [image] Настройка HASP…

Также в этом разделе:

Два способа подключения к ключу HASP: локальное и сетевое

Файл лицензий

Установка сетевого ключа HASP. Настройка соединения с сетевым ключом на рабочих местах

Просмотр подключений к сетевому ключу HASP

Просмотр функций, прописанных в файле лицензий


Защита от несанкционированного копирования. Установка сетевого ключа HASP. Настройка соединения с сетевым ключом на рабочих местах

Защита от несанкционированного копирования

Установка сетевого ключа HASP. Настройка соединения с сетевым ключом на рабочих местах

Чтобы установить сетевой ключ HASP, выполните следующие действия:

  1. Выберите компьютер, на который будет установлен сетевой ключ. Обычно его устанавливают на сервере или на одном из рабочих компьютеров, который постоянно включен и не перезагружается в течение рабочего дня.
  2. Подключите аппаратный ключ HASP к USB-порту компьютера.
Замечание
Для корректной работы с ключом HASP необходимо, чтобы на компьютере был установлен драйвер ключа. При установке системы с диска он инсталлируется автоматически.
Если оказалось, что драйвер ключа на компьютере не установлен, то можно воспользоваться выборочной установкой, где указать пункт Драйвер ключа HASP (см. подробнее). Кроме того, дистрибутив драйвера находится на установочном диске в папке Дополнительные программы. Последняя версия дистрибутива всегда доступна на сайте компании.
  3. Для работы сетевого ключа HASP необходимо, чтобы на компьютере была установлена программа Менеджер лицензий. При выполнении серверной установки (см. подробнее) эта программа устанавливается автоматически. Кроме того, можно воспользоваться выборочной установкой, где указать пункт Менеджер сетевого ключа HASP (см. подробнее) или запустить дистрибутив с установочного диска (он расположен в папке Дополнительные программы). Последняя версия дистрибутива всегда доступна на сайте компании.

На рабочих местах:

  4. Запустите систему IndorGIS. При этом должно появиться диалоговое окно, в котором сообщается о том, что ключ не найден.
  5. Нажмите в этом окне кнопку Настроить HASP и повторить… При этом открывается диалоговое окно настройки подключения к ключу HASP.
  6. Установите флаг Искать ключи HASP в локальной и глобальной сети. Это означает, что при запуске системы на данном рабочем месте в сети будет найден компьютер, на котором установлен менеджер лицензий, и выполнен запрос о возможности запуска системы IndorGIS в полнофункциональном режиме.
  7. Если в сети имеется несколько ключей HASP, то нужно указать, какие адреса менеджеров лицензий следует использовать. Для этого установите флаг Использовать только следующие адреса менеджеров лицензий и введите в поле сетевой адрес сервера лицензий.
  8. Если на компьютере, который является сервером лицензий, установлено несколько менеджеров лицензий, необходимо указать имя менеджера лицензий, к которому следует обращаться. Для этого установите флаг Использовать только следующие адреса менеджеров лицензий и введите в поле имя менеджера лицензий.

Настройка подключения к сетевому ключу HASP

Кроме этого, можно отметить галочками разрешённые протоколы доступа к менеджеру лицензий, а также задать ограничения по времени ожидания отклика от сервера: Максимальное время попытки установления связи и Максимальное время приема и передачи пакетов.

Также в этом разделе:

Два способа подключения к ключу HASP: локальное и сетевое

Файл лицензий

Настройка соединения с локальным ключом HASP

Просмотр подключений к сетевому ключу HASP

Просмотр функций, прописанных в файле лицензий


Защита от несанкционированного копирования. Просмотр подключений к сетевому ключу HASP

Защита от несанкционированного копирования

Просмотр подключений к сетевому ключу HASP

Для просмотра информации о количестве рабочих мест, прописанных в лицензии, а также о том, сколько в данный момент запущено копий системы, используется программа Aladdin Monitor. Её дистрибутив находится на установочном диске в папке Дополнительные программы, в подпапке HASP.

Рассмотрим кратко интерфейс программы. В списке слева показываются все компьютеры в сети, где установлена программа Менеджер лицензий. В составе компьютера можно выбрать интересующий ключ, и тогда справа появится информация по этому ключу, в частности:

  • В списке Program Table - информация о количестве рабочих мест, которое допускает лицензия (Maximum Stations), и количестве запущенных в данных момент копий системы (Current Stations).
  • В списке Login Table - информация по каждому компьютеру, с которого запущена система.

Просмотр подключений к сетевому ключу HASP в программе Aladdin Monitor

Также в этом разделе:

Два способа подключения к ключу HASP: локальное и сетевое

Файл лицензий

Настройка соединения с локальным ключом HASP

Установка сетевого ключа HASP. Настройка соединения с сетевым ключом на рабочих местах

Просмотр функций, прописанных в файле лицензий


Защита от несанкционированного копирования. Просмотр функций, прописанных в файле лицензий

Защита от несанкционированного копирования

Просмотр функций, прописанных в файле лицензий

Список функций системы IndorInfo/Power, которыми позволяет пользоваться текущая лицензия, применяемая на рабочем месте, можно увидеть в окне настройки системы (команда меню IndorInfo/Power| [image] Настройка IndorInfo/Power…) на закладке Лицензии.

Просмотр файла лицензий

Если какие-то из необходимых лицензий отсутствуют, обратитесь в отдел продаж компании "ИндорСофт" для получения нового файла лицензий, после чего обновите его на рабочих местах.

Также в этом разделе:

Два способа подключения к ключу HASP: локальное и сетевое

Файл лицензий

Настройка соединения с локальным ключом HASP

Установка сетевого ключа HASP. Настройка соединения с сетевым ключом на рабочих местах

Просмотр подключений к сетевому ключу HASP


Начало работы. Запуск системы

Начало работы

Запуск системы

Запустить систему IndorGIS можно через меню Пуск панели задач Windows, выбрав пункт Программы|IndorSoft|IndorGIS.

Запуск системы IndorGIS

Система IndorInfo/Power может работать и без системы IndorGIS. В таком случае она предоставляет доступ только к атрибутивной составляющей системы: работа с паспортами объектов в базе данных, эксплуатационной информацией, просмотр ведомостей, формирование отчётов и пр. Чтобы запустить систему IndorInfo/Power в таком режиме, в меню Пуск панели задач Windows выберите пункт Программы|IndorSoft|IndorPower| [image] Консоль IndorPower.

Запуск системы IndorInfo/Power

Также в этом разделе:

Назначение системы IndorInfo/Power

Системные требования

Структура установки системы

Установка системы на клиентских местах

Установка серверной части

Выборочная установка

Полная установка

Использование демонстрационного проекта

Содержимое установочного диска

Обновление версии системы

Защита от несанкционированного копирования

Демонстрационный режим

Служба технической поддержки

Обзор других решений компании "ИндорСофт"


Начало работы. Демонстрационный режим

Начало работы

Демонстрационный режим

Если на рабочем месте настроено подключение к ключу HASP, но тем не менее система не находит ключа HASP и предлагает запуститься только в демонстрационном режиме, рекомендуем проверить следующие моменты:

  • При использовании локального ключа HASP:
    • Убедитесь, что в настройках подключения к ключу HASP установлен флаг Использовать локальные ключи HASP.
    • Проверьте, подключен ли к компьютеру аппаратный ключ HASP.
    • Проверьте, проинициализирован ли ключ HASP системой (в нём должна гореть лампочка). И если нет, то, возможно, на Вашем компьютере не установлен драйвер ключа HASP. Если после установки драйвера ключ всё равно не проинициализирован системой, то, возможно, он неисправен. В этом случае проверьте его работоспособность на другом компьютере (для этого достаточно подключить ключ к компьютеру и установить на нем драйвер), и если неисправность подтвердится, обратитесь в службу технической поддержки компании "ИндорСофт".
  • При использовании сетевого ключа HASP:
    • Проверьте, правильно ли указаны настройки подключения к ключу HASP (должен быть установлен флаг Искать ключи HASP в локальной и глобальной сети и желательно указан IP-адрес компьютера, на котором установлен ключ).
    • Обратитесь к Вашему системному администратору с целью выяснить, включен и работает ли компьютер, на котором установлен ключ HASP, проинициализирован ли ключ HASP на этом компьютере, а также запущена ли программа Менеджер лицензий.
    • После установки ключа в USB-порт необходимо перезапустить менеджер лицензий.
Замечание
Если система запускается, но некоторые функции недоступны, проверьте, есть ли на Вашем компьютере файл лицензий (в папках Program Files/IndorSoft/IndorGIS/Bin/Licenses и Program Files/IndorSoft/ IndorPower/Bin/Licenses) и соответствует ли он ключу HASP. Кроме этого, ознакомьтесь со списком функций, разрешённых файлом лицензий, - возможно, Ваш файл лицензий не предусматривает работу с некоторыми модулями.

Также в этом разделе:

Назначение системы IndorInfo/Power

Системные требования

Структура установки системы

Установка системы на клиентских местах

Установка серверной части

Выборочная установка

Полная установка

Использование демонстрационного проекта

Содержимое установочного диска

Обновление версии системы

Защита от несанкционированного копирования

Запуск системы

Служба технической поддержки

Обзор других решений компании "ИндорСофт"


Начало работы. Служба технической поддержки

Начало работы

Служба технической поддержки

Служба технической поддержки компании "ИндорСофт" оказывает поддержку партнёрам компании, покупателям, а также некоммерческим пользователям продуктов "ИндорСофт". Вопросы, выходящие за рамки технической поддержки программных продуктов "ИндорСофт", необходимо адресовать соответствующим разработчикам стороннего программного обеспечения и т.п.

Также в этом разделе:

Вопросы по работе с системой

Обнаруженные ошибки в работе системы

Предложения и пожелания


Служба технической поддержки. Вопросы по работе с системой

Служба технической поддержки

Вопросы по работе с системой

В случае возникновения вопросов по работе с системами IndorInfo/Power, IndorGIS и IndorElectra рекомендуется поступить одним из следующих способов:

  1. Изучите доступную информацию по этому вопросу в документации по системе и попытайтесь самостоятельно найти решение проблемы. После установки системы документация в форматах PDF и CHM доступна в меню Пуск|Программы|IndorSoft|IndorGIS, Пуск|Программы|Indorsoft|IndorInfoPower и Пуск|Программы|IndorSoft|IndorElectra. Кроме этого, она хранится на Вашем установочном диске в папке Документация.

Самая последняя версия документации всегда доступна на сайте компании.

Документация в формате CHM - справка - открывается непосредственно из системы IndorGIS при выполнении команды ?| [image] Помощь по модулю| [image] IndorInfo/Power… В процессе работы с программой можно воспользоваться контекстной справкой: если нажать клавишу F1 при открытом диалоговом окне либо включенном режиме, то справка откроется именно на том разделе, где описывается данное диалоговое окно или режим.

  2. Обратитесь к обучающим видеороликам по системе. После установки системы они доступны в меню Пуск|Программы|IndorSoft|IndorGIS, Пуск|Программы|Indorsoft|IndorInfoPower и Пуск|Программы|IndorSoft|IndorElectra. Кроме этого, они хранятся на Вашем установочном диске в папке Обучающие ролики.

Самые последние версии видеороликов всегда доступны на сайте компании.

На текущий момент в обучающих видеороликах подробно рассмотрены следующие темы: работа со слоями, создание графического изображения электрических сетей, ввод атрибутивных и эксплуатационных данных.

Замечание
Начинающим пользователям рекомендуется в первую очередь ознакомиться с обучающими видеороликами, поскольку в них последовательно - от простого к сложному - рассматриваются функциональные возможности системы. Принципы работы с системой показываются на конкретных практических примерах.
  3. Вы можете обсудить Вашу проблему на форуме, действующем на сайте компании, либо воспользоваться поиском по форуму - возможно, такая проблема уже возникала у других пользователей и её решение обсуждалось на форуме.
  4. Если описанные выше варианты не помогли справиться с проблемой, обратитесь в службу технической поддержки, действующую на сайте компании.

Подать обращение в службу технической поддержки могут только зарегистрированные на сайте пользователи, поэтому если Вы в первый раз отправляете обращение, Вам сначала будет предложено зарегистрироваться. При повторном обращении будет предложено авторизоваться, т.е. ввести регистрационное имя (логин) и пароль.

Ниже представлена форма подачи обращения в службу технической поддержки.

Пример подачи обращения в службу технической поддержки

  5. Если у Вас нет возможности зайти на наш сайт, напишите письмо в службу технической поддержки на электронный адрес: support@indorsoft.ru. При необходимости в письмо можно также вложить файл проекта.
  6. Позвоните в "ИндорСофт" по телефонам: (3822) 651-386, 651-387.

Также в этом разделе:

Обнаруженные ошибки в работе системы

Предложения и пожелания


Служба технической поддержки. Обнаруженные ошибки в работе системы

Служба технической поддержки

Обнаруженные ошибки в работе системы

Мы будем Вам признательны, если в случае обнаружения ошибки в работе программы Вы сообщите нам о ней. Это можно сделать, отправив обращение в службу технической поддержки на сайте компании или написав письмо в службу технической поддержки на электронный адрес: support@indorsoft.ru.

Также в этом разделе:

Вопросы по работе с системой

Предложения и пожелания


Служба технической поддержки. Предложения и пожелания

Служба технической поддержки

Предложения и пожелания

Помимо вопросов по работе с программой, Вы можете отправлять в компанию "ИндорСофт" свои пожелания и предложения (оставив обращение на сайте или отправив письмо на электронную почту). В случае подачи обращения в службу технической поддержки на сайте компании выберите в обращении категорию Предложения и пожелания. Мы постараемся учесть все Ваши предложения.

Также в этом разделе:

Вопросы по работе с системой

Обнаруженные ошибки в работе системы


Обзор других решений компании "ИндорСофт". Информационная система автомобильных дорог IndorInfo/Road

Обзор других решений компании "ИндорСофт"

Информационная система автомобильных дорог IndorInfo/Road

Информационная система автомобильных дорог IndorInfo/Road предназначена для ведения всей технической и эксплуатационной информации по сети автомобильных дорог в электронном виде.

В основе IndorInfo/Road лежит единая информационная модель сети автомобильных дорог. Система интегрирует в себе такую информацию, как сведения паспортизации, мониторинга и диагностики, сведения о текущей эксплуатации и планах выполнения работ. Информационная система IndorInfo/Road может применяться как в рамках территориальных дорожных сетей, так и для улично-дорожных сетей городов. Система полностью интегрирована с универсальной геоинформационной системой IndorGIS и обладает всеми её функциями.

Области применения IndorInfo/Road

  • Федеральные автомобильные дороги, подразделения Росавтодора.
  • Территориальная сеть автомобильных дорог.
  • Ведомственные дороги, месторождения.
  • Улично-дорожная сеть городов.

Паспортизация

Система IndorInfo/Road позволяет вести детальные или упрощённые паспорта по следующим разделам:

  • строительная часть дороги;
  • инженерные сооружения;
  • объекты придорожной полосы;
  • различные объекты недвижимости;
  • разбиение титулов на логические участки;
  • топологическое моделирование сложных объектов.

Эксплуатация

Система позволяет хранить сведения по всем эксплуатационным событиям, сопровождающим объекты дорожной сети:

  • в строительстве;
  • при вводе в эксплуатацию;
  • при текущем и расширенном содержании;
  • при текущем, среднем и капитальном ремонтах; мониторинге.

Для всех событий указываются время и место, состав и объём работ, исполнители, сведения о выявленных и устранённых дефектах, проведённых измерениях. Также имеется возможность сохранять в базе данных связанные с событиями документы. Кроме эксплуатационных событий, имеется возможность заносить сведения о ДТП.

Диагностика и мониторинг

Система IndorInfo/Road позволяет вести архив информации по результатам диагностики и мониторинга, который содержит подробное описание расположения и характера дефектов с привязкой к конкретным объектам, изображения дефектов, подробное описание локализации измеренных величин.

Геоинформационная подсистема IndorGIS

Информационная система автомобильных дорог IndorInfo/Road может использоваться в связке с геоинформационной системой (ГИС) IndorGIS для представления пространственных данных в виде электронных карт.

Геоинформационная система обеспечивает визуальные средства отображения пространственной информации по дорогам, такой как геометрия трассы, участки дороги, инженерные сооружения, придорожная полоса, объекты недвижимости, события на дороге и т.д. Существует возможность привязки дорожной сети к топооснове, то есть наложение дорог и их объектов на цифровую модель местности.

Использование ГИС предусматривает решение ряда задач, таких как связь графического изображения объекта с его информационным описанием, автоматическое формирование изображений дорог по хранящимся в информационной системе данным, а также обратная связь по коррекции пространственных данных между ГИС и информационной системой.

Таким образом, интеграция с геоинформационной системой IndorGIS даёт возможность:

  • формировать подробные планы дорог на цифровой модели местности на основе информации о топологии, размерах и координатных привязках, содержащихся в базе данных паспортов; корректировать их или создавать новые и передавать в базу данных;
  • совместно представлять автомобильные и городские дороги, а также другие инженерные коммуникации на электронной топографической основе;
  • просматривать карту дорожной сети с интерактивной выдачей любой паспортной и эксплуатационной информации по любому отображаемому объекту дорожной сети;
  • выполнять поиск объектов на карте по их описанию;
  • формировать исходные данные для различных транспортных расчётов;
  • отображать на карте обнаруженные дефекты за тот или иной период;
  • отображать на карте места ДТП;
  • отображать на карте участки проведения работ;
  • выполнять над векторными слоями основные операции алгебры карт, включая построение оверлеев и буферных зон;
  • распечатывать электронные карты и чертежи с качеством, соответствующим нормам составления картографических материалов любых масштабов.

Также в этом разделе:

Системы проектирования IndorCAD


Обзор других решений компании "ИндорСофт". Системы проектирования IndorCAD

Обзор других решений компании "ИндорСофт"

Системы проектирования IndorCAD

В состав линейки программных продуктов IndorCAD входят:

  • система подготовки топографических планов IndorCAD/Topo;
  • система проектирования автомобильных дорог IndorCAD/Road;
  • система проектирования генеральных планов IndorCAD/Site;
  • система подготовки лоцманских карт и проектирования русловых работ IndorCAD/River.

Система подготовки топографических планов IndorCAD/Topo

Система подготовки топографических планов IndorCAD/Topo предназначена для ввода и обработки данных, полученных в ходе инженерно-геодезических и геологических изысканий, и подготовки цифровых моделей местности с возможностью последующей работы с ними в других продуктах линейки IndorCAD (IndorCAD/Road, IndorCAD/Site, IndorCAD/River).

Исходными данными для системы служат теодолитные, нивелировочные, тахеометрические журналы или файлы с соответствующих электронных приборов. Возможно использование данных с систем спутниковой навигации и файлов из сторонних систем: файлов открытого обменного формата CREDO, растровых файлов, трёхмерных DXF-файлов, шейп-файлов ESRI.

Инструментальные средства системы позволяют:

  • вводить данные, полученные в результате геодезических изысканий (параметры станций теодолитного хода и съёмочные точки), импортировать файлы электронных геодезических приборов;
  • обрабатывать полученные данные и выполнять геодезические расчёты;
  • загружать данные из файлов, подготовленных в других системах;
  • вводить данные по растровой подложке (сканированные карты, чертежи, аэрофотоснимки);
  • формировать геологическую модель местности;
  • выполнять анализ и редактирование поверхности, полученной на основе исходных данных; эффект "псевдо 3D" (изменение цвета поверхности в зависимости от направления уклонов и источника света), изолинии, изоконтуры и градиенты стоков позволяют визуально оценить рельеф построенной поверхности;
  • работать с несколькими поверхностями (существующей и любым числом проектных);
  • вычислять разности поверхностей, линии нулевых работ, подсчитывать объёмы земляных работ;
  • наносить объекты инженерного и сервисного обустройства, зелёные насаждения, здания, ограждения и др.;
  • формировать отчётные документы.

Благодаря широкому применению точечных, линейных, площадных и специальных условных знаков, цифровая модель местности может быть представлена в соответствии с существующими требованиями оформления топографических планов. Система комплектуется стандартной библиотекой условных знаков для топографических планов масштабов от 1:500 до 1:5000.

Файлы с цифровой моделью местности, подготовленные в системе IndorCAD/Topo, могут быть переданы в любую из систем автоматизированного проектирования IndorCAD и использованы для проектирования объектов транспортного, промышленного и гражданского строительства.

Система проектирования автомобильных дорог IndorCAD/Road

Система проектирования автомобильных дорог IndorCAD/Road позволяет проектировать автомобильные дороги всех технических категорий на стадии их строительства, реконструкции и ремонта, проектировать транспортные развязки и разрабатывать проекты организации движения. IndorCAD/Road отвечает всем требованиям действующих нормативных документов по проектированию дорог и сертифицирована Центром сертификации программных средств в строительстве.

В системе IndorCAD/Road реализованы следующие основные разделы проектирования: План, Продольный профиль, Верх земляного полотна, Поперечный профиль, 3D-вид. В составе системы могут поставляться дополнительные модули: геодезический редактор, редактор дорожных знаков, редактор инженерных коммуникаций, имитационная система транспортных потоков, модуль трансформации растров и др.

Инструментальные средства системы IndorCAD/Road дают возможность:

  • импортировать данные из обменных форматов (Credo DAT, файлы GPS-съёмки, файлы DXF, шейп-файлы ESRI, текстовые файлы с координатами точек);
  • обрабатывать данные геодезических изысканий (при помощи модуля IndorSurvey);
  • векторизовать растровые картографические материалы;
  • формировать цифровую модель местности;
  • формировать поверхности с учётом структурных линий рельефа, выполнять ручное редактирование триангуляционной модели;
  • вычислять разности поверхностей, линии нулевых работ, подсчитывать объёмы земляных работ;
  • моделировать объекты местности: здания, сооружения, инженерные сети, зелёные насаждения, ограждения, дорожные знаки, реперы и пр.;
  • оформлять топографические карты;
  • выполнять трассирование как с применением классических геометрических элементов (дуг окружностей и клотоид), так и современных инструментов вычислительной математики (кривых Безье 3-го и 5-го порядков);
  • работать с произвольным количеством трасс и выполнять вариантное трассирование;
  • удобно и наглядно редактировать трассы (параллельный перенос трассы, изменение азимута начального направления, добавление и смещение вершин углов, изменение параметров вписанных кривых и т.д.);
  • выполнять разбивку трассы на поперечные профили (дискретизацию отметок трассы с заданным интервалом);
  • проектировать продольный профиль трассы классическим или сплайновым методом;
  • проектировать верх земляного полотна (виражи), переходно-скоростные и разделительные полосы, автобусные карманы;
  • конструировать дорожную одежду и поперечные профили, как типовые, так и индивидуальные;
  • рассчитывать объёмы земляных работ, дорожной одежды, площадей откосов;
  • "привязывать" к трассе дополнительные объекты инженерного обустройства: элементы дорожной разметки, дорожные знаки, ограждения и сигнальные столбики, мосты и путепроводы; привязка объектов выполняется в координатах относительно трассы, что приводит к автоматическому смещению этих объектов при изменении планового положения трассы;
  • просматривать существующие и проектные трассы в 3D-виде, визуально оценивать дальность видимости объектов на автомобильной дороге; выполнять "проезд" по проектной трассе (вид с точки зрения водителя), что позволяет наиболее качественно оценить проектное решение;
  • формировать чертежи, сводные ведомости, таблицы и отчёты по проекту.

Система проектирования генеральных планов IndorCAD/Site

Система автоматизированного проектирования генеральных планов IndorCAD/Site предназначена для создания генеральных планов промышленных и гражданских объектов, проектов детальной планировки.

Инструментальные средства системы позволяют решать задачи, возникающие при проектировании генеральных планов застройки территорий:

  • импортировать, строить и анализировать цифровые модели местности;
  • строить поверхность с заданным уклоном;
  • производить автоматическое измерение уклонов поверхности в интересующих участках;
  • отображать в произвольных точках существующие, проектные и рабочие отметки поверхности (разности между проектными и существующими отметками);
  • размещать объекты транспортной и инженерной инфраструктур;
  • автоматически достраивать откосы от проектной поверхности до существующей;
  • производить подсчёт объёмов земляных работ по сетке;
  • просматривать проектные решения в 3D-виде;
  • формировать отчётные ведомости, таблицы и чертежи, принятые при проектировании генеральных планов.

Система подготовки лоцманских карт и проектирования русловых работ IndorCAD/River

Система IndorCAD/River предназначена для составления и корректировки лоцманских карт и проектирования дноуглубительных работ.

Инструментальные средства системы дают возможность:

  • выполнять построение цифровых моделей рельефа побережья и дна водоёмов;
  • выполнять построение цифровых моделей местности;
  • проектировать дноуглубительные работы;
  • оформлять лоцманские карты;
  • рассчитывать фактические объёмы работ по результатам исполнительных съёмок.

Также в этом разделе:

Информационная система автомобильных дорог IndorInfo/Road


Основы работы в системе. Модель информационной системы

Основы работы в системе

Модель информационной системы

В основе информационной системы лежит модель, описывающая некоторым образом электрическую сеть и события, которые с ней происходят. Модель сети включает в себя:

  • графическую базу данных, содержащую трассы ЛЭП, планы подстанций, карты, на которые накладываются данные трассы и планы;
  • атрибутивную базу данных, хранящую информацию по техническим паспортам, эксплуатации и справочники;
  • принцип отображения информации пользователю.

Модель сети, лежащая в основе информационной системы

Информационная система состоит из разделов. Раздел - это набор карт или схем, предназначенный для выполнения некоторого цикла работ, и может рассматриваться как автоматизированное рабочее место (АРМ) для службы линий, службы подстанций, производственного, технического и абонентского отделов, диспетчерской службы, служб релейной защиты и других пользователей информационной системы. Каждый раздел характеризуется набором видов и представлений объектов и режимов работы с этими объектами.

В качестве типичного набора разделов предлагается следующий:

  • Трассы ЛЭП и планы подстанций на карте местности (плане территории)

Пример внешнего вида раздела представлен ниже на рисунках. Он предназначен для служб линий и подстанций, а также для отдела согласования.

Представление плана подстанции на карте местности

Представление трасс ЛЭП на карте местности

В разделе представлены трассы ЛЭП и планы подстанций, совмещённые с детальной электронной картой местности. Трассы ЛЭП отображают положения и планы опор, фундаментов, контуров заземления, габариты пролётов. Планы подстанций представляют в различных слоях планы фундаментов, сооружений и оборудования, ошиновку, контуры заземления, кабельные каналы, подъездные пути и контуры заземления. На карте местности изображены контуры (возможно, и поэтажные планы) зданий и сооружений, трассы инженерных коммуникаций, улично-дорожная сеть, виды угодий, гидрография, рельеф.

  • Технологическая схема на карте местности

Пример внешнего вида раздела представлен ниже на рисунке. Данный раздел предназначен для производственного и технического отделов, службы подстанций, релейной защиты, абонентского отдела. В разделе представлены технологические схемы подстанций и схемы линий электропередачи, а также условное расположение абонентов. Подстанции изображаются схематично на карте в местах их приблизительного расположения. Линии электропередачи также представлены схематично. При увеличении масштаба просмотра в контурах подстанций появляются их оперативные технологические схемы. В этом разделе представлено всё оборудование подстанций, а также абоненты, размещённые на карте.

Оперативная технологическая схема на плане местности

  • Оперативная (диспетчерская) схема

Данный раздел предназначен главным образом для диспетчерской службы и службы режимов. Здесь представлена упрощённая однолинейная схема всей сети - аналог диспетчерского щита. Основным отличием является то, что на этой схеме можно совместно представлять сети разных классов напряжений - от 0,4 до 1150 кВ. При этом, чтобы избежать перегруженности схемы, сети более низких классов напряжений изображаются в уменьшенных масштабах. При увеличении масштаба они появляются на схеме, а при уменьшении - скрываются.

Нормальная схема сетей энергосистемы

На базе данной схемы может работать система электрических расчётов IndorElectra. Этот раздел данных может использоваться для интеграции с телеметрическими системами, чтобы отображать текущие состояния коммутаторов и значения измерений.

Также в этом разделе:

Понятие проекта, карты и слоя

Обзор рабочей области

Настройка панелей инструментов в системе IndorGIS

Настройка панелей инструментов для работы с системой IndorInfo/Power

Просмотр карты

Элементы диалоговых окон

Подключение к базе данных на клиентских местах


Основы работы в системе. Понятие проекта, карты и слоя

Основы работы в системе

Понятие проекта, карты и слоя

Графическая часть информационной системы (карты, трассы линий электропередачи, планы подстанций, изображение электрических схем) реализована средствами геоинформационной системы IndorGIS.

В геоинформационной системе вся графическая информация на картах состоит из упорядоченной совокупности графических слоёв. В пределах одного слоя обычно объединяется семантически одинаковая в некотором смысле графическая информация. Например, слой электрической схемы, содержащий все элементы электрических сетей, или слой стран, слой рек и слой городов на карте мира.

Послойная структура упрощает просмотр и анализ графической информации, а также позволяет работать только с теми данными, которые необходимы в текущий момент. Например, можно отключить видимость тех слоёв, с которыми в данный момент не ведётся работа.

Совокупность всех слоёв образует карту. Карта может содержать слои топоосновы, слои, представляющие объекты на карте местности, и слои с объектами электрической схемы. Схему можно рисовать как на плане местности, так и без привязки к объектам на карте. В тех случаях, когда схема рисуется без привязки к местности и карта не содержит слои топоосновы, т.е. в ней представляются только слои электрической схемы, под термином карта можно понимать область для рисования схемы.

Проект в системе IndorGIS в самом простом случае представляет собой набор карт и хранится в отдельном файле с расширением *.upr.

Структура проекта в системе IndorGIS

Слои карт могут быть сохранены в проекте либо в отдельных файлах. В последнем случае один и тот же слой можно использовать в разных картах и проектах, кроме этого, становится возможной настройка доступа к слою на уровне операционной системы.

Также в этом разделе:

Модель информационной системы

Обзор рабочей области

Настройка панелей инструментов в системе IndorGIS

Настройка панелей инструментов для работы с системой IndorInfo/Power

Просмотр карты

Элементы диалоговых окон

Подключение к базе данных на клиентских местах


Обзор рабочей области. Менеджер проектов

Обзор рабочей области

Менеджер проектов

После запуска системы IndorGIS открывается окно менеджера проектов. Оно предназначено для управления рабочими проектами и картами, входящими в состав проектов. В левой части окна расположено дерево проектов, которое содержит все текущие рабочие проекты, при этом каждому проекту соответствует отдельная ветвь дерева.

В верхней части окна менеджера проектов находятся главное меню и панели инструментов. Главное меню содержит все доступные в данный момент команды системы. Кнопки панелей инструментов дублируют команды главного меню и обеспечивают быстрый доступ к командам. Они расположены под главным меню.

Чтобы открыть существующий проект, выполните команду меню Файл| [image] Открыть проект… или нажмите кнопку [image] Открыть проект… на панели инструментов Проекты и выберите в диалоговом окне файл проекта с расширением *.upr.

Окно менеджера проектов

При нажатии на знак "+", расположенный рядом с названием проекта, раскрывается его содержимое - в дереве отображаются все карты, входящие в состав проекта.

Дерево проектов

Выделите один из проектов в дереве. В правой части окна менеджера проектов отобразится информация о нём, включающая в себя сведения об авторе проекта, учреждении, имени файла проекта и его краткое описание. Если выделить любую карту в проекте, то в правой части также появится краткая информация об этой карте.

Чтобы создать новый проект, выполните команду меню Файл| [image] Создать новый проект или нажмите кнопку [image] Создать проект на панели инструментов Проекты.

Для того чтобы создать в проекте новую карту, сделайте активным нужный проект (т.е. выделите его в дереве) и выполните команду меню Документ| [image] Создать документ| [image] Карту или нажмите кнопку [image] Создать карту на панели инструментов Документы.

Карту проекта можно открыть из окна менеджера проектов. Для этого дважды щёлкните мышью на названии карты или откройте контекстное меню щелчком правой кнопки мыши на карте и выполните команду [image] Открыть. При этом открывается окно редактора карт выбранной карты.

Также в этом разделе:

Редактор карт

Переключение между картами


Обзор рабочей области. Редактор карт

Обзор рабочей области

Редактор карт

Интерфейсы менеджера проектов и редактора карт реализованы по единому принципу. В верхней части окна находится главное меню. Под ним расположены панели инструментов. Но в менеджере проектов главное меню содержит команды для управления проектами и картами, а редактор карт содержит инструменты для редактирования карт.

В центральной части редактора находится область просмотра и редактирования карты. В левой части отображается легенда карты, представляющая собой дерево слоёв, из которых состоит карта.

Окно редактора карт

Замечание
При создании новой карты появляется окно, в котором нужно указать, что карта будет использоваться информационной системой IndorInfo/Power. После этого в новой карте станут доступными команды информационной системы.
Для существующей карты это окно открывается командой меню Карта| [image] Настройка IndorInfo/Power…

Настройка новой карты

При нажатии кнопки ОК система выдаёт окно, где можно сразу настроить подключение к базе данных (см. подробнее).
После появляется ещё одно окно, в котором можно указать, чтобы система автоматически настроила панели инструментов для работы с IndorInfo/Power (см. подробнее).

Подтверждение настройки панелей инструментов

Также в этом разделе:

Менеджер проектов

Переключение между картами


Обзор рабочей области. Переключение между картами

Обзор рабочей области

Переключение между картами

В системе может быть открыто одновременно несколько карт. Все открытые на текущий момент карты отображаются в виде списка в меню Окно. Чтобы переключиться на одну из открытых карт, достаточно выбрать её в этом списке.

Для переключения в окно менеджера проектов предназначена специальная команда [image] Менеджер проектов на панели инструментов Power Проекты.

Чтобы закрыть окно редактора карты, нажмите кнопку [image] в правом верхнем углу окна редактора карт (не путать с [image] - кнопкой закрытия приложения, находящейся в верхнем углу окна IndorGIS!).

Также в этом разделе:

Менеджер проектов

Редактор карт


Основы работы в системе. Настройка панелей инструментов в системе IndorGIS

Основы работы в системе

Настройка панелей инструментов в системе IndorGIS

Панели инструментов в системе IndorGIS можно настраивать по своему усмотрению, раскладывая их в желаемом порядке на экране, а также включая и выключая их видимость. Настройка панелей инструментов позволяет отображать на экране только панели инструментов с часто используемыми командами, а остальные панели скрывать и вызывать их по мере необходимости.

Все панели инструментов в своей левой части имеют специальную область с двумя вертикальными чертами. Чтобы переместить панель, нажмите в этой области кнопку мыши и, удерживая её нажатой, перенесите панель в нужное место.

Перемещение панели инструментов

Включение и выключение панелей можно выполнять с помощью контекстного меню, которое вызывается нажатием правой кнопки мыши в области расположения панелей инструментов. Чтобы включить/выключить панель инструментов, выберите соответствующий пункт в этом меню.

Контекстное меню панелей инструментов

Замечание
Основные команды информационной системы объединены на панели инструментов IndorInfo/Power. Также при работе с системой появляются дополнительные режимы на панели инструментов Режимы работы.

В системе IndorGIS есть возможность создавать новые панели инструментов для размещения наиболее часто используемых команд. Откройте окно настройки панелей инструментов, выполнив команду [image] Настройка… в контекстном меню панелей инструментов.

На закладке Панели инструментов отображается список всех панелей в системе. Галочками отмечены видимые панели. Кнопки Выключить все и Включить все позволяют отключить или включить видимость сразу всех панелей инструментов. Таким образом, видимость панелей можно настраивать не только из контекстного меню, а также и в этом диалоговом окне.

Для создания новой панели инструментов нажмите кнопку Добавить…, после чего введите в списке название новой панели.

Создание новой панели инструментов

Кнопка Изменить… предназначена для изменения названий созданных панелей инструментов. Удалять можно только собственные панели (т.е. созданные самим пользователем). Для этого выделите панель инструментов в списке и нажмите кнопку Удалить.

Далее можно разместить на созданной панели инструментов необходимые команды, для этого перейдите на закладку Команды. В левой части окна находится список категорий команд, а справа - доступные команды из выбранной слева категории.

Сначала выберите в выпадающем списке в верхней части окна настраиваемую панель инструментов, а затем перетащите нужные команды на изображение панели.

Для каждой команды на панели инструментов можно открыть контекстное меню. По команде [image] Удалить кнопка удаляется с панели инструментов, а по команде [image] Свойства… открывается диалоговое окно, в котором можно задать название кнопки, указать текст всплывающей подсказки и выбрать отображаемую на кнопке иконку.

Настройка содержимого новой панели инструментов

Также в этом разделе:

Модель информационной системы

Понятие проекта, карты и слоя

Обзор рабочей области

Настройка панелей инструментов для работы с системой IndorInfo/Power

Просмотр карты

Элементы диалоговых окон

Подключение к базе данных на клиентских местах


Основы работы в системе. Настройка панелей инструментов для работы с системой IndorInfo/Power

Основы работы в системе

Настройка панелей инструментов для работы с системой IndorInfo/Power

Панели инструментов в редакторе карт можно специальным образом настроить для удобной работы с информационной системой. Откройте окно настройки системы (команда меню IndorInfo/Power| [image] Настройка IndorInfo/Power… или кнопка [image] Настройка IndorInfo/Power… на панели инструментов IndorInfo/Power), перейдите на закладку ГИС и нажмите кнопку Настроить панель инструментов. Настроить панели инструментов можно также сразу при создании карты (см. подробнее).

Настройка панелей состоит в следующем:

  • отключается видимость всех стандартных панелей инструментов системы IndorGIS;
  • создаются новые панели, в названии которых присутствует префикс Power, и на них располагаются только те команды, которые могут понадобиться при работе с информационной системой IndorInfo/Power.

Рассмотрим состав новых панелей инструментов.

Power Проекты

Эта панель содержит команды для сохранения проекта и переключения в окно менеджера проектов.

Power Слои

На этой панели собраны команды для работы со слоями карты.

Power Навигация

На этой панели присутствуют команды для осуществления навигации по карте.

Power Правка

Команды этой панели предназначены для работы с буфером обмена и выполнения различных операций с объектами.

Power Настройка карты

На этой панели собраны команды для настройки сетки карты.

Power Режимы общие, Power Режимы

На этих панелях инструментов располагаются все режимы работы, доступные в информационной системе.

IndorInfo/Powerя

На этой панели располагаются команды, предназначенные только для работы с IndorInfo/Power. Эти команды доступны также в подменю IndorInfo/Power главного меню.

Замечания
  1. После настройки панелей для IndorInfo/Power остаются доступными все стандартные панели IndorGIS, видимость любой из них можно включить. Все команды геоинформационной системы остаются доступными из главного меню.
  2. Далее в руководстве при рассмотрении команд будем ссылаться на панели инструментов IndorInfo/Power, а не на стандартные панели системы IndorGIS.

Также в этом разделе:

Модель информационной системы

Понятие проекта, карты и слоя

Обзор рабочей области

Настройка панелей инструментов в системе IndorGIS

Просмотр карты

Элементы диалоговых окон

Подключение к базе данных на клиентских местах


Основы работы в системе. Просмотр карты

Основы работы в системе

Просмотр карты

Используя режимы просмотра карты и различные команды навигации, можно отображать в редакторе карт нужный в текущий момент фрагмент карты. Например, можно отобразить всю карту целиком, увеличивать отдельные фрагменты, просматривать фрагменты карты, выходящие за пределы видимой области.

Для просмотра карты предназначены стандартные режимы увеличения, уменьшения и панорамирования изображения. Они расположены на панели инструментов Power Режимы общие.

Режимы просмотра карты

Увеличение изображения

Чтобы увеличить отдельный фрагмент карты, растяните прямоугольную рамку, удерживая нажатой кнопку мыши. Изображение, попавшее внутрь этой рамки, будет увеличено до размеров рабочей области.

Однократный щелчок мыши в области просмотра приводит к увеличению масштаба карты на 25%.

Уменьшение изображения

Удерживая нажатой кнопку мыши, растяните прямоугольную рамку. Видимое в области просмотра изображение будет уменьшено до размеров рамки.

Однократный щелчок мыши в области просмотра приводит к уменьшению масштаба карты на 25%.

Панорамирование изображения

В этом режиме осуществляется навигация по карте без изменения масштаба. Нажав и удерживая кнопку мыши, можно перемещать изображение в любом направлении.

Совет
Для изменения масштаба карты удобно использовать колесо мыши. При прокручивании его в одну сторону масштаб будет увеличиваться, в другую - уменьшаться.
Режим панорамирования включается, если нажать и удерживать колесо прокрутки мыши. После того как колесо будет отпущено, восстановится режим, который был включен ранее.

На панели инструментов Power Навигация собраны дополнительные команды, с помощью которых можно выполнять однократные действия на карте. Рассмотрим их.

Панель инструментов Power Навигация

Вписывает в область просмотра всю карту.

Вписывает в область просмотра все объекты выделенного слоя (или нескольких выделенных слоёв).

Вписывает в область просмотра все выделенные фигуры.

Также в этом разделе:

Модель информационной системы

Понятие проекта, карты и слоя

Обзор рабочей области

Настройка панелей инструментов в системе IndorGIS

Настройка панелей инструментов для работы с системой IndorInfo/Power

Элементы диалоговых окон

Подключение к базе данных на клиентских местах


Основы работы в системе. Элементы диалоговых окон

Основы работы в системе

Элементы диалоговых окон

Рассмотрим типичные элементы диалоговых окон, при помощи которых выполняются все основные операции по работе с данными в информационной системе.

Элементы диалогового окна

  • Закладки. Данный элемент интерфейса позволяет перемещаться между страницами, на которых расположена различная информация. Название текущей закладки сверху выделяется цветной полоской.
  • Флажки. Этот элемент отражает логические значения "да"/"нет" - в случае, если "галочка" установлена, считается, что флажок имеет значение "да", иначе - "нет".
  • Кнопки. При нажатии мышью на кнопку, как правило, выполняется некоторое действие, например, выводится окно. Зачастую окна имеют внизу две кнопки: ОК - записать изменения, произведённые в окне, и Отмена - отказаться от изменений и закрыть окно.
  • Поля ввода текстовой, числовой и иной информации. Это могут быть:
    • Поле для ввода текстовой информации.
    • Поле со списком, значение которого можно выбрать из списка, выпадающего при нажатии на кнопку [image], расположенную справа.
    • Поле для ввода чисел. Значение в это поле можно вводить с клавиатуры, используя кнопки прокрутки [image], расположенные справа, клавиши управления курсором Стрелка вверх и Стрелка вниз, клавиши Page up и Page down, а также при помощи встроенных калькуляторов, вызываемых клавишей F4.
Простой калькулятор | Калькулятор для углов

Инженерный калькулятор

  • Разделители предназначены для изменения размеров панелей внутри одного окна. При наведении указателя мыши на разделитель он превращается в двойную черту со стрелками. Таким указателем можно "перетащить" разделитель на новое место, тем самым сузив одну панель и расширив другую.

Также в этом разделе:

Модель информационной системы

Понятие проекта, карты и слоя

Обзор рабочей области

Настройка панелей инструментов в системе IndorGIS

Настройка панелей инструментов для работы с системой IndorInfo/Power

Просмотр карты

Подключение к базе данных на клиентских местах


Основы работы в системе. Подключение к базе данных на клиентских местах

Основы работы в системе

Подключение к базе данных на клиентских местах

Перед началом работы с информационной системой необходимо на каждом клиентском месте настроить соединение с атрибутивной базой данных. Как правило, на всех клиентских местах находится рабочий проект, содержащий определённое количество разделов (или карт). Чтобы настроить соединение, откройте одну из карт и укажите в редакторе этой карты, к какой базе данных следует подключаться. Параметры соединения, заданные в одной из карт, автоматически применяются ко всем картам проекта.

Откройте окно настройки системы, выполнив команду меню IndorInfo/Power| [image] Настройка IndorInfo/Power… или нажав кнопку [image] Настройка IndorInfo/Power… на панели IndorInfo/Power. Параметры подключения клиента к атрибутивной базе данных задаются в этом окне на закладке Подключение.

Параметры подключения клиента к базе данных

  • Выберите тип используемого сервера баз данных, введите имя сервера и имя базы данных, в которой хранится информация по рабочему проекту.
  • Укажите способ проверки аутентификации пользователя:
    • Если выбран вариант Авторизация Windows NT, то подключение к SQL-серверу происходит от имени пользователя, под которым Вы зашли в операционную систему, а проверка пользователя осуществляется средствами Windows.
    • Если выбран вариант Авторизация SQL-сервера, то пользователь подключается к SQL-серверу под своим уникальным именем, которое было создано для него администратором SQL-сервера. При подключении пользователя SQL-сервер проверяет, существует ли пользователь с таким именем, и проверяет его пароль. Если установлен флаг Запрашивать имя и пароль при входе, то при открытии карт в проекте всегда будет появляться диалоговое окно для ввода имени пользователя и пароля. Чтобы не вводить каждый раз пароль, можно установить флаг Запомнить.
  • Если установлен флаг Подключаться сразу после применения параметров, то при указании новых параметров соединения старое соединение разрывается и устанавливается новое в соответствии с указанными параметрами. В противном случае новое соединение будет установлено только после перезапуска системы IndorGIS.
  • При задании параметров подключения можно воспользоваться мастером подключения, который открывается кнопкой Мастер подключения… На закладке Подключение можно выбрать сервер и существующую базу данных, ввести имя пользователя и пароль, а также сразу проверить подключение с указанными параметрами.

Также в этом разделе:

Модель информационной системы

Понятие проекта, карты и слоя

Обзор рабочей области

Настройка панелей инструментов в системе IndorGIS

Настройка панелей инструментов для работы с системой IndorInfo/Power

Просмотр карты

Элементы диалоговых окон


Работа со слоями

В геоинформационной системе вся графическая информация на картах состоит из упорядоченной совокупности графических слоёв. В пределах одного слоя обычно объединяется семантически одинаковая в некотором смысле графическая информация. Послойная структура упрощает просмотр и анализ графической информации, а также позволяет работать только с теми данными, которые необходимы в текущий момент.

Также в этом разделе:

Типы слоёв

Понятие EX-шрифта, темы и слоя чертежа

Регистрация EX-шрифтов и тем

Создание и удаление слоёв

Представление слоёв шейп-файла и чертежа в дереве слоёв

Изменение места хранения слоя

Добавление слоёв в карту

Объединение слоёв в папки

Порядок отрисовки слоёв

Сохранение и перезагрузка данных слоя

Совместная работа нескольких пользователей с одним слоем

Редактирование внутренних атрибутов слоя

Визуализация слоёв


Работа со слоями. Типы слоёв

Работа со слоями

Типы слоёв

Геоинформационная система IndorGIS поддерживает возможность работы с различными типами слоёв. Ниже перечислены те из них, которые используются при работе с информационной системой IndorInfo/Power:

  • Слой шейп-файла. Слой векторной нетопологической графики бывает трёх основных типов: точек, полилиний и полигонов. Соответствующие слои карты называются точечными, линейными или полигональными (площадными). Объекты точечного слоя представляют собой точки, имеющие две координаты. Объекты линейного слоя представляют одну или несколько ломаных на плоскости, а объекты полигонального слоя - один или несколько полигонов на плоскости. В информационной системе эти слои используются в основном для представления топоосновы (рельеф, здания, проезжие части, мосты, озеленение, водоёмы), а также для представления прочих инженерных сетей, линий электропередачи, абонентов и т.д.
  • Слой чертежа. САПРовский слой векторной графики предназначен для создания сложных графических изображений, таких как технологические схемы, а также для создания элементов карт, не представимых точками, линиями и полигонами, например привязок коммуникаций к зданиям. Объектами слоя чертежа могут быть размерные линии, условные обозначения различного оборудования, произвольные полигоны, линии, кривые, надписи. В информационной системе эти слои используются для разметки кабельных и воздушных линий электропередачи, разметки планов подстанций, электрических схем, а также внутренней планировки цехов, оборудования.
  • Слой растра. Этот слой предназначен для представления растровой подложки на карте и векторизации фотографий, сканированных изображений карт, схем и т.д.
  • Слой рамки. Рамка оформления предназначена для подготовки карт и чертежей к печати. С помощью этого слоя можно задать стандартное оформление карт и чертежей стандартных масштабов.
  • Папка слоёв. Предназначена для объединения некоторой группы слоёв вместе для удобства их совместной манипуляции, например для включения и отключения видимости всех слоёв, входящих в папку.

Также в этом разделе:

Понятие EX-шрифта, темы и слоя чертежа

Регистрация EX-шрифтов и тем

Создание и удаление слоёв

Представление слоёв шейп-файла и чертежа в дереве слоёв

Изменение места хранения слоя

Добавление слоёв в карту

Объединение слоёв в папки

Порядок отрисовки слоёв

Сохранение и перезагрузка данных слоя

Совместная работа нескольких пользователей с одним слоем

Редактирование внутренних атрибутов слоя

Визуализация слоёв


Работа со слоями. Понятие EX-шрифта, темы и слоя чертежа

Работа со слоями

Понятие EX-шрифта, темы и слоя чертежа

Система IndorGIS предоставляет широкие возможности для изображения различных элементов схем электрических сетей. Для этого используются библиотеки элементов, называемые EX-шрифты. EX-шрифт хранит в себе векторные изображения элементов и может быть легко изменён и дополнен с помощью встроенного редактора элементов.

Для изображения схем в различных отраслях требуются разные наборы элементов, поэтому из необходимых для данной отрасли элементов EX-шрифтов формируют список элементов, называемый Тема, который может содержать символы из различных EX-шрифтов.

Замечание
При обычной установке системы IndorInfo/Power EX-шрифт с символами электрических сетей копируется в папку Program Files/IndorSoft/ ExFonts (он называется Символы электрических сетей.xfs), а тема для создания электрических схем копируется в папку Program Files/ IndorSoft/Themes (она называется Тема электрические сети.gst).

Слои чертежа в системе IndorGIS создаются на основе некоторой темы. Содержимое темы определяет, какие элементы могут присутствовать в слое, созданном на её основе. Например, для того чтобы нарисовать электрическую схему, достаточно создать слой чертежа на основе темы, содержащей список элементов электрических сетей. В дальнейшем будем называть такой слой Слой электрической схемы.

В теме элементы объединяются в группы (линии, трансформаторы, коммутаторы и т.д.) и для каждого элемента хранится список его атрибутов. Ниже на рисунке показана структура темы для создания электрических схем.

В списке справа содержатся все типы элементов, которые может содержать слой схемы, слева показан список групп, на которые разбиты элементы, а в центре - содержание выделенной группы.

Тема Электрические сети

Замечания
  1. В теме хранится не сам элемент EX-шрифта, а ссылка на него. Поэтому при изменении вида элемента в EX-шрифте он автоматически изменяется во всех слоях, созданных на основе этой темы. Таким образом, чертёж ссылается на тему, а тема, в свою очередь, на EX-шрифт.
  2. Каждая тема имеет внутреннее название, которое должно быть зарегистрировано в системе IndorGIS, причём в списке зарегистрированных тем не может быть повторяющихся названий. При попытке зарегистрировать тему с тем же именем, которое уже было зарегистрировано в системе, предыдущая тема удаляется из списка зарегистрированных. Таким образом, разные темы (физически хранящиеся в разных файлах), ссылающиеся на разные EX-шрифты, могут иметь одинаковые внутренние имена. Но слой чертежа, ссылающийся на тему с данным именем, будет отображаться в зависимости от того, какая тема в данный момент зарегистрирована в системе.

На рисунке показаны фрагменты двух схем, нарисованных в слоях чертежа, которые созданы на основе темы Электрические сети.

Примеры схем

Здесь изображён чертёж опоры ЛЭП, нарисованный в слое чертежа, который создан на основе темы Тема простых чертежей.

Чертёж опоры

Также в этом разделе:

Типы слоёв

Регистрация EX-шрифтов и тем

Создание и удаление слоёв

Представление слоёв шейп-файла и чертежа в дереве слоёв

Изменение места хранения слоя

Добавление слоёв в карту

Объединение слоёв в папки

Порядок отрисовки слоёв

Сохранение и перезагрузка данных слоя

Совместная работа нескольких пользователей с одним слоем

Редактирование внутренних атрибутов слоя

Визуализация слоёв


Работа со слоями. Регистрация EX-шрифтов и тем

Работа со слоями

Регистрация EX-шрифтов и тем

Для создания слоя на основе некоторой темы необходимо, чтобы эта тема была зарегистрирована в системе, а также EX-шрифт (или несколько EX-шрифтов), на элементы которого ссылается тема.

Также в этом разделе:

Регистрация тем

Регистрация EX-шрифтов


Регистрация EX-шрифтов и тем. Регистрация тем

Регистрация EX-шрифтов и тем

Регистрация тем

Список всех зарегистрированных в системе тем можно просмотреть, выполнив команду меню Файл| [image] Темы| [image] Открыть из реестра…

Список зарегистрированных тем

Чтобы зарегистрировать новую тему в системе, нажмите кнопку [image] Добавить тему в список зарегистрированных… и в появившемся диалоговом окне открытия файла выберите файл темы. Темы хранятся в файлах с расширением *.gst.

Для удаления темы из реестра выделите её в списке и нажмите кнопку [image] Удалить тему из списка зарегистрированных.

Также в этом разделе:

Регистрация EX-шрифтов


Регистрация EX-шрифтов и тем. Регистрация EX-шрифтов

Регистрация EX-шрифтов и тем

Регистрация EX-шрифтов

Список всех зарегистрированных в системе EX-шрифтов отображается в окне, которое открывается командой меню Файл| [image] EX-шрифты| [image] Открыть из реестра…

Список зарегистрированных EX-шрифтов

Чтобы зарегистрировать новый EX-шрифт в системе, выполните команду меню Файл| [image] EX-шрифты| [image] Зарегистрировать… и в появившемся диалоговом окне открытия файла выберите файл шрифта.

Для удаления EX-шрифта из реестра выполните команду меню Файл| [image] EX-шрифты| [image] Удалить из реестра…, в появившемся диалоговом окне выделите нужный шрифт и нажмите кнопку Удалить.

Замечание
При установке системы IndorInfo/Power с дистрибутива необходимые для рисования схем тема и EX-шрифт автоматически регистрируются в системе.

Также в этом разделе:

Регистрация тем


Работа со слоями. Создание и удаление слоёв

Работа со слоями

Создание и удаление слоёв

Чтобы создать новый слой в карте, выберите пункт главного меню Слой| [image] Создать новый слой или нажмите кнопку [image] Создать новый слой на панели инструментов Power Слои. Появится список со всеми типами слоёв, которые могут быть созданы в системе IndorGIS. В нём нужно выбрать тип создаваемого слоя.

Выбор типа создаваемого слоя

Также в этом разделе:

Создание слоёв шейп-файла

Создание слоёв чертежа

Удаление слоёв


Создание и удаление слоёв. Создание слоёв шейп-файла

Создание и удаление слоёв

Создание слоёв шейп-файла

Для создания слоя шейп-файла выберите в этом списке один из пунктов: Слой точек, [image] Слой полилиний или [image] Слой полигонов. Откроется диалоговое окно, в котором нужно указать место хранения слоя:

  • В файле проекта.
  • В отдельном файле. В этом случае нужно ввести в поле путь к файлу и имя файла, в который будет сохранён слой, или указать файл в диалоговом окне, открывающемся при нажатии кнопки [image]. Слои шейп-файла имеют расширение *.shp.

Создание слоя шейп-файла

При нажатии кнопки ОК в карте создается новый слой.

Также в этом разделе:

Создание слоёв чертежа

Удаление слоёв


Создание и удаление слоёв. Создание слоёв чертежа

Создание и удаление слоёв

Создание слоёв чертежа

Для создания слоя чертежа укажите в списке выбора типа слоя пункт [image] Слой чертежа. Откроется диалоговое окно, где нужно указать:

  • Тему, на основе которой должен быть создан новый слой. Для создания слоя электрической схемы выберите тему Электрические сети.
Замечание
Список в центре окна содержит все зарегистрированные в системе темы. Если в нём нет нужной темы, зарегистрируйте её, нажав кнопку [image] Добавить тему в список зарегистрированных…
  • Место хранения слоя: В файле проекта или В отдельном файле чертежа. Слои чертежей сохраняются в файлы с расширением *.gsh.

Создание слоя чертежа

При нажатии кнопки ОК в карте создаётся новый слой.

Замечания
  1. Слой нужно сохранять в отдельном файле, если данные слоя могут быть использованы в других картах, а также если слой будет редактироваться несколькими пользователями.
  2. При повреждении файла проекта данные слоёв, хранящиеся в этом файле, нельзя будет восстановить.
  3. Если слой, сохранённый в файле проекта, содержит большие объёмы информации, то это может привести к долгой загрузке проекта и медленной работе.

Также в этом разделе:

Создание слоёв шейп-файла

Удаление слоёв


Создание и удаление слоёв. Удаление слоёв

Создание и удаление слоёв

Удаление слоёв

Для удаления слоя карты выделите его в дереве слоёв и выполните команду меню Слой| [image] Удалить слой.

Замечание
Если слой сохранён в отдельном файле, то эта команда удаляет только слой карты, а файл слоя на диске не удаляется.

Также в этом разделе:

Создание слоёв шейп-файла

Создание слоёв чертежа


Работа со слоями. Представление слоёв шейп-файла и чертежа в дереве слоёв

Работа со слоями

Представление слоёв шейп-файла и чертежа в дереве слоёв

Слои шейп-файла в дереве слоёв представляются следующими элементами:

  • Флаг видимости легенды слоя. Щелчок мыши на знак [image] или [image] позволяет включать/отключать видимость легенды слоя в дереве слоёв.
  • Флаг видимости слоя. Флажками отмечаются те слои, которые в настоящий момент отображаются на карте. Флажок видимости устанавливается/снимается щелчком мыши.
  • Значок типа слоя. Этот значок показывает тип слоя (точечный, линейный, площадной и пр.).
  • Название слоя. Его можно изменить непосредственно в дереве слоёв. Для этого выделите слой, щёлкнув мышью на его названии, а затем ещё раз щёлкните мышью - надпись перейдёт в режим редактирования.
  • Папка. Таким значком отображаются папки слоёв. Если отключить флаг видимости у папки, то станут невидимыми все слои, входящие в папку.
  • Легенда слоя. Обычно в легенде слоя отображается условный знак или их совокупность, которой слой отображается на карте. Если для слоя задано несколько визуализаторов, то легенда может состоять из нескольких частей со своими значками.

Ниже на рисунке показана легенда слоя Опоры. Для этого слоя задано два визуализатора: визуализация подписями и единообразная визуализация (см. подробнее). Оба визуализатора отображаются в легенде слоя.

Легенда слоя с двумя визуализаторами

В легенде слоя чертежа отображаются все элементы, которые можно создать в этом слое. Они объединены в группы в соответствии со структурой, заданной в теме.

Легенда слоя электрической схемы

Рядом с каждой группой имеется знак [image] или [image], позволяющий раскрыть или скрыть содержимое группы.

Флажками [image] в дереве объектов отмечаются те элементы и группы элементов, которые в настоящий момент отображаются на карте. Флажок видимости устанавливается/снимается щелчком мыши.

Также в этом разделе:

Типы слоёв

Понятие EX-шрифта, темы и слоя чертежа

Регистрация EX-шрифтов и тем

Создание и удаление слоёв

Изменение места хранения слоя

Добавление слоёв в карту

Объединение слоёв в папки

Порядок отрисовки слоёв

Сохранение и перезагрузка данных слоя

Совместная работа нескольких пользователей с одним слоем

Редактирование внутренних атрибутов слоя

Визуализация слоёв


Работа со слоями. Изменение места хранения слоя

Работа со слоями

Изменение места хранения слоя

Откройте окно свойств слоя, выполнив команду меню Слой| [image] Свойства… или нажав кнопку [image] Свойства слоя… на панели инструментов Power Слои. Информация о том, где сохранён слой, отображается на закладке Общие.

Иногда бывает необходимо изменить место хранения слоя. К примеру, если слой сохранён в файле проекта и выяснилось, что его нужно использовать в нескольких картах, то предварительно придётся сохранить его в отдельном файле.

Свойства слоя (закладка Общие)

Чтобы сохранить существующий слой, хранящийся в файле проекта, в отдельном файле, выполните команду меню Слой| [image] Сохранить как…

Можно выполнить и обратную операцию: если слой сохранён в отдельном файле, то его можно сохранить в файле проекта, выполнив команду меню Слой| [image] Сохранить в проекте. При этом файл слоя не удалится, а останется на диске.

Также в этом разделе:

Типы слоёв

Понятие EX-шрифта, темы и слоя чертежа

Регистрация EX-шрифтов и тем

Создание и удаление слоёв

Представление слоёв шейп-файла и чертежа в дереве слоёв

Добавление слоёв в карту

Объединение слоёв в папки

Порядок отрисовки слоёв

Сохранение и перезагрузка данных слоя

Совместная работа нескольких пользователей с одним слоем

Редактирование внутренних атрибутов слоя

Визуализация слоёв


Работа со слоями. Добавление слоёв в карту

Работа со слоями

Добавление слоёв в карту

Если слой сохранён в отдельном файле, то его можно добавить в другую карту или сразу несколько карт. Для этого выполните команду меню Слой| [image] Добавить слой… или нажмите кнопку [image] Добавить слой карты… на панели инструментов Power Слои и в диалоговом окне открытия файла выберите файл с нужным слоем.

Замечания
  1. При добавлении слоя в карту место хранения файла слоя на диске не меняется. Поэтому если один слой добавлен в несколько карт, значит, его данные одновременно используются в этих картах. Порядок совместного использования слоя рассматривается ниже (см. подробнее).
  2. Если добавленный слой не должен использоваться одновременно в нескольких картах, т.е. он будет редактироваться отдельно в данной карте, сохраните его в другом файле, выполнив команду меню
    Слой| [image] Сохранить как…

Также в этом разделе:

Типы слоёв

Понятие EX-шрифта, темы и слоя чертежа

Регистрация EX-шрифтов и тем

Создание и удаление слоёв

Представление слоёв шейп-файла и чертежа в дереве слоёв

Изменение места хранения слоя

Объединение слоёв в папки

Порядок отрисовки слоёв

Сохранение и перезагрузка данных слоя

Совместная работа нескольких пользователей с одним слоем

Редактирование внутренних атрибутов слоя

Визуализация слоёв


Работа со слоями. Объединение слоёв в папки

Работа со слоями

Объединение слоёв в папки

При наличии большого количества слоёв в карте удобно объединять их в папки. Это, во-первых, позволяет структурировать слои определённым образом, чтобы было проще среди них ориентироваться, а во-вторых, упрощает их совместную манипуляцию, например включение или отключение видимости всех слоёв, входящих в папку.

Рассмотрим для примера карту, в которой представлен подробный план местности, трассы линий электропередачи и планы подстанций. Слои этой карты могут быть объединены в три папки: "Топооснова" - слои, представляющие план местности, "Подстанции" - слои, в которых нарисованы планы подстанций, и "Линии" - слои, в которых нарисованы трассы линий электропередачи.

Объединить слои в папку можно двумя способами:

  • Создать новую папку, а затем переместить в неё нужные слои.

Для создания папки выполните команду меню Слой| [image] Создать новый слой| [image] Папку слоёв или нажмите кнопку [image] Создать новую пустую папку на панели инструментов Power Слои. В появившемся диалоговом окне свойств папки введите имя новой папки.

Задание имени новой папки

Переместите нужные слои в эту папку. Для этого нажмите кнопку мыши на слое и, удерживая её нажатой, переместите указатель мыши внутрь папки, после чего отпустите кнопку.

Перемещение слоёв в папку

  • Выделить несколько слоев, а затем выполнить команду объединения этих слоёв в новую папку.

Объединение выделенных слоёв в новую папку

Удерживая нажатой клавишу Ctrl, выделите нужные слои в дереве слоёв. Выполните команду меню Слой| [image] Создать новый слой| [image] Объединить в папку и в появившемся диалоговом окне свойств папки введите имя новой папки. В результате создаётся новая папка и в неё перемещаются выделенные слои.

Также в этом разделе:

Типы слоёв

Понятие EX-шрифта, темы и слоя чертежа

Регистрация EX-шрифтов и тем

Создание и удаление слоёв

Представление слоёв шейп-файла и чертежа в дереве слоёв

Изменение места хранения слоя

Добавление слоёв в карту

Порядок отрисовки слоёв

Сохранение и перезагрузка данных слоя

Совместная работа нескольких пользователей с одним слоем

Редактирование внутренних атрибутов слоя

Визуализация слоёв


Работа со слоями. Порядок отрисовки слоёв

Работа со слоями

Порядок отрисовки слоёв

Слои отображаются на карте в порядке их следования в дереве слоёв: самый нижний слой в дереве отрисовывается первым, а самый верхний - последним, т.е. объекты слоёв, расположенных в дереве выше, перекрывают нижние слои. Поэтому важно правильно установить порядок слоёв в дереве. Менять положение слоёв в дереве можно, перетаскивая их с помощью мыши или воспользовавшись командами в меню Слой| [image] Переместить слой.

Для примера рассмотрим слои, представляющие планы подстанций. Ниже на рисунках приведён пример ситуации, когда слой Контуры подстанций расположен в дереве слоёв выше, чем слои Здания, Площадки и Коммутаторы. Поэтому на карте объекты этих слоёв перекрываются изображением контура подстанции.

Положение слоёв в дереве и соответствующее отображение на карте

Изменим порядок слоёв в дереве, переместив слой Контуры подстанций ниже всех слоёв в папке Подстанции.

Положение слоёв в дереве после перемещения и соответствующее отображение на карте

Для этого нажмите кнопку мыши на слое и, удерживая её, перетащите слой на нужную позицию или воспользуйтесь командами [image] Вверх, [image] Вниз в меню Слой| [image] Переместить слой.

Также в этом разделе:

Типы слоёв

Понятие EX-шрифта, темы и слоя чертежа

Регистрация EX-шрифтов и тем

Создание и удаление слоёв

Представление слоёв шейп-файла и чертежа в дереве слоёв

Изменение места хранения слоя

Добавление слоёв в карту

Объединение слоёв в папки

Сохранение и перезагрузка данных слоя

Совместная работа нескольких пользователей с одним слоем

Редактирование внутренних атрибутов слоя

Визуализация слоёв


Работа со слоями. Сохранение и перезагрузка данных слоя

Работа со слоями

Сохранение и перезагрузка данных слоя

По окончании сеанса работы с проектом, а также периодически в процессе редактирования данных необходимо сохранять произведённые изменения.

Можно сохранить весь проект, выполнив команду меню Файл| [image] Сохранить проект или нажав кнопку [image] Сохранить проект на панели инструментов Power Проекты, а можно сохранить данные только одного или нескольких слоёв, которые редактировались в текущий сеанс работы. Чтобы сохранить данные одного слоя, выполните команду меню Слой| [image] Сохранить или нажмите кнопку [image] Сохранить данные текущего слоя на панели инструментов Power Слои.

Если в процессе редактирования в слое были выполнены нежелательные изменения, которые необходимо отменить, выполните команду меню Слой| [image] Перезагрузить. Она возвращает данные слоя в то состояние, которое было при последнем сохранении.

Также в этом разделе:

Типы слоёв

Понятие EX-шрифта, темы и слоя чертежа

Регистрация EX-шрифтов и тем

Создание и удаление слоёв

Представление слоёв шейп-файла и чертежа в дереве слоёв

Изменение места хранения слоя

Добавление слоёв в карту

Объединение слоёв в папки

Порядок отрисовки слоёв

Совместная работа нескольких пользователей с одним слоем

Редактирование внутренних атрибутов слоя

Визуализация слоёв


Работа со слоями. Совместная работа нескольких пользователей с одним слоем

Работа со слоями

Совместная работа нескольких пользователей с одним слоем

Слой, хранящийся в отдельном файле и добавленный в несколько проектов, может редактироваться разными пользователями на своих рабочих местах.

В один момент времени редактировать слой может только один пользователь. Для всех остальных пользователей в этот момент слой будет закрыт от изменений: в нём будут недоступны команды создания и редактирования объектов, а также команда сохранения слоя. Когда пользователь закончит редактирование слоя и сохранит изменения, он должен выполнить команду меню Слой| [image] Завершить редактирование слоя или нажать соответствующую кнопку на панели инструментов Power Слои. После этого другой пользователь на своём рабочем месте может начать редактирование "освобождённого" слоя. Для этого ему необходимо выполнить команду меню Слой| [image] Начать редактирование слоя или нажать соответствующую кнопку на панели инструментов Power Слои.

Замечание
Когда пользователь, редактирующий слой, сохраняет изменения, у других пользователей появляется сообщение о том, что слой был изменён. В этом диалоге следует указать, нужно ли перезагрузить слой в соответствии с внесёнными в него другим пользователем изменениями.

Также в этом разделе:

Типы слоёв

Понятие EX-шрифта, темы и слоя чертежа

Регистрация EX-шрифтов и тем

Создание и удаление слоёв

Представление слоёв шейп-файла и чертежа в дереве слоёв

Изменение места хранения слоя

Добавление слоёв в карту

Объединение слоёв в папки

Порядок отрисовки слоёв

Сохранение и перезагрузка данных слоя

Редактирование внутренних атрибутов слоя

Визуализация слоёв


Работа со слоями. Редактирование внутренних атрибутов слоя

Работа со слоями

Редактирование внутренних атрибутов слоя

В системе IndorGIS слой шейп-файла (точек, линий или полигонов) имеет набор внутренних атрибутов, который хранится непосредственно в слое. Объекты слоя характеризуются значениями атрибутов из набора.

Список внутренних атрибутов слоя можно просмотреть в окне настройки свойств слоя (команда меню Слой| [image] Свойства слоя…) на закладке Атрибуты. Кнопки Выше и Ниже предназначены для перемещения атрибутов в списке (на одну позицию выше или ниже).

Список внутренних атрибутов слоя

Чтобы удалить атрибут, выделите его в списке и нажмите кнопку Удалить.

Для создания в слое нового атрибута нажмите кнопку Добавить… и в появившемся окне Параметры атрибута введите имя атрибута, выберите его тип, а затем задайте размер атрибута.

Это окно появляется также при нажатии кнопки Свойства… В нём можно изменить введённые ранее свойства атрибута.

Редактирование свойств атрибута

Атрибуты могут быть четырёх типов в зависимости от типов значений, которые они могут принимать:

  • Если значениями атрибута являются числа, то тип атрибута - Численный. Размер атрибута определяет количество знаков до и после запятой.
  • Если значениями атрибута являются строки, то тип атрибута - Строка. Размер атрибута определяет максимальное количество символов в строке.
  • Если атрибут может принимать только два значения - "да" или "нет", то тип атрибута - Логический.
  • Если значения атрибута - это даты, то тип атрибута - Дата.

Редактирование значений атрибутов в инспекторе объектов

Чтобы задать значение атрибута для конкретного объекта, выделите объект, откройте инспектор объектов (команда меню Вид| [image] Инспектор объектов) и на закладке Атрибуты введите значение.

Также в этом разделе:

Типы слоёв

Понятие EX-шрифта, темы и слоя чертежа

Регистрация EX-шрифтов и тем

Создание и удаление слоёв

Представление слоёв шейп-файла и чертежа в дереве слоёв

Изменение места хранения слоя

Добавление слоёв в карту

Объединение слоёв в папки

Порядок отрисовки слоёв

Сохранение и перезагрузка данных слоя

Совместная работа нескольких пользователей с одним слоем

Визуализация слоёв


Работа со слоями. Визуализация слоёв

Работа со слоями

Визуализация слоёв

Объекты шейп-слоёв отображаются на карте с помощью так называемых визуализаторов - специальных алгоритмов, отрисовывающих точки, линии и полигоны в соответствии с определёнными настройками и в зависимости от задаваемых атрибутов.

Каждому слою может быть сопоставлено любое количество визуализаторов, что позволяет комбинированно отображать на карте сразу несколько параметров объектов. Например, для слоя опор на карте местности можно разными условными знаками отобразить разные типы опор, а затем подписями показать номера опор.

Также в этом разделе:

Создание и удаление визуализаторов

Настройка единообразной визуализации

Настройка условной визуализации

Настройка визуализации подписями

Перемещение подписей у отдельных объектов

Сохранение и загрузка настроек визуализаторов


Визуализация слоёв. Создание и удаление визуализаторов

Визуализация слоёв

Создание и удаление визуализаторов

Список визуализаторов, заданных для слоя, можно просмотреть в окне настройки свойств слоя (команда меню Слой| [image] Свойства слоя…) на закладке Визуализация.

По умолчанию в каждом новом слое создаётся один визуализатор, который называется Единообразная визуализация. Он отрисовывает все объекты слоя одним условным знаком (см. подробнее).

Список визуализаторов слоя

Чтобы создать в слое новый визуализатор, нажмите кнопку Добавить… и в появившемся диалоговом окне выберите тип создаваемого визуализатора.

Выбор типа визуализатора

Аналогичное окно появляется для выделенного в списке визуализатора при нажатии кнопки Изменить… В нём можно изменить тип уже созданного визуализатора.

Кнопка Настроить… открывает окно, в котором указываются параметры выделенного визуализатора. Параметры настройки для разных типов визуализаторов рассматриваются ниже. Для удаления визуализатора воспользуйтесь кнопкой Удалить.

По умолчанию к слою одновременно применяются все заданные для него визуализаторы. Например, если для слоя опор задана единообразная и условная визуализации, то на карте опоры отображаются двумя условными знаками, соответствующими обоим визуализаторам.

Поэтому если необходимо показать только условную отрисовку опор, отключите единообразную визуализацию, и наоборот, если все опоры нужно отображать одинаково, отключите условную визуализацию.

Отключение видимости визуализаторов

Визуализаторы отрисовываются на карте в порядке их следования в легенде слоя: самый нижний визуализатор отрисовывается первым, а самый верхний - последним. Если какие-то визуализаторы должны применяться одновременно и могут перекрывать друг друга, то нужно правильно настроить порядок их отрисовки. Порядок визуализаторов можно менять в легенде слоя или в окне свойств слоя на закладке Визуализация, перемещая их с помощью мыши.

Также в этом разделе:

Настройка единообразной визуализации

Настройка условной визуализации

Настройка визуализации подписями

Перемещение подписей у отдельных объектов

Сохранение и загрузка настроек визуализаторов


Визуализация слоёв. Настройка единообразной визуализации

Визуализация слоёв

Настройка единообразной визуализации

Рассмотрим самый простой способ отображения данных - единообразную визуализацию, которая отрисовывает все объекты слоя одним условным знаком. При создании слоя ему задаются определённые параметры единообразной визуализации, а соответствующий условный знак отображается в легенде слоя.

Отображение единообразной визуализации в легенде слоя

Чтобы настроить параметры единообразной визуализации, выделите её в списке визуализаторов в окне свойств слоя и нажмите кнопку Настроить… или дважды щёлкните на соответствующем условном знаке в легенде слоя. Параметры единообразной визуализации для точечных, линейных и полигональных слоёв отличаются, поэтому рассмотрим их отдельно.

Для точек можно задать тип метки (кружок, квадрат, треугольник и т.д.), размер метки, цвет контура и заливки, угол поворота символа. При нажатии кнопки Специальный символ… открывается диалоговое окно, где можно выбрать стиль точки в одном из EX-шрифтов символов, зарегистрированных в системе.

Параметры единообразной визуализации точек

Для линий можно задать тип линии (сплошная, тире, точка-тире и т.д.), цвет и толщину линии. При нажатии кнопки Специальная линия… открывается диалоговое окно, где можно выбрать стиль линии в одном из EX-шрифтов линий, зарегистрированных в системе.

Параметры единообразной визуализации линий

Для полигонов можно задать тип линии контура объекта (сплошная, тире, точка-тире и т.д.), цвет и толщину контура, выбрать тип заливки полигона (сплошная, штриховка в определённом направлении или текстура) и цвет заливки. Если в качестве заливки выбрана штриховка, то можно задать её цвет фона (поле Фон), а если текстура - то можно выбрать одну из стандартных текстур, предусмотренных в системе (поле Текстура). Заливка полигона может отображаться на карте полупрозрачной, для этого нужно установить флаг Полупрозрачная заливка.

При нажатии кнопки Специальная заливка… открывается диалоговое окно, где можно выбрать стиль заливки полигона в одном из EX-шрифтов полигонов, зарегистрированных в системе.

Параметры единообразной визуализации полигонов

Масштабируемость условных знаков

Большинство визуализаторов векторных данных и условных знаков бывают масштабируемыми или нет. Если они масштабируются, то при увеличении масштаба карты пропорционально увеличиваются и отображаемые на экране размеры условных знаков, если не масштабируются - то их размер на экране всегда одинаковый независимо от текущего масштаба карты.

Чтобы визуализатор был масштабируемым, установите флаг в разделе Масштабируемость. В поле Базовый масштаб введите такой масштаб карты, при котором условный знак будет на экране как раз указанного в параметрах размера.

Также в этом разделе:

Создание и удаление визуализаторов

Настройка условной визуализации

Настройка визуализации подписями

Перемещение подписей у отдельных объектов

Сохранение и загрузка настроек визуализаторов


Визуализация слоёв. Настройка условной визуализации

Визуализация слоёв

Настройка условной визуализации

Условная визуализация позволяет отображать объекты слоя разными условными знаками в зависимости от значения какого-либо атрибута. Например, опоры линий электропередачи могут отображаться разными условными знаками в зависимости от того, из какого материала они изготовлены (металл, железобетон, дерево и т.д.).

Чтобы настроить для слоя условную визуализацию, создайте новый визуализатор, выберите его тип - Условная визуализация, и откройте окно настройки (см. подробнее).

  1. Из выпадающего списка Атрибут для классификации выберите тот атрибут, по значениям которого нужно классифицировать объекты. Список содержит все атрибуты слоя: внутренние и подключенные (или внешние).
Замечание
Если нужного атрибута нет в списке, подключите к слою набор данных, содержащий этот атрибут (см. подробнее).
  2. Нажмите кнопку Классифицировать. Она автоматически формирует список всех уникальных значений выбранного атрибута у объектов слоя.
  3. Если нужно добавить в классификацию значение атрибута, которое пока не задано ни для одного объекта слоя, но его использование предполагается, нажмите кнопку Добавить и укажите новое значение атрибута в поле Значение. Кнопка Удалить позволяет удалить выделенное в списке значение атрибута.
  4. В поле Описание введите текст, который будет показываться для значения атрибута в легенде слоя.

Параметры условной визуализации

  5. Задайте для каждого значения в классификации условный знак, которым он будет отображаться на карте. Для этого выделите значение и нажмите кнопку Изменить символ… или дважды щёлкните на изображении условного знака.
  6. Те объекты, для которых не определено значение атрибута классификации, отображаются условным знаком, заданным в поле Другие.

Условная визуализация опор по виду материала

На рисунке показан фрагмент карты: опоры, изготовленные из разных материалов, отображаются на карте условными знаками, заданными в окне настройки условной визуализации.

Также в этом разделе:

Создание и удаление визуализаторов

Настройка единообразной визуализации

Настройка визуализации подписями

Перемещение подписей у отдельных объектов

Сохранение и загрузка настроек визуализаторов


Визуализация слоёв. Настройка визуализации подписями

Визуализация слоёв

Настройка визуализации подписями

Визуализация подписями позволяет выводить рядом с объектами слоя некоторую надпись. Можно выводить определённую надпись у всех объектов слоя или значение некоторого атрибута, например, рядом с изображением опор - их номера.

Чтобы настроить для слоя визуализацию подписями, создайте новый визуализатор, выберите его тип - Визуализация подписями, и откройте окно настройки (см. подробнее).

  1. Из выпадающего списка Текст подписи выберите атрибут, значение которого будет выводиться в качестве подписи. Список содержит все атрибуты слоя: внутренние и подключенные (или внешние).
Замечание
Если нужного атрибута нет в списке, подключите к слою набор данных, содержащий этот атрибут (см. подробнее).
  2. В поле Текст в легенде введите поясняющий текст, отображаемый для этого визуализатора в легенде слоя.
  3. Выберите в списке Положение способ расположения подписи относительно объекта.
  4. Укажите параметры подписи: шрифт, размер, цвет.

Параметры визуализации подписями

Ниже на рисунке показан фрагмент карты: рядом с изображением опор подписаны их номера.

Вывод номеров опор на карту

Также в этом разделе:

Создание и удаление визуализаторов

Настройка единообразной визуализации

Настройка условной визуализации

Перемещение подписей у отдельных объектов

Сохранение и загрузка настроек визуализаторов


Визуализация слоёв. Перемещение подписей у отдельных объектов

Визуализация слоёв

Перемещение подписей у отдельных объектов

В окне настройки визуализации подписями можно задать точное положение подписи относительно всех объектов слоя, например сверху или снизу относительно точки. В этом разделе рассмотрим, каким образом можно перемещать подписи индивидуально у каждого объекта.

  1. Создайте два новых атрибута в слое, например DX и DY, тип атрибутов - численный (см. подробнее). Эти атрибуты будут содержать значения смещений подписи относительно объекта по X и Y.

Создание новых атрибутов

  2. В окне настройки визуализации подписями выберите в списках Смещение от подписываемого объекта по X и по Y новые атрибуты, определяющие смещение.

Выбор атрибутов для смещения подписи

  3. Выделите визуализатор подписями в легенде слоя и включите режим [image] Редактирование подписей визуализатора на панели Power Режимы общие.

Включение режима перемещения подписей
  4. Выделите нужную подпись и переместите её.

Перемещение подписи

Также в этом разделе:

Создание и удаление визуализаторов

Настройка единообразной визуализации

Настройка условной визуализации

Настройка визуализации подписями

Сохранение и загрузка настроек визуализаторов


Визуализация слоёв. Сохранение и загрузка настроек визуализаторов

Визуализация слоёв

Сохранение и загрузка настроек визуализаторов

Параметры визуализатора могут быть сохранены в файл для дальнейшего использования, например, чтобы применить их к слою в другой карте.

Откройте окно свойств слоя (команда меню Слой| [image] Свойства…) и перейдите на закладку Визуализация. Для сохранения настроек визуализатора в файл выделите в списке нужный визуализатор, нажмите кнопку Сохранить… и в диалоговом окне сохранения файла введите имя файла. Настройки визуализатора сохраняются в файл с расширением *.rnd.

Список визуализаторов слоя

Чтобы применить к слою параметры визуализации из файла, нажмите кнопку Загрузить… и в диалоговом окне открытия файла выберите нужный файл. В результате к слою будет добавлен новый визуализатор и к нему применятся сохранённые в файле настройки.

Также в этом разделе:

Создание и удаление визуализаторов

Настройка единообразной визуализации

Настройка условной визуализации

Настройка визуализации подписями

Перемещение подписей у отдельных объектов


Технология рисования в системе IndorGIS. Режим создания новых фигур

Технология рисования в системе IndorGIS

Режим создания новых фигур

В зависимости от типа слоя (точки, линии, полигоны и т.д.) он может содержать определённый набор типов фигур:

  • В слое точек могут присутствовать фигуры только одного типа: Точка.
  • В слое полилиний могут быть созданы фигуры [image] Отрезок, [image] Полилиния, [image] Прямоугольник, [image] Окружность, [image] Эллипс.
  • В слое площадных фигур (полигонов) - [image] Полигон, [image] Прямоугольник, [image] Круг, [image] Эллипс.
  • Набор элементов, которые можно создать в слое чертежа, определяется в теме (см. подробнее).

Создание новых фигур осуществляется в специальном режиме, которому соответствует кнопка на панели инструментов Power Режимы общие. Набор фигур, создаваемых в этом режиме, зависит от того, какой слой в данный момент является активным (т.е. выделен в дереве слоёв). Если в активном слое могут присутствовать фигуры нескольких типов, то кнопка содержит всплывающую панель инструментов.

Чтобы создать на карте новую фигуру, выделите нужный слой, а затем включите режим создания фигуры.

Также в этом разделе:

Создание точек, линий и полигонов

Режим редактирования фигур

Редактирование узловых точек

Привязка к сетке

Подтяжка фигур слоя

Операции с фигурамия

Создание и редактирование фигур, состоящих из нескольких контуров


Технология рисования в системе IndorGIS. Создание точек, линий и полигонов

Технология рисования в системе IndorGIS

Создание точек, линий и полигонов

Чтобы создать точку, щёлкните мышью в том месте на карте, где она должна находиться.

Создание точек

Линии и полигоны состоят из так называемых узловых точек, которые определяют форму фигуры. Процесс создания таких фигур заключается в последовательном вводе узловых точек (щелчками мыши). Ввод фигуры завершается нажатием правой кнопки мыши.

Создание линии

Чтобы очередной сегмент линии был перпендикулярен предыдущему, удерживайте в процессе построения нажатой клавишу Ctrl.

Создание линии с перпендикулярными сегментами

Построение произвольного полигона в режиме [image] Полигон аналогично созданию линии. Отличие состоит в том, что при построении полигона первая и последняя узловые точки всегда соединяются отрезком, поскольку полигон - замкнутая фигура.

В процессе ввода узловых точек линии или полигона можно вызвать контекстное меню. Для этого щёлкните правой кнопкой мыши, удерживая при этом нажатой клавишу Shift.

Контекстное меню при рисовании линии или полигона

По команде [image] Отменить ввод построенная фигура удаляется из карты. По команде [image] Закончить завершается построение фигуры. Чтобы исключить из фигуры последнюю введённую узловую точку, выполните команду [image] Удалить последнюю точку.

Для создания прямоугольников используйте режим [image] Прямоугольник. Выберите место на карте, где он будет находиться, затем нажмите кнопку мыши и, не отпуская её, растяните прямоугольник, после чего отпустите кнопку.

Создание прямоугольника

Также в этом разделе:

Режим создания новых фигур

Режим редактирования фигур

Редактирование узловых точек

Привязка к сетке

Подтяжка фигур слоя

Операции с фигурамия

Создание и редактирование фигур, состоящих из нескольких контуров


Технология рисования в системе IndorGIS. Режим редактирования фигур

Технология рисования в системе IndorGIS

Режим редактирования фигур

В режиме [image] Редактирование фигур можно менять форму, положение, размер фигур и выполнять различные операции с фигурами. Кнопка, соответствующая этому режиму, находится на панели инструментов Power Режимы общие.

Редактировать можно только выделенную фигуру. Чтобы выделить фигуру, включите режим редактирования фигур и щёлкните на ней мышью. Обратите внимание, что при этом должен быть активным слой, которому принадлежит выделяемая фигура.

Совет
Для определения, в каком слое находится фигура, можно использовать комбинацию клавиш Ctrl+Alt+Shift. Если щёлкать мышью на карте, удерживая нажатыми указанные клавиши, то будут перебираться все фигуры, над которыми находится мышь, и соответствующие им слои будут становиться активными.

Выделенная фигура находится в фазе редактирования узловых точек. В этом состоянии на ней визуализируются узловые точки и так называемые точки настройки. Точки настройки отображаются квадратами со знаком "+" внутри. В фазе редактирования узловых точек может находиться только одна фигура.

Фигура в фазе редактирования узловых точек

Перемещая узловые точки, можно производить коррекцию геометрии фигуры, а перемещая точки настройки, можно создавать новые узловые точки.

Перемещение узловой точки | Перемещение точки настройки

Если ещё раз щёлкнуть мышью на фигуре, которая находится в фазе редактирования узловых точек, то она перейдёт в фазу выполнения блочных операций.

Выделенный блок может состоять из нескольких фигур. Чтобы выделить несколько фигур, щёлкайте на них мышью, удерживая нажатой клавишу Shift.

Выделенный блок отрисовывается с пунктирным прямоугольником вокруг, а также со специальными управляющими точками. При перемещении круглых точек ( [image]) происходит вращение фигуры, при перемещении квадратных точек ( [image]) - растяжение/сжатие фигуры, а при перемещении прямоугольных точек ( [image]) меняется угол наклона фигуры.

Фигура в фазе выполнения блочных операций

Выделенный блок можно с помощью мыши синхронно перемещать по карте, "ухватив" за одну из фигур.

Также в этом разделе:

Режим создания новых фигур

Создание точек, линий и полигонов

Редактирование узловых точек

Привязка к сетке

Подтяжка фигур слоя

Операции с фигурамия

Создание и редактирование фигур, состоящих из нескольких контуров


Технология рисования в системе IndorGIS. Редактирование узловых точек

Технология рисования в системе IndorGIS

Редактирование узловых точек

В процессе редактирования узловых точек можно вызвать контекстное меню щелчком правой кнопки мыши. В подменю [image] Точки содержатся команды для редактирования узловых точек фигуры.

Команды контекстного меню для редактирования узловых точек

Также в этом разделе:

Создание узловой точки

Удаление узловой точки

Вставка промежуточных узловых точек

Сглаживание узловой точки окружностью

Удаление "лишних" узловых точек


Редактирование узловых точек. Создание узловой точки

Редактирование узловых точек

Создание узловой точки

Чтобы создать узловую точку в произвольном месте на контуре фигуры, подведите указатель мыши к этому месту и откройте контекстное меню. Выполните в подменю [image] Точки команду [image] Вставить точку.

Также в этом разделе:

Удаление узловой точки

Вставка промежуточных узловых точек

Сглаживание узловой точки окружностью

Удаление "лишних" узловых точек


Редактирование узловых точек. Удаление узловой точки

Редактирование узловых точек

Удаление узловой точки

Для удаления узловой точки подведите к ней указатель мыши, откройте контекстное меню и выполните в подменю [image] Точки команду [image] Удалить точку.

Также в этом разделе:

Создание узловой точки

Вставка промежуточных узловых точек

Сглаживание узловой точки окружностью

Удаление "лишних" узловых точек


Редактирование узловых точек. Вставка промежуточных узловых точек

Редактирование узловых точек

Вставка промежуточных узловых точек

Вдоль контура линии или полигона можно добавить произвольное количество дополнительных узловых точек. Эта операция может использоваться, например, для создания линии сложной формы: сначала можно нарисовать на карте отрезок, соединяющий начальную и конечную точки линии, затем добавить вдоль линии с определённым интервалом промежуточные узловые точки и после этого уточнить их положение.

Выделите на карте линию, к которой нужно добавить промежуточные узловые точки, откройте контекстное меню и выполните в подменю [image] Точки команду [image] Вставить промежуточные… В диалоговом окне введите значение Максимальная длина ребра. Промежуточные точки будут добавлены к фигуре таким образом, чтобы максимальная длина каждого сегмента не превышала заданного значения.

Параметры создания промежуточных точек

Если полилиния достаточно протяжённая, то при определённом значении длины ребра может оказаться, что количество промежуточных точек очень большое. В таком случае можно задать максимальное количество промежуточных точек, которые могут быть добавлены к фигуре. Для этого установите флаг Количество точек в фигуре не более и введите в поле максимальное число точек.

При нажатии кнопки ОК ко всем рёбрам фигуры, длина которых превышает заданное значение, добавляются промежуточные узловые точки. Они распределяются вдоль линии равномерно (т.е. сегменты линии, образованные промежуточными точками, имеют одинаковую длину). В данном примере длина каждого нового сегмента не превышает 3.

Добавление промежуточных точек к линии

Также в этом разделе:

Создание узловой точки

Удаление узловой точки

Сглаживание узловой точки окружностью

Удаление "лишних" узловых точек


Редактирование узловых точек. Сглаживание узловой точки окружностью

Редактирование узловых точек

Сглаживание узловой точки окружностью

Узловую точку линии или полигона можно сглаживать окружностью. При выполнении такой команды к объекту добавляются новые узловые точки, которые по форме образуют дугу определённого радиуса, заданного в настройках команды. Степень "сглаженности" этой кривой определяется количеством узловых точек, образующих дугу.

Выделите фигуру, подведите указатель мыши к узлу, в который нужно вписать окружность, откройте контекстное меню и выполните в подменю [image] Точки команду [image] Сгладить окружностью… В диалоговом окне введите радиус скругления и количество точек, образующих дугу.

Параметры скругления

При нажатии кнопки ОК выбранная узловая точка сглаживается окружностью указанного радиуса. Ниже на рисунке показан полигон, вершины которого сглажены окружностями одинакового радиуса.

Сглаживание узлов фигуры окружностями

Также в этом разделе:

Создание узловой точки

Удаление узловой точки

Вставка промежуточных узловых точек

Удаление "лишних" узловых точек


Редактирование узловых точек. Удаление "лишних" узловых точек

Редактирование узловых точек

Удаление "лишних" узловых точек

Некоторые фигуры могут содержать так называемые "лишние" узловые точки. "Лишними" считаются, во-первых, те точки, которые принадлежат прямолинейным сегментам фигуры, а во-вторых, "близкие" точки, расстояние между которыми меньше, чем точность слоя.

Точность слоя задаётся в окне настройки свойств слоя на закладке Подтяжка. Этот параметр измеряется в единицах карты, задаваемых в окне настройки свойств карты (команда меню Карта| [image] Параметры карты…) на закладке Координаты.

Свойства слоя (закладка Подтяжка)

Ниже на рисунке показана фигура, контур которой содержит "близкие" узловые точки, а также точки, принадлежащие прямолинейным сегментам.

"Лишние" точки фигуры

Для удаления "лишних" узловых точек выделите фигуру, откройте контекстное меню и выполните в подменю [image] Точки команду [image] Удалить лишние.

Удаление "лишних" узловых точек

Данная команда позволяет удалять "лишние" точки только выборочно у конкретных фигур. Но можно настроить автоматическое удаление таких точек в линиях и полигонах при создании или редактировании фигур.

Откройте окно настройки системы (команда меню Сервис| [image] Настройка системы…) и перейдите на закладку Редактор. В разделе Автоудаление установите флаг Автоудаление "лишних" вершин в полилиниях и полигонах.

Настройка автоудаления "лишних" узловых точек

Теперь при редактировании фигур, например при создании или перемещении узловых точек, автоматически будут удаляться "лишние" точки.

Также в этом разделе:

Создание узловой точки

Удаление узловой точки

Вставка промежуточных узловых точек

Сглаживание узловой точки окружностью


Технология рисования в системе IndorGIS. Привязка к сетке

Технология рисования в системе IndorGIS

Привязка к сетке

При рисовании фигур на карте можно использовать вспомогательную сетку, предназначенную для выравнивания и точного позиционирования фигур на карте. Если привязка к сетке включена, то при создании или редактировании фигур координаты узловых точек выравниваются по сетке, т.е. узловые точки как бы "прилипают" к узлам сетки. Привязку удобно использовать при рисовании на карте различных диаграмм, электрических схем и т.п.

Команды для настройки параметров сетки находятся на панели инструментов Power Настройка карты. Чтобы отобразить сетку на карте, включите режим [image] Показывать сетку, а чтобы активировать привязку к сетке, включите режим [image] Привязывать к сетке.

Шаг сетки задаётся в окне настройки карты. Оно открывается кнопкой [image] Свойства карты на панели инструментов Power Настройка карты или командой меню Карта| [image] Параметры карты… Перейдите на закладку Редактор и установите шаг сетки по горизонтали и вертикали. Здесь же в разделе Показывать сетку можно выбрать стиль и цвет отображения сетки.

Параметры сетки карты

Замечание
Если режим привязки к сетке не включен, то любую фигуру на карте можно выровнять по сетке, выполнив для неё команду контекстного меню [image] Подтяжка| [image] Выровнять по сетке.

Также в этом разделе:

Режим создания новых фигур

Создание точек, линий и полигонов

Режим редактирования фигур

Редактирование узловых точек

Подтяжка фигур слоя

Операции с фигурамия

Создание и редактирование фигур, состоящих из нескольких контуров


Технология рисования в системе IndorGIS. Подтяжка фигур слоя

Технология рисования в системе IndorGIS

Подтяжка фигур слоя

Подтяжка фигур может значительно упростить манипуляции мышью в процессе ввода и редактирования фигур на карте. Если установлена подтяжка, то при перемещении узловых точек фигур они "подтягиваются" точно к контурам или узлам других фигур. Причём подтяжка может осуществляться не ко всем фигурам на карте, а только к фигурам в указанных слоях.

Подтяжку фигур рекомендуется использовать, если нужно создавать линии таким образом, чтобы начало очередной линии совпадало с концом предыдущей, или при изображении линий коммуникаций, подходящих к зданиям, когда начало (или конец) линии должно находиться точно на контуре здания, и в других подобных случаях.

Рассмотрим настройку автоматической подтяжки фигур на конкретном примере: при изображении трасс линий электропередачи и подстанций на карте местности желательно, чтобы линии притягивались к контурам подстанций.

Рисование линий с подтяжкой к контурам подстанций

Параметры подтяжки для слоя задаются в окне настройки свойств слоя (команда меню Слой| [image] Свойства…) на закладке Подтяжка.

  1. Введите параметр Точность слоя. Он задаёт область вокруг контура фигуры. Если при редактировании узловой точки указатель мыши попадает в эту область, то она автоматически "подтягивается" к контуру фигуры.

Область, задаваемая параметром Точность слоя
  2. Отметьте галочками те слои карты, к которым должны подтягиваться фигуры слоя, например слой Контуры подстанций.

Параметры подтяжки фигур слоя

  3. Чтобы подтяжка фигур осуществлялась сразу при вводе или коррекции данных, установите в разделе Автоматическая подтяжка флажки После ввода данных и После изменения данных.

Если автоматическая подтяжка не установлена, то можно выборочно подтягивать только нужные фигуры, выполняя для них команду контекстного меню [image] Подтяжка| [image] Подтянуть.

Совет
Для подтяжки фигур удобно использовать специальные клавиши. Если при перемещении узловой точки удерживать нажатой клавишу Alt, то она будет притягиваться к контурам фигур этого же слоя, а если удерживать клавиши Alt+Shift - то и к контурам фигур во всех других слоях.

Также в этом разделе:

Режим создания новых фигур

Создание точек, линий и полигонов

Режим редактирования фигур

Редактирование узловых точек

Привязка к сетке

Операции с фигурамия

Создание и редактирование фигур, состоящих из нескольких контуров


Технология рисования в системе IndorGIS. Операции с фигурами

Технология рисования в системе IndorGIS

Операции с фигурами

Для выполнения различных операций с фигурами предназначены команды в меню Фигуры, они также продублированы в контекстном меню.

Также в этом разделе:

Копирование фигур

Удаление фигур

Поворот и зеркальное отражение фигур

Порядок фигур

Выравнивание фигур

Распределение фигур

Разрезание фигур

Разрезание и соединение линий

Объединение "близких" линий

Создание параллельных линий

Объединение, пересечение, разность полигонов

Выпрямление углов у полигонов

Исключение самопересечений у полигонов

Поиск некорректных фигур

Координатные преобразования фигур


Операции с фигурами. Копирование фигур

Операции с фигурами

Копирование фигур

Чтобы скопировать (вырезать) фигуру в буфер обмена, выделите её, а затем выполните команду меню Фигуры| [image] Копировать ( [image] Вырезать) или нажмите кнопку [image] Копировать ( [image] Вырезать) на панели инструментов Power Правка.

При вставке фигуры из буфера обмена можно указывать её местоположение на карте. Она может располагаться точно по координатам исходной фигуры, в центре окна или любом другом месте, указанном пользователем.

Чтобы вставить фигуру из буфера обмена, раскройте в меню Фигуры подменю [image] Вставить и выполните подходящую команду или нажмите соответствующую кнопку на панели Power Правка.

Команды для вставки объектов из буфера обмена

При выполнении команды [image] С перемещением рядом с указателем мыши появляется изображение фигуры в буфере обмена. Для вставки фигуры выберите её местоположение на карте и щёлкните мышью.

Также в этом разделе:

Удаление фигур

Поворот и зеркальное отражение фигур

Порядок фигур

Выравнивание фигур

Распределение фигур

Разрезание фигур

Разрезание и соединение линий

Объединение "близких" линий

Создание параллельных линий

Объединение, пересечение, разность полигонов

Выпрямление углов у полигонов

Исключение самопересечений у полигонов

Поиск некорректных фигур

Координатные преобразования фигур


Операции с фигурами. Удаление фигур

Операции с фигурами

Удаление фигур

Чтобы удалить фигуру на карте, выделите её, после чего выполните команду меню Фигуры| [image] Удалить или нажмите сочетание клавиш Ctrl+Delete.

Также в этом разделе:

Копирование фигур

Поворот и зеркальное отражение фигур

Порядок фигур

Выравнивание фигур

Распределение фигур

Разрезание фигур

Разрезание и соединение линий

Объединение "близких" линий

Создание параллельных линий

Объединение, пересечение, разность полигонов

Выпрямление углов у полигонов

Исключение самопересечений у полигонов

Поиск некорректных фигур

Координатные преобразования фигур


Операции с фигурами. Поворот и зеркальное отражение фигур

Операции с фигурами

Поворот и зеркальное отражение фигур

Выделенную фигуру, находящуюся в фазе выполнения блочных операций, можно поворачивать визуально на произвольный угол с помощью мыши, перемещая круглые управляющие точки (см. подробнее). Чтобы повернуть фигуру на определённый угол, воспользуйтесь командами в меню Фигуры| [image] Преобразовать. Часть из них продублирована на панели инструментов Power Правка.

Команды для поворота и зеркального отражения фигур

Фигуру можно повернуть на 90° против часовой стрелки (команда [image] Повернуть налево), на 90° по часовой стрелке (команда [image] Повернуть на право), на 180° (команда [image] Повернуть на 180°) или на любой произвольный угол (команда [image] Повернуть на угол).

При выполнении последней команды открывается диалоговое окно, где задаётся угол и направление поворота фигуры.

Поворот фигуры на произвольный угол

Поворот фигуры на определённый угол

Фигуру на карте можно зеркально отразить слева направо или сверху вниз относительно линии, проходящей через её центр. Соответствующие команды расположены в меню Фигуры| [image] Преобразовать и на панели инструментов Power Правка.

Зеркальное отражение фигуры

Также в этом разделе:

Копирование фигур

Удаление фигур

Порядок фигур

Выравнивание фигур

Распределение фигур

Разрезание фигур

Разрезание и соединение линий

Объединение "близких" линий

Создание параллельных линий

Объединение, пересечение, разность полигонов

Выпрямление углов у полигонов

Исключение самопересечений у полигонов

Поиск некорректных фигур

Координатные преобразования фигур


Операции с фигурами. Порядок фигур

Операции с фигурами

Порядок фигур

В пределах одного слоя можно менять порядок отрисовки фигур, если они перекрывают друг друга. Соответствующие команды расположены в меню [image] Порядок контекстного меню. Они позволяют переместить фигуру выше или ниже на один уровень в слое либо выше или ниже всех фигур в слое.

Команды для изменения порядка фигур

Также в этом разделе:

Копирование фигур

Удаление фигур

Поворот и зеркальное отражение фигур

Выравнивание фигур

Распределение фигур

Разрезание фигур

Разрезание и соединение линий

Объединение "близких" линий

Создание параллельных линий

Объединение, пересечение, разность полигонов

Выпрямление углов у полигонов

Исключение самопересечений у полигонов

Поиск некорректных фигур

Координатные преобразования фигур


Операции с фигурами. Выравнивание фигур

Операции с фигурами

Выравнивание фигур

Для выравнивания нескольких фигур используйте команды меню Фигуры| [image] Выровнять. Они позволяют выполнить горизонтальное выравнивание фигур по левому, правому краю или по середине, а также вертикальное выравнивание по верхнему, нижнему краю или по середине.

Команды для выравнивания фигур

Также в этом разделе:

Копирование фигур

Удаление фигур

Поворот и зеркальное отражение фигур

Порядок фигур

Распределение фигур

Разрезание фигур

Разрезание и соединение линий

Объединение "близких" линий

Создание параллельных линий

Объединение, пересечение, разность полигонов

Выпрямление углов у полигонов

Исключение самопересечений у полигонов

Поиск некорректных фигур

Координатные преобразования фигур


Операции с фигурами. Распределение фигур

Операции с фигурами

Распределение фигур

Несколько фигур можно равномерно распределить по вертикали или горизонтали путём распределения расстояний между фигурами или центрами фигур. Соответствующие команды расположены в меню Фигуры| [image] Распределить.

Команды для распределения фигур

Также в этом разделе:

Копирование фигур

Удаление фигур

Поворот и зеркальное отражение фигур

Порядок фигур

Выравнивание фигур

Разрезание фигур

Разрезание и соединение линий

Объединение "близких" линий

Создание параллельных линий

Объединение, пересечение, разность полигонов

Выпрямление углов у полигонов

Исключение самопересечений у полигонов

Поиск некорректных фигур

Координатные преобразования фигур


Операции с фигурами. Разрезание фигур

Операции с фигурами

Разрезание фигур

В системе IndorGIS предусмотрены специальные команды для разрезания фигур. Можно разрезать фигуру (или несколько фигур) по прямой линии, по контуру прямоугольника или произвольного полигона. Значения атрибутов новых фигур, полученных после разрезания, копируются из исходной фигуры. Команды для разрезания фигур объединены в меню Фигуры| [image] Операции.

Команды для разрезания фигур

Если фигуры нужно разрезать по прямой линии, выделите их, выполните команду [image] Разрезать линией, а затем двумя щелчками мыши укажите линию разрезания. В режиме редактирования фигур можно увидеть, что исходная фигура разрезана на две.

Разрезание фигуры линией

Если фигуры нужно разрезать по прямоугольному контуру, выделите их, выполните команду [image] Разрезать прямоугольником, а затем нарисуйте прямоугольный контур отсечения. В режиме редактирования фигур можно увидеть фигуры, полученные в результате разрезания.

Разрезание фигуры прямоугольником

Если фигуры нужно разрезать по произвольному контуру, выделите их, выполните команду [image] Разрезать полигоном, а затем щелчками мыши обозначьте на карте контур полигона. Щелчком правой кнопки мыши завершите построение полигона.

Разрезание фигур произвольным контуром

Также в этом разделе:

Копирование фигур

Удаление фигур

Поворот и зеркальное отражение фигур

Порядок фигур

Выравнивание фигур

Распределение фигур

Разрезание и соединение линий

Объединение "близких" линий

Создание параллельных линий

Объединение, пересечение, разность полигонов

Выпрямление углов у полигонов

Исключение самопересечений у полигонов

Поиск некорректных фигур

Координатные преобразования фигур


Операции с фигурами. Разрезание и соединение линий

Операции с фигурами

Разрезание и соединение линий

Для разрезания одной линии на две используйте команду контекстного меню [image] Полилинии| [image] Разорвать на две. Выделенная линия разрезается в точке вызова контекстного меню. Значения атрибутов исходной линии копируются в каждую новую линию.

Разрезание линии на две

Две (или более) линии на карте могут быть соединены в одну. Эта операция может использоваться, если некоторая линейная фигура нарисована как совокупность нескольких линий, а для дальнейшей работы необходимо, чтобы она являлась единой фигурой.

Соединение двух линий возможно, если расстояние между их крайними узловыми точками меньше, чем точность слоя. Напомним, что точность слоя задаётся в окне настройки свойств слоя (команда меню Слой| [image] Свойства…) на закладке Подтяжка. Этот параметр измеряется в единицах карты, которые задаются в окне настройки свойств карты (команда меню Карта| [image] Параметры карты…) на закладке Координаты.

Чтобы соединить две линии, вызовите контекстное меню в точке их касания и выполните команду Полилинии| [image] Соединить две в одну. Если нужно соединить несколько линий в одну, выделите их и выполните аналогичную команду. В процессе соединения среди выделенных линий каждый раз находятся две, которые могут быть соединены, и выдаётся сообщение, в котором можно подтвердить или отменить их соединение. Если нажать кнопку Да для всех, то все последующие найденные линии будут соединены без предварительного предупреждения.

Подтверждение соединения линий

Ниже на рисунке показан результат соединения трёх линий.

Результат соединения линий

Также в этом разделе:

Копирование фигур

Удаление фигур

Поворот и зеркальное отражение фигур

Порядок фигур

Выравнивание фигур

Распределение фигур

Разрезание фигур

Объединение "близких" линий

Создание параллельных линий

Объединение, пересечение, разность полигонов

Выпрямление углов у полигонов

Исключение самопересечений у полигонов

Поиск некорректных фигур

Координатные преобразования фигур


Операции с фигурами. Объединение "близких" линий

Операции с фигурами

Объединение "близких" линий

Две полилинии считаются "близкими", если их узловые точки совпадают с точностью, заданной в свойствах слоя. Такие линии могут появиться на карте, например, после слияния в один нескольких слоёв, которые редактировались разными пользователями. Чтобы объединить "близкие" полилинии, выделите их и выполните в контекстном меню команду [image] Полилинии| [image] Объединить близкие.

Заметим, что выделить совпадающие с некоторой точностью фигуры можно, используя поиск некорректных фигур (см. подробнее).

Объединение "близких" линий

Также в этом разделе:

Копирование фигур

Удаление фигур

Поворот и зеркальное отражение фигур

Порядок фигур

Выравнивание фигур

Распределение фигур

Разрезание фигур

Разрезание и соединение линий

Создание параллельных линий

Объединение, пересечение, разность полигонов

Выпрямление углов у полигонов

Исключение самопересечений у полигонов

Поиск некорректных фигур

Координатные преобразования фигур


Операции с фигурами. Создание параллельных линий

Операции с фигурами

Создание параллельных линий

Для любой линии на карте можно создать произвольное количество параллельных линий, расположенных на заданном расстоянии от неё. Удобно использовать эту операцию, например, при создании параллельных уличных сегментов на карте города.

Выделите на карте линию, для которой нужно создать параллельные, и выполните в контекстном меню команду [image] Полилинии| [image] Создать параллельные… В появившемся диалоговом окне введите расстояния между линиями (они измеряются в единицах карты) и укажите количество линий, которые нужно создать справа и слева от исходной.

Параметры создания параллельных линий

При нажатии кнопки ОК на заданном расстоянии создаются параллельные линии.

Создание параллельных линий

Также в этом разделе:

Копирование фигур

Удаление фигур

Поворот и зеркальное отражение фигур

Порядок фигур

Выравнивание фигур

Распределение фигур

Разрезание фигур

Разрезание и соединение линий

Объединение "близких" линий

Объединение, пересечение, разность полигонов

Выпрямление углов у полигонов

Исключение самопересечений у полигонов

Поиск некорректных фигур

Координатные преобразования фигур


Операции с фигурами. Объединение, пересечение, разность полигонов

Операции с фигурами

Объединение, пересечение, разность полигонов

Два или несколько полигонов на карте можно объединить в один. При этом удаляются те части контуров исходных полигонов, которые ограничивают перекрываемые области. Если в объединяемых полигонах есть самопересекающиеся контуры, то после выполнения операции объединения они будут устранены разбиением на отдельные полигоны.

В результате объединения полигонов, не перекрывающих друг друга, образуется полиполигон, состоящий из нескольких замкнутых контуров (см. подробнее).

Чтобы объединить полигоны, выделите их и выполните команду меню Фигуры| [image] Операции| [image] Объединение полигонов. В качестве значений атрибутов нового полигона используются атрибуты того полигона, который был выделен первым.

Объединение двух полигонов

При выполнении операции пересечения полигонов создаётся новый полигон, ограничивающий область, в которой перекрываются все исходные полигоны. Для пересечения полигонов выделите их и выполните команду меню Фигуры| [image] Операции| [image] Пересечение полигонов. В качестве значений атрибутов нового полигона используются атрибуты того полигона, который был выделен первым.

Пересечение двух полигонов

Операцию разности полигонов (команда меню Фигуры| [image] Операции| [image] Разность полигонов) можно выполнить для двух полигонов. В результате из каждого полигона удаляются те области, в которых они перекрываются.

Разность двух полигонов

Также в этом разделе:

Копирование фигур

Удаление фигур

Поворот и зеркальное отражение фигур

Порядок фигур

Выравнивание фигур

Распределение фигур

Разрезание фигур

Разрезание и соединение линий

Объединение "близких" линий

Создание параллельных линий

Выпрямление углов у полигонов

Исключение самопересечений у полигонов

Поиск некорректных фигур

Координатные преобразования фигур


Операции с фигурами. Выпрямление углов у полигонов

Операции с фигурами

Выпрямление углов у полигонов

При редактировании полигонов можно использовать команду выпрямления углов. По этой команде все углы в полигоне или группе выделенных полигонов становятся равными 90°. Таким образом можно, например, корректировать форму полигонов, представляющих на карте здания прямоугольной формы.

Выделите на карте полигон или несколько полигонов, в которых все углы должны быть прямыми (например, ряд зданий, расположенных вдоль улицы).

Выполните в контекстном меню команду [image] Полигоны| [image] Выпрямить углы. При этом появится диалоговое окно. Если для выполнения операции выделен один полигон, то в окне отображается угол наклона этого полигона, если несколько - то угол, вычисленный как средний угол наклона всех выделенных полигонов.

Выделение полигонов на карте | Параметры выпрямления углов

В этом окне можно ввести другой угол наклона, который приобретут все полигоны после выполнения операции выпрямления. Если установить флаг Не усреднять углы, то каждый полигон после выпрямления будет иметь свой угол наклона.

В данном примере нужно усреднить углы полигонов для того, чтобы здания были отрисованы ровно вдоль оси улицы. Поэтому не нужно устанавливать флаг Не усреднять углы.

Результат выпрямления углов полигонов

Также в этом разделе:

Копирование фигур

Удаление фигур

Поворот и зеркальное отражение фигур

Порядок фигур

Выравнивание фигур

Распределение фигур

Разрезание фигур

Разрезание и соединение линий

Объединение "близких" линий

Создание параллельных линий

Объединение, пересечение, разность полигонов

Исключение самопересечений у полигонов

Поиск некорректных фигур

Координатные преобразования фигур


Операции с фигурами. Исключение самопересечений у полигонов

Операции с фигурами

Исключение самопересечений у полигонов

Если в полигоне есть самопересекающиеся контуры, то для него можно выполнить команду, по которой он будет преобразован в полиполигон с несколькими замкнутыми контурами. Ниже на рисунке показан пример полигона с самопересекающимся контуром.

Пример полигона с самопересекающимся контуром

Чтобы исключить самопересечение у полигона, выделите его и выполните в контекстном меню команду [image] Полигоны| [image] Убрать самопересечения. Полученный полиполигон можно разбить на отдельные полигоны, выполнив команду контекстного меню [image] Полигоны| [image] Разбить на полигоны.

Полиполигон с двумя замкнутыми контурами

Также в этом разделе:

Копирование фигур

Удаление фигур

Поворот и зеркальное отражение фигур

Порядок фигур

Выравнивание фигур

Распределение фигур

Разрезание фигур

Разрезание и соединение линий

Объединение "близких" линий

Создание параллельных линий

Объединение, пересечение, разность полигонов

Выпрямление углов у полигонов

Поиск некорректных фигур

Координатные преобразования фигур


Операции с фигурами. Поиск некорректных фигур

Операции с фигурами

Поиск некорректных фигур

Нарисованные на карте фигуры можно проверять на корректность, задавая различные критерии поиска. Выполнять поиск некорректных фигур можно среди всех фигур некоторого слоя либо только среди выделенных.

Для поиска некорректных фигур выполните в меню Фигуры команду [image] Выделение| [image] Специальное выделение| [image] Некорректные фигуры… Укажите в появившемся диалоговом окне необходимые критерии поиска:

  • Количество узловых точек в контуре. Можно найти все фигуры в слое, у которых количество узловых точек меньше или больше, чем указанное значение.
  • Длина сегментов в контуре. Можно найти все фигуры в слое, у которых есть сегменты длиной менее чем указанное значение.
  • Угол между смежными сегментами. Если задано это условие, то будут найдены все фигуры, в контурах которых есть углы менее чем указанное значение.

Критерии поиска некорректных фигур

  • Самопересечение контуров. Можно найти все фигуры с самопересекающимися контурами.
  • Совпадающие вершины. Этот критерий позволяет найти все фигуры, у которых есть вершины, совпадающие с указанной точностью.
  • Размер объемлющего прямоугольника. Можно найти все фигуры с объемлющим прямоугольником менее чем указанное значение. В качестве размера объемлющего прямоугольника используется длина его большей стороны.

  • Площадь фигуры. Для полигональных слоёв в качестве критерия поиска можно задать площадь фигуры. В этом случае будут найдены все фигуры, площадь которых менее чем указанное значение.
  • Совпадающие фигуры. Этот критерий позволяет найти в слое фигуры, совпадающие с заданной точностью.
  • Контур, находящийся внутри другой фигуры. В слое могут быть найдены все фигуры, расположенные внутри контуров других фигур.
Замечание
Если для поиска некорректных фигур указано несколько критериев, то будут найдены фигуры, удовлетворяющие хотя бы одному из них.

Также в этом разделе:

Копирование фигур

Удаление фигур

Поворот и зеркальное отражение фигур

Порядок фигур

Выравнивание фигур

Распределение фигур

Разрезание фигур

Разрезание и соединение линий

Объединение "близких" линий

Создание параллельных линий

Объединение, пересечение, разность полигонов

Выпрямление углов у полигонов

Исключение самопересечений у полигонов

Координатные преобразования фигур


Операции с фигурами. Координатные преобразования фигур

Операции с фигурами

Координатные преобразования фигур

Над координатами фигур карты могут быть выполнены различные преобразования, такие как сдвиг, поворот, масштабирование, отражение и т.д. Откройте окно выполнения координатного преобразования, выполнив команду меню Карта| [image] Координатное преобразование…

Параметры координатного преобразования фигур

  • Выберите фигуры, подлежащие преобразованию. Ими могут быть фигуры во всех слоях карты, фигуры в выделенных слоях или только выделенные фигуры.
  • Укажите тип выполняемого преобразования: сдвиг, поворот, масштабирование, отражение, проекция или аффинное по матрице.
  • В зависимости от выбранного вида преобразования в нижней части диалога укажите необходимые параметры:
    • Если выбрано преобразование Сдвиг, то нужно указать смещение координат фигур по горизонтали и вертикали.
    • При повороте фигур указывается угол поворота и его центр. Точные координаты центра поворота можно ввести в поля Центр X, Y или указать нужную точку на карте, нажав кнопку Задать по карте… Поворот может быть также выполнен вокруг точки, являющейся центром фигур, участвующих в преобразовании (кнопка По центру фигур).

    Параметры поворота фигур

    • Для выполнения масштабирования нужно задать координаты центра преобразования и коэффициент масштабирования.

    Параметры масштабирования фигур

    • Если выбрано преобразование Отражение, то нужно задать направление отражения: вертикальное или горизонтальное, и указать координату оси преобразования.

    Параметры отражения фигур

Также в этом разделе:

Копирование фигур

Удаление фигур

Поворот и зеркальное отражение фигур

Порядок фигур

Выравнивание фигур

Распределение фигур

Разрезание фигур

Разрезание и соединение линий

Объединение "близких" линий

Создание параллельных линий

Объединение, пересечение, разность полигонов

Выпрямление углов у полигонов

Исключение самопересечений у полигонов

Поиск некорректных фигур


Технология рисования в системе IndorGIS. Создание и редактирование фигур, состоящих из нескольких контуров

Технология рисования в системе IndorGIS

Создание и редактирование фигур, состоящих из нескольких контуров

Полиполилиния - это фигура, состоящая из двух или нескольких полилиний, но имеющая один набор значений атрибутов.

Полиполигон - это фигура, состоящая из двух или нескольких полигонов, но имеющая один набор значений атрибутов.

Полиполигоном на карте может быть представлено здание, состоящее из нескольких корпусов. Графическое представление такого здания - это несколько отдельных полигонов, но атрибутивное описание для них одно (адрес, тип здания и т.д.).

Также в этом разделе:

Создание полиполилиний и полиполигонов

Редактирование полиполилиний и полиполигонов

Удаление контуров полиполилиний и полиполигонов

Разбиение фигур, состоящих из нескольких контуров, на отдельные фигуры


Создание и редактирование фигур, состоящих из нескольких контуров. Создание полиполилиний и полиполигонов

Создание и редактирование фигур, состоящих из нескольких контуров

Создание полиполилиний и полиполигонов

Создать полиполилинию или полиполигон можно двумя способами:

  • Выделите полигоны (или полилинии), которые являются частями одной фигуры, и выполните в контекстном меню команду [image] Полигоны| [image] Объединить в полиполигон (или [image] Полилинии| [image] Объединить в полиполилинию). В результате создаётся фигура, состоящая из нескольких контуров.

Создание полиполигона
Замечание
Если для исходных фигур были заданы значения атрибутов, то после объединения результирующей фигуре присваиваются значения атрибутов той фигуры, на которой было вызвано контекстное меню.
  • Нарисуйте на карте первый контур фигуры (полилинию или полигон), затем выполните в контекстном меню команду [image] Контур| [image] Добавить и нарисуйте следующий контур и т.д.

Создание полиполилинии

Также в этом разделе:

Редактирование полиполилиний и полиполигонов

Удаление контуров полиполилиний и полиполигонов

Разбиение фигур, состоящих из нескольких контуров, на отдельные фигуры


Создание и редактирование фигур, состоящих из нескольких контуров. Редактирование полиполилиний и полиполигонов

Создание и редактирование фигур, состоящих из нескольких контуров

Редактирование полиполилиний и полиполигонов

Фигуры, состоящие из нескольких контуров, редактируются аналогично простым линиям и полигонам. Нужно включить режим редактирования фигур и щёлкнуть мышью на фигуре: на всех контурах визуализируются узловые точки. Каждый контур редактируется как отдельная фигура: можно добавлять новые узловые точки, перемещать или удалять существующие.

Редактирование контуров полиполигона

Также в этом разделе:

Создание полиполилиний и полиполигонов

Удаление контуров полиполилиний и полиполигонов

Разбиение фигур, состоящих из нескольких контуров, на отдельные фигуры


Создание и редактирование фигур, состоящих из нескольких контуров. Удаление контуров полиполилиний и полиполигонов

Создание и редактирование фигур, состоящих из нескольких контуров

Удаление контуров полиполилиний и полиполигонов

Чтобы удалить контур из полиполилинии или полиполигона, выделите фигуру, подведите указатель мыши к контуру, который следует удалить, и выполните в контекстном меню команду [image] Контур| [image] Удалить.

Также в этом разделе:

Создание полиполилиний и полиполигонов

Редактирование полиполилиний и полиполигонов

Разбиение фигур, состоящих из нескольких контуров, на отдельные фигуры


Создание и редактирование фигур, состоящих из нескольких контуров. Разбиение фигур, состоящих из нескольких контуров, на отдельные фигуры

Создание и редактирование фигур, состоящих из нескольких контуров

Разбиение фигур, состоящих из нескольких контуров, на отдельные фигуры

Фигуру, состоящую из нескольких контуров (полиполилинию или полиполигон), можно разбить на отдельные фигуры с одним контуром. Для этого выделите фигуру и выполните в контекстном меню команду [image] Полигоны| [image] Разбить на полигоны или [image] Полилинии| [image] Разбить на полилинии.

Значения атрибутов исходной фигуры копируются в каждую новую фигуру, полученную при разбиении.

Также в этом разделе:

Создание полиполилиний и полиполигонов

Редактирование полиполилиний и полиполигонов

Удаление контуров полиполилиний и полиполигонов


Рисование электрических схем. Создание элементов схемы

Рисование электрических схем

Создание элементов схемы

Создание новых элементов схемы осуществляется в режиме Создание новых объектов, расположенном на панели инструментов Power Режимы общие. При нажатии этой кнопки появляется меню, в котором сначала нужно выбрать группу элементов, а затем - режим создания конкретного элемента.

Режимы создания новых элементов схемы

Совет
Режим создания элемента схемы можно включить из легенды слоя, нажав на пиктограмму нужного элемента.

Включение режима создания элемента схемы

Если элемент является символом (например, это трансформатор, выключатель и пр.), то для его создания достаточно щёлкнуть мышью в нужном месте на карте. Если это линия электропередачи, соединительная линия или шина, то нужно последовательными щелчками мыши указать на карте узловые точки линии. Завершить построение линии можно щелчком правой кнопки мыши.

Создание выключателя | Создание соединительной линии

При рисовании схем электрических сетей следует помнить следующее:

  • В отличие от линий, которые имеют два контакта на концах, шина является сплошным контактом, однако две пересекающиеся на чертеже шины не будут электрически связаны.
  • Соединительная линия имеет два контакта на концах, но, в отличие от линии электропередачи, не является ветвью электрической сети. Она не обладает электрическим сопротивлением и не имеет параметров. Два узла, связанные соединительной линией, превращаются в один.
  • Каждый трансформатор имеет высокую и низкую либо высокую, среднюю и низкую стороны. При вводе параметров каждой стороне ставится в соответствие номинальное напряжение, которое используется при расчёте для начального приближения напряжения в данном узле. Поэтому при рисовании необходимо помнить, что линии высокого напряжения должны быть присоединены к стороне высокого напряжения, а линии низкого напряжения - к сторонам низкого напряжения.

Также в этом разделе:

Редактирование элементов схемы

Инспектор объектов

Использование шаблонов

Привязка к сетке элементов электрических схем

Проверка схемы

Базовый масштаб слоя чертежа


Рисование электрических схем. Редактирование элементов схемы

Рисование электрических схем

Редактирование элементов схемы

В режиме [image] Редактирование фигур можно изменить форму линий, положение и размер нарисованных на карте элементов схемы. Кнопка, соответствующая этому режиму, находится на панели инструментов Power Режимы общие.

Также в этом разделе:

Выделение элементов

Редактирование элементов

Выделение группы элементов

Поворот и зеркальное отражение элементов

Копирование элементов

Удаление элементов


Редактирование элементов схемы. Выделение элементов

Редактирование элементов схемы

Выделение элементов

Редактировать можно только выделенный элемент (или элементы) схемы. Чтобы выделить элемент схемы, включите режим редактирования фигур и щёлкните мышью на элементе. Обратите внимание, что при этом должен быть активным слой, которому принадлежит выделяемый элемент.

Совет
Для определения, в каком слое находится элемент, можно использовать комбинацию клавиш Ctrl+Alt+Shift. Если щёлкать мышью на карте, удерживая нажатыми указанные клавиши, то будут перебираться все элементы, над которыми находится мышь, и соответствующие им слои будут становиться активными.

В режиме редактирования на линии визуализируются составляющие её узловые точки и точки настройки, а на символьном элементе - контакты (см. подробнее) и узловая точка, являющаяся центром символа. Контакты элементов показываются красным цветом.

Также в этом разделе:

Редактирование элементов

Выделение группы элементов

Поворот и зеркальное отражение элементов

Копирование элементов

Удаление элементов


Редактирование элементов схемы. Редактирование элементов

Редактирование элементов схемы

Редактирование элементов

Чтобы изменить положение символьного элемента, перенесите его за центр в нужное место.

Перемещение элемента

При перемещении контактов элемента меняется его размер и угол поворота.

Перемещение контакта элемента

Корректировать форму линии можно, перемещая её узловые точки и контакты. При перемещении точки настройки создаётся новая узловая точка.

Перемещение узловой точки | Перемещение точки настройки

Также в этом разделе:

Выделение элементов

Выделение группы элементов

Поворот и зеркальное отражение элементов

Копирование элементов

Удаление элементов


Редактирование элементов схемы. Выделение группы элементов

Редактирование элементов схемы

Выделение группы элементов

Чтобы выделить группу элементов схемы, последовательно указывайте их мышью, удерживая нажатой клавишу Shift, или обведите нужную группу элементов рамкой. Группа выделенных элементов окружается пунктирным прямоугольником со специальными управляющими точками.

При перемещении круглых точек ( [image]) выполняется поворот группы элементов, при перемещении квадратных точек ( [image]) - изменение размера (растяжение/сжатие) группы.

Группа выделенных элементов

Группу выделенных элементов можно с помощью мыши синхронно перемещать по карте, "ухватив" за один из элементов.

Перемещение группы элементов

Также в этом разделе:

Выделение элементов

Редактирование элементов

Поворот и зеркальное отражение элементов

Копирование элементов

Удаление элементов


Редактирование элементов схемы. Поворот и зеркальное отражение элементов

Редактирование элементов схемы

Поворот и зеркальное отражение элементов

Для поворота и зеркального отражения элемента или группы элементов можно использовать кнопки, расположенные на панели инструментов Power Правка.

Повернуть налево. Поворачивает выделенный элемент (или элементы) на 90° против часовой стрелки вокруг центра.

Повернуть направо. Поворачивает выделенный элемент (или элементы) на 90° по часовой стрелке вокруг центра.

Отразить сверху вниз. Отражает выделенный элемент (или элементы) сверху вниз относительно горизонтальной линии, проходящей через центр элемента (или группы элементов).

Отразить слева направо. Отражает выделенный элемент (или элементы) слева направо относительно вертикальной линии, проходящей через центр элемента (или группы элементов).

Замечание
Аналогичные действия (поворот и зеркальное отражение) можно также выполнить, используя инспектор объектов (см. подробнее).

Также в этом разделе:

Выделение элементов

Редактирование элементов

Выделение группы элементов

Копирование элементов

Удаление элементов


Редактирование элементов схемы. Копирование элементов

Редактирование элементов схемы

Копирование элементов

Для копирования элементов схемы можно использовать буфер обмена. Чтобы скопировать (или вырезать) элемент в буфер обмена, выделите его и нажмите кнопку [image] Копировать (или [image] Вырезать) на панели инструментов Power Правка.

При вставке элемента из буфера обмена можно указывать его местоположение на карте. Он может располагаться точно по координатам исходного элемента или в любом другом месте на карте, указанном пользователем.

Для вставки элемента из буфера обмена точно по координатам исходного элемента нажмите кнопку [image] Вставить точно по координатам на панели инструментов Power Правка.

При нажатии кнопки [image] Вставить в центр окна и переместить указатель мыши помещается точно в центр окна, а рядом с ним появляется изображение элемента в буфере обмена. Выберите местоположение элемента на карте, после чего щёлкните мышью для того, чтобы элемент был вставлен из буфера обмена.

Создать копию выделенного элемента можно также другим способом. Откройте контекстное меню щелчком правой кнопки мыши и выполните команду [image] Рисовать такой же элемент. Рядом с указателем появится изображение элемента. Щелчком мыши укажите положение нового элемента на карте.

Также в этом разделе:

Выделение элементов

Редактирование элементов

Выделение группы элементов

Поворот и зеркальное отражение элементов

Удаление элементов


Редактирование элементов схемы. Удаление элементов

Редактирование элементов схемы

Удаление элементов

Чтобы удалить элемент схемы, выделите его и нажмите клавиши Ctrl+Delete или выполните в контекстном меню команду [image] Удалить элемент.

Также в этом разделе:

Выделение элементов

Редактирование элементов

Выделение группы элементов

Поворот и зеркальное отражение элементов

Копирование элементов


Рисование электрических схем. Инспектор объектов

Рисование электрических схем

Инспектор объектов

Любой элемент схемы имеет набор настраиваемых параметров, таких как размер, угол поворота, цвета составляющих символа и т.д. Эти параметры редактируются в инспекторе объектов, который открывается кнопкой [image] Инспектор объектов на панели инструментов Power Правка, командой меню Вид| [image] Инспектор объектов или клавишами Ctrl+B.

Некоторые параметры элементов могут быть зафиксированы в теме. Например, для трансформатора можно зафиксировать в теме цвета отображения обмоток высокого и низкого напряжений. В этом случае все создаваемые элементы данного типа будут отображаться в соответствии с этими настройками и их нельзя будет редактировать в инспекторе объектов. Но все свободные параметры элемента, не зафиксированные в теме, останутся доступными для редактирования.

Чтобы настроить параметры элемента, выделите его и откройте инспектор объектов. На закладке Свойства отображаются параметры выделенного на карте элемента. Рассмотрим их.

Цвет[i]. В символе может быть несколько настраиваемых цветов (например, цвет обмоток высокого и низкого напряжений трансформатора). Данный параметр позволяет изменить цвет некоторой составляющей символа.

Состояние. Этот параметр присутствует в инспекторе объектов, если для выделенного элемента схемы (такого как выключатель или разъединитель) определено несколько состояний. В этом поле можно выбрать из выпадающего списка нужное состояние элемента (включен/выключен).

Совет
Состояние элемента можно также переключать соответствующими командами контекстного меню.

Поворот. Задаёт угол поворота символа вокруг центра против часовой стрелки в градусах.

Размер. Определяет условный размер символа, который примерно равен диаметру окружности, описанной вокруг символа.

Зеркальность. При установке этого флага элемент зеркально отображается относительно вертикальной оси.

Центр: X, Y. Эти параметры задают координаты точки, являющейся центром символа.

Контакт [i]: X, Y. Эти параметры задают координаты контактов элемента.

Параметры элемента схемы

Замечание
Значения параметров, устанавливаемые в инспекторе объектов, запоминаются системой, а затем применяются к другим создаваемым элементам. Например, если выделить некоторый трансформатор на схеме и изменить для него в инспекторе объектов цвет обмотки низкого напряжения, то все вновь создаваемые трансформаторы будут иметь указанный цвет обмотки низкого напряжения.

Также в этом разделе:

Создание элементов схемы

Редактирование элементов схемы

Использование шаблонов

Привязка к сетке элементов электрических схем

Проверка схемы

Базовый масштаб слоя чертежа


Рисование электрических схем. Использование шаблонов

Рисование электрических схем

Использование шаблонов

Для слоёв чертежа в системе IndorGIS реализован механизм шаблонов, позволяющий запоминать часто повторяющиеся блоки изображения, а затем добавлять эти блоки на карту. В виде шаблонов можно сохранить схемы типовых подстанций, чтобы в дальнейшем использовать их при рисовании схем.

Замечание
Каждый слой чертежа имеет свой набор ассоциированных с ним шаблонов.

Команды для работы с шаблонами находятся в меню Слой| [image] Шаблоны главного меню.

Команды для работы с шаблонами

Рассмотрим работу с шаблонами чертежа. Выделите фрагмент чертежа, который нужно сохранить в качестве шаблона. Затем выполните команду [image] Шаблоны| [image] Запомнить… и введите в появившемся диалоговом окне имя шаблона.

Выделенный фрагмент чертежа

Чтобы просмотреть список шаблонов, ассоциированных с текущим слоем, выполните команду [image] Шаблоны| [image] Менеджер шаблонов… В окне менеджера шаблонов можно изменить описание любого шаблона (кнопка Описание) или удалить шаблон (кнопка Удалить).

Чтобы добавить в слой ранее запомненный шаблон, выполните одну из команд: Шаблоны| [image] Вставить точно…, [image] Вставить пропорционально… или [image] Вставить произвольно… При выполнении этих команд открывается окно менеджера шаблонов, в котором нужно выбрать шаблон для вставки и нажать кнопку Вставить.

Первая команда вставляет шаблон такого же размера, что и исходный фрагмент чертежа при запоминании. Для вставки достаточно щёлкнуть мышью в нужном месте на карте.

Менеджер шаблонов

Вторая команда позволяет вставить фрагмент с пропорциональным растяжением по вертикали и горизонтали. Для вставки нужно растянуть на карте рамку, определяющую размер шаблона при вставке.

Третья команда позволяет вставить шаблон с растяжением по вертикали и горизонтали, возможно, не пропорциональным.

Также в этом разделе:

Создание элементов схемы

Редактирование элементов схемы

Инспектор объектов

Привязка к сетке элементов электрических схем

Проверка схемы

Базовый масштаб слоя чертежа


Рисование электрических схем. Привязка к сетке элементов электрических схем

Рисование электрических схем

Привязка к сетке элементов электрических схем

Каждый элемент схемы имеет контакты. Контакт задаётся точкой, т.е. двумя координатами. Элементы электрической схемы считаются соединенными только, если их контакты лежат в одной точке. Не всегда бывает возможно совместить два контакта таким образом, чтобы они оказались точно в одной точке. Поэтому, для того чтобы контакты элементов схемы точно соприкасались, необходимо использовать привязку к сетке во время рисования схемы.

Пример использования привязки к сетке

Если привязка к сетке включена, то при создании или редактировании фигур на карте координаты всех узловых точек и контактов выравниваются по сетке, т.е. как бы "прилипают" к узлам сетки.

Команды для настройки параметров сетки находятся на панели инструментов Power Настройка карты. Чтобы отобразить сетку на карте, включите режим [image] Показывать сетку, а чтобы активировать привязку к сетке, включите режим [image] Привязывать к сетке. Теперь при перемещении узловых точек элементов они будут попадать точно в узлы сетки.

Элемент схемы привязывается к сетке следующим образом: сначала притягивается центр, а затем контакты элементов. В случае если элемент (такой как трёхобмоточный трансформатор) имеет более двух контактов, в процессе редактирования может возникнуть ситуация, когда один из контактов оказывается лежащим вне сетки, а сам элемент приобретает поворот вокруг оси. Это связано с тем, что, привязывая два контакта к сетке, мы тем самым изменяем размер элемента, а поскольку при этом расстояния между всеми контактами также пропорционально изменяются, третий контакт может оказаться не строго в узле сетки.

Поворот элемента при привязке к сетке

Чтобы избежать этого, необходимо перед началом рисования схемы правильно подобрать шаг сетки относительно размера элементов схемы. При этом также нужно учитывать, что для обеспечения достаточной точности наиболее удобным считается шаг сетки, при котором элементы перекрывают 6-8 делений.

Шаг сетки задаётся в окне настройки карты (кнопка [image] Свойства карты на панели инструментов Power Настройка карты или команда меню Карта| [image] Параметры карты…).

Переключитесь на закладку Редактор и установите шаг сетки по горизонтали и вертикали. Установленный в этом окне шаг сетки применяется ко всем слоям карты, для которых не заданы индивидуальные настройки сетки.

Установка шага сетки

Совет
Если по какой-то причине привязка элементов к сетке сбилась, например после зеркального отражения или переноса группы элементов, то её можно восстановить. Для этого выделите нужные элементы и выполните команду контекстного меню [image] Подтяжка| [image] Выровнять по сетке.

При необходимости в разных слоях карты можно рисовать с разным шагом сетки. Например, если схема разбита по классам напряжения на несколько слоёв и в зависимости от класса фрагменты схемы отображаются большими или меньшими по размеру, или если в нескольких слоях объекты рисуются с разной точностью.

Чтобы задать индивидуальные параметры сетки для некоторого слоя, выделите этот слой в дереве и нажмите кнопку [image] Настроить индивидуальную сетку слоя на панели инструментов Power Настройка карты.

Индивидуальные параметры сетки слоя

В диалоговом окне установите флаг Слой имеет индивидуальные настройки сетки и введите значение шага сетки по вертикали и горизонтали. Ниже можно выбрать значок для отображения узлов сетки и их цвет.

Также в этом разделе:

Создание элементов схемы

Редактирование элементов схемы

Инспектор объектов

Использование шаблонов

Проверка схемы

Базовый масштаб слоя чертежа


Рисование электрических схем. Проверка схемы

Рисование электрических схем

Проверка схемы

По окончании рисования схемы желательно выполнить её проверку на корректность, которая заключается в выявлении элементов, созданных в одном и том же месте на карте, и проверке связности схемы.

Также в этом разделе:

Исключение многократного наложения элементов

Проверка связности графа сети


Проверка схемы. Исключение многократного наложения элементов

Проверка схемы

Исключение многократного наложения элементов

При рисовании схем могут возникать такие ошибки, как создание нескольких элементов в одном месте на карте. Рекомендуется производить поиск таких элементов для того, чтобы удалить лишние.

Откройте окно поиска некорректных фигур, выполнив команду меню Фигуры| [image] Выделение| [image] Специальное выделение| [image] Некорректные фигуры… В нём можно указывать различные критерии поиска некорректных элементов. Для поиска совпадающих элементов установите флаг Есть совпадающие фигуры и укажите точность совпадения элементов (в единицах карты).

Критерии для поиска совпадающих фигур

Также можно указать, чтобы одна из совпадающих фигур оставалась невыделенной. Это нужно для того, чтобы сразу можно было удалить оставшиеся выделенные фигуры.

Также в этом разделе:

Проверка связности графа сети


Проверка схемы. Проверка связности графа сети

Проверка схемы

Проверка связности графа сети

Для проверки связности графа сети следует использовать режим [image] Проверка связности без коммутаторов, расположенный на панели инструментов Power Режимы. Он позволяет выявить на схеме места, где контакты соседних элементов находятся не в одном узле сетки, в результате чего нарушается связность схемы.

Режимы выделения подсхем

Укажите мышью элемент на схеме. При этом выделится та часть схемы, которая имеет соединение с указанным элементом. Состояния коммутаторов в этом режиме не учитываются, поскольку необходимо проверить только связность соседних элементов.

Проверка связности графа сети

Также в этом разделе:

Исключение многократного наложения элементов


Базовый масштаб слоя чертежа. Понятие базового масштаба

Базовый масштаб слоя чертежа

Понятие базового масштаба

Для слоёв чертежа определено понятие базового масштаба. Базовый масштаб задаёт размер создаваемых элементов схемы на экране: чем меньше базовый масштаб, тем большими по величине отображаются на экране элементы схемы (при одинаковом масштабе карты).

Ниже на рисунке изображена часть электрической схемы. В первом слое нарисован фрагмент схемы со значением базового масштаба 1:1000, а во втором - со значением 1:500. Элементы второго слоя в два раза меньше по размеру, чем элементы первого, поскольку базовый масштаб слоя в два раза больше.

Фрагмент карты с двумя слоями электрической схемы, нарисованными в разных базовых масштабах

Базовый масштаб следует настраивать, если схема рисуется поверх уже нарисованных в других слоях объектов, где нужно согласовывать размеры элементов электрической схемы с этими объектами, или если схема разбита по классам напряжения на несколько слоёв и в зависимости от класса фрагменты схемы отображаются большими или меньшими по размеру.

Также в этом разделе:

Установка базового масштаба

Подбор базового масштаба для рисования частей схем в разных масштабах

Приведение схемы, нарисованной в одном базовом масштабе, к другому базовому масштабу

Подбор базового масштаба для рисования схем на плане местности


Базовый масштаб слоя чертежа. Установка базового масштаба

Базовый масштаб слоя чертежа

Установка базового масштаба

Для новых слоёв базовый масштаб задаётся равным 1:3779,5. При этом подразумевается, что единицы карты (расстояние между ближайшими точками сетки с единичным шагом) - метры и, кроме того, элементы имеют размер, равный 10. При таком стандартном размере величина элемента соответствует толщине линий, из которых состоит элемент. Оптимальный шаг сетки для такого базового масштаба и размера элементов - 5.

Значение базового масштаба для слоя устанавливается в окне настройки его свойств (команда меню Слой| [image] Свойства слоя…) на закладке Отрисовка в поле Базовый масштаб.

Задание базового масштаба для слоя

Замечание
Поле Базовый масштаб становится доступным после установки единиц карты. Для задания единиц карты откройте окно настройки параметров карты (команда главного меню Карта| [image] Параметры карты…), переключитесь на закладку Координаты и выберите в поле Единицы карты - метры.

Также в этом разделе:

Понятие базового масштаба

Подбор базового масштаба для рисования частей схем в разных масштабах

Приведение схемы, нарисованной в одном базовом масштабе, к другому базовому масштабу

Подбор базового масштаба для рисования схем на плане местности


Базовый масштаб слоя чертежа. Подбор базового масштаба для рисования частей схем в разных масштабах

Базовый масштаб слоя чертежа

Подбор базового масштаба для рисования частей схем в разных масштабах

Рассмотрим карту, содержащую один слой электрической схемы с названием "Схема 1". Для него установлено значение базового масштаба по умолчанию 1: 3779,5. Ниже на рисунке приведён фрагмент этого слоя.

Фрагмент слоя электрической схемы "Схема 1"

Предположим, необходимо нарисовать на карте часть схемы таким образом, чтобы её элементы были в два раза меньше, чем элементы в слое "Схема 1". Для этого нужно, во-первых, создать новый слой (будем называть его "Схема 2"), а во-вторых, настроить для него значение базового масштаба.

Как следует из понятия базового масштаба, данного выше, чтобы элементы отображались на экране меньшими по размеру, необходимо увеличить базовый масштаб слоя. Поскольку размер элементов нужно уменьшить в два раза, значит, базовый масштаб слоя "Схема 2" нужно увеличить в два раза относительно слоя "Схема 1", т.е. он должен быть равен 1:1889,75. Обратите внимание, что размер элементов в инспекторе объектов менять не нужно.

Установка базового масштаба для слоя "Схема 2"

Шаг сетки, равный 5, для слоя "Схема 2" большой, так как размер элементов уменьшился в два раза. Поэтому для этого слоя шаг следует уменьшить в два раза (примерно во столько же раз, во сколько уменьшился размер элементов), т.е. он должен быть равен 2,5.

На рисунке показан фрагмент карты со слоями "Схема 1" и "Схема 2": элементы в слое "Схема 2" отображаются в два раза меньшими по размеру по сравнению с элементами в слое "Схема 1".

Фрагмент карты со слоями "Схема 1" и "Схема 2"

Замечание
Уменьшать размер элементов схемы, изменяя параметр Размер в инспекторе объектов, нельзя, поскольку в этом случае нарушается соотношение толщина/размер у элементов схемы. То есть размер элементов всегда должен быть равен 10.
На рисунке слева размер элементов схемы равен 10, а на рисунке справа - 5, и поэтому элементы на нём выглядят жирнее.
Размер элементов равен 10 | Размер элементов равен 5

Теперь сформулируем ещё одно понятие базового масштаба.

Если просматривать карту в масштабе, равном базовому масштабу некоторого слоя, то размер элементов этого слоя на экране будет равен размеру, установленному для элементов в инспекторе объектов. То есть если установить масштаб карты, равный 1:3779,5, то размер на экране элементов слоя "Схема 1" будет равен 10. Если же установить масштаб карты, равный 1:1889,75, то размер на экране элементов слоя "Схема 2" будет равен 10.

Масштаб карты можно установить в поле, расположенном в левом нижнем углу редактора карт. Оно становится доступным после установки единиц карты.

Поле для задания масштаба карты

На рисунке слева показан вид схемы при масштабе карты, равном базовому масштабу слоя "Схема 1", 1:3779,5, а на рисунке справа - при масштабе карты, равном базовому масштабу слоя "Схема 2", 1:1889,75.

Вид схемы при разных масштабах карты: слева - масштаб равен 1:3779,5, справа - масштаб равен 1:1889,75

Как видно из рисунка, размер элементов слоя "Схема 1" на рисунке слева совпадает с размером элементов слоя "Схема 2" на рисунке справа и равен 10.

Также в этом разделе:

Понятие базового масштаба

Установка базового масштаба

Приведение схемы, нарисованной в одном базовом масштабе, к другому базовому масштабу

Подбор базового масштаба для рисования схем на плане местности


Базовый масштаб слоя чертежа. Приведение схемы, нарисованной в одном базовом масштабе, к другому базовому масштабу

Базовый масштаб слоя чертежа

Приведение схемы, нарисованной в одном базовом масштабе, к другому базовому масштабу

Рассмотрим, как можно привести схему, нарисованную в одном базовом масштабе, к другому базовому масштабу. Эта операция может понадобиться, если необходимо объединить в один слой несколько частей схемы, нарисованных в разных слоях и с разными базовыми масштабами.

Для наглядности будем использовать рассмотренный ранее пример. Приведём размер элементов слоя "Схема 2" к размеру элементов слоя "Схема 1".

Установите базовый масштаб слоя "Схема 2", равный базовому масштабу слоя "Схема 1", т.е. 1:3779,5. При изменении базового масштаба слоя будет выдано сообщение, в котором нужно ответить - Да.

Сообщение при изменении базового масштаба слоя

После изменения базового масштаба нарисованные в слое элементы стали "толще", поскольку теперь они соответствуют базовому масштабу - 1:3779,5. Размер элементов в инспекторе объектов уменьшился во столько раз, во сколько был уменьшен базовый масштаб, в нашем примере в 2 раза.

Изменение базового масштаба слоя "Схема 2"

Теперь нужно увеличить размер фрагмента схемы во столько же раз, во сколько был уменьшен базовый масштаб слоя. Коэффициент масштабирования вычисляется как Старый базовый масштаб/Новый базовый масштаб. В нашем примере он равен 2 = (1:1889,75)/(1:3779,5).

Выделите нужный фрагмент схемы в слое "Схема 2" и откройте окно Координатное преобразование (команда меню Карта| [image] Координатное преобразование…). В этом окне укажите, что преобразовывать необходимо Выделенные фигуры, выберите тип преобразования - Масштабирование, задайте центр преобразования, например По центру фигур, а затем введите коэффициент масштабирования.

Параметры координатного преобразования

Ниже на рисунке показан вид схемы после масштабирования. Теперь фрагменты схемы в слоях "Схема 1" и "Схема 2" могут быть объединены в один слой.

Результат выполнения масштабирования

Также в этом разделе:

Понятие базового масштаба

Установка базового масштаба

Подбор базового масштаба для рисования частей схем в разных масштабах

Подбор базового масштаба для рисования схем на плане местности


Базовый масштаб слоя чертежа. Подбор базового масштаба для рисования схем на плане местности

Базовый масштаб слоя чертежа

Подбор базового масштаба для рисования схем на плане местности

Рассмотрим карту местности, на которой схематично изображены контуры подстанций в местах их приблизительного расположения. Внутри контуров необходимо нарисовать схемы подстанций.

Контуры подстанций на плане местности

Подберём базовый масштаб слоя электрической схемы таким образом, чтобы схемы подстанций поместились внутри контуров.

Установите такой масштаб карты, чтобы контур некоторой подстанции полностью отображался на экране.

Поле для задания масштаба карты

Задайте этот масштаб в качестве базового масштаба для слоя электрической схемы и нарисуйте на карте трёхобмоточный трансформатор (размер элемента должен быть равен 10). Это нужно для того, чтобы оценить, какой размер на карте имеют элементы схемы при заданном значении базового масштаба слоя. В нашем примере элементы схемы отображаются большими по величине, значит, базовый масштаб слоя необходимо увеличить.

Оценка размера элементов схемы

Подберите значение базового масштаба слоя таким образом, чтобы элементы схемы имели подходящий размер на карте внутри контуров подстанций.

Подходящий размер элементов схемы

Теперь нужно подобрать размер шага сетки для слоя схемы. Шаг должен быть таким, чтобы элемент перекрывал нужное количество делений сетки (обычно 6-8) и все контакты лежали в узлах сетки. Включите режим отображения сетки и режим привязки к сетке и установите для слоя электрической схемы индивидуальные настройки шага сетки (путём подбора).

При установленном шаге сетки может оказаться, что контакты создаваемого элемента лежат недостаточно близко к узлам сетки.

Контакты элемента лежат недостаточно близко к узлам сетки

В этом случае необходимо уточнить размер элементов схемы. В режиме редактирования фигур подтяните верхний контакт трансформатора к узлу сетки, затем, взяв нижний контакт, вертикально растяните трансформатор таким образом, чтобы все контакты оказались точно в узлах сетки.

Уточнение размера элемента

Запомните ближайшее целое число к величине Размера растянутого трансформатора в инспекторе объектов.

Установите это значение в качестве размера элементов схемы. Для этого включите режим рисования какого-либо элемента и введите в инспекторе объектов параметр Размер. После этого все вновь создаваемые элементы будут иметь данный размер и контакты элементов будут точно "привязываться" к узлам сетки.

Замечание
Уточнять размер элементов схемы необходимо для того, чтобы избежать возможных ошибок при подтягивании элементов к узлам сетки.

Схема, нарисованная внутри контура подстанции

На рисунке показан итоговый вид схемы, нарисованной внутри контура подстанции.

Также в этом разделе:

Понятие базового масштаба

Установка базового масштаба

Подбор базового масштаба для рисования частей схем в разных масштабах

Приведение схемы, нарисованной в одном базовом масштабе, к другому базовому масштабу


Ввод атрибутивных данных

В системе IndorInfo/Power сети, линии электропередачи, подстанции и оборудование представляются в виде иерархии объектов. Каждый объект характеризуется общей технической и инвентарной информацией (атрибутивные данные), связанными с ним документами, а также списками планируемых и выполненных работ, измеренными значениями, архивом сведений по неисправностям (эксплуатационные данные).

Также в этом разделе:

Основные правила ввода данных

Формирование структуры сетевого предприятия

Информационная модель оборудования подстанции

Настройка соответствия объектов информационной системы и слоёв

Технология ввода атрибутивных данных

Добавление документов по объектам в базу данных

Редактирование справочников

Экспорт параметров объектов в систему IndorElectra


Ввод атрибутивных данных. Основные правила ввода данных

Ввод атрибутивных данных

Основные правила ввода данных

При вводе атрибутивных данных по объектам электрических сетей следует учитывать несколько основных правил формирования информационной модели сети в базе данных:

  1. Любой объект, хранящийся в базе данных, должен иметь владельца. Владелец некоторого объекта называется главным объектом по отношению к нему или его родителем. В результате такой организации данных в базе формируется дерево (или иерархия) объектов, образующих сеть электроснабжения. Такая структура позволяет упорядочить объекты электрических сетей и обеспечивает возможность выполнения разнообразных видов атрибутивных запросов и выборки объектов по заданным критериям.

Ниже на рисунке представлен пример простейшей иерархии объектов: объекты "Подстанция 1" и "Подстанция 2" входят в состав или принадлежат объекту "ПЭС 1", а он, в свою очередь, является для них главным объектом, владельцем или родителем.

Пример простейшей иерархии объектов

  2. Большинство объектов электрических сетей, описываемых в базе данных, имеют графическое представление на карте (подстанции и оборудование, линии электропередачи, опоры и пр.), поэтому после создания в базе данных описания какого-либо объекта необходимо указывать, какой фигуре на карте оно соответствует. Эта процедура называется "связывание описаний объектов с фигурами на карте". Если фигура связана с некоторым описанием в базе данных, то, указав её мышью на карте, можно будет получить всю информацию по этому объекту из базы.
  3. Для любого объекта нужно создавать только одно атрибутивное описание в базе данных, несмотря на то, что графически он может быть представлен несколько раз на разных картах. При этом изображения одного объекта на разных картах будет необходимо связать с его описанием в базе данных.

Ниже на рисунке показаны представления одной подстанции на разных картах. Оборудование подстанции, например автотрансформатор, также представлено на трёх картах, но ему соответствует одно атрибутивное описание в базе данных.

Представление объекта на нескольких картах и связь изображений с описанием этого объекта в базе данных

Также в этом разделе:

Формирование структуры сетевого предприятия

Информационная модель оборудования подстанции

Настройка соответствия объектов информационной системы и слоёв

Технология ввода атрибутивных данных

Добавление документов по объектам в базу данных

Редактирование справочников

Экспорт параметров объектов в систему IndorElectra


Ввод атрибутивных данных. Формирование структуры сетевого предприятия

Ввод атрибутивных данных

Формирование структуры сетевого предприятия

Ввод данных рекомендуется начинать с формирования структуры всего сетевого предприятия и его подразделений. Ниже на рисунке представлен пример структуры некоторой региональной энергосистемы, состоящей из трёх предприятий электрических сетей, которые, в свою очередь, состоят из нескольких районных электрических сетей.

Пример структуры сетевого предприятия

После создания в базе данных структуры предприятия можно приступить к описанию подстанций и линий электропередачи, входящих в состав каждой сети электроснабжения.

Линии электропередачи и подстанции, входящие в состав сетей

Затем можно создавать полное описание оборудования каждой подстанции и линии электропередачи.

Также в этом разделе:

Основные правила ввода данных

Информационная модель оборудования подстанции

Настройка соответствия объектов информационной системы и слоёв

Технология ввода атрибутивных данных

Добавление документов по объектам в базу данных

Редактирование справочников

Экспорт параметров объектов в систему IndorElectra


Ввод атрибутивных данных. Информационная модель оборудования подстанции

Ввод атрибутивных данных

Информационная модель оборудования подстанции

Рассмотрим структуру представления оборудования подстанции в базе данных:

  1. В подстанции выделяются распределительные устройства.
  2. В каждом распределительном устройстве создаются секции, входящие в его состав.

Распределительные устройства и секции в подстанции

  3. Внутри каждой секции выделяются принадлежащие им ячейки.
Замечание
Те ячейки, которые нельзя отнести к какой-либо секции (например, ячейка, в которой стоит межсекционный разъединитель), можно добавлять непосредственно к распределительному устройству.
  4. Внутри каждой ячейки создаётся описание оборудования, входящего в её состав.

Ячейки, принадлежащие секциям

При таком подходе каждый объект в составе подстанции имеет своего владельца. Например, для распределительных устройств владельцем является подстанция, для секций владельцем может быть распределительное устройство или подстанция, для ячеек - секция или распределительное устройство, а трансформаторы, выключатели, разъединители и другое оборудование могут создаваться только в составе ячеек.

Также в этом разделе:

Основные правила ввода данных

Формирование структуры сетевого предприятия

Настройка соответствия объектов информационной системы и слоёв

Технология ввода атрибутивных данных

Добавление документов по объектам в базу данных

Редактирование справочников

Экспорт параметров объектов в систему IndorElectra


Ввод атрибутивных данных. Настройка соответствия объектов информационной системы и слоёв

Ввод атрибутивных данных

Настройка соответствия объектов информационной системы и слоёв

Настройка соответствия между объектами информационной системы и слоями необходима для того, чтобы можно было связывать фигуры на карте с их описаниями в базе данных (см. подробнее). В процессе настройки соответствия для каждого слоя карты указывается, какие именно объекты электрических сетей представляют фигуры слоя. Если для слоя не настроено соответствие, то система будет "воспринимать" фигуры этого слоя как некоторые точки, линии, полигоны или элементы схемы (в зависимости от типа слоя), а не как объекты электрических сетей.

Чтобы настроить соответствие для слоя, выделите его и нажмите кнопку [image] Настройка соответствия слоёв… на панели инструментов IndorInfo/Power. В открывшемся диалоговом окне в поле Слой отображается выделенный слой карты, а в выпадающем списке можно выбрать для настройки любой другой слой карты.

Настройка соответствия слоя Опоры с объектами информационной системы

В списке Типы фигур слоя отображаются все типы фигур, которые могут присутствовать в выбранном слое. Например, в точечном слое Опоры могут быть фигуры только одного типа - Точки. Выберите тип фигур, щёлкнув на нём мышью. После этого станет доступным список в правой части окна с полным набором объектов электрических сетей. Отметьте в нём галочками те типы, которыми являются фигуры выбранного слоя.

В списке соответствующих объектов можно указывать более одного типа. Например, фигурам в слое Трассы ЛЭП 110/35 кВ соответствуют два типа объекта: ЛЭП 110 кВ и ЛЭП 35 кВ.

Настройка соответствия слоя Трассы ЛЭП 110/35 кВ с объектами

Замечание
Окно настройки соответствия слоёв можно открыть из окна настройки системы IndorInfo/Power, нажав кнопку Настройка соответствия слоёв… на закладке ГИС.

Также в этом разделе:

Настройка соответствия для слоя электрической схемы


Настройка соответствия объектов информационной системы и слоёв. Настройка соответствия для слоя электрической схемы

Настройка соответствия объектов информационной системы и слоёв

Настройка соответствия для слоя электрической схемы

В слое электрической схемы могут присутствовать несколько типов элементов, которые имеют собственные электрические параметры, и значит, для каждого типа элемента должны быть указаны соответствующие объекты. Чтобы не делать это вручную, в системе предусмотрена автоматическая настройка соответствия для слоёв электрических схем.

Настройка соответствия для слоя электрической схемы

При нажатии кнопки [image] Настройка соответствия слоёв… система пытается анализировать (по названию темы, на основе которой создан слой), является ли выделенный в данный момент слой слоем электрической схемы (аналогичная проверка выполняется при выборе слоя из выпадающего списка в окне настройки соответствия). И если является, то выдаётся диалоговое окно, где предлагается автоматически настроить соответствие для всех элементов слоя.

Автоматическая настройка соответствия для слоя электрической схемы

Параметры автоматической настройки берутся из специального файла с названием Настройка темы Электрические сети.cfg, который копируется в папку IndorSoft/IndorPower/Bin/ при установке системы с дистрибутива. Если по какой-то причине данный файл отсутствует в указанной папке, то автоматически настроить соответствие будет нельзя.

Совет
При необходимости можно изменить настройки соответствия, устанавливаемые по умолчанию. Для этого достаточно перезаписать файл Настройка темы Электрические сети.cfg. Установите в окне настройки подходящие параметры соответствия, нажмите кнопку [image] Сохранить настройки слоя в файл и в появившемся диалоговом окне выберите нужный файл. Теперь при автоматической настройке слоёв будут применяться параметры, записанные в файл.

Можно создать свой собственный файл настроек и применять его для нужных слоёв карты. Чтобы сохранить настройки соответствия в файл, нажмите кнопку [image] Сохранить настройки слоя в файл и введите в появившемся диалоговом окне имя файла. Для применения к слою настроек соответствия из файла нажмите кнопку [image] Загрузить настройки слоя из файла и выберите в диалоговом окне нужный файл.

Также в этом разделе:

Настройка соответствия объектов информационной системы и слоёв

Наверх [image] Назад [image] Вперёд Авторское право © 2009 ООО "ИндорСофт"


Технология ввода атрибутивных данных. Общие сведения

Технология ввода атрибутивных данных

Общие сведения

Ввод данных в информационной системе осуществляется в специальном режиме, который включается кнопкой [image] Ввод данных на панели инструментов Power Режимы.

В этом режиме курсор меняет свою форму ( [image]) и при щелчке на фигурах карты, относящихся к электрическим сетям, появляется окно для ввода данных. Параметры в этом окне соответствуют тому типу объекта, с которым установлено соответствие у указанной фигуры (см. подробнее).

Замечания
  1. Если для фигуры не настроено соответствие с объектами электрических сетей, то при указании её в режиме ввода данных ничего не происходит, т.е. окно для ввода данных не открывается.
  2. Если в окне настройки системы (команда меню IndorInfo/Power| [image] Настройка IndorInfo/Power…) на закладке Прочее установлен флаг Подмигивать редактируемый объект, то перед открытием окна ввода данных указанная мышью фигура подсвечивается. Это позволяет убедиться, что выбрана нужная фигура, или наоборот, выяснить, что была указана не та фигура.

В заголовке и левой части окна отображается наименование указанного мышью объекта, а в правой части окна отображаются параметры этого объекта.

Окно ввода данных

Напомним, что многие объекты информационной системы могут содержать в себе объекты других типов, т.е. являться "родительскими" по отношению к ним (см. подробнее). Если указанный мышью объект содержит в себе другие объекты, то их можно увидеть, нажав на знак [image] слева от названия объекта (знак [image] при этом изменится на [image]). При нажатии на знак [image] содержимое объекта скрывается.

Если входящие в состав объекты, в свою очередь, также содержат в себе другие объекты, то их можно увидеть, раскрыв аналогичным образом соответствующую ветвь.

Содержимое подстанции Северная | Содержимое распределительного устройства ОРУ-220

Некоторые объекты содержат в себе папки. Они предназначены для того, чтобы группировать объекты определённых типов, например здания внутри подстанций или устройства релейной защиты и автоматики внутри тех объектов, к которым они могут быть добавлены.

Содержимое папки Здания ТП

Таким образом, в области слева в окне ввода данных формируется древовидная структура, в корне которой находится указанный в режиме ввода данных объект. Эту область будем называть деревом объектов.

Замечание
Двойной щелчок мыши на названии объекта (или папки) раскрывает его содержимое, если оно было скрыто, и наоборот, скрывает содержимое, если оно было раскрыто.
Совет
Рекомендуется скрывать содержимое тех объектов, с которыми в данный момент не ведётся работа. Это значительно упрощает ориентацию в дереве при большом количестве объектов.

В области справа отображаются параметры того объекта, который выделен в дереве. Будем называть его текущим. Если у объекта достаточно много параметров, то они размещаются на нескольких закладках.

Текущий объект в дереве объектов и его параметры

В верхней части окна ввода данных расположено меню с командами для ввода различной информации по объектам и получения отчётов. Все команды меню продублированы на панели инструментов.

Замечание
Почти все действия, производимые при выполнении команд меню или нажатии кнопок панели инструментов, относятся к текущему объекту.

Также в этом разделе:

Поиск по дереву объектов

Прокрутка и масштабирование карты из окна ввода данных

Создание и редактирование объектов, запись в базу данных

Использование справочников при вводе параметров

Ввод дополнительной информации по объекту

Перемещение объектов в дереве

Копирование объектов

Переход к "родителю" объекта

Удаление объектов из базы данных

Связывание объектов с фигурами на карте

Поиск объектов на карте

Просмотр объектов, связанных с фигурами на карте

Просмотр фигур на карте, не связанных с объектами в базе данных

Загрузка описания объекта из XML-файла


Технология ввода атрибутивных данных. Поиск по дереву объектов

Технология ввода атрибутивных данных

Поиск по дереву объектов

В нижней части окна под деревом объектов расположено поле для поиска объектов в дереве по наименованию. При вводе в этом поле текста фокус переключается на первый объект, название которого начинается с указанного вхождения. Поиск осуществляется только по открытым ветвям дерева.

Также в этом разделе:

Общие сведения

Прокрутка и масштабирование карты из окна ввода данных

Создание и редактирование объектов, запись в базу данных

Использование справочников при вводе параметров

Ввод дополнительной информации по объекту

Перемещение объектов в дереве

Копирование объектов

Переход к "родителю" объекта

Удаление объектов из базы данных

Связывание объектов с фигурами на карте

Поиск объектов на карте

Просмотр объектов, связанных с фигурами на карте

Просмотр фигур на карте, не связанных с объектами в базе данных

Загрузка описания объекта из XML-файла


Технология ввода атрибутивных данных. Прокрутка и масштабирование карты из окна ввода данных

Технология ввода атрибутивных данных

Прокрутка и масштабирование карты из окна ввода данных

Работая в окне ввода данных, можно переместить карту и/или изменить масштаб просмотра карты так, чтобы был виден нужный фрагмент. Для этого нажмите кнопку [image] Прокрутка и масштабирование текущей карты на панели инструментов или выполните команду меню Карта| [image] Прокрутка карты. По этой команде окно ввода данных временно исчезает с экрана и включается режим прокрутки карты. После одного перемещения карты режим отключается и появляется окно ввода данных.

Совет
Чтобы выполнить несколько перемещений карты, нажимайте колесо мыши при перемещении, а не левую кнопку мыши. Для увеличения/уменьшения масштаба просмотра карты прокручивайте колесо мыши.

Также в этом разделе:

Общие сведения

Поиск по дереву объектов

Создание и редактирование объектов, запись в базу данных

Использование справочников при вводе параметров

Ввод дополнительной информации по объекту

Перемещение объектов в дереве

Копирование объектов

Переход к "родителю" объекта

Удаление объектов из базы данных

Связывание объектов с фигурами на карте

Поиск объектов на карте

Просмотр объектов, связанных с фигурами на карте

Просмотр фигур на карте, не связанных с объектами в базе данных

Загрузка описания объекта из XML-файла


Технология ввода атрибутивных данных. Создание и редактирование объектов, запись в базу данных

Технология ввода атрибутивных данных

Создание и редактирование объектов, запись в базу данных

Чтобы создать новый объект, выделите в дереве тот объект, в составе которого должен находиться новый. Для создания нового объекта внутри некоторой папки выделите эту папку в дереве объектов.

Напомним, что для каждого типа объекта в системе хранится информация о том, какие типы объектов могут быть созданы в его составе (см. подробнее). При нажатии кнопки [image] Добавить объект на панели инструментов или выполнении команды меню Объект| [image] Добавить объект появляется подменю со всеми типами объектов, которые могут быть созданы в составе выделенного.

Выбор типа создаваемого объекта

Если к выделенному объекту может быть добавлен только один тип объекта, то при нажатии соответствующей кнопки на панели инструментов сразу же создаётся новый объект.

Создание нового объекта

Если к выделенному объекту не может быть добавлен ни один объект, то кнопка на панели инструментов и команда меню будут недоступны.

После выбора нужного типа объекта в соответствующей ветви дерева создаётся новый объект, а в области справа появляются его параметры. Введите значения параметров нового объекта и запишите их в базу данных, нажав кнопку Записать.

Замечание
Некоторые параметры объектов, такие как наименование и марка оборудования, являются обязательными для заполнения. Если хотя бы один из таких параметров не указан, то записать описание объекта в базу данных будет нельзя.

Ввод параметров нового объекта

Чтобы изменить параметры одного из объектов в дереве, выделите его, измените в области справа нужные параметры и нажмите кнопку Записать. При нажатии кнопки Отмена все изменения текущего объекта, не записанные в базу данных, удаляются, и считываются последние записанные в базу значения параметров.

Совет
Чтобы изменения автоматически записывались в базу данных (без использования кнопки Записать), включите режим [image] Автосохранение изменений на панели инструментов. Он включается/отключается также командой меню Объект| [image] Автосохранение изменений.

Также в этом разделе:

Общие сведения

Поиск по дереву объектов

Прокрутка и масштабирование карты из окна ввода данных

Использование справочников при вводе параметров

Ввод дополнительной информации по объекту

Перемещение объектов в дереве

Копирование объектов

Переход к "родителю" объекта

Удаление объектов из базы данных

Связывание объектов с фигурами на карте

Поиск объектов на карте

Просмотр объектов, связанных с фигурами на карте

Просмотр фигур на карте, не связанных с объектами в базе данных

Загрузка описания объекта из XML-файла


Технология ввода атрибутивных данных. Использование справочников при вводе параметров

Технология ввода атрибутивных данных

Использование справочников при вводе параметров

Справочники информационной системы предназначены для систематизации различной информации: типов и марок оборудования, возможных значений параметров и т.п. Результатом такой систематизации становится то, что, занося некоторую информацию в систему, пользователь может вводить те и только те значения, которые содержатся в соответствующем справочнике. Это, во-первых, облегчает ввод, во-вторых, устраняет некоторые ошибки (опечатки), в-третьих, упрощает последующий анализ.

Если рядом с полем в окне ввода данных имеется специальная кнопка [image], значит, в такое поле можно заносить только значение из справочника. При нажатии кнопки [image] появляется выпадающий список с записями соответствующего для данного поля справочника, из которого следует выбрать подходящее значение. Если необходимое значение отсутствует в списке, то его можно добавить в справочник. Кнопка [image] открывает окно редактора справочников, где можно добавлять новые и редактировать существующие записи (см. подробнее).

Совет
Желательно, чтобы редактирование справочников выполнял только один пользователь. Это позволит избежать дублирования данных, которое может возникнуть, если несколько пользователей независимо друг от друга будут добавлять новые значения в справочники.

Элементы некоторых справочников выводятся не в виде простого списка, а объединяются в папки, образуя древовидную структуру. Это сделано для удобства выбора значений из справочника.

Организация значений справочника в виде дерева

Также в этом разделе:

Общие сведения

Поиск по дереву объектов

Прокрутка и масштабирование карты из окна ввода данных

Создание и редактирование объектов, запись в базу данных

Ввод дополнительной информации по объекту

Перемещение объектов в дереве

Копирование объектов

Переход к "родителю" объекта

Удаление объектов из базы данных

Связывание объектов с фигурами на карте

Поиск объектов на карте

Просмотр объектов, связанных с фигурами на карте

Просмотр фигур на карте, не связанных с объектами в базе данных

Загрузка описания объекта из XML-файла


Технология ввода атрибутивных данных. Ввод дополнительной информации по объекту

Технология ввода атрибутивных данных

Ввод дополнительной информации по объекту

Все объекты информационной системы имеют ряд дополнительных параметров. Они редактируются в окне, которое открывается кнопкой [image] Дополнительная информация по текущему объекту на панели инструментов или командой меню Объект| [image] Дополнительная информация…

Дополнительная информация по объекту включает: код в базе данных, уникальный код объекта, дату создания (при условии, что информация о создании объекта имеется в базе). Для редактирования доступны следующие параметры: инвентарный номер, балансовая стоимость, количество условных единиц (кнопка [image] рядом с полем автоматически вычисляет этот параметр для объекта по информации, содержащейся в базе данных), организация-владелец, обслуживающая организация, главный объект (т.е. тот, в состав которого входит объект) и примечание.

В нижней части окна отображается история принадлежности объекта.

Дополнительные параметры объекта

Также в этом разделе:

Общие сведения

Поиск по дереву объектов

Прокрутка и масштабирование карты из окна ввода данных

Создание и редактирование объектов, запись в базу данных

Использование справочников при вводе параметров

Перемещение объектов в дереве

Копирование объектов

Переход к "родителю" объекта

Удаление объектов из базы данных

Связывание объектов с фигурами на карте

Поиск объектов на карте

Просмотр объектов, связанных с фигурами на карте

Просмотр фигур на карте, не связанных с объектами в базе данных

Загрузка описания объекта из XML-файла


Технология ввода атрибутивных данных. Перемещение объектов в дереве

Технология ввода атрибутивных данных

Перемещение объектов в дереве

В пределах одной "ветви" дерева объекты располагаются в том порядке, в котором они были созданы. При большом количестве объектов удобнее расположить их так, чтобы было проще среди них ориентироваться. Переместить объект на одну позицию вверх или вниз по списку можно с помощью кнопок [image] Переместить вверх по списку и [image] Переместить вниз по списку на панели инструментов. Эти команды продублированы также в меню Объект.

Объект может быть перемещён в другую ветвь дерева - при этом изменится его владелец. Нажмите кнопку мыши на объекте и, удерживая её нажатой, перетащите объект на тот, в состав которого он должен входить.

Перемещение объекта в другую ветвь дерева

Также в этом разделе:

Общие сведения

Поиск по дереву объектов

Прокрутка и масштабирование карты из окна ввода данных

Создание и редактирование объектов, запись в базу данных

Использование справочников при вводе параметров

Ввод дополнительной информации по объекту

Копирование объектов

Переход к "родителю" объекта

Удаление объектов из базы данных

Связывание объектов с фигурами на карте

Поиск объектов на карте

Просмотр объектов, связанных с фигурами на карте

Просмотр фигур на карте, не связанных с объектами в базе данных

Загрузка описания объекта из XML-файла


Технология ввода атрибутивных данных. Копирование объектов

Технология ввода атрибутивных данных

Копирование объектов

При создании однотипных объектов, например ячеек, удобно использовать операцию копирования. Объект копируется аналогично перемещению (нужно перетащить его на нового владельца), но при этом следует удерживать клавишу Shift.

Копирование объекта
Замечание
Объект перемещается или копируется вместе со всеми объектами, входящими в его состав.

Также в этом разделе:

Общие сведения

Поиск по дереву объектов

Прокрутка и масштабирование карты из окна ввода данных

Создание и редактирование объектов, запись в базу данных

Использование справочников при вводе параметров

Ввод дополнительной информации по объекту

Перемещение объектов в дереве

Переход к "родителю" объекта

Удаление объектов из базы данных

Связывание объектов с фигурами на карте

Поиск объектов на карте

Просмотр объектов, связанных с фигурами на карте

Просмотр фигур на карте, не связанных с объектами в базе данных

Загрузка описания объекта из XML-файла


Технология ввода атрибутивных данных. Переход к "родителю" объекта

Технология ввода атрибутивных данных

Переход к "родителю" объекта

Корневым объектом в дереве является тот объект, для которого было вызвано окно ввода данных. На рисунке, представленном выше, это подстанция. Если необходимо перейти к владельцу корневого объекта, выделите его в дереве и нажмите кнопку [image] Перейти к родителю на панели инструментов или выполните команду меню Объект| [image] Перейти к родителю.

Также в этом разделе:

Общие сведения

Поиск по дереву объектов

Прокрутка и масштабирование карты из окна ввода данных

Создание и редактирование объектов, запись в базу данных

Использование справочников при вводе параметров

Ввод дополнительной информации по объекту

Перемещение объектов в дереве

Копирование объектов

Удаление объектов из базы данных

Связывание объектов с фигурами на карте

Поиск объектов на карте

Просмотр объектов, связанных с фигурами на карте

Просмотр фигур на карте, не связанных с объектами в базе данных

Загрузка описания объекта из XML-файла


Технология ввода атрибутивных данных. Удаление объектов из базы данных

Технология ввода атрибутивных данных

Удаление объектов из базы данных

Объекты могут быть удалены из базы данных без возможности восстановления либо перемещены в корзину, из которой впоследствии они могут быть восстановлены.

Чтобы переместить объект в корзину, выделите его в дереве объектов и нажмите кнопку [image] Удалить объект на панели инструментов. Также можно выполнить команду меню Объект| [image] Удалить объект или нажать клавишу Delete. Объект удаляется вместе со всеми "потомками", т.е. теми объектами, которые входят в его состав. При нажатии клавиш Shift+Delete объект удаляется без предварительного помещения в корзину, т.е. без возможности восстановления.

Корзина представляет отдельную ветвь в дереве объектов. При выделении корзины справа отображается её содержимое.

Просмотр содержимого корзины

Любой объект, находящийся в корзине, можно восстановить. Для этого выделите его и нажмите кнопку [image] Восстановить объект. Объект восстанавливается вмести со всеми своими потомками. Главным объектом для восстанавливаемого становится тот, который был ранее. Если же бывший владелец уже удалён из базы данных, то при попытке восстановления объекта появляется следующее предупреждение:

Предупреждение об отсутствии владельца

То есть пользователю следует самостоятельно определить нового родителя, "перетащив на него" объект из корзины.

Чтобы удалить объект из корзины, выделите его, нажмите кнопку [image] Удалить объект или клавишу Delete и подтвердите удаление в появившемся диалоговом окне.

Подтверждение удаления объекта

Для удаления всех объектов из корзины выделите корзину в дереве объектов и нажмите кнопку Очистить корзину.

Также в этом разделе:

Общие сведения

Поиск по дереву объектов

Прокрутка и масштабирование карты из окна ввода данных

Создание и редактирование объектов, запись в базу данных

Использование справочников при вводе параметров

Ввод дополнительной информации по объекту

Перемещение объектов в дереве

Копирование объектов

Переход к "родителю" объекта

Связывание объектов с фигурами на карте

Поиск объектов на карте

Просмотр объектов, связанных с фигурами на карте

Просмотр фигур на карте, не связанных с объектами в базе данных

Загрузка описания объекта из XML-файла


Технология ввода атрибутивных данных. Связывание объектов с фигурами на карте

Технология ввода атрибутивных данных

Связывание объектов с фигурами на карте

Если описанный в базе данных объект имеет графическое представление на карте, то следует связать описание с соответствующей фигурой. Для этого выделите объект в дереве и нажмите кнопку [image] Связать выделенный объект с фигурой на карте на панели инструментов или выполните команду меню Карта| [image] Связать с фигурой. При этом окно ввода данных временно скрывается для того, чтобы указать мышью соответствующую фигуру на карте. Возможны следующие варианты при выборе фигуры:

  • если указанная фигура ещё не связана ни с одним объектом в базе данных, то устанавливается связь с текущим объектом;
  • если указанная фигура уже связана с каким-то объектом в базе данных, то открывается окно, где будет предложено разорвать существующую связь и установить новую.
Замечание
Установить связь возможно только с теми фигурами, для которых настроено соответствие с нужным типом объекта (см. подробнее).

Существует также другой способ установления связи между объектами в базе данных и фигурами на карте. Основное отличие от предыдущего способа заключается в том, что сначала указывается фигура на карте, а затем выбирается соответствующий ей объект в базе данных.

Включите режим [image] Связывание фигур с объектами в базе данных (в окне редактора карт на панели инструментов Power Режимы) и щёлкните мышью на фигуре, с которой нужно связать некоторое описание.

Откроется окно с иерархией объектов в базе данных. Выберите в нём нужное описание объекта и нажмите кнопку ОК. Эта кнопка будет доступна только, если выбран объект, с которым у данной фигуры установлено соответствие.

Выбор соответствующего объекта в базе данных

Совет
Если установить флаг Запомнить, то текущее положение в дереве запоминается и при последующем открытии окна дерево будет раскрыто до данной позиции.

Разорвать связь между фигурой на карте и объектом можно в режиме [image] Удаление связей между фигурами и объектами в базе данных. Щёлкните мышью на фигуре, и если она связана с каким-то объектом в базе данных, то появится окно с краткой информацией о нём. При нажатии кнопки ОК связь фигуры с объектом разрывается.

Удаление связи между фигурой и объектом

Также в этом разделе:

Общие сведения

Поиск по дереву объектов

Прокрутка и масштабирование карты из окна ввода данных

Создание и редактирование объектов, запись в базу данных

Использование справочников при вводе параметров

Ввод дополнительной информации по объекту

Перемещение объектов в дереве

Копирование объектов

Переход к "родителю" объекта

Удаление объектов из базы данных

Поиск объектов на карте

Просмотр объектов, связанных с фигурами на карте

Просмотр фигур на карте, не связанных с объектами в базе данных

Загрузка описания объекта из XML-файла


Технология ввода атрибутивных данных. Поиск объектов на карте

Технология ввода атрибутивных данных

Поиск объектов на карте

Чтобы найти на текущей карте фигуру, соответствующую выделенному в дереве объекту, нажмите кнопку [image] Подсветить объект на текущей карте на панели инструментов или выполните команду меню Карта| [image] Подсветить.

Для поиска соответствующей фигуры на других картах проекта предназначена кнопка [image] Найти объект на карте, указанной пользователем… или команда меню Карта| [image] Найти на карте… Она открывает диалоговое окно, где можно выбрать карту, на которой требуется найти выделенный объект.

Выбор карты для поиска объекта

Также в этом разделе:

Общие сведения

Поиск по дереву объектов

Прокрутка и масштабирование карты из окна ввода данных

Создание и редактирование объектов, запись в базу данных

Использование справочников при вводе параметров

Ввод дополнительной информации по объекту

Перемещение объектов в дереве

Копирование объектов

Переход к "родителю" объекта

Удаление объектов из базы данных

Связывание объектов с фигурами на карте

Просмотр объектов, связанных с фигурами на карте

Просмотр фигур на карте, не связанных с объектами в базе данных

Загрузка описания объекта из XML-файла


Технология ввода атрибутивных данных. Просмотр объектов, связанных с фигурами на карте

Технология ввода атрибутивных данных

Просмотр объектов, связанных с фигурами на карте

При связывании объектов с фигурами на карте можно выполнять дополнительную проверку, выясняя, какие объекты в дереве уже связаны с фигурами, а какие - нет. Для этого включите режим [image] Выделять цветом объекты, связанные с фигурами на карте. В этом режиме все объекты в дереве, связанные с фигурами, отображаются на синем фоне.

Просмотр объектов, связанных с фигурами

Также в этом разделе:

Общие сведения

Поиск по дереву объектов

Прокрутка и масштабирование карты из окна ввода данных

Создание и редактирование объектов, запись в базу данных

Использование справочников при вводе параметров

Ввод дополнительной информации по объекту

Перемещение объектов в дереве

Копирование объектов

Переход к "родителю" объекта

Удаление объектов из базы данных

Связывание объектов с фигурами на карте

Поиск объектов на карте

Просмотр фигур на карте, не связанных с объектами в базе данных

Загрузка описания объекта из XML-файла


Технология ввода атрибутивных данных. Просмотр фигур на карте, не связанных с объектами в базе данных

Технология ввода атрибутивных данных

Просмотр фигур на карте, не связанных с объектами в базе данных

Можно выполнить и другой вид проверки, выяснив, какие фигуры на карте связаны с объектами в базе данных, а какие - нет.

  • Нажмите кнопку [image] Выделить фигуры, не связанные с объектами в базе данных на панели инструментов IndorInfo/Power или выполните команду меню IndorInfo/Power| [image] Выделить несвязанные фигуры. Эта команда подсвечивает на карте те фигуры, которые не связаны ни с одним объектом в базе данных. В проверке участвуют все фигуры на карте.
  • Чтобы выполнить проверку среди фигур в некоторой области, включите режим [image] Выделение фигур, не связанных с объектами в базе данных на панели инструментов Power Режимы и обведите нужный фрагмент карты рамкой. В указанной области будут выделены все фигуры, не связанные с объектами в базе данных. Этот режим удобно использовать, чтобы проверить, все ли элементы в схеме некоторой подстанции связаны с соответствующими объектами в базе данных.

Выделение фигур на карте, не связанных с объектами в базе данных

Также в этом разделе:

Общие сведения

Поиск по дереву объектов

Прокрутка и масштабирование карты из окна ввода данных

Создание и редактирование объектов, запись в базу данных

Использование справочников при вводе параметров

Ввод дополнительной информации по объекту

Перемещение объектов в дереве

Копирование объектов

Переход к "родителю" объекта

Удаление объектов из базы данных

Связывание объектов с фигурами на карте

Поиск объектов на карте

Просмотр объектов, связанных с фигурами на карте

Загрузка описания объекта из XML-файла


Технология ввода атрибутивных данных. Загрузка описания объекта из XML-файла

Технология ввода атрибутивных данных

Загрузка описания объекта из XML-файла

Атрибутивное описание объекта можно сохранить в файл с расширением *.xml. Это открытый обменный формат файла. Он может быть использован для того, чтобы загружать в базу данных атрибутивные описания объектов, сохранённые в XML-файл.

Чтобы сохранить описание объекта в XML-файл, выделите объект в дереве, выполните команду меню Объект| [image] Экспорт в XML… и в появившемся диалоговом окне введите имя файла.

Для загрузки атрибутивного описания объекта из XML-файла выполните команду меню Объект| [image] Импорт из XML… и выберите в диалоговом окне нужный файл.

Также в этом разделе:

Общие сведения

Поиск по дереву объектов

Прокрутка и масштабирование карты из окна ввода данных

Создание и редактирование объектов, запись в базу данных

Использование справочников при вводе параметров

Ввод дополнительной информации по объекту

Перемещение объектов в дереве

Копирование объектов

Переход к "родителю" объекта

Удаление объектов из базы данных

Связывание объектов с фигурами на карте

Поиск объектов на карте

Просмотр объектов, связанных с фигурами на карте

Просмотр фигур на карте, не связанных с объектами в базе данных


Ввод атрибутивных данных. Добавление документов по объектам в базу данных

Ввод атрибутивных данных

Добавление документов по объектам в базу данных

Для каждого объекта информационной системы в базе данных может быть сохранён произвольный набор сопутствующих документов. Эта возможность позволяет систематизировать и структурировать ведение документации по электрическим сетям, избежать их путаницы, утери и т.п. Сохранять в базу данных можно любые виды документов: документ Microsoft Word, книгу Microsoft Excel, различные виды изображений, видеоролики и многие другие.

Окно редактирования документов по объекту открывается из окна ввода данных. Для этого выделите объект в дереве и выполните команду меню Документы| [image] Общий список… или нажмите кнопку [image] Список документов текущего объекта… на панели инструментов. В появившемся окне отображается список прикреплённых к объекту документов.

Список сопутствующих документов объекта

Также в этом разделе:

Добавление документа

Редактирование документа

Удаление документа

Сохранение документа в отдельный файл


Добавление документов по объектам в базу данных. Добавление документа

Добавление документов по объектам в базу данных

Добавление документа

Чтобы добавить к объекту очередной сопутствующий документ, нажмите кнопку [image] Новый документ… и в появившемся диалоговом окне открытия файла выберите файл, в котором хранится документ. Запишите документ в базу данных, нажав кнопку [image] Сохранить в базу. Исходный файл документа теперь может быть удалён, поскольку информация останется в базе.

Добавить документ к объекту можно также из окна ввода данных, нажав кнопку [image] Добавить новый документ… на панели инструментов или выполнив команду меню Документы| [image] Добавить…

Также в этом разделе:

Редактирование документа

Удаление документа

Сохранение документа в отдельный файл


Добавление документов по объектам в базу данных. Редактирование документа

Добавление документов по объектам в базу данных

Редактирование документа

При добавлении документа в базу данных в качестве имени используется имя файла, из которого он был открыт. Если нужно изменить название документа, выделите его в списке и нажмите кнопку [image] Переименовать документ.

Чтобы отредактировать содержимое документа, нажмите кнопку [image] Редактировать документ… Документ будет открыт средствами того приложения, с которым ассоциированы файлы данного расширения. Если документ необходимо редактировать средствами другого приложения, нажмите кнопку [image] Редактировать документ с помощью… и выберите в появившемся окне исполняемый файл нужной программы.

По окончании редактирования документа запишите изменения в базу данных, нажав кнопку [image] Сохранить в базу.

Также в этом разделе:

Добавление документа

Удаление документа

Сохранение документа в отдельный файл


Добавление документов по объектам в базу данных. Удаление документа

Добавление документов по объектам в базу данных

Удаление документа

Чтобы удалить из базы данных прикреплённый к объекту документ, выделите его в списке и нажмите кнопку [image] Удалить документ.

Также в этом разделе:

Добавление документа

Редактирование документа

Сохранение документа в отдельный файл


Добавление документов по объектам в базу данных. Сохранение документа в отдельный файл

Добавление документов по объектам в базу данных

Сохранение документа в отдельный файл

Прикреплённый к объекту документ можно извлечь из базы данных и сохранить в виде файла на диск. Для этого нажмите кнопку [image] Сохранить в файл… и в появившемся окне укажите, куда следует сохранить файл. Теперь с этим файлом можно будет работать как с копией документа, переносить его на диске, отправлять по электронной почте и т.п.

Также в этом разделе:

Добавление документа

Редактирование документа

Удаление документа


Редактирование справочников. Общие сведения

Редактирование справочников

Общие сведения

Справочники информационной системы предоставляются уже наполненными, так что не требуется их предварительной настройки. Однако в процессе эксплуатации может возникнуть потребность корректировки справочных значений или добавления новых. Это связано с тем, что на предприятии может использоваться оборудование, параметры которого отличны от типовых. Информацию о таком оборудовании лучше внести в справочники, чтобы не вводить каждый раз вручную параметры, а выбирать нужный тип из справочника.

Окно редактора справочников открывается при нажатии кнопки [image] Справочники… на панели инструментов IndorInfo/Power.

Окно редактора справочников показано ниже на рисунке. В левой части окна отображаются наименования всех справочников информационной системы, сгруппированные по типам (Линии, Организации, Строительные части и т.д.).

Выберите в списке один из справочников (например, Виды опор). В правой части окна в разделе Описание будут отображены все элементы данного справочника. Если выбрать один из них, то ниже появятся список параметров, характерных для данного справочника, и значения этих параметров для выбранного элемента. Если элементы справочника характеризуются только наименованием, то список параметров будет пуст.

В нижней части окна располагается ряд кнопок, предназначенных для создания и редактирования элементов справочника.

Окно редактора справочников

Также в этом разделе:

Поиск элементов по наименованию

Создание новых элементов

Удаление элементов

Редактирование параметров элементов

Запись изменений в базу данных


Редактирование справочников. Поиск элементов по наименованию

Редактирование справочников

Поиск элементов по наименованию

В верхней части окна над списком элементов расположено поле для поиска элементов справочника по наименованию. При вводе в этом поле текста фокус переключается на первый элемент, содержащий указанное вхождение. Жёлтым цветом отображается первое вхождение, зелёным - все остальные. Переключаться по найденным элементам можно с помощью кнопок [image] [image], расположенных рядом с полем поиска.

Поиск элементов в справочнике по наименованию

Также в этом разделе:

Общие сведения

Создание новых элементов

Удаление элементов

Редактирование параметров элементов

Запись изменений в базу данных


Редактирование справочников. Создание новых элементов

Редактирование справочников

Создание новых элементов

Чтобы создать новый элемент справочника, нажмите кнопку [image] Добавить и введите название нового элемента.

Создание нового элемента справочника

Также в этом разделе:

Общие сведения

Поиск элементов по наименованию

Удаление элементов

Редактирование параметров элементов

Запись изменений в базу данных


Редактирование справочников. Удаление элементов

Редактирование справочников

Удаление элементов

Для удаления элемента из справочника выделите его в списке и нажмите кнопку [image] Удалить.

Также в этом разделе:

Общие сведения

Поиск элементов по наименованию

Создание новых элементов

Редактирование параметров элементов

Запись изменений в базу данных


Редактирование справочников. Редактирование параметров элементов

Редактирование справочников

Редактирование параметров элементов

Изменить название элемента справочника можно, нажав кнопку [image] Изменить.

Изменение названия элемента

Чтобы изменить значение параметра элемента справочника, щёлкните мышью в поле, после чего отредактируйте значение. Параметры элементов могут быть следующих типов:

  • Текстовое поле. Значение вводится в поле с клавиатуры.

Редактирование текстового поля

  • Числовое поле. Значение можно ввести с клавиатуры или использовать кнопки [image], расположенные в правой части поля.

Редактирование числового поля

  • Поле со списком. Значение выбирается из выпадающего списка.

Редактирование поля со списком

  • Поле с изображением. В этом поле можно задать связанное с элементом изображение (например, чертёж опоры). Если файл с изображением не задан, то поле содержит надпись "изображение не задано".

Редактирование поля с изображением

Чтобы задать файл с изображением, нажмите кнопку [image] и в появившемся окне откройте файл с изображением, нажав кнопку [image] Открыть. Кнопка [image] Записать в базу предназначена для записи изображения в базу данных, а кнопка [image] Сохранить - для сохранения изображения в отдельный файл.

Задание изображения для элемента справочника

Также в этом разделе:

Общие сведения

Поиск элементов по наименованию

Создание новых элементов

Удаление элементов

Запись изменений в базу данных


Редактирование справочников. Запись изменений в базу данных

Редактирование справочников

Запись изменений в базу данных

После редактирования параметров элемента справочника следует записать изменения в базу данных, нажав кнопку [image] Сохранить. Если не выполнить сохранение изменений, то при переключении на другой элемент справочника система выдаёт запрос о сохранении.

Чтобы изменения автоматически записывались в базу данных (без использования кнопки [image] Сохранить), включите режим [image] Автосохранение.

Также в этом разделе:

Общие сведения

Поиск элементов по наименованию

Создание новых элементов

Удаление элементов

Редактирование параметров элементов


Ввод атрибутивных данных. Экспорт параметров объектов в систему IndorElectra

Ввод атрибутивных данных

Экспорт параметров объектов в систему IndorElectra

Совместно с информационной системой электрических сетей IndorInfo/Power может использоваться система электрических расчётов IndorElectra. Система IndorElectra использует свою внутреннюю базу данных для хранения параметров объектов. При этом база данных информационной системы содержит все необходимые данные для выполнения электрических расчётов. Поэтому при совместном использовании систем не имеет смысла дважды вносить данные - в информационной системе и системе электрических расчётов. Правильнее будет занести один раз данные в систему IndorInfo/Power, а затем при необходимости выполнить экспорт данных в систему IndorElectra.

Замечание
Если данные в информационной системе интерактивно изменяются операторами, то они являются актуальными в любой момент времени. Поэтому возможность интеграции с системой электрических расчётов IndorElectra позволяет автоматизировать процесс расчёта текущего режима сети на основе актуальных данных, получаемых из информационной системы.

На панели инструментов IndorInfo/Power, а также в меню IndorInfo/Power доступна команда [image] Экспорт параметров в IndorElectra… При выполнении этой команды открывается диалоговое окно, где можно выбрать экспортируемые в IndorElectra данные.

Параметры экспорта данных в IndorElectra

В списке Используемые слои отображаются названия всех слоёв электрической схемы, присутствующих на текущей карте. Отметьте галочками те слои, данные по которым будут экспортированы в систему электрических расчётов. Далее укажите, параметры каких объектов должны быть экспортированы в IndorElectra (линий электропередачи, трансформаторов, компенсирующих устройств, потребителей).

Также в этом разделе:

Основные правила ввода данных

Формирование структуры сетевого предприятия

Информационная модель оборудования подстанции

Настройка соответствия объектов информационной системы и слоёв

Технология ввода атрибутивных данных

Добавление документов по объектам в базу данных

Редактирование справочников


Ввод данных по устройствам релейной защиты и автоматики (УРЗА). Редактирование справочников по УРЗА

Ввод данных по устройствам релейной защиты и автоматики (УРЗА)

Редактирование справочников по УРЗА

Справочники, используемые при вводе данных по устройствам РЗА, расположены в редакторе справочников в группе Оборудование и объединены в подгруппу УРЗА. Рассмотрим редактирование этих справочников.

Набор справочников по устройствам РЗА

Также в этом разделе:

Справочник "Классы УРЗА"

Справочник "Типы реле"

Справочник "Типы УРЗА"

Справочник "Группы периодичности ТО"


Редактирование справочников по УРЗА. Справочник "Классы УРЗА"

Редактирование справочников по УРЗА

Справочник "Классы УРЗА"

Данный справочник содержит все предусмотренные в системе классы устройств релейной защиты и автоматики. Он недоступен для редактирования пользователем.

Справочник Классы УРЗА

Также в этом разделе:

Справочник "Типы реле"

Справочник "Типы УРЗА"

Справочник "Группы периодичности ТО"


Редактирование справочников по УРЗА. Справочник "Типы реле"

Редактирование справочников по УРЗА

Справочник "Типы реле"

Этот справочник содержит все типы реле, которые могут использоваться при вводе данных, а также при настройке других справочников.

Справочник Типы реле

Также в этом разделе:

Справочник "Классы УРЗА"

Справочник "Типы УРЗА"

Справочник "Группы периодичности ТО"


Редактирование справочников по УРЗА. Справочник "Типы УРЗА"

Редактирование справочников по УРЗА

Справочник "Типы УРЗА"

Этот справочник содержит все типы устройств релейной защиты и автоматики, которые могут использоваться при вводе данных. Справочник доступен для редактирования: можно создавать новые типы УРЗА, редактировать или удалять существующие типы.

Справочник Типы УРЗА

Рассмотрим редактирование параметров некоторого типа УРЗА:

  • Если при вводе данных по устройствам РЗА данного типа нужно указывать значения уставок, то возможные уставки следует предварительно задать в справочнике. Для этого предназначены кноп-ки под списком Уставки. Чтобы добавить новую уставку, нажмите кнопку [image] Добавить, после чего в списке Уставки появится новый элемент. Чтобы изменить название уставки, выделите её в списке и нажмите кнопку [image] Изменить, а затем введите новое название. Кнопка [image] Удалить предназначена для удаления выделенной в списке уставки.
  • В списке Реле для реализации отображаются все типы реле из соответствующего справочника. Отметьте галочками те типы, которые могут использоваться в устройствах РЗА данного типа.
  • В списке Подтип устройства выберите, чем является данный тип УРЗА: защита, автоматика или прочее устройство.
  • При необходимости укажите дополнительную информацию в поле Примечание.
  • Все параметры, значения которых могут указываться при вводе данных по устройствам РЗА данного типа, следует задать в справочнике. Они отображаются в списке Параметры.

Чтобы добавить очередной параметр, нажмите кнопку [image] Добавить, расположенную под списком. При этом открывается диалоговое окно, где нужно ввести наименование параметра и выбрать его тип.

Если какой-то фрагмент текста в наименовании параметра должен отображаться в нижнем регистре (например, "Wур1, витков"), то в наименовании параметра этот текст нужно окружить символами $_ $~ (например, "W$_ур1$~, витков"). В диалоговых окнах наименование параметра будет выглядеть так:

Свойства числового параметра

Параметры могут быть трёх типов в зависимости от типов значений, которые они могут принимать: числовые, строковые и перечисление. Если значениями параметра являются числа, то его тип - Числовой. Если значениями параметра являются строки, то тип параметра - Строковый. Если значения параметра выбираются из списка допустимых значений, то его тип - Перечисление. При выборе этого типа параметра в диалоговом окне становятся доступными список Возможные значения и кнопки под этим списком. Чтобы добавить новое возможное значение параметра, нажмите кнопку [image] Добавить. Чтобы изменить наименование значения, выделите его в списке и нажмите кнопку [image] Изменить, а затем введите наименование. Кнопка [image] Удалить предназначена для удаления выделенного в списке значения.

Свойства параметра Перечисление

Также в этом разделе:

Справочник "Классы УРЗА"

Справочник "Типы реле"

Справочник "Группы периодичности ТО"


Редактирование справочников по УРЗА. Справочник "Группы периодичности ТО"

Редактирование справочников по УРЗА

Справочник "Группы периодичности ТО"

Этот справочник содержит группы периодичности технического обслуживания (ТО) устройств РЗА.

  • В поле Описание состава группы введите описание оборудования, которое может входить в состав группы.

Справочник Группы периодичности ТО

  • Укажите длительность цикла технического обслуживания, после чего появится таблица, столбцы в которой соответствуют годам.
  • Выберите из выпадающих списков работы, которые должны быть выполнены в определённые года цикла.

При выборе работы доступны следующие варианты:

    К - профилактический контроль;

    К1 - первый профилактический контроль;

    Т - тестовый контроль;

    О - опробование;

    М - снятие масштабных характеристик.

Количество столбцов в таблице равно двум циклам плюс 1. Дополнительный год (самый первый в таблице, его порядковый номер 0) соответствует наладке оборудования, поэтому в этом столбце автоматически устанавливается цифра Н.

Первый цикл технического обслуживания: от наладки до первого восстановления (в примере, приведённом выше на рисунке, это годы с 1-го по 8-й), отличается от стандартного, поэтому для него отдельно задаётся периодичность технического обслуживания.

Второй цикл является стандартным (в примере - годы с 9-го по 16-й), он повторяется для оборудования с заданной периодичностью.

В последнем году первого и второго циклов автоматически устанавливается цифра В, что соответствует профилактическому восстановлению.

Также в этом разделе:

Справочник "Классы УРЗА"

Справочник "Типы реле"

Справочник "Типы УРЗА"


Ввод данных по устройствам релейной защиты и автоматики (УРЗА). Ввод данных по УРЗА

Ввод данных по устройствам релейной защиты и автоматики (УРЗА)

Ввод данных по УРЗА

Устройства релейной защиты и автоматики могут быть добавлены к тем объектам информационной системы, в составе которых имеется папка Защита, автоматика и прочие.

Папка Защита, автоматика и прочие в составе объектов

Чтобы создать устройство РЗА, выделите в дереве объектов папку Защита, автоматика и прочие и нажмите кнопку [image] Создать объект на панели инструментов. В составе сложного устройства РЗА могут быть созданы простые устройства. Для этого выделите сложное устройство в дереве объектов и нажмите кнопку [image] Создать объект. Ниже на рисунке показан список защит, созданных в ячейке. Одна из защит является сложной и содержит в себе простую защиту.

Список защит в ячейке

Рассмотрим параметры, задаваемые для устройства РЗА.

  • Общие данные

На закладке Общие данные указывается наименование устройства. Далее из выпадающего списка выбирается Тип защищаемого объекта. Этот список содержит все значения справочника Классы УРЗА. В следующем списке выбирается сам защищаемый объект (если его описание присутствует в базе данных).

Далее выбирается подтип данного устройства РЗА: защита, автоматика или прочее. В следующем списке выбирается Тип УРЗА.

Замечание
Этот список содержит все типы УРЗА, заданные в справочнике Типы УРЗА, для которых значением параметра Подтип устройства является значение, выбранное в списке Подтип УРЗА.

Ниже выбирается диспетчерское управление и группа по техническому обслуживанию, в состав которой входит данное устройство РЗА, указывается номинальное напряжение устройства.

Для сложных устройств нужно установить флаг Является сложным устройством. В поле Примечание можно ввести дополнительную информацию по устройству РЗА. Также на этой закладке указывается способ срабатывания защиты: На отключение или На сигнал, и, находится ли защита в работе.

Параметры объекта УРЗА (закладка Общие данные)

  • Реализация

На закладке Реализация задаётся ступень защиты устройства РЗА, выбирается тип основного реле и указывается их количество. Если защита имеет вспомогательные реле, их нужно добавить в список, расположенный ниже. Чтобы добавить вспомогательное реле, нажмите кнопку [image], расположенную под списком, а затем выберите из выпадающего списка нужный тип реле. Кнопка [image] удаляет выбранное реле из списка.

Параметры объекта УРЗА (закладка Реализация)

Замечание
Списки, в которых выбираются типы реле, содержат только те типы реле, которые указаны в справочнике для данного типа УРЗА (см. подробнее).
  • Трансформаторы

На закладке Трансформаторы выбираются трансформаторы тока и напряжения, используемые защитой.

Параметры объекта УРЗА (закладка Трансформаторы)

Чтобы добавить очередной трансформатор тока или напряжения, нажмите кнопку [image], расположенную под соответствующим списком. Откроется диалоговое окно, в котором представлены в виде дерева все описанные в базе данных объекты. Найдите в иерархии описание нужного трансформатора, выделите его и нажмите кнопку ОК.

Выбор трансформатора напряжения, используемого защитой

На случай, если в базе данных не созданы описания нужных трансформаторов тока или напряжения, предусмотрена возможность ввода вручную наименований этих объектов в списке Дополнительное описание трансформаторов тока и напряжения. Указанные наименования будут использоваться при формировании отчётов по устройствам РЗА.

Флаг Использовать общие для присоединения трансформаторы нужно устанавливать у тех защит в ячейке, которые используют общие трансформаторы тока и напряжения. В карте уставок для таких защит создаётся общая ячейка, где отображаются используемые защитами трансформаторы тока и напряжения. Информация о трансформаторах берётся у одной из защит этой группы. Таким образом, для корректного ввода данных по таким защитам нужно задавать трансформаторы тока и напряжения только для одной защиты из группы или задавать одинаковые трансформаторы тока и напряжения для всех защит.

  • Уставки и параметры

Если для редактируемого типа УРЗА в справочнике заданы уставки и/или параметры, то на закладке Уставки и параметры можно задать их значения. Для каждой уставки указывается её значение на первичной и вторичной обмотках измерительного трансформатора.

Ниже указывается время срабатывания защиты. Чтобы добавить очередное значение времени, нажмите кнопку [image], расположенную под списком, и укажите значение времени. Чтобы добавить исполнительный механизм, нажмите кнопку [image], расположенную справа в поле ввода, после чего в диалоговом окне выбора объекта укажите нужный коммутатор.

Параметры объекта УРЗА (закладка Уставки и параметры)

Для задания значений параметров устройства РЗА нужно сначала выбрать среди допустимых те параметры, которые определены для данного устройства. Нажмите кнопку Выбрать используемые параметры и в появившемся диалоговом окне отметьте галочками параметры, которые будут задаваться.

Замечание
Список в этом окне содержит только те параметры, которые заданы в справочнике для данного типа УРЗА.

Выбор задаваемых параметров для данного устройства

Указанные параметры появятся на закладке Уставка и параметры, после чего можно будет ввести их значения.

Также в этом разделе:

Редактирование справочников по УРЗА

Формирование графика технического обслуживания УРЗА


Ввод данных по устройствам релейной защиты и автоматики (УРЗА). Формирование графика технического обслуживания УРЗА

Ввод данных по устройствам релейной защиты и автоматики (УРЗА)

Формирование графика технического обслуживания УРЗА

График технического обслуживания может быть сформирован по устройствам релейной защиты и автоматики, входящим в состав некоторой подстанции. Среди параметров подстанции в окне ввода данных имеется кнопка График ТО УРЗА… Она открывает окно, где можно просмотреть информацию по всем работам, заданным для устройств РЗА данной подстанции, а также сформировать план работ по этим устройствам.

Открытие окна формирования графика ТО УРЗА некоторой подстанции

При открытии окна на закладке Информация по ТО отображаются в виде списка все устройства РЗА данной подстанции. Для каждой защиты показывается её порядковый номер в списке и название ячейки, в которой она расположена.

Список устройств РЗА подстанции

При нажатии кнопки [image] Обновить список, расположенной в нижней части окна, для каждой защиты появляется информация о её последней работе. По работе выводится информация о начале и окончании работы по плану и по факту.

Замечание
Работы для защит задаются аналогично другим объектам (см. подробнее).

Работы защиты сортируются следующим образом: самой последней (или поздней) считается та работа, у которой позже дата окончания по факту. Для работ, у которых эта дата не установлена или одинаковая, сравниваются даты начала работы по факту. Затем сравниваются даты окончания работы по плану и после этого - даты начала работы по плану.

Информация по техническому обслуживанию устройств РЗА

Таким образом, работы по защите упорядочиваются в порядке от самой первой (ранней) до самой последней (поздней) работы.

Чтобы просмотреть информацию по другим работам защиты (запланированным, выполненным и т.д.), раскройте список в поле Вид ТО. Работы выводятся в список в определённом порядке сверху вниз - от самой поздней работы к самой ранней. При выборе одной из работ в полях справа появляется аналогичная информация: начало и окончание работы по плану и по факту.

Из этого окна можно открыть окно редактирования любой из работ. Для этого выделите работу и нажмите кнопку [image] Редактировать выбранную работу, расположенную в нижней части окна.

Переключитесь на закладку План ТО, чтобы сформировать план технического обслуживания по устройствам РЗА.

Для автоматического построения графика ТО установите Год планируемого ТО и нажмите кнопку Построить. Если на указанный год для защиты запланирована некоторая работа, то она выводится в поле Вид ТО.

План технического обслуживания по устройствам РЗА

Рассмотрим процедуру формирования графика технического обслуживания. Напомним, что при вводе данных по устройствам РЗА следует указывать группу по ТО, в состав которой они входят (см. подробнее). В справочнике Группы периодичности ТО описаны циклы технического обслуживания (первый и последующий) для каждой группы (см. подробнее). Вид работы, устанавливаемый для защиты на планируемый год, определяется исходя из группы по техническому обслуживанию.

Планируемая работа определяется по соответствующему циклу следующим образом:

  • Выясняется, в каком году для защиты было проведено последнее восстановление. Если восстановление ещё не проводилось, т.е. идёт только первый цикл, то выясняется, в каком году была проведена наладка.
  • Далее по циклу технического обслуживания определяется, какая работа должна быть выполнена в год планирования.

Теперь вернёмся к примеру, представленном выше на рисунке. Известно, что для защиты №1 в 2007 году была выполнена работа "Наладка", работа "Восстановление" для неё ещё не проводилась, а для защиты №3 последнее восстановление было выполнено в 2007 году. Обе этих защиты входят в группу по техническому обслуживанию "Группа 1". Ниже показан цикл этой группы.

Цикл технического обслуживания для группы "Группа 1"

По циклу можно определить, что для защиты №1 в следующем за наладкой 2009 году должен быть выполнен первый профилактический контроль (К1), а для защиты №3 в следующем после восстановления году должен быть выполнен профилактический контроль (К).

Как видно из рисунка, представленного выше, в результате автоматического планирования для защит были выставлены именно эти виды работ на год планирования.

Замечание
После автоматического планирования для некоторых защит в поле Вид ТО может оказаться знак "?". Это происходит в двух случаях: если для данной защиты не задана группа по техническому обслуживанию и, следовательно, невозможно определить планируемую работу или если год планирования задан такой, что интервал времени от последнего восстановления (или наладки) до планируемого года превышает количество лет в цикле технического обслуживания.

График технического обслуживания может быть сформирован не автоматически, а задан вручную. Для этого предназначены команды в разделе Установить вид ТО вручную.

Установка ТО вручную заключается в том, что пользователь сам задаёт вид ТО и планируемую дату и устанавливает эти параметры для указанного диапазона защит. В поле Номера укажите нужный диапазон номеров защит (можно задать номера через запятую: "2,7,28", диапазон номеров: "5-15", несколько диапазонов: "2-6, 5-15"). Затем выберите из списка вид ТО и укажите дату, на которую планируются работы. После этого нажмите кнопку Установить.

Задание плана технического обслуживания вручную

Кнопка Очистить удаляет установленный вид ТО для защит с номерами, указанными в поле Номера. Кнопка Очистить всё полностью удаляет план технического обслуживания.

Чтобы установленный в этом окне план технического обслуживания был записан в базу данных, нажмите кнопку Записать. При этом заданные в плане работы добавляются в качестве запланированных к устройствам РЗА. Если перед нажатием кнопки Записать установить флаг "Закрыть" работы, то запланированные работы создаются в статусе Принятые.

Также в этом разделе:

Редактирование справочников по УРЗА

Ввод данных по УРЗА


Ввод данных по потребителям

В информационной системе IndorInfo/Power реализованы функции для ввода информации по потребителям электроэнергии, которая включает применяемые к потребителю тарифы, его приборы учёта и пр. К потребителям применяются тарифы из справочника, содержащего все действующие типы тарифов. Справочник можно дополнить новыми тарифами или изменить параметры существующих.

Один потребитель может иметь более одного тарифа (например, тарифы, действующие в разное время суток). Тарифы упорядочиваются в соответствии с устанавливаемыми для них приоритетами.

В системе поддерживаются различные модели потребителей:

  • потребители бытового сектора, имеющие один прибор учёта;
  • потребители частного бытового сектора, имеющие один прибор учёта на несколько потребителей либо не имеющие приборов учёта;
  • потребители промышленного сектора или иные крупные потребители, имеющие несколько приборов учёта.

Также в этом разделе:

Ввод измерений приборов учёта

Редактирование справочника "Тарифы"

Ввод данных по потребителям

Виды потребителей


Ввод данных по потребителям. Ввод измерений приборов учёта

Ввод данных по потребителям

Ввод измерений приборов учёта

В информационной системе прибору учёта электроэнергии соответствует объект Измерительный прибор. Этот объект характеризуется некоторой измеряемой величиной. В архиве измерений для него хранятся зафиксированные значения измеряемой величины, снятые с прибора. Показания прибора могут быть занесены в архив измерений вручную. Кроме этого, передача измерений возможна средствами телеметрии в режиме реального времени (см. подробнее). Измерительный прибор может быть добавлен к тем объектам информационной системы, в составе которых есть папка Измерительные приборы.

Рассмотрим некоторые параметры этого объекта. На закладке Общие данные указывается наименование прибора и выбирается его марка. В справочнике Типы измерительного оборудования для каждой марки указано, какие величины может измерять прибор данной марки. Эти величины отображаются в выпадающем списке Измеряемая величина, где следует выбрать величину, которую измеряет данный прибор.

После записи информации об измерительном приборе в базу данных (кнопка Записать) становится доступным поле Значение для ввода показаний прибора. Время снятия показаний с прибора устанавливается автоматически при нажатии кнопки Зафиксировать.

Параметр Коэффициент поправки необходимо указывать для коррекции измерений (например, в связи с изменением характеристик вследствие износа или брака).

Параметры объекта Измерительный прибор (закладка Общие данные)

На закладке Архив измерений отображаются все зафиксированные показания прибора (вручную или средствами телеметрии).

Параметры объекта Измерительный прибор (закладка Архив измерений)

Также в этом разделе:

Редактирование справочника "Тарифы"

Ввод данных по потребителям

Виды потребителей


Ввод данных по потребителям. Редактирование справочника "Тарифы"

Ввод данных по потребителям

Редактирование справочника "Тарифы"

Справочник тарифов хранит информацию обо всех тарифах, по которым может рассчитываться стоимость электроэнергии. Тарифы разбиты на следующие группы: Население, Сельскохозяйственные потребители, Бюджетные потребители, Прочие потребители ВН (110 кВ и выше), Прочие потребители СН I (35 кВ), Прочие потребители СН II (20-1 кВ), Прочие потребители НН (0,4 кВ и ниже), Оптовые тарифы.

В группах выделяются следующие типы тарифов:

Население:

  • Город:
    • Одноставочный тариф.
    • Одноставочный тариф, учитывающий наличие плиты:

      • - газовые плиты;

      - электроплиты.

    • Тарифы, дифференцированные по зонам суток:

      • - дневная зона;

      - ночная зона.

    • Ограниченные по соцнорме:

      • - в пределах соцнормы;

      - сверх соцнормы.

    • Тариф выходного дня (суббота, воскресенье, праздники).
  • Село:
    • Одноставочный тариф.
    • Ограниченные по соцнорме:

      • - в пределах соцнормы;

      - сверх соцнормы.

Сельскохозяйственные потребители:

    • Одноставочный тариф.
    • Тарифы, дифференцированные по зонам суток:

      • - ночная зона;

      - полупиковая зона;

      - пиковая зона.

Бюджетные потребители:

    • Одноставочный тариф.
    • Тарифы, дифференцированные по зонам суток:

      • - ночная зона;

      - полупиковая зона;

      - пиковая зона.

Прочие потребители:

    • Двухставочный тариф:

      • - ставка за мощность;

      - ставка за энергию.

    • Одноставочный тариф:

      • - >7000 кВт;

      - 6000-7000 кВт;

      - 5000-6000 кВт;

      - 4000-5000 кВт;

      - 3000-4000 кВт;

      - 2000-3000 кВт;

      - <2000 кВт.

Оптовые тарифы:

    • Двухставочный тариф:

      • - ставка за мощность;

      - ставка за энергию.

Для тарифов, дифференцированных по времени суток, действуют следующие временные рамки:

    • ночная зона 23:00-7:00;
    • полупиковая зона 7:00-8:00, 11:00-18:00 и 21:00-23:00;
    • пиковая зона 8:00-11:00 и 18:00-21:00;
    • дневная зона 7:00-23:00.

В редакторе справочник тарифов располагается в группе Добавочные. Для тарифа задаются следующие параметры:

  • Группа. В этом поле указывается группа тарифов, которой принадлежит данный тариф.
  • Наименование. Здесь указывается наименование тарифа.
  • Условие применения. Это поле содержит формулу, при истинности которой данный тариф можно применить.
  • Дата ввода и дата отмены. Эти параметры определяют период, когда тариф является действующим для организации - поставщика электроэнергии (например, в связи с приказами о введении/отмене тарифа).
  • Стоимость. В этом поле указывается стоимость за 1 кВ потреблённой мощности.
  • Приоритет. Этот параметр указывает на порядок применения тарифов относительно друг друга (если для потребителя применяются несколько тарифов).

Справочник Тарифы

Справочник тарифов предоставляется уже наполненным. Однако существует возможность добавлять новые тарифы или изменять существующие (см. подробнее).

Также в этом разделе:

Ввод измерений приборов учёта

Ввод данных по потребителям

Виды потребителей


Ввод данных по потребителям. Ввод данных по потребителям

Ввод данных по потребителям

Ввод данных по потребителям

Потребителю электроэнергии в информационной системе соответствует объект Потребитель. Он может быть добавлен в состав тех объектов, в которых есть папка Потребители (например, Сеть электроснабжения). Рассмотрим параметры, задаваемые для потребителя.

На закладке Общие данные указывается наименование потребителя, из выпадающего списка выбирается Тип нагрузки (список содержит все значения справочника Типы потребителей). Затем указывается номинальное напряжение потребителя, организация, являющаяся его владельцем, и сеть, в состав которой входит потребитель. Также можно указать адрес потребителя и некоторую дополнительную информацию в поле Примечание.

Параметры объекта Потребитель (закладка Общие данные)

Список используемых потребителем тарифов задаётся на закладке Тарифы. Напомним, что один потребитель может иметь более одного тарифа (например, тарифы, действующие в разное время суток).

Параметры объекта Потребитель (закладка Тарифы)

Чтобы добавить очередной тариф, нажмите кнопку [image] Добавить тариф, расположенную под списком тарифов абонента. В появившемся диалоговом окне выберите нужный тариф из справочника, укажите период его действия для данного потребителя (например, в связи с заключением договора с организацией, поставляющей электроэнергию на определённый срок), он ограничивается датами ввода и отмены, установленными для тарифа в справочнике.

Также при необходимости можно изменить приоритет тарифа у данного потребителя. В разделе Дополнительная информация отображаются параметры выбранного тарифа, заданные в справочнике.

Добавление нового тарифа

Чтобы изменить параметры выделенного в списке тарифа, нажмите кнопку [image] Изменить тариф. Кнопка [image] удаляет выделенный тариф из списка тарифов потребителя.

Если для потребителя задано несколько тарифов, то в списке они отображаются в порядке уменьшения приоритета: самый верхний в списке тариф обладает самым высоким приоритетом, самый последний - самым низким приоритетом. Тарифы можно перемещать по списку, изменяя тем самым их приоритет. Для этого предназначены кнопки [image] Переместить выделенный тариф вверх по списку и [image] Переместить выделенный тариф вниз по списку.

При выделении в списке одного из тарифов слева отображается период его использования для данного потребителя (поля Начало расчёта и Окончание расчёта).

На этой же закладке (Тарифы) задаются приборы учёта, снимающие показания по потребителю. Чтобы добавить очередной прибор, нажмите кнопку [image] Добавить описание прибора учёта, расположенную под списком измерительных приборов абонента.

В появившемся диалоговом окне выберите измерительный прибор, используемый для потребителя. Он появится в списке приборов учёта потребителя.

Выбор измерительного прибора в базе данных

При нажатии кнопки [image] Редактировать выделенное описание для выделенного прибора учёта открывается диалоговое окно редактирования его параметров, в котором, например, можно просмотреть архив измерений прибора. Кнопка [image] удаляет выделенный прибор из списка приборов учёта потребителя.

Рассмотрим дополнительные параметры, устанавливаемые для измерительных приборов:

  • Для каждого прибора следует указывать, для каких целей он используется: учёт электроэнергии (переключатель Учёт) или же контроль (переключатель Контроль).
  • Измерительный прибор может рассчитывать стоимость по собственным, запрограммированным тарифам. Для таких приборов следует установить флаг Собственная программа.
  • Галочка, отображаемая рядом с названием измерительного прибора, определяет, по какому тарифу (или тарифам) рассчитываются его показания. Например, чтобы указать, что показания прибора учёта Измерительный прибор 1 рассчитываются по Дневному тарифу, нужно выделить этот тариф в списке и установить галочку рядом с названием измерительного прибора (см. рисунок выше).

Также в этом разделе:

Ввод измерений приборов учёта

Редактирование справочника "Тарифы"

Виды потребителей


Ввод данных по потребителям. Виды потребителей

Ввод данных по потребителям

Виды потребителей

Рассмотрим возможные виды потребителей:

  1. Потребители бытового сектора города - у каждого потребителя имеется собственный прибор учёта. Показания одного прибора учёта могут рассчитываться по разным тарифам (например, дневной тариф и ночной).

Для такого потребителя нужно добавить все используемые им тарифы, добавить используемый прибор учёта, после чего "пройти" по всем тарифам и установить галочку рядом с измерительным прибором, тем самым указав, что при расчёте следует использовать показания этого прибора.

Потребитель, использующий один прибор учёта

  2. Несколько потребителей частного бытового сектора могут иметь один прибор учёта (например, единственный прибор учёта установлен на дом, в котором имеется 2 квартиры). Для таких потребителей задаётся Коэффициент учёта. Он отражает, какая часть электроэнергии, учтённая данным прибором учёта, была потреблена каждым из потребителей. При прочих равных условиях (количество проживающих в квартире, наличие электроплиты и т.п.) коэффициент учёта для каждого из двух потребителей равен 0,5.

Потребители, использующие один прибор учёта

Для таких потребителей следует выполнить те же действия, что и в п. 1. Однако для измерительного прибора каждого потребителя нужно установить соответствующий ему коэффициент учёта.

  3. Потребители промышленного сектора или иные крупные потребители могут иметь более одного прибора учёта.

Для такого потребителя нужно добавить все используемые им тарифы и приборы учёта. Затем для каждого тарифа нужно указать, какой прибор учёта используется при расчёте по данному тарифу.

Потребитель, использующий несколько приборов учёта

В примере, представленном на рисунке, тарифы Двуставочный за энергию и Двуставочный за мощность используют показания прибора учёта Измерительный прибор 3, а все остальные тарифы - показания прибора учёта Измерительный прибор 4.

Также в этом разделе:

Ввод измерений приборов учёта

Редактирование справочника "Тарифы"

Ввод данных по потребителям

Наверх [image] Назад [image] Вперёд Авторское право © 2009 ООО "ИндорСофт"


Ввод эксплуатационных данных

Под эксплуатационной информацией будем понимать совокупность работ, планируемых и выполняемых для объектов информационной системы, проведённые оценки и измерения, обнаруженные неисправности. При вводе этих данных используются Эксплуатационные справочники. Они предоставляются частично наполненными, однако в процессе ввода данных может потребоваться их дополнительная корректировка. Ниже рассматривается настройка эксплуатационных справочников и процедуры ввода данных по работам, измерениям и неисправностям.

Также в этом разделе:

Ввод данных по работам объекта

Ввод данных по измерениям и испытаниям объекта

Ввод данных по неисправностям объекта


Ввод данных по работам объекта. Общие сведения

Ввод данных по работам объекта

Общие сведения

Работа может находиться в одном из следующих состояний (или статусов):

  • Запланирована. Это работа, поставленная в план работ по объекту.
  • Поставлена в график. При утверждении запланированной работы она переходит в состояние Поставлена в график.
  • Текущая. При установке даты начала работы по факту она переходит в состояние Текущая. Текущей считается и законченная работа, т.е. та, у которой установлена дата окончания.
  • Принятая. Законченная работа, для которой указано, что она была принята, переходит в состояние Принятая.
  • Просроченная. Из состояния Текущая работа может оказаться в состоянии Просроченная. Это происходит, если работа не была начата или закончена в срок.

Создать работу можно на любом этапе её жизненного цикла: запланирована, поставлена в график, текущая или принята. Например, можно сразу создать работу со статусом Поставлена в график, минуя стадию Запланирована.

Работа может включать в себя другие работы, которые могут выполняться как для этого же объекта, так и для любого другого объекта информационной системы. Такие работы называются подработами.

Также в этом разделе:

Редактирование справочника "Виды работ"

Процедура ввода данных по работам

Создание подработ в составе работы

Просмотр общего списка работ


Ввод данных по работам объекта. Редактирование справочника "Виды работ"

Ввод данных по работам объекта

Редактирование справочника "Виды работ"

Данный справочник содержит все виды работ, которые могут быть заданы для объектов информационной системы. Справочник доступен для редактирования: можно создавать новые виды работ, редактировать или удалять существующие виды.

При создании нового вида работы укажите следующие параметры:

  • Введите наименование, определяющее вид работы (например, Приёмка, Осмотр без отключения, Демонтаж и т.д.).

Ввод наименования работы

  • Выберите класс, к которому относится работа. Возможные варианты: Создание, Ввод в эксплуатацию, Осмотр, Испытание, Текущий ремонт, Капитальный ремонт, Реконструкция, Вывод в резерв, Уничтожение. Набор классов работ прописан в системе и недоступен для редактирования пользователем.
  • Выберите тип объекта, для которого выполняется работа.

Справочник Виды работ

Замечания
  1. В названии вида работы отображается тип объекта, для которого она выполняется (например, Подстанция - Приёмка, ЛЭП 35 кВ - Осмотр без отключения, ЛЭП 10 кВ - Демонтаж и т.д.). Он выводится в название автоматически из поля Тип объекта, и сделано это для удобства поиска нужной работы в списке.
  2. В одном классе может быть создано несколько видов работ для разных типов объектов. Например, в классе Создание могут присутствовать такие виды работ: Подстанция - Приёмка, Подстанция - Изыскания, ЛЭП 35 кВ - Приёмка, ЛЭП 35 кВ - Изыскания и т.д.
  • Укажите, с какой периодичностью должна выполняться работа (поле Нормативная периодичность) и на какой период выполнение работы может отклоняться от сроков (поле Допуск по срокам).
  • Можно задать в виде шаблона список подработ, которые могут быть выполнены в составе работы данного вида. Это значительно упрощает ввод данных по подработам (см. подробнее). Добавление подработы в шаблон заключается в выборе типа объекта и соответствующего вида работы по этому объекту.

Чтобы добавить подработу в шаблон, нажмите кнопку [image], расположенную под списком подработ. В появившемся диалоговом окне выберите тип объекта и раскройте список его работ. Этот список формируется из всех видов работ, заданных в справочнике Виды работ для данного типа объекта. Выберите тип подработы, выполняемый для указанного объекта в составе данного вида работы.

Добавление подработы в шаблон

Выбранная работа появится в Списке подработ для редактируемого вида работы. Кнопка [image], расположенная под списком подработ, предназначена для удаления подработы.

Также в этом разделе:

Общие сведения

Процедура ввода данных по работам

Создание подработ в составе работы

Просмотр общего списка работ


Ввод данных по работам объекта. Процедура ввода данных по работам

Ввод данных по работам объекта

Процедура ввода данных по работам

Задание списка работ по объекту выполняется из окна ввода данных. Выделите в дереве объектов нужный объект и нажмите кнопку [image] Планировщик работ по текущему объекту… на панели инструментов или выполните команду меню Работы| [image] План работ…

Открытие окна редактирования работ по объекту

Окно редактирования работ по объекту содержит пять закладок для отображения работ в разных статусах. На закладке План отображаются все запланированные работы по объекту, на закладке График - все утверждённые работы, на закладке Текущие - текущие работы объекта, а на закладке Принятые - принятые работы. Если имеются просроченные работы по данному объекту, то они отображаются на закладке Просроченные.

Запланированные работы объекта

Для каждой работы в названии отображается дата начала по графику (если работа запланирована или поставлена в график) или дата начала по факту (если работа является текущей или принятой). Далее отображается название объекта и вид работы.

В нижней части окна располагаются кнопки для создания и редактирования работ:

Обновляет список работ по объекту.

Создаёт новую работу и открывает окно редактирования её свойств.

Открывает окно редактирования свойств выделенной в списке работы.

Удаляет выделенную в списке работу.

Рассмотрим создание новой работы и переходы работы от состояния Запланирована до состояния Принята.

Чтобы создать новую работу, нажмите кнопку [image] Добавить работу. В появившемся диалоговом окне из выпадающего списка выберите вид работы.

Замечание
Список содержит только те виды работ, которые заданы в справочнике для текущего типа объекта (см. подробнее).

Для постановки работы в план установите флаг Работа запланирована и введите соответствующую дату. По умолчанию в качестве даты планирования устанавливается текущая дата.

Создание работы и постановка работы в план

После записи работы в базу данных (кнопка Записать) и закрытия окна на закладке План появляется новая запланированная работа (см. рисунок выше).

Чтобы утвердить работу и тем самым поставить её в график, откройте окно редактирования работы. Для этого выделите работу на закладке План и нажмите кнопку [image] Редактировать работу. В диалоговом окне редактирования работы установите флаг Работа утверждена и введите соответствующую дату (по умолчанию устанавливается текущая дата). Далее можно уточнить даты начала и окончания работы по графику.

Замечание
Дата утверждения работы не может быть меньше, чем дата, когда она была запланирована.

Переход работы в состояние Поставлена в график

После записи изменений статус работы изменится на Поставлена в график, а после закрытия окна она переместится на закладку График.

График работ объекта

Для работы, которая начата по факту, установите в диалоговом окне редактирования работы флаг Работа начата и укажите дату начала работы по факту.

Переход работы в состояние Текущая

После записи изменений статус работы изменится на Текущая, а после закрытия окна она будет перемещена на закладку Текущие.

Текущие работы объекта

Когда работа будет закончена по факту, установите в диалоговом окне редактирования работы флаг Работа окончена и введите дату окончания работы. При этом статус работы не изменится, она будет считаться текущей.

Фиксация окончания работы по факту

После того как завершённая работа будет принята, установите в окне редактирования работы флаг Принята. При этом работа перейдёт в состояние Принята и переместится на закладку Принятые.

Замечание
Нельзя принять работу до тех пор, пока она не будет завершена.

Принятые работы объекта

Рассмотрим ситуации, когда работа из статуса текущей переходит в статус просроченной.

  1. Если работа не была начата в срок. То есть для работы ещё не установлена дата начала по факту, а текущая дата больше, чем дата начала работы по графику. В качестве текущей используется дата, которая установлена на компьютере пользователя.
  2. Если работа не была закончена в срок. То есть для работы ещё не установлена дата окончания по факту, а текущая дата больше, чем дата окончания работы по графику.

Просроченные работы объекта

Также в этом разделе:

Общие сведения

Редактирование справочника "Виды работ"

Создание подработ в составе работы

Просмотр общего списка работ


Ввод данных по работам объекта. Создание подработ в составе работы

Ввод данных по работам объекта

Создание подработ в составе работы

Рассмотрим создание подработ в составе работы. Напомним, что подработы могут относиться как к тому же объекту, что и сама работа, так и к другим объектам информационной системы.

Чтобы создать в составе работы подработу, откройте окно редактирования работы и нажмите кнопку [image] Добавить подработу на панели инструментов. При этом появляется подменю, в котором нужно выбрать, к какому объекту относится подработа.

Выбор объекта, к которому относится подработа

Для текущего объекта. При выполнении этой команды создаётся подработа, относящаяся к тому же объекту, что и сама работа. В дереве этой работе соответствует отдельная ветвь. После создания подработы в полях справа укажите её параметры, аналогичные тем, которые устанавливаются для работы.

Подработа в составе работы

Для другого объекта. Эта команда предназначена для создания подработы, относящейся к другому объекту. При выполнении команды открывается диалоговое окно, где следует выбрать тип объекта. В следующем окне выбирается непосредственно сам объект, для которого выполняется подработа.

Выбор типа объекта | Выбор конкретного объекта

Для удобства рядом с подработой отображается пиктограмма, по которой можно быстро определить, к какому типу объекта она относится.

Редактирование подработы

Из шаблона. Если для редактируемой работы в справочнике задан шаблон подработ (см. подробнее), то эта команда открывает дополнительное диалоговое окно, позволяющее задать подработы с использованием шаблона. В списке слева отображаются все подработы, заданные в шаблоне, а рядом с каждой из них показывается пиктограмма того типа объекта, к которому она относится.

Добавление подработ с использованием шаблона

При выделении в списке одной из подработ справа становятся доступными кнопки, позволяющие выбирать конкретные объекты текущего типа, для которых выполняется указанный вид подработы.

Добавить подработы для всех объектов текущего типа. При нажатии этой кнопки выбираются все объекты текущего типа, входящие в состав того объекта, для которого выполняется основная работа (например, все автотрансформаторы в подстанции "Северная"). Для каждого объекта автоматически создаются подработы (например, "Осмотр без отключения" для автотрансформаторов "АТ1" и "АТ2").

Добавить подработу для указанного объекта текущего типа. При нажатии этой кнопки открывается диалоговое окно выбора объекта, в котором можно выбрать нужный объект текущего типа. Для него автоматически создаётся подработа.

Удалить подработу для текущего объекта. Эта кнопка удаляет подработу для объекта, выделенного в списке.

Параметры, указанные в полях под списком объектов, применяются к подработам выбранных объектов.

Подработы, входящие в состав работы, отображаются в окне редактирования работ. Чтобы раскрыть список подработ для некоторой работы, нажмите на знак [image] слева от работы.

Подработы, входящие в состав работы

Замечание
Рядом с некоторыми работами на закладке Текущие отображается галочка [image]. Так обозначаются законченные работы, т.е. работы, у которых установлена дата окончания по факту.

Статус подработ может отличаться от статуса основной работы. Например, некоторые из подработ могут быть уже приняты, а основная работа - нет. Такие подработы отображаются на соответствующей им закладке в составе основной работы. Но, поскольку статус самой работы не соответствует закладке, она отображается серым цветом.

Отображение работы на закладке, которая не соответствует её статусу

Также в этом разделе:

Общие сведения

Редактирование справочника "Виды работ"

Процедура ввода данных по работам

Просмотр общего списка работ


Ввод данных по работам объекта. Просмотр общего списка работ

Ввод данных по работам объекта

Просмотр общего списка работ

Работы по всем объектам информационной системы можно просмотреть в общем списке в одном окне. Оно открывается при нажатии кнопки [image] Журнал работ… на панели инструментов IndorInfo/Power, а также при выполнении команды меню IndorInfo/Power| [image] Журнал работ…

Общий список работ по всем объектам

Работы располагаются на четырёх закладках: на закладке План отображаются все запланированные работы, на закладке График - все работы, поставленные в график, на закладке Текущие - все начатые и уже законченные (но не принятые) работы, просроченные работы отображаются на закладке Просроченные.

Из журнала работ можно создавать новые работы. Для этого предназначена кнопка [image] Добавить работу на панели инструментов. Но так как это окно представляет работы по всем объектам, то при создании новой работы сначала появляется диалоговое окно выбора объекта, для которого будет создана новая работа.

Кнопки [image] Редактировать работу и [image] Удалить работу позволяют открыть окно редактирования выделенной работы или удалить выделенную работу.

Если в окне настроек системы (кнопка [image] Настройка IndorInfo/Power… на панели инструментов IndorInfo/Power) установлен флаг Показывать принятые работы в общем списке работ, то в журнале работ появляется дополнительная закладка Принятые, на которой показываются все принятые работы по объектам информационной системы.

Дополнительные настройки системы IndorInfo/Power

Дополнительно можно указать, чтобы при запуске системы появлялся список со всеми просроченными работами. Для этого установите флаг Выводить напоминание о просроченных работах при запуске системы.

Также в этом разделе:

Общие сведения

Редактирование справочника "Виды работ"

Процедура ввода данных по работам

Создание подработ в составе работы


Ввод данных по измерениям и испытаниям объекта. Редактирование справочника "Типы измерений"

Ввод данных по измерениям и испытаниям объекта

Редактирование справочника "Типы измерений"

Данный справочник содержит все типы измерений, которые могут использоваться при вводе данных по измерениям. Справочник доступен для редактирования: можно создавать новые типы измерений, удалять или редактировать существующие.

При создании нового типа измерения укажите следующие параметры:

  • Введите наименование, определяющее тип измерения (например, Замеры тока по фазам, Сопротивление изоляции и т.д.).

    • Ввод наименования измерения

  • Выберите тип объекта, для которого проводится измерение.

    • Справочник Типы измерений

Замечание
В названии типа измерения отображается тип объекта, для которого оно проводится (например, Автотрансформатор - Испытания масла, ЛЭП 10 кВ - Замеры тока по фазам и т.д.). Он выводится в название автоматически из поля Тип объекта и сделано это для удобства поиска нужного измерения в списке.
  • Задайте величины, измеряемые в ходе данного измерения. Для создания новой измеряемой величины нажмите кнопку [image], расположенную под списком, и введите её название и единицы измерения. Кнопка [image] удаляет выделенную измеряемую величину из списка.

Также в этом разделе:

Процедура ввода данных по измерениям


Ввод данных по измерениям и испытаниям объекта. Процедура ввода данных по измерениям

Ввод данных по измерениям и испытаниям объекта

Процедура ввода данных по измерениям

Ввод значений измерений по объекту выполняется из окна ввода данных. Выделите в дереве объектов нужный объект и нажмите кнопку [image] Измерения и испытания текущего объекта… на панели инструментов или выполните команду меню Измерения| [image] Измерения…

Открытие окна редактирования измерений по объекту

В окне редактирования измерений можно просматривать значения измерений, зафиксированные по объекту, и добавлять новые измерения. Одновременно можно просматривать значения измерений только одного типа, который выбирается в списке Тип измерения.

Замечание
Этот список формируется по справочнику Типы измерений и содержит только те измерения справочника, для которых в поле Тип объекта выбран тип редактируемого в данный момент объекта.
Выбор типа измерения | Выбор периода

В списке, расположенном справа, можно выбрать период для отображения измерений. Возможны следующие варианты: за последние сутки; за последнюю неделю; за последний месяц; за последний год; также можно выбрать неограниченный период, тогда будут показаны все измерения выбранного типа у объекта.

Измерения выводятся в виде списка в центре окна. Для каждого измерения показываются дата, точное время замера и значения характеристик, зафиксированных в ходе измерения.

Измерения объекта

Чтобы добавить новое измерение выбранного типа, дважды щёлкните мышью в первом пустом поле столбца Дата измерения. По умолчанию в поле будут установлены текущая дата и время. Их можно изменить, указав нужные значения. Затем становятся доступными поля для задания значений различных характеристик, которые измеряются в данном типе измерения (они берутся из справочника Типы измерений). Для удаления измерения предназначена кнопка [image], расположенная под списком измерений.

Также в этом разделе:

Редактирование справочника "Типы измерений"


Ввод данных по неисправностям объекта. Редактирование справочника "Типы неисправностей"

Ввод данных по неисправностям объекта

Редактирование справочника "Типы неисправностей"

Данный справочник содержит все типы неисправностей, которые могут использоваться при вводе данных. Справочник доступен для редактирования: можно создавать новые типы неисправностей, удалять или редактировать существующие.

При создании нового типа неисправности укажите следующие параметры:

  • Введите наименование, определяющее тип неисправности (например, Наличие в охранной зоне ВЛ стогов соломы, Дефекты сварки троса).

    • Ввод наименования неисправности

  • Выберите тип объекта, к которому относится неисправность.

    • Справочник Типы неисправностей

  • При необходимости введите единицы измерения неисправности.
  • Укажите возможные следствия неисправности. Чтобы добавить очередное возможное следствие, нажмите кнопку [image] Добавить и введите описание следствия. Кнопка [image] Изменить предназначена для изменения описания следствия, в кнопка [image] Удалить - для удаления выделенного в списке следствия.
  • Аналогичным образом можно задать возможные причины неисправности на следующей закладке.

    • Возможные причины неисправности

Также в этом разделе:

Процедура ввода данных по неисправностям


Ввод данных по неисправностям объекта. Процедура ввода данных по неисправностям

Ввод данных по неисправностям объекта

Процедура ввода данных по неисправностям

Ввод информации об обнаруженных по объекту неисправностях выполняется из окна ввода данных. Выделите в дереве объектов нужный объект и нажмите кнопку [image] Неисправности текущего объекта… на панели инструментов или выполните команду меню Неисправности| [image] Неисправности…

Открытие окна редактирования неисправностей объекта

В появившемся окне можно просматривать и редактировать выявленные неисправности объекта. По каждой неисправности показывается следующая информация: тип неисправности и её количественная оценка, даты обнаружения и срока, когда она должна быть исправлена, текущий статус.

Список неисправностей можно отфильтровать, если установить флаг Только неисправленные. Тогда в список будут выводиться только те неисправности, для которых не задана дата устранения.

Список неисправностей объекта

Для удаления неисправности объекта из базы данных нажмите кнопку [image] Удалить неисправность.

Чтобы добавить новую неисправность, нажмите кнопку [image] Создать неисправность. При этом открывается окно для ввода параметров неисправности. Аналогичное окно появляется при нажатии кнопки [image] Изменить неисправность - в нём можно отредактировать параметры существующей неисправности.

По каждой неисправности учитывается следующая информация:

  • Тип неисправности выбирается из выпадающего списка. Он формируется по справочнику Типы неисправностей и содержит только те элементы справочника, для которых задан соответствующий тип объекта.
  • Количественная оценка. Это поле доступно, если для выбранного типа неисправности в справочнике заданы единицы измерения.
  • Дата обнаружения неисправности.
  • Дата, до которой необходимо устранить неисправность.
  • При необходимости в поле Примечание можно ввести дополнительную информацию по неисправности.
  • Если известна дата устранения неисправности, то её следует указать в поле Когда устранена.

Параметры неисправности

Нажмите кнопку Записать, чтобы занести в базу данных информацию по неисправности.

После записи неисправности становится возможным указание причин её возникновения. Для добавления причины нажмите кнопку [image] Добавить причину неисправности и в появившемся списке выберите причину. Список возможных причин формируется по справочнику Типы неисправностей.

Также в этом разделе:

Редактирование справочника "Типы неисправностей"


Работа с готовым проектом

Под готовым проектом будем понимать проект с необходимым количеством разделов (или карт), в каждом из которых нанесено соответствующее изображение (плана местности, трасс линий электропередачи, электрической схемы и пр.), введены атрибутивные данные по всему оборудованию, а также установлены связи между описаниями объектов в базе данных и соответствующими фигурами на карте.

Готовый проект может использоваться специалистами разных отделов предприятия для решения задач, встающих перед ними в процессе эксплуатации электрической сети. Использование информационной системы подразумевает просмотр и редактирование атрибутивных данных по объектам электрической сети, формулирование запросов к базе данных с целью поиска необходимой информации, настройку отображения графической информации в соответствии с решаемыми задачами, поиск интересующих объектов в базе данных и на карте, внесение и дополнение эксплуатационной информации для дальнейшего планирования работ, а также решение многих других задач.

Также в этом разделе:

Просмотр краткой и полной информации по объектам

Поиск объектов на карте

Просмотр каталога сетей

Просмотр ведомостей по объектам

Формирование отчётов

Подключение внешних атрибутов к карте

Вывод на карту значений атрибутов отдельных фигур

Коммутация переключателей

Выделение электрически связанной части схемы

Выделение части схемы с одним классом напряжения

Раскрашивание схемы по классам напряжения

Раскрашивание частей схемы, запитанных от разных источников

Раскрашивание фидеров, запитанных от разных подстанций

Просмотр телеметрической информации на схеме

Измерение расстояний и площадей по карте

Построение буферных зон

Печать карты


Работа с готовым проектом. Просмотр краткой и полной информации по объектам

Работа с готовым проектом

Просмотр краткой и полной информации по объектам

По любому элементу схемы или другому объекту на карте, относящемуся к электрическим сетям, можно получить краткую информацию. Для этого включите режим [image] Краткая информация на панели инструментов Power Режимы и укажите мышью фигуру на карте.

Появится окно с краткой информацией по указанному объекту.

Получение краткой информации по объекту

Для получения полной информации по объектам включите режим [image] Ввод данных на панели инструментов Power Режимы и укажите мышью фигуру. Появится окно, где представлены все параметры объекта, доступные для редактирования (см. подробнее).

Замечание
Если окно краткой или полной информации не появляется, значит, указанная фигура не связана ни с одним объектом в базе данных (см. подробнее).

Также в этом разделе:

Поиск объектов на карте

Просмотр каталога сетей

Просмотр ведомостей по объектам

Формирование отчётов

Подключение внешних атрибутов к карте

Вывод на карту значений атрибутов отдельных фигур

Коммутация переключателей

Выделение электрически связанной части схемы

Выделение части схемы с одним классом напряжения

Раскрашивание схемы по классам напряжения

Раскрашивание частей схемы, запитанных от разных источников

Раскрашивание фидеров, запитанных от разных подстанций

Просмотр телеметрической информации на схеме

Измерение расстояний и площадей по карте

Построение буферных зон

Печать карты


Работа с готовым проектом. Поиск объектов на карте

Работа с готовым проектом

Поиск объектов на карте

По описанию объекта в базе данных можно найти соответствующую ему фигуру на карте. Откройте окно поиска, нажав кнопку [image] Поиск объекта на карте… на панели инструментов IndorInfo/Power или выполнив команду меню IndorInfo/Power| [image] Поиск…

  • Выберите способ поиска объекта: по наименованию, инвентарному номеру или примечанию, установив переключатель в разделе Как искать в соответствующее положение.
  • Выберите карту, на которой необходимо найти объект, и тип искомого объекта (подстанция, линия электропередачи и т.д.).
  • В зависимости от указанного способа поиска выберите в последнем выпадающем списке конкретное наименование, инвентарный номер или примечание, после чего нажмите кнопку Найти.

    • Поиск объекта на карте

Совет
Для выбора значений из выпадающих списков удобно использовать поиск. Введите одну или несколько первых букв, и будет выбран первый элемент списка, название которого начинается с указанного вхождения. Кнопки [image] [image] выбирают следующий или предыдущий элемент списка.

Если соответствующая объекту фигура будет найдена на выбранной карте, то карта позиционируется на эту фигуру и фигура подсветится. Окно поиска объекта после этого не закрывается, чтобы можно было продолжить поиск.

Замечание
Если фигура не находится, значит, указанный объект не связан ни с одной фигурой на выбранной карте.

Также в этом разделе:

Просмотр краткой и полной информации по объектам

Просмотр каталога сетей

Просмотр ведомостей по объектам

Формирование отчётов

Подключение внешних атрибутов к карте

Вывод на карту значений атрибутов отдельных фигур

Коммутация переключателей

Выделение электрически связанной части схемы

Выделение части схемы с одним классом напряжения

Раскрашивание схемы по классам напряжения

Раскрашивание частей схемы, запитанных от разных источников

Раскрашивание фидеров, запитанных от разных подстанций

Просмотр телеметрической информации на схеме

Измерение расстояний и площадей по карте

Построение буферных зон

Печать карты


Работа с готовым проектом. Просмотр каталога сетей

Работа с готовым проектом

Просмотр каталога сетей

Структура сетевого предприятия и его подразделений, описанная в базе данных, отображается в окне, которое открывается кнопкой [image] Каталог сетей… на панели инструментов IndorInfo/Power или командой меню IndorInfo/Power| [image] Каталог сетей…

Выберите в этом окне какую-либо сеть и нажмите кнопку ОК. Откроется окно ввода данных для выбранной сети.

Каталог сетей

Совет
Это окно удобно использовать для поиска описания нужного объекта (подстанции, линии электропередачи, потребителя и т.д.). В каталоге выбирается сеть, в состав которой входит объект, а затем в окне ввода данных выбирается нужный объект в этой сети.

Окно ввода данных для выбранной сети

Также в этом разделе:

Просмотр краткой и полной информации по объектам

Поиск объектов на карте

Просмотр ведомостей по объектам

Формирование отчётов

Подключение внешних атрибутов к карте

Вывод на карту значений атрибутов отдельных фигур

Коммутация переключателей

Выделение электрически связанной части схемы

Выделение части схемы с одним классом напряжения

Раскрашивание схемы по классам напряжения

Раскрашивание частей схемы, запитанных от разных источников

Раскрашивание фидеров, запитанных от разных подстанций

Просмотр телеметрической информации на схеме

Измерение расстояний и площадей по карте

Построение буферных зон

Печать карты


Работа с готовым проектом. Просмотр ведомостей по объектам

Работа с готовым проектом

Просмотр ведомостей по объектам

По объектам, хранящимся в базе данных, можно производить выборку, задавая различные критерии. Например, можно сформировать ведомость по оборудованию определённого типа, принадлежащему некоторой подстанции, или по всем линиям электропередачи из заданной сети электроснабжения. Окно для формирования ведомостей по объектам открывается при нажатии кнопки [image] Ведомости… на панели инструментов IndorInfo/Power или при выполнении команды меню IndorInfo/Power| [image] Ведомости…

Формировать ведомости можно по сетям, подстанциям, линиям электропередачи, оборудованию подстанции, объектам телеметрии, устройствам РЗА, потребителям и измерительным приборам. Каждому из этих объектов соответствует отдельная закладка в окне формирования ведомостей.

На закладках располагаются поля, где можно задать критерии выполнения выборки. Если в поле выбран вариант <не задано>, то по этому параметру объекты не фильтруются. Чтобы сформировать ведомость, нажмите кнопку [image] в нижней части окна, после чего все объекты, удовлетворяющие заданным критериям, будут выведены в список.

Рассмотрим критерии выборки, которые можно задавать для объектов:

  • Сети:
    • Принадлежность другим сетям (параметр Находятся в). В выборку попадают все сети, которые входят в состав сети, указанной в этом поле.
    • Организация-владелец (параметр Владелец). В выборку попадают все сети, для которых владельцем является указанная организация.

    Ведомость сетей электроснабжения

  • Подстанции:
    • Принадлежность сети электроснабжения (параметр Находятся в). В выборку попадают все подстанции, входящие в состав указанной сети.
    • Организация-владелец (параметр Владелец). В выборку попадают все подстанции, для которых владельцем является указанная организация.
    • Тип подстанции (параметр Тип). В выборку попадают подстанции указанного типа.

    Ведомость подстанций

  • Линии электропередачи:
    • Принадлежность сети электроснабжения (параметр Находятся в). В выборку попадают все линии электропередачи, входящие в состав указанной сети.
    • Класс напряжения (параметр Unom). В выборку попадают линии электропередачи указанного класса напряжения.
    • Организация-владелец (параметр Владелец). В выборку попадают все линии электропередачи, для которых владельцем является указанная организация.
    • Только ЛЭП. Если этот флаг установлен, то в выборку попадают только линии электропередачи, иначе - попадают также отпайки и участки линий электропередачи.

    Ведомость линий электропередачи

  • Оборудование подстанций:
    • Принадлежность подстанции (параметр Подстанция). В выборку попадает оборудование только из указанной подстанции.
    • Вид оборудования (параметр Вид оборудования). В выборку попадает только оборудование указанного типа. Чтобы вывести в ведомость всё оборудование подстанции, выберите в списке пункт Все виды.

    Ведомость оборудования подстанции

  • Объекты телеметрии:
    • Принадлежность подстанции (параметр Подстанция). В выборку попадают объекты телеметрии только из указанной подстанции.
    • Вид телеметрии. В выборку попадают только указанные в поле объекты телеметрии (измерительные приборы или включатели) или все объекты, если выбран пункт Все виды.

    Ведомость объектов телеметрии

  • Устройства релейной защиты и автоматики:
    • Принадлежность подстанции (параметр Подстанция). В выборку попадают устройства РЗА только из указанной подстанции.
    • Тип защищаемого объекта. В выборку попадают защиты, установленные для выбранного типа объекта. Или все защиты, если выбран пункт Все виды защит.

    Ведомость устройств РЗА

  • Потребители:
    • Принадлежность потребителя (параметр Находятся в). В выборку попадают все потребители, входящие в состав указанного объекта (сети, подстанции, ячейки и пр.).
    • Организация-владелец (параметр Владелец). В выборку попадают все потребители, для которых владельцем является указанная организация.

    Ведомость потребителей

  • Измерительные приборы:
    • Принадлежность подстанции (параметр Подстанция). В выборку попадают все измерительные приборы из выбранной подстанции.
    • Класс напряжения (параметр Unom). В выборку попадают измерительные приборы указанного класса напряжения.

    Ведомость измерительных приборов

Объекты в ведомости можно дополнительно отфильтровать по признаку: имеются ли у них просроченные работы. Для этого установите флаг Имеющие просроченные работы, расположенный под списком объектов.

Для быстрого поиска нужного объекта в ведомости введите в поле Найти текст и нажмите клавишу Enter. Фокус переключится на первый элемент списка, в котором есть указанное вхождение. Причём поиск осуществляется во всех ячейках, а не только в ячейке Наименование.

В нижней части окна расположены кнопки для работы с объектами ведомости:

Открывает окно ввода данных для выделенного в списке объекта.

Удаляет выделенный в списке объект в корзину.

Подсвечивает на карте фигуру, с которой связан выделенный объект.

Открывает окно поиска объектов на карте.

Включает режим перемещения карты. Окно при этом временно скрывается.

Загружает описание объекта из XML-файла.

Сохраняет описание объекта в XML-файл.

Также в этом разделе:

Просмотр краткой и полной информации по объектам

Поиск объектов на карте

Просмотр каталога сетей

Формирование отчётов

Подключение внешних атрибутов к карте

Вывод на карту значений атрибутов отдельных фигур

Коммутация переключателей

Выделение электрически связанной части схемы

Выделение части схемы с одним классом напряжения

Раскрашивание схемы по классам напряжения

Раскрашивание частей схемы, запитанных от разных источников

Раскрашивание фидеров, запитанных от разных подстанций

Просмотр телеметрической информации на схеме

Измерение расстояний и площадей по карте

Построение буферных зон

Печать карты


Работа с готовым проектом. Формирование отчётов

Работа с готовым проектом

Формирование отчётов

Система IndorInfo/Power позволяет формировать сводные отчёты по электрическим сетям, линиям электропередачи, подстанциям и оборудованию; инвентарные отчёты, включающие информацию о технических параметрах оборудования, отчёты по эксплуатации и другие виды отчётов. Чтобы сформировать произвольный отчёт по объектам электрических сетей и включить в него только нужную информацию, можно воспользоваться мастером отчётов.

Замечание
Для формирования некоторых видов отчётов (например, по эксплуатации) необходимо наличие файлов шаблонов. При установке системы шаблоны копируются в папку Program Files/ IndorSoft/ IndorPower/ Templates. Путь к этой папке следует указать в окне настройки информационной системы (команда меню IndorInfo/Power| [image] Настройка IndorInfo/Power…) на закладке Прочее в поле Расположение шаблонов отчётов.

Откройте окно выбора вида отчёта, нажав кнопку [image] Отчёты… на панели инструментов IndorInfo/Power или выполнив команду меню IndorInfo/Power| [image] Отчёты…

В левой части окна в виде списка отображаются все виды отчётов, которые могут быть сформированы в информационной системе, а справа - описание выделенного отчёта. Если для выполнения выделенного отчёта необходим файл шаблона, то в нижней части окна отображается название этого файла.

Чтобы сформировать отчёт, выберите его в списке и нажмите кнопку [image] Выполнить. После этого запускается программа Microsoft Excel, где формируется отчёт, который затем можно будет сохранить или распечатать.

Окно выбора вида отчёта

Также в этом разделе:

Сводные отчёты

Инвентарные отчёты

Отчёты по эксплуатации

Отчёты по подстанциям

Отчёты по линиям

Отчёты по устройствам релейной защиты и автоматики

Редактирование шапки отчётов

Мастер отчётов

Отчёт по конкретному объекту


Формирование отчётов. Сводные отчёты

Формирование отчётов

Сводные отчёты

Отчёт по сетям

Сводный отчёт по сетям даёт структурированную информацию по протяжённости видов линий электропередачи, количеству и типу подстанций, а также основному силовому оборудованию. В диалоговом окне, которое открывается при выполнении отчёта, можно указать, какие объекты включить в отчёт. Возможны следующие условия на объекты:

  • Сеть. В отчёт включаются все объекты из выбранной сети электроснабжения, т.е. те, для которых эта сеть является главным объектом в иерархии объектов в базе данных.
  • Организация-владелец. В отчёт включаются объекты, для которых выбранная организация является владельцем (организация-владелец задаётся для объектов в окне ввода данных в поле Владелец).
  • Обслуживающая организация. В отчёт включаются объекты, которые обслуживаются выбранной организацией (обслуживающая организация задаётся для объектов в окне ввода данных в поле Обслуживающая организация).

В отчёт включаются объекты, удовлетворяющие всем заданным условиям. Если ни одно условие на объекты не задано, то отчёт формируется по всем объектам базы данных.

Параметры сводного отчёта по сетям

Годовой отчёт по сетям

Этот отчёт содержит информацию о значениях различных показателей для электрических сетей, находящихся на балансе энергосистемы или обслуживаемых ею. В диалоговом окне, которое открывается при выполнении отчёта, необходимо ввести отчётный год и указать, по каким объектам следует сформировать отчёт. Возможны следующие варианты:

  • Сеть. В отчёт включаются все объекты из выбранной сети электроснабжения, т.е. те, для которых эта сеть является главным объектом в иерархии объектов в базе данных.
  • Организация-владелец. В отчёт включаются те объекты, для которых выбранная организация является владельцем (организация-владелец задаётся для объектов в окне ввода данных в поле Владелец).

При выборе этого переключателя становится доступным флаг Включить в отчёт доп. часть по обслуживаемым элементам. И если его установить, то в отчёт также будут включены объекты, которые состоят на балансе организации, выбранной в поле Состоящим на балансе, и обслуживаются организацией, которая указана в поле Организация-владелец.

Параметры годового отчёта по сетям

Все линии

Сводный отчёт по всем линиям даёт информацию по их наименованиям, протяжённости, количеству опор и электрическим параметрам, а также суммарную протяжённость по классам напряжений и общую суммарную протяжённость. При выполнении отчёта открывается диалоговое окно настройки параметров (см. подробнее).

Марки провода ВЛЭП

Сводный отчёт по воздушным линиям (по маркам проводов) даёт информацию по суммарной протяжённости отдельных марок проводов и общей суммарной протяжённости. При выполнении отчёта открывается диалоговое окно настройки параметров (см. подробнее).

Опоры

Сводный отчёт по опорам воздушных линий даёт информацию по количеству опор, их типам и суммарному количеству опор. Учитывается прохождение нескольких линий по одной опоре. При выполнении отчёта открывается диалоговое окно настройки параметров (см. подробнее).

Марки кабеля ЛЭП

Сводный отчёт по кабельным линиям (маркам кабелей) даёт информацию по суммарной протяжённости отдельных марок проводов и общей суммарной протяженности. При выполнении отчёта открывается диалоговое окно настройки параметров (см. подробнее).

Подстанции по типам

Сводный отчёт по подстанциям даёт информацию по их наименованиям и количеству, сгруппированную по типам подстанций. При выполнении отчёта открывается диалоговое окно настройки параметров (см. подробнее).

Подстанции и оборудование

Сводный отчёт по оборудованию подстанций даёт информацию по количеству и маркам основного оборудования. При выполнении отчёта открывается диалоговое окно настройки параметров (см. подробнее).

Силовые трансформаторы, [image] Выключатели, [image] Прочие коммутаторы, [image] Трансформаторы тока и напряжения, [image] Прочее оборудование

Сводные отчёты по оборудованию дают информацию по типам оборудования и их количеству. При выполнении отчётов открывается диалоговое окно настройки параметров (см. подробнее).

Также в этом разделе:

Инвентарные отчёты

Отчёты по эксплуатации

Отчёты по подстанциям

Отчёты по линиям

Отчёты по устройствам релейной защиты и автоматики

Редактирование шапки отчётов

Мастер отчётов

Отчёт по конкретному объекту


Формирование отчётов. Инвентарные отчёты

Формирование отчётов

Инвентарные отчёты

Инвентарные отчёты дают подробную информацию по паспортным данным и составу тех или иных объектов и оборудования. В системе реализованы следующие инвентарные отчёты: Силовые трансформаторы, [image] Выключатели, [image] Прочие коммутаторы, [image] Трансформаторы тока и напряжения, [image] Прочее оборудование, [image] Линии, [image] Измерительные приборы.

При выборе в списке инвентарного отчёта в нижней части окна становится доступным флаг Настройки. Он показывает, будет ли выводиться окно настроек перед выполнением отчёта. Рассмотрим настройки инвентарного отчёта на примере отчёта по силовым трансформаторам.

Окно настроек содержит несколько закладок по разным видам трансформаторов. Для каждого вида трансформатора можно указать, будет ли он включаться в отчёт, установив соответствующий флаг.

Настройка инвентарного отчёта

Те параметры трансформатора, которые будут включены в отчёт, отображаются в списке Включить в отчёт, остальные параметры - в списке Не включать в отчёт. Для перемещения параметров между списками предназначены специальные кнопки >, <, >>, <<. Чтобы переместить элемент из левого списка в правый, выделите его и нажмите кнопку >. Чтобы переместить элемент из правого списка в левый, выделите его и нажмите кнопку <. Кнопки >> и << предназначены для перемещения всех элементов из одного списка в другой.

Кроме того, для каждого вида трансформатора можно задать формат вывода: в виде таблицы или в виде списка. Если выбран вариант Список, то следует указать, какое поле использовать в качестве заголовка.

При нажатии кнопки Принадлежность… открывается окно, где можно указать, какие объекты включить в отчёт. Возможны следующие варианты:

  • Сеть. В отчёт включаются все объекты из выбранной сети электроснабжения, т.е. те, для которых эта сеть является главным объектом в иерархии объектов в базе данных.
  • Организация-владелец. В отчёт включаются те объекты, для которых выбранная организация является владельцем (организация-владелец задаётся для объектов в окне ввода данных в поле Владелец).
  • Обслуживающая организация. В отчёт включаются объекты, которые обслуживаются выбранной организацией (обслуживающая организация задаётся для объектов в окне ввода данных в поле Обслуживающая организация).

Параметры сводного отчёта по сетям

В отчёт включаются объекты, удовлетворяющие всем заданным условиям. Если ни одно условие на объекты не задано, то отчёт формируется по всем объектам базы данных.

При настройке инвентарного отчёта для линий электропередачи в нижней части окна имеется кнопка Выбор классов напряжений. Она открывает окно, где можно указать классы напряжений линий, которые следует включить в отчёт.

Выбор классов напряжений

Также в этом разделе:

Сводные отчёты

Отчёты по эксплуатации

Отчёты по подстанциям

Отчёты по линиям

Отчёты по устройствам релейной защиты и автоматики

Редактирование шапки отчётов

Мастер отчётов

Отчёт по конкретному объекту


Формирование отчётов. Отчёты по эксплуатации

Формирование отчётов

Отчёты по эксплуатации

Ведомость работ на ВЛЭП

Отчёт содержит сведения о проведённых работах на воздушных линиях электропередачи за определённый период времени. В диалоговом окне, которое появляется при выполнении отчёта, можно указать период проведения работ, а также по каким линиям следует сформировать отчёт. Возможны следующие условия:

  • Сеть. В отчёт включаются все объекты из выбранной сети электроснабжения, т.е. те, для которых эта сеть является главным объектом в иерархии объектов в базе данных.
  • Организация-владелец. В отчёт включаются те объекты, для которых выбранная организация является владельцем (организация-владелец задаётся для объектов в окне ввода данных в поле Владелец).
  • Обслуживающая организация. В отчёт включаются объекты, которые обслуживаются выбранной организацией (обслуживающая организация задаётся для объектов в окне ввода данных в поле Обслуживающая организация).

Параметры отчёта

В отчёт включаются объекты, удовлетворяющие всем заданным условиям. Если ни одно условие на объекты не задано, то отчёт формируется по всем объектам базы данных.

Также в этом разделе:

Сводные отчёты

Инвентарные отчёты

Отчёты по подстанциям

Отчёты по линиям

Отчёты по устройствам релейной защиты и автоматики

Редактирование шапки отчётов

Мастер отчётов

Отчёт по конкретному объекту


Формирование отчётов. Отчёты по подстанциям

Формирование отчётов

Отчёты по подстанциям

Эта группа отчётов включает в себя различные виды отчётов как непосредственно по имеющимся в системе подстанциям, так и по входящему в их состав оборудованию.

Трансформаторы

Отчёт содержит суммарные показатели по количеству, высшему напряжению и мощности трансформаторов. Данные сгруппированы по диапазонам мощностей трансформаторов. Какие из трансформаторов, имеющихся в системе, следует включить в отчёт, указывается в окне настройки параметров (см. подробнее).

Выключатели

Отчёт содержит информацию о количестве и марках выключателей. В отчёте выключатели объединяются в группы в соответствии с типом и значением номинального напряжения. При выполнении отчёта открывается диалоговое окно настройки принадлежности объектов (см. подробнее).

Объём подстанций 35-220 кВ в у.е.

Отчёт содержит информацию о количестве оборудования и количестве условных единиц, в которое оценивается оборудование. При выполнении отчёта открывается диалоговое окно настройки принадлежности объектов (см. подробнее).

Характеристика подстанций

Отчёт содержит такие характеристики подстанции, как наименование, описание и количество условных единиц. Также в отчёт включается информация о различных видах трансформаторов в составе подстанции и их суммарная мощность. При выполнении отчёта открывается диалоговое окно настройки принадлежности объектов (см. подробнее).

Техническое состояние оборудования подстанций

Этот отчёт содержит информацию о техническом состоянии оборудования подстанций. При выполнении отчёта открывается диалоговое окно настройки принадлежности объектов (см. подробнее). Для данного отчёта в этом окне есть дополнительное поле Минимальный срок службы. В отдельное поле в отчёте выводится количество каждого оборудования, у которого срок службы превышает заданное в этом поле значение.

Годовой отчёт по силовым трансформаторам

Отчёт содержит информацию об установленных трансформаторах, находящихся на балансе энергосистемы либо обслуживаемых энергосистемой. В диалоговом окне, которое открывается при выполнении отчёта, необходимо ввести отчётный год и указать, по каким объектам следует сформировать отчёт.

Возможны следующие варианты:

  • Сеть. В отчёт включаются все объекты из выбранной сети электроснабжения, т.е. те, для которых эта сеть является главным объектом в иерархии объектов в базе данных.
  • Организация-владелец. В отчёт включаются те объекты, для которых выбранная организация является владельцем (организация-владелец задаётся для объектов в окне ввода атрибутивных данных в поле Владелец).

При выборе этого переключателя становится доступным флаг Включить в отчёт доп. часть по обслуживаемым элементам. И если его установить, то в отчёт также будут включены объекты, которые состоят на балансе организации, выбранной в поле Состоящим на балансе, и обслуживаются организацией, которая указана в поле Организация-владелец.

Параметры годового отчёта по силовым трансформаторам

Годовой отчёт по коммутационным аппаратам

Отчёт содержит информацию о коммутационных аппаратах, находящихся на балансе энергосистемы либо обслуживаемых энергосистемой. При выполнении отчёта открывается диалоговое окно настройки параметров (см. подробнее).

Годовой отчёт по измерительным трансформаторам

Отчёт содержит информацию об измерительных трансформаторах, находящихся на балансе энергосистемы либо обслуживаемых энергосистемой. При выполнении отчёта открывается диалоговое окно настройки параметров (см. подробнее).

Годовой график ремонта оборудования

При выполнении этого отчёта в Microsoft Excel формируется шаблон, в который выводится всё оборудование, удовлетворяющее условиям, указанным в настройках отчёта.

Параметры годового графика ремонта оборудования

Степень износа выключателей

Отчёт содержит информацию о степени износа выключателей. При выполнении отчёта появляется диалоговое окно, в котором можно указать, по каким выключателям следует сформировать отчёт (см. подробнее), а также минимальный процент износа. Тогда в отчёт попадут выключатели со степенью износа, более или равной указанной величине.

Рассмотрим, каким образом вычисляется процент износа выключателя. Напомним, что у выключателей есть параметр Максимально допустимое количество КЗ. Из архива коммутаций выключателя можно выяснить, сколько раз производилось его отключение по причине короткого замыкания. Если для выключателя задана одна или несколько работ Капитальный ремонт, то количество отключений считается от последнего капитального ремонта выключателя. Далее вычисляется, какой процент составляет количество отключений по причине КЗ от максимально допустимого количества КЗ. Это и есть процент износа выключателя.

Опорно-стержневая и подставная изоляция

В данный отчёт выводится информация по опорно-стержневой и подставной изоляции, включая дату её установки или замены.

Паспорт подстанции

Отчёт содержит информацию по выбранной подстанции: общие характеристики подстанции, характеристики строительной части, информацию по ячейкам, сгруппированную по классам напряжения, данные по силовым трансформаторам. При выполнении отчёта открывается диалоговое окно, в котором следует выбрать подстанцию для формирования отчёта.

Паспорт трансформатора

В паспорт трансформатора выводятся значения всех заданных для него характеристик. При выполнении отчёта открывается диалоговое окно, в котором следует выбрать трансформатор для формирования отчёта.

Паспортная карта подстанции

При выполнении этого отчёта для каждой подстанции, попавшей в выборку, создаётся отдельный документ Microsoft Excel, где на нескольких листах размещается информация по подстанции - титульный лист, общая информация по подстанции, спецификация оборудования, потребители, запитанные от подстанции, и эксплуатационные характеристики.

Также в этом разделе:

Сводные отчёты

Инвентарные отчёты

Отчёты по эксплуатации

Отчёты по линиям

Отчёты по устройствам релейной защиты и автоматики

Редактирование шапки отчётов

Мастер отчётов

Отчёт по конкретному объекту


Формирование отчётов. Отчёты по линиям

Формирование отчётов

Отчёты по линиям

Эта группа отчётов включает в себя различные виды отчётов по имеющимся в системе линиям электропередачи.

Технические характеристики линии

Этот отчёт представляет собой сводную таблицу технических характеристик линий электропередачи выбранных классов напряжения и их элементов.

ВЛ со сроком службы 25 лет и более

Отчёт содержит характеристики воздушных линий электропередачи выбранных классов напряжения со сроком службы 25 лет и более.

При выполнении двух последних отчётов открывается диалоговое окно, где указывается принадлежность линий электропередачи, а также классы напряжения линий, которые необходимо включить в отчёт.

Параметры отчёта по техническим характеристикам ВЛ

Паспорт воздушной линии

В отчёт включается паспортная информация для воздушной линии электропередачи. Отчёт содержит базовые характеристики линии и её элементов, а также эксплуатационную информацию.

Паспорт кабельной линии

В отчёт включается паспортная информация для кабельной линии 0,4/6/10 кВ. Отчёт содержит базовые характеристики линии и её элементов, а также эксплуатационную информацию.

Также в этом разделе:

Сводные отчёты

Инвентарные отчёты

Отчёты по эксплуатации

Отчёты по подстанциям

Отчёты по устройствам релейной защиты и автоматики

Редактирование шапки отчётов

Мастер отчётов

Отчёт по конкретному объекту


Формирование отчётов. Отчёты по устройствам релейной защиты и автоматики

Формирование отчётов

Отчёты по устройствам релейной защиты и автоматики

Карты уставок

В этот отчёт выводится следующая информация по устройствам РЗА: уставки, значения параметров, примечание, типы и количество реле, используемые трансформаторы тока и напряжения. Защиты группируются по принадлежности ячейке, секции и т.д.

Фрагмент отчёта Карта уставок

Технический паспорт УРЗА

Технический паспорт УРЗА содержит информацию о типах и количестве сложных и простых устройств РЗА. Устройства РЗА группируются по принадлежности подстанции, в составе подстанции - по принадлежности ячейке, секции и т.д.

Фрагмент отчёта Технический паспорт УРЗА

Годовой отчёт по УРЗА

Годовой отчёт по УРЗА содержит информацию о количестве устройств РЗА разных типов в подстанциях. Отчёт располагается на четырёх листах: Сложные устройства, Защиты, Автоматика, Прочие устройства.

Для сложных и прочих устройств выводится количество УРЗА всех типов, определённых в справочнике. Для устройств с признаком Защита или Автоматика устройства определённым образом группируются, например сначала по классу напряжения, затем по количеству реле и т.д.

Фрагмент Годового отчёта по УРЗА (закладка Сложные устройства)

Периодичность ТО

В этот отчёт выводится содержимое справочника Группы периодичности ТО.

Фрагмент отчёта Периодичность ТО УРЗА

Годовой график ТО УРЗА

В годовом графике технического обслуживания для каждого устройства РЗА выводится запланированная на указанный год работа. Если работа была запланирована на этот год и она уже выполнена, то выводится отметка о выполнении. Также в отчёте отображается год последнего восстановления устройства, год наладки, цикл технического обслуживания и некоторые другие характеристики.

Фрагмент отчёта Годовой график ТО УРЗА

Месячный график ТО УРЗА

В отчёт выводятся те устройства РЗА, для которых на указанный месяц запланирована некоторая работа.

Фрагмент отчёта Месячный график ТО УРЗА

Объёмы выполненных работ

В этот отчёт выводится информация о суммарном количестве всех видов работ, выполненных за указанный период на выбранных подстанциях.

Фрагмент отчёта Объёмы выполненных работ

Также в этом разделе:

Сводные отчёты

Инвентарные отчёты

Отчёты по эксплуатации

Отчёты по подстанциям

Отчёты по линиям

Редактирование шапки отчётов

Мастер отчётов

Отчёт по конкретному объекту


Формирование отчётов. Редактирование шапки отчётов

Формирование отчётов

Редактирование шапки отчётов

Пользователи могут по своему усмотрению менять шаблоны, используемые при формировании отчётов. Для этого нужно открыть файл шаблона в программе Microsoft Excel, а затем добавить или удалить строки, изменить надписи и сохранить файл.

Пример шаблона для отчёта Ведомость работ на ВЛ

Те отчёты, для которых нет своего специального шаблона, используют в качестве шаблона файл Отчёт.xls. По умолчанию этот файл пустой, но в него можно добавить шапку, и тогда все отчёты, не имеющие специальных шаблонов, будут создаваться с этой шапкой.

Файл шаблона Отчет.xls

Чтобы создать шапку в этом отчёте, добавьте строки выше первой строки отчёта и введите нужную информацию.

Также в этом разделе:

Сводные отчёты

Инвентарные отчёты

Отчёты по эксплуатации

Отчёты по подстанциям

Отчёты по линиям

Отчёты по устройствам релейной защиты и автоматики

Мастер отчётов

Отчёт по конкретному объекту


Формирование отчётов. Мастер отчётов

Формирование отчётов

Мастер отчётов

Для получения произвольных отчётов по объектам электрических сетей используется мастер отчётов. В процессе его работы нужно выполнять определённые действия на закладках окна мастера. Для навигации по закладкам используются кнопки < Назад - перейти к предыдущей закладке, и Далее > - перейти к следующей закладке. Кнопка Выход предназначена для закрытия окна и прекращения работы мастера.

Чтобы запустить мастер отчётов, выберите в списке отчётов (в окне выбора вида отчёта) пункт Мастер отчётов и нажмите кнопку [image] Выполнить.
Замечание
Если отчёт выполнялся ранее и его конфигурация была сохранена в файл, то можно загрузить настройки этого отчёта из файла. Для этого перед нажатием кнопки [image] Выполнить установите флаг Из файла, расположенный рядом с кнопкой.

На первой закладке мастера отчётов отметьте галочками те типы объектов, которые следует включить в отчёт, и нажмите кнопку Далее >.

Выбор типа объектов

На второй закладке можно указать, какие объекты следует включить в отчёт.

Выбор объектов для включения в отчёт

Возможны следующие условия:

  • Выделенные на карте объекты.
  • Объекты, принадлежащие выбранной в списке организации.
  • Объекты, обслуживаемые указанной организацией.
  • Объекты, входящие в состав других объектов. Если задано это условие, то необходимо выбрать в списке те объекты, в состав которых они могут входить.

Отчёт формируется по объектам, удовлетворяющим всем указанным условиям. Если ни одно условие на объекты не задано, то отчёт формируется по всем объектам в системе.

На третьей закладке мастера задаются условия на значения параметров объектов. После установки флага Учитывать условия на параметры становятся доступными параметры объектов, для которых можно задать условия. Если отчёт формируется по нескольким типам объектов, то условия на параметры можно задать для каждого из них.

Задание условий на параметры

Рядом с каждым параметром имеются 2 поля. В первом поле выбирается тип условия: больше ">", меньше "<", равно "=", содержит и др. Во втором поле указывается значение параметра. Например, для параметров линий электропередачи могут быть заданы такие условия: название линии электропередачи должно содержать определённый текст, например "ВЛ-220", длина линии должна быть больше 5 км и т.п.

На четвертой закладке мастера задаются условия на события, которые происходили с объектами в определённые периоды времени. Для этого установите флаг Учитывать условия на события, после чего выберите в списке те события, которые должны были происходить с объектами, и для каждого события укажите временной интервал. Если отчёт формируется по нескольким типам объектов, то условия на события можно задать для каждого из них.

Задание условий на события

На пятой закладке можно выбрать один из стандартных видов отчётов, который будет сформирован для попавших в выборку объектов. Для этого установите флаг Сформировать стандартный отчёт и выберите нужный отчёт в списке, после чего нажмите кнопку Готово.

Чтобы сохранить конфигурацию данного отчёта в файл для дальнейшего использования, нажмите кнопку Сохранить и введите в диалоговом окне имя файла. Конфигурация отчёта сохраняется в файл с расширением *.xml.

Выбор стандартного отчёта

Если по выбранным объектам необходимо сформировать произвольный отчёт, а не один из стандартных, то на пятой закладке нажмите кнопку Далее > и на шестой закладке укажите, какую именно информацию нужно выводить в отчёт.

Настройка произвольной формы отчёта

Можно добавить в отчёт общую информацию по объектам, технические параметры, информацию по событиям, включающую в себя выполненные работы, обнаруженные неисправности и результаты измерений, а также информацию по составным частям (с рекурсией по составным частям или без). Информация по составным частям может включать в себя общую информацию по объектам, технические параметры и информацию по событиям.

При нажатии кнопки Список полей… открывается диалоговое окно для выбора полей, отображаемых в отчёте. Чтобы перемещать значения между списками, используйте кнопки > и <. Кнопки >> и << используются для перемещения всех записей из одного списка в другой.

Настройка отображаемых в отчёте полей

Кнопка Сохранить позволяет сохранить конфигурацию данного отчёта в файл с расширением *.xml.

При нажатии кнопки Готово запускается программа Microsoft Excel, где формируется отчёт, который затем можно будет сохранить или распечатать.

Также в этом разделе:

Сводные отчёты

Инвентарные отчёты

Отчёты по эксплуатации

Отчёты по подстанциям

Отчёты по линиям

Отчёты по устройствам релейной защиты и автоматики

Редактирование шапки отчётов

Отчёт по конкретному объекту


Формирование отчётов. Отчёт по конкретному объекту

Формирование отчётов

Отчёт по конкретному объекту

В окне ввода данных на панели инструментов имеется специальная кнопка [image] Выполнение отчётов по текущему объекту… Она открывает окно выбора вида отчёта для того объекта, который выделен в дереве слева. Набор доступных отчётов зависит от типа выбранного объекта. Сформированный отчёт будет включать в себя информацию только по выбранному объекту.

Также в этом разделе:

Сводные отчёты

Инвентарные отчёты

Отчёты по эксплуатации

Отчёты по подстанциям

Отчёты по линиям

Отчёты по устройствам релейной защиты и автоматики

Редактирование шапки отчётов

Мастер отчётов


Работа с готовым проектом. Подключение внешних атрибутов к карте

Работа с готовым проектом

Подключение внешних атрибутов к карте

При оформлении карт часто возникают задачи, для решения которых необходима информация из базы данных. Например, требуется вывести рядом с изображениями подстанций их названия или отобразить разными условными знаками опоры в зависимости от типа и т.д.

Название подстанции, тип опоры и другая подобная информация хранится в некоторой таблице в базе данных, и для того, чтобы использовать её в проекте, нужно подключить к карте соответствующую таблицу. Атрибуты из подключенных таблиц будем называть внешними, поскольку, в отличие от внутренних атрибутов слоя (см. подробнее), они хранятся не в слое карты, а в базе данных.

Также в этом разделе:

Интерфейсы с БД

Добавление наборов данных в интерфейс

Создание SQL-запросов в интерфейсе

Подключение наборов данных к слоям

Формирование дерева подключений

Подключение к слоям SQL-запросов


Подключение внешних атрибутов к карте. Интерфейсы с БД

Подключение внешних атрибутов к карте

Интерфейсы с БД

Для описания параметров подключаемых баз данных и их наборов данных в системе IndorGIS введено понятие интерфейса с базой данных, или просто интерфейса. Интерфейс содержит в себе одну или несколько подключенных баз данных, каждая из которых состоит из множества наборов данных (таблиц, запросов, хранимых процедур).

  • Интерфейс может быть создан внутри конкретной карты, и тогда его наборы данных будут доступны для подключения к слоям этой карты.
  • Интерфейс может быть создан внутри проекта, и тогда его наборы данных будут доступны для подключения в любых картах этого проекта.
  • Кроме того, интерфейс может храниться в отдельном файле с расширением *.gdi. Тогда для использования интерфейса необходимо подключить его к конкретной карте или проекту.

Если система IndorGIS используется с модулем информационной системы IndorInfo/Power, то при создании нового проекта в нём создаётся также интерфейс с БД, который по умолчанию называется Интерфейс БД для IndorInfo/Power. Этот интерфейс хранится внутри проекта, поэтому его наборы данных будут доступны во всех картах, созданных в проекте.

Чтобы просмотреть список доступных интерфейсов проекта, переключитесь в окно менеджера проектов, выделите нужный проект в дереве проектов и выполните команду главного меню Документ| [image] Интерфейсы проекта. При выборе интерфейса в этом меню открывается редактор указанного интерфейса.

Для создания нового интерфейса в проекте следует выполнить в этом меню команду [image] Создать новый. При этом создаётся новый интерфейс и сразу открывается его редактор.

Команды для работы с интерфейсами

При выполнении команды [image] Свойства… открывается диалоговое окно со списком всех интерфейсов проекта. В поле рядом с названием интерфейса отображается информация о том, где он хранится: путь к файлу, если интерфейс сохранён в отдельном файле, или значение Внутренний интерфейс, если интерфейс сохранён в файле проекта.

Список интерфейсов проекта

Кнопки в правой части окна позволяют создать новый интерфейс в проекте (кнопка Создать), добавить к проекту интерфейс, хранящийся в отдельном файле (кнопка Добавить…), удалить интерфейс из проекта (кнопка Удалить), переименовать интерфейс (кнопка Переименовать), сохранить интерфейс в отдельном файле (кнопка Сохранить как…).

Рассмотрим работу с интерфейсами в редакторе интерфейсов:

  1. Подключите к интерфейсу базу данных. Для этого выполните команду меню Базы данных| [image] Новая БД. При этом появится подменю, где нужно выбрать требуемый тип подключения. Система IndorGIS позволяет подключать базы данных по нескольким стандартам. Для примера рассмотрим подключение через ADO-соединение.

Выбор типа подключения базы данных

Новое соединение отображается в левой части редактора. Его можно переименовать, например, "БД для IndorInfo/Power". В правой части показываются параметры подключения для выделенного соединения.

Параметры подключения базы данных

  2. Чтобы настроить параметры соединения, нажмите кнопку [image], расположенную справа в поле Параметры соединения. На экране появится стандартный диалог подключения базы данных.
  3. На первой закладке выберите провайдер данных. Если тип сервера - Microsoft SQL Server, то нужно выбрать провайдер Microsoft OLE DB Provider for SQL Server, если PostgreSQL, то - PostgreSQL OLE DB Provider.
  4. На второй закладке укажите основные требуемые провайдером параметры соединения с базой данных: имя сервера, имя подключаемой базы данных, имя пользователя и пароль.
Выбор провайдера данных | Настройка параметров соединения

Если в параметрах соединения установлен флаг Диалог входа, то при первом обращении к базе данных в течение сеанса работы пользователя будет спрашиваться имя пользователя и пароль, указанные в параметрах соединения.

Чтобы проверить, правильно ли указаны параметры подключения, нажмите кнопку Проверить. Если подключение прошло успешно, то будет выдано подтверждение.

Также в этом разделе:

Добавление наборов данных в интерфейс

Создание SQL-запросов в интерфейсе

Подключение наборов данных к слоям

Формирование дерева подключений

Подключение к слоям SQL-запросов


Подключение внешних атрибутов к карте. Добавление наборов данных в интерфейс

Подключение внешних атрибутов к карте

Добавление наборов данных в интерфейс

После подключения базы данных следует добавить в интерфейс необходимые наборы данных из базы. Для этого выполните команду меню Базы данных| [image] Добавить…

Откроется диалоговое окно со списком всех доступных таблиц выбранной базы данных. Выберите в этом окне таблицу, содержащую нужную информацию, и нажмите кнопку ОК.

Выбор подключаемой таблицы

Подключенные из базы данных таблицы отображаются в левой части редактора интерфейсов. Они доступны для подключения к слоям карты.

Параметры подключенного набора данных

В редакторе интерфейсов можно просматривать и редактировать содержимое подключенных наборов данных (на закладке Данные), а также настраивать параметры подключения (на закладке Параметры). Например, можно установить запрет на изменение данных, включив опцию Запрет на запись. Поля наборов данных, для которых установлен запрет на запись, нельзя редактировать в инспекторе объектов и инспекторе данных.

Также в этом разделе:

Интерфейсы с БД

Создание SQL-запросов в интерфейсе

Подключение наборов данных к слоям

Формирование дерева подключений

Подключение к слоям SQL-запросов


Подключение внешних атрибутов к карте. Создание SQL-запросов в интерфейсе

Подключение внешних атрибутов к карте

Создание SQL-запросов в интерфейсе

К интерфейсу может быть подключен набор данных, сформированный в результате выполнения произвольного запроса к базе данных. Основным отличием подключения наборов данных от SQL-запросов является то, что при подключении набора данных вся таблица целиком добавляется в интерфейс, а SQL-запрос позволяет включить в набор только необходимую информацию из нескольких таблиц, причём сами таблицы, из которых производится выборка, не нужно добавлять в интерфейс.

Чтобы создать SQL-запрос в интерфейсе, выполните команду меню Базы данных| [image] Создать| [image] Запрос. Созданный запрос появится в дереве подключений, и можно будет его переименовать.

Рассмотрим некоторые варианты использования запросов. Например, включим в запрос наименования всех объектов, описанных в базе данных. Ниже приведён текст соответствующего SQL-запроса.

SELECT GUID, Наименование FROM Объект

Поле GUID необходимо для установления связи с фигурами, изображёнными на карте (см. подробнее), поэтому оно также включается в запрос.

Текст запроса вводится в поле Текст на закладке Параметры.

Параметры SQL-запроса

Чтобы выполнить запрос, переключитесь на закладку Данные и нажмите кнопку [image] Выполнить SQL-запрос на панели инструментов.

Набор данных, полученный в результате выполнения запроса, отображается на этой же закладке. Его можно подключать к слоям карт, входящих в состав проекта.

Результат выполнения SQL-запроса

Теперь сформируем с помощью SQL-запроса набор данных, содержащий наименование и марку некоторого оборудования подстанций (например, масляных выключателей и автотрансформаторов). Для других типов элементов запрос формируется аналогично. Кроме этого, с помощью оператора UNION в этот запрос можно включить информацию по всем интересующим типам объектов.

Ниже приведён текст соответствующего SQL-запроса.

(SELECT GUID, Наименование, Описание FROM Объект

INNER JOIN Автотрансформатор ON

Объект.Код_объекта=Автотрансформатор.Код_трансформатора

INNER JOIN Справочник_автотрансформаторов ON

Автотрансформатор.Код_типа_трансформатора=

Справочник_автотрансформаторов.Код_типа_трансформатора)

UNION

(SELECT GUID, Наименование, Описание FROM Объект

INNER JOIN Масляный_выключатель ON

Объект.Код_объекта=Масляный_выключатель.Код_коммутатора

INNER JOIN Справочник_масляных_выключателей ON

Масляный_выключатель.Код_типа_выключателя=

Справочник_масляных_выключателей.Код_типа_выключателя)

Ниже представлен набор данных, формируемый в результате выполнения данного запроса. В нём содержатся наименования и марки всех масляных выключателей и автотрансформаторов, описанных в базе данных.

Набор данных, получаемый в результате выполнения SQL-запроса

Сформулируем ещё раз преимущества использования SQL-запросов:

  • В итоговый набор данных попадают только необходимые данные.
  • Не нужно подключать в интерфейс все таблицы, из которых производится выборка данных.
  • Использование SQL-запросов значительно увеличивает быстродействие, потому что нет необходимости постоянно перечитывать содержимое подключенных таблиц из базы данных.

Также в этом разделе:

Интерфейсы с БД

Добавление наборов данных в интерфейс

Подключение наборов данных к слоям

Формирование дерева подключений

Подключение к слоям SQL-запросов


Подключение внешних атрибутов к карте. Подключение наборов данных к слоям

Подключение внешних атрибутов к карте

Подключение наборов данных к слоям

Помимо набора внутренних атрибутов, которые хранятся непосредственно в слое, к слою могут быть подключены внешние атрибуты из базы данных, добавленной в интерфейс проекта.

Далее рассмотрим, каким образом устанавливается связь фигуры на карте с соответствующей записью набора данных.

Основной набор данных в базе данных - Объект - содержит базовые сведения обо всех объектах информационной системы, среди них - уникальный код каждого объекта, хранящийся в атрибуте GUID. При создании нового объекта генерируется очередное уникальное значение атрибута GUID. Этот атрибут представляет собой 16-байтное число и генерируется стандартными функциями Windows.

В каждом слое есть атрибут _LINK. Когда устанавливается связь описания некоторого объекта с фигурой на карте (см. подробнее), атрибуту _LINK данной фигуры присваивается значение параметра GUID соответствующей записи в таблице Объект. Таким образом, всегда можно определить, какое описание в базе данных соответствует фигуре на карте.

Установка соответствия фигур с описаниями в базе данных

Первым к слою подключается набор данных Объект, поскольку он содержит атрибут GUID, через который устанавливается связь с фигурами на карте. Также можно подключить набор данных, получаемый в результате выполнения SQL-запроса и содержащий атрибут GUID (см. подробнее). Первый набор данных подключается к набору внутренних атрибутов слоя.

Связь записей одной таблицы с записями другой таблицы устанавливается через равенство двух атрибутов. В главной таблице, к которой подключается набор данных, выделяется Главное поле связи, а в подключаемой таблице - Подчинённое поле связи. Некоторой записи в главной таблице соответствует та запись в подключаемой таблице, у которой подчинённое поле связи равно главному полю связи.

При подключении набора данных Объект к слою главной таблицей является набор внутренних атрибутов слоя, а главным полем связи в этой таблице - атрибут _LINK. Подключаемая таблица - это набор данных Объект, подчинённое поле связи в ней - атрибут GUID. Значит, некоторой строке в наборе внутренних атрибутов слоя соответствует та строка набора данных Объект, у которой атрибут GUID равен атрибуту _LINK.

Соответствие строк главной и подключаемой таблиц

После подключения набора данных к слою в полный список атрибутов слоя добавляются атрибуты из подключенного набора данных.

Теперь рассмотрим технологию подключения наборов данных к слоям в системе IndorGIS. Подключение наборов данных к слоям производится в окне настройки свойств слоя на закладке Дерево данных. На этой закладке слева отображается дерево подключений слоя, справа - параметры выделенного набора данных. В дереве подключений самый первый элемент (Слой карты) представляет набор внутренних атрибутов слоя.

Создаваемый набор данных подключается к выделенному в дереве набору. Чтобы создать новый набор данных, нажмите кнопку [image] Добавить набор данных, после чего в дереве подключений появится новый элемент. Затем выберите в списке доступный интерфейс, базу данных в выбранном интерфейсе и подключаемый набор данных из указанной базы. После этого выберите из списка главное поле связи (список содержит все поля главного набора данных) и подчинённое поле связи (список содержит все поля подключаемого набора данных).

Подключение набора данных к слою

Ниже на рисунках показан вид инспектора объектов: слева - на закладке Атрибуты отображаются только внутренние атрибуты некоторой фигуры слоя, справа - в список атрибутов добавлены поля из подключенного набора данных Объект.

Замечание
Если для визуализации слоёв используются атрибуты из подключенных наборов данных (например, подписи у объектов), то при изменении каких-либо параметров в базе данных обновление визуализации на карте происходит не сразу. Для этого выполните какое-либо обращение к базе данных, например, выделите фигуру и откройте для неё инспектор объектов на закладке Атрибуты. После этого выполните команду меню Слой| [image] Обновить визуализацию (для слоёв шейп-файлов) или команду Слой| [image] Обновить подписи (для слоёв чертежа).
Внутренние атрибуты слоя | Внутренние и подключенные атрибуты слоя

Также в этом разделе:

Интерфейсы с БД

Добавление наборов данных в интерфейс

Создание SQL-запросов в интерфейсе

Формирование дерева подключений

Подключение к слоям SQL-запросов


Подключение внешних атрибутов к карте. Формирование дерева подключений

Подключение внешних атрибутов к карте

Формирование дерева подключений

К слою можно подключить одновременно несколько наборов данных. При этом они могут быть связаны со слоем независимо друг от друга или представлять дерево подключений, когда один набор данных подключается к уже подключенному набору.

Напомним, что таблица Объект содержит базовые сведения обо всех объектах информационной системы, остальные параметры объектов содержатся в других таблицах, которые определённым образом связаны с таблицей Объект. Поэтому для того чтобы "добраться" до нужного атрибута, следует подключить к набору данных Объект тот набор данных, который содержит нужный атрибут, а также все промежуточные таблицы, если два этих набора данных связаны через другие таблицы.

Рассмотрим формирование дерева подключений на конкретном примере. Допустим, необходимо вывести на карту информацию о марках автотрансформаторов.

В таблице Объект имеется атрибут Код типа объекта, определяющий тип объекта информационной системы и, по сути, таблицу, в которой содержится более подробная информация по нему (в данном примере это таблица Автотрансформатор). Кроме этого, в таблице Объект имеется атрибут Код объекта, определяющий запись в таблице Автотрансформатор, соответствующую данному объекту. В таблице Автотрансформатор имеется атрибут Код типа трансформатора, который определяет соответствующий для данного трансформатора тип в справочнике. Описание (или марка) автотрансформатора хранится в справочнике в атрибуте Описание.

Связь наборов данных Объект, Автотрансформатор, Справочник автотрансформаторов

Как видно из примера, подключение наборов данных к уже подключенным наборам осуществляется аналогично подключению к набору внутренних атрибутов (через равенство главного и подчинённого полей связи). Только в данном случае главной таблицей является набор данных, к которому подключается другой набор данных.

Подключение набора данных Автотрансформатор к набору данных Объект

Чтобы подключить набор данных Автотрансформатор, выделите в дереве подключений набор Объект, нажмите кнопку [image] Добавить набор данных и выберите из списка подключаемый набор данных. Затем выберите Главное поле связи - это атрибут Код объекта в таблице Объект, и Подчинённое поле связи - это атрибут Код трансформатора в таблице Автотрансформатор.

Затем нужно аналогично подключить Справочник автотрансформаторов, но здесь главное поле связи - это атрибут Код типа трансформатора в таблице Автотрансформатор, а подчинённое поле - атрибут Код типа трансформатора в таблице Справочник автотрансформаторов.

Подключение набора данных Справочник автотрансформаторов к набору данных Автотрансформатор

Напомним, что таблицы Автотрансформатор и Справочник автотрансформаторов должны быть добавлены в интерфейс (см. подробнее).

Ниже на рисунке представлен вид инспектора объектов для некоторого автотрансформатора после подключения наборов данных. Обратите внимание, что к слою добавляются все атрибуты из всех подключенных таблиц.

Инспектор объектов для автотрансформатора

Совет
Чтобы подключенные атрибуты были недоступны для редактирования в инспекторе объектов, в интерфейсе с базами данных установите для наборов данных флаг Запрет на запись.

Также в этом разделе:

Интерфейсы с БД

Добавление наборов данных в интерфейс

Создание SQL-запросов в интерфейсе

Подключение наборов данных к слоям

Подключение к слоям SQL-запросов


Подключение внешних атрибутов к карте. Подключение к слоям SQL-запросов

Подключение внешних атрибутов к карте

Подключение к слоям SQL-запросов

Обычно из всех атрибутов, добавленных при подключении наборов данных, действительно необходимы только некоторые. Например, в рассмотренном выше примере необходим только атрибут Описание (марка). Рассмотрим, как можно получить эту информацию других способом, через SQL-запрос.

Добавьте в интерфейс новый SQL-запрос, примерный вид которого приведён выше (см.подробнее). Набор данных, получаемый в результате выполнения такого запроса, содержит поля GUID, Наименование, Описание. Этот набор данных подключите к набору внутренних атрибутов слоя.

Подключение SQL-запроса к набору внутренних атрибутов слоя

Обратите внимание, что к слою добавлены только те атрибуты, которые были указаны в запросе.

Инспектор объектов для автотрансформатора

Совет
Можно создать SQL-запрос, в который включить нужную информацию по всем интересующим элементам схемы, и после этого подключить запрос к слою электрической схемы. Тогда к каждому типу элемента будут подключены только "его" атрибуты.

Также в этом разделе:

Интерфейсы с БД

Добавление наборов данных в интерфейс

Создание SQL-запросов в интерфейсе

Подключение наборов данных к слоям

Формирование дерева подключений


Работа с готовым проектом. Вывод на карту значений атрибутов отдельных фигур

Работа с готовым проектом

Вывод на карту значений атрибутов отдельных фигур

Если по объектам информационной системы занесена информация в базу данных, то для удобства просмотра карты можно выводить значения некоторых атрибутов рядом с фигурами. Например, у элементов схемы можно выводить наименование и марку, у линий электропередачи - длину. Для создания таких подписей используется элемент слоя электрической схемы [image] Полка атрибутов.

  1. Создайте элемент схемы Полка атрибутов. Он находится в группе элементов Надписи. Контакт полки атрибутов следует подвести точно к элементу, атрибут которого нужно вывести.
Полка атрибутов в легенде слоя | Полка атрибутов на схеме
  2. Выделите полку атрибутов, откройте инспектор объектов (команда меню Вид| [image] Инспектор объектов) и установите флаг Собственная настройка. После этого в инспекторе объектов появятся дополнительные поля.

Свойства полки атрибутов

  3. В поле Слой выберите слой карты, в котором находится элемент. Нажмите кнопку [image] в соответствующем поле (Атрибут сверху или Атрибут снизу). При этом появится диалоговое окно, где можно выбрать или ввести вручную необходимые атрибуты.

Задание атрибутов, выводимых на полку

  4. Выберите из списка Тип элемента нужный тип, например Автотрансформатор. Данный список содержит все типы элементов, которые могут присутствовать в выбранном слое.
  5. Выберите в списке Доступные атрибуты слоя нужный атрибут, например Snom (мощность трансформатора), и нажмите кнопку Добавить. Аналогичным образом можно вывести и другие атрибуты слоя на эту же полку.
Замечание
Если в списке нет необходимого атрибута, подключите соответствующий набор данных к слою (см. подробнее).

Добавленные атрибуты отображаются в поле Формат выдачи информации по объектам. Название атрибута окружено символами %%. Любой текст, который будет написан за пределами знаков %%, выводится на полку в виде текстовой надписи. Таким способом можно, к примеру, добавить рядом со значением атрибута его описание.

Если необходимо вывести вычисляемое значение (например, мощность трансформатора, заданную в МВА, вывести в кВА), нужно написать следующий текст: %S*1000% кВА.

Ниже на рисунке показан пример полки, подведённой к автотрансформатору. Снизу на полке отображается название и мощность, а сверху - марка автотрансформатора.

Вывод параметров на полку атрибутов

Совет
Если нужно создать полки с одинаковыми параметрами у нескольких элементов, выделите нужную полку атрибутов, выполните команду контекстного меню [image] Рисовать такой же элемент, после чего нарисуйте новую полку.

Также в этом разделе:

Просмотр краткой и полной информации по объектам

Поиск объектов на карте

Просмотр каталога сетей

Просмотр ведомостей по объектам

Формирование отчётов

Подключение внешних атрибутов к карте

Коммутация переключателей

Выделение электрически связанной части схемы

Выделение части схемы с одним классом напряжения

Раскрашивание схемы по классам напряжения

Раскрашивание частей схемы, запитанных от разных источников

Раскрашивание фидеров, запитанных от разных подстанций

Просмотр телеметрической информации на схеме

Измерение расстояний и площадей по карте

Построение буферных зон

Печать карты


Работа с готовым проектом. Коммутация переключателей

Работа с готовым проектом

Коммутация переключателей

Для имитации состояний коммутаторов (включен/выключен) при работе с электрическими схемами предназначен режим коммутации переключателей. Он включается кнопкой [image] Коммутация переключателей на панели инструментов Power Режимы.

В зависимости от состояния выключатели отображаются на карте разными цветами ( [image], [image]), а различного рода разъединители - соответствующими обозначениями ( [image], [image] ).

Коммутация переключателей

Чтобы изменить состояние коммутатора, щёлкните на нём мышью в режиме коммутации переключателей.

Если изображение коммутатора не связано с объектом в базе данных, то изменится только его отображение на карте. В противном случае информация о переключении будет также записана в базу данных.

Кроме того, для выключателей при изменении состояния появляется окно, в котором следует указать причину переключения. Время переключения устанавливается автоматически при нажатии кнопки ОК.

Причина изменения состояния выключателя

Таким образом, в базу данных поступает точная информация о переключениях коммутаторов, т.е. формируется журнал коммутаций. Для любого коммутатора журнал коммутаций можно просмотреть в окне ввода данных на закладке Коммутации, где указана дата и причина каждого переключения.

Архив коммутаций выключателя

Если переключение коммутаторов осуществляется на нескольких рабочих местах, то в определённый момент времени может оказаться, что отображаемые на карте состояния коммутаторов не соответствуют их реальным положениям, записанным в базе данных. В этом случае нужно нажать кнопку [image] Обновить состояние коммутаторов из базы на панели инструментов IndorGIS/Power или выполнить команду IndorInfo/Power| [image] Обновить.

Чтобы не выполнять каждый раз эту команду, можно настроить автоматическое обновление состояний коммутаторов на карте. Для этого в окне настройки системы (команда меню IndorInfo/Power| [image] Настройка IndorInfo/Power…) на закладке Прочее установите флаг Автоматическое обновление состояния коммутаторов из базы. Тогда с определённым интервалом из базы данных будут считываться текущие состояния коммутаторов и в соответствии с ними будет обновляться отображение коммутаторов на карте.

Также в этом разделе:

Просмотр краткой и полной информации по объектам

Поиск объектов на карте

Просмотр каталога сетей

Просмотр ведомостей по объектам

Формирование отчётов

Подключение внешних атрибутов к карте

Вывод на карту значений атрибутов отдельных фигур

Выделение электрически связанной части схемы

Выделение части схемы с одним классом напряжения

Раскрашивание схемы по классам напряжения

Раскрашивание частей схемы, запитанных от разных источников

Раскрашивание фидеров, запитанных от разных подстанций

Просмотр телеметрической информации на схеме

Измерение расстояний и площадей по карте

Построение буферных зон

Печать карты


Работа с готовым проектом. Выделение электрически связанной части схемы

Работа с готовым проектом

Выделение электрически связанной части схемы

Для выделения электрически связанных частей схемы реализован режим [image] Выделение части сети, расположенный на панели инструментов Power Режимы.

Режимы выделения подсхем

Укажите в этом режиме элемент схемы. На карте выделится часть схемы, которая имеет электрическое соединение с этим элементом. При этом учитываются состояния коммутаторов.

Выделение электрически связанной части сети

Также в этом разделе:

Просмотр краткой и полной информации по объектам

Поиск объектов на карте

Просмотр каталога сетей

Просмотр ведомостей по объектам

Формирование отчётов

Подключение внешних атрибутов к карте

Вывод на карту значений атрибутов отдельных фигур

Коммутация переключателей

Выделение части схемы с одним классом напряжения

Раскрашивание схемы по классам напряжения

Раскрашивание частей схемы, запитанных от разных источников

Раскрашивание фидеров, запитанных от разных подстанций

Просмотр телеметрической информации на схеме

Измерение расстояний и площадей по карте

Построение буферных зон

Печать карты


Работа с готовым проектом. Выделение части схемы с одним классом напряжения

Работа с готовым проектом

Выделение части схемы с одним классом напряжения

Для выделения части схемы с одним классом напряжения включите режим [image] Выделение класса напряжения (см. рисунок) и укажите мышью элемент схемы. На карте выделится часть сети, имеющая электрическое соединение с этим элементом и тот же класс напряжения.

Выделение части схемы с одним классом напряжения

Также в этом разделе:

Просмотр краткой и полной информации по объектам

Поиск объектов на карте

Просмотр каталога сетей

Просмотр ведомостей по объектам

Формирование отчётов

Подключение внешних атрибутов к карте

Вывод на карту значений атрибутов отдельных фигур

Коммутация переключателей

Выделение электрически связанной части схемы

Раскрашивание схемы по классам напряжения

Раскрашивание частей схемы, запитанных от разных источников

Раскрашивание фидеров, запитанных от разных подстанций

Просмотр телеметрической информации на схеме

Измерение расстояний и площадей по карте

Построение буферных зон

Печать карты


Работа с готовым проектом. Раскрашивание схемы по классам напряжения

Работа с готовым проектом

Раскрашивание схемы по классам напряжения

Для удобства работы со схемой её можно раскрасить по классам напряжения. Нажмите кнопку [image] Раскрасить схему по классам напряжения на панели инструментов IndorInfo/Power или выполните команду меню IndorInfo/Power| [image] Раскрасить по Unom.

По этой команде в один цвет окрашиваются элементы электрической схемы, обладающие одинаковым номинальным напряжением. При этом кольца трансформаторов окрашиваются в цвет, который соответствует номинальному напряжению стороны трансформатора.

Раскрашивание схемы по классам напряжения

Если в окне настройки системы (команда меню IndorInfo/Power| [image] Настройка IndorInfo/Power…) на закладке Прочее установлен флаг Показывать диалог настройки раскраски Unom, то перед выполнением команды раскрашивания появляется диалоговое окно, в котором можно настроить цвета окраски элементов схемы.

Настройка цветов окраски элементов схемы

В списке в центре окна отображаются возможные значения номинального напряжения и для каждого из них - соответствующий цвет окраски. Чтобы изменить цвет, нажмите кнопку [image], расположенную справа от поля, и выберите в палитре нужный цвет. Можно воспользоваться кнопкой По умолчанию для установки цветов, предусмотренных для номинальных напряжений по умолчанию, или кнопкой Палитра для выбора одной из стандартных цветовых палитр. Кнопки Вверх и Вниз предназначены для перемещения выделенного цвета по списку.

Если в схеме есть элементы, для которых не определено значение номинального напряжения, то они окрашиваются в Цвет неподключенных элементов. Чтобы выбранный в этом поле цвет не был применён к элементам схемы, установите флаг Оставить прежним.

Если какие-то из элементов электрической схемы нарисованы в простых шейп-файлах (например, линии электропередачи - в линейных слоях, абоненты - в точечном слое), то для раскрашивания таких объектов в слое создаётся новый визуализатор. После выполнения команды видимость всех остальных визуализаторов слоя отключается.

Новый визуализатор в слое для раскрашивания по классам напряжения

Замечание
Точечные, линейные и полигональные слои участвуют в раскрашивании только, если для них настроено соответствие с объектами электрических сетей (см. подробнее).

Также в этом разделе:

Просмотр краткой и полной информации по объектам

Поиск объектов на карте

Просмотр каталога сетей

Просмотр ведомостей по объектам

Формирование отчётов

Подключение внешних атрибутов к карте

Вывод на карту значений атрибутов отдельных фигур

Коммутация переключателей

Выделение электрически связанной части схемы

Выделение части схемы с одним классом напряжения

Раскрашивание частей схемы, запитанных от разных источников

Раскрашивание фидеров, запитанных от разных подстанций

Просмотр телеметрической информации на схеме

Измерение расстояний и площадей по карте

Построение буферных зон

Печать карты


Работа с готовым проектом. Раскрашивание частей схемы, запитанных от разных источников

Работа с готовым проектом

Раскрашивание частей схемы, запитанных от разных источников

В разные цвета можно окрасить те части схемы, которые запитаны от разных источников. Нажмите кнопку [image] Раскрасить части схемы, запитанные от разных источников на панели инструментов IndorInfo/Power или выполните команду меню IndorInfo/Power| [image] Раскрасить по источникам.

Элемент считается присоединённым к источнику электроэнергии, если на схеме он соединён с элементом Генератор. При выполнении команды части схемы, подключенные к разным источникам, окрашиваются в свой цвет. Неподключенная часть схемы окрашивается в серый цвет.

Раскрашивание частей схемы, запитанных от разных источников

Если в окне настройки системы (команда меню IndorInfo/Power| [image] Настройка IndorInfo/Power…) на закладке Прочее установлен флаг Показывать диалог настройки раскраски фидеров, то перед выполнением команды раскрашивания появляется диалоговое окно, в котором можно настроить цвета окраски элементов схемы.

В списке в центре окна отображаются обнаруженные источники электроэнергии и для каждого из них - соответствующий цвет окраски. Чтобы изменить цвет, нажмите кнопку [image], расположенную справа от поля, и выберите в палитре нужный цвет. Можно воспользоваться кнопкой По умолчанию для установки цветов, предусмотренных для номинальных напряжений по умолчанию, или кнопкой Палитра для выбора одной из стандартных цветовых палитр. Кнопки Вверх и Вниз предназначены для перемещения выделенного цвета по списку. Если в схеме есть элементы, не подключенные ни к одному источнику, то они окрашиваются в Цвет неподключенных элементов.

Настройка цветов окраски элементов схемы

Если какие-то из элементов электрической схемы нарисованы в простых шейп-файлах (например, линии электропередачи - в линейных слоях, абоненты - в точечном слое), то для раскрашивания таких объектов в слое создаётся новый визуализатор. После выполнения команды видимость всех остальных визуализаторов слоя отключается.

Новый визуализатор в слое для раскрашивания по источникам

Также в этом разделе:

Просмотр краткой и полной информации по объектам

Поиск объектов на карте

Просмотр каталога сетей

Просмотр ведомостей по объектам

Формирование отчётов

Подключение внешних атрибутов к карте

Вывод на карту значений атрибутов отдельных фигур

Коммутация переключателей

Выделение электрически связанной части схемы

Выделение части схемы с одним классом напряжения

Раскрашивание схемы по классам напряжения

Раскрашивание фидеров, запитанных от разных подстанций

Просмотр телеметрической информации на схеме

Измерение расстояний и площадей по карте

Построение буферных зон

Печать карты


Работа с готовым проектом. Раскрашивание фидеров, запитанных от разных подстанций

Работа с готовым проектом

Раскрашивание фидеров, запитанных от разных подстанций

В разные цвета можно окрасить фидеры, которые запитаны от разных подстанций. Для этого нажмите кнопку [image] Раскрашивание частей схемы, запитанных от разных подстанций на панели инструментов IndorInfo/Power или выполните команду меню IndorInfo/Power| [image] Раскрасить по фидерам.

Раскрашивание фидеров, запитанных от разных подстанций

Если в окне настройки системы (команда меню IndorInfo/Power| [image] Настройка IndorInfo/Power…) на закладке Прочее установлен флаг Показывать диалог настройки раскраски фидеров, то перед выполнением команды раскрашивания появляется диалоговое окно, в котором можно настроить цвета окраски элементов схемы.

В списке в центре окна отображаются обнаруженные фидеры и для каждого из них - соответствующий цвет окраски. Чтобы изменить цвет, нажмите кнопку [image], расположенную справа от поля, и выберите в палитре нужный цвет. Можно воспользоваться кнопкой По умолчанию для установки цветов, предусмотренных для номинальных напряжений по умолчанию, или кнопкой Палитра для выбора одной из стандартных цветовых палитр. Кнопки Вверх и Вниз предназначены для перемещения выделенного цвета по списку.

Новый визуализатор в слое для раскрашивания фидеров

Если какие-то из элементов электрической схемы нарисованы в простых шейп-файлах (например, линии электропередачи - в линейных слоях, абоненты - в точечном слое), то для раскрашивания таких объектов в слое создаётся новый визуализатор. После выполнения команды видимость всех остальных визуализаторов слоя отключается.

Также в этом разделе:

Просмотр краткой и полной информации по объектам

Поиск объектов на карте

Просмотр каталога сетей

Просмотр ведомостей по объектам

Формирование отчётов

Подключение внешних атрибутов к карте

Вывод на карту значений атрибутов отдельных фигур

Коммутация переключателей

Выделение электрически связанной части схемы

Выделение части схемы с одним классом напряжения

Раскрашивание схемы по классам напряжения

Раскрашивание частей схемы, запитанных от разных источников

Просмотр телеметрической информации на схеме

Измерение расстояний и площадей по карте

Построение буферных зон

Печать карты


Просмотр телеметрической информации на схеме. Задачи интеграции с системой телеметрии

Просмотр телеметрической информации на схеме

Задачи интеграции с системой телеметрии

Интеграция системы IndorInfo/Power с системой телеметрии предназначена для решения задачи автоматизации диспетчерского управления. Системы телеметрии поставляют данные о состояниях коммутаторов и значениях контрольных замеров на диспетчерский пульт (щит), где визуально отображается соответствующая информация. Также ведётся отслеживание выхода значений замеров из контрольных диапазонов, о чём производится оповещение диспетчера.

Система телеметрии в электрической сети наблюдает за параметрами следующих объектов телеметрии: коммутаторов (положение, переходный ток), секций подстанций (напряжения по фазам), вводов и отходящих фидеров подстанций (ток по фазам, активная, реактивная мощности и коэффициент мощности), вводов трансформаторов и компенсирующего оборудования (ток по фазам, активная, реактивная мощность и коэффициент мощности). В ряде случаев измеряются дополнительные параметры объектов телеметрии (напряжения, токи, потоки мощности, частоты) для восстановления целостной картины состояния сети при отсутствии средств аналитического расчёта.

При этом основной задачей является отображение изменений состояний элементов (коммутаторов, оборудования, линий и т.п.) в зависимости от поступающих значений с использованием ГИС-анимации. Первый вид элементов - коммутатор - должен отображать свое состояние (включен, выключен, выведен из работы, авария). Далее, секции, вводы и фидеры должны иметь подписи измеряемых значений. При выходе из контрольного диапазона должны выдаваться оповещения, а элементы - выделяться цветом или подсвечиваться.

Также в этом разделе:

Подключение к серверу рассылки телеметрических данных

Сопоставление элементов схемы с объектами телеметрии

Способы отображения измеренных значений на схеме

Отображение состояний выключателей

Отображение значений измерительного прибора

Журнал телеметрии


Просмотр телеметрической информации на схеме. Подключение к серверу рассылки телеметрических данных

Просмотр телеметрической информации на схеме

Подключение к серверу рассылки телеметрических данных

Рассмотрим подключение к серверу рассылки телеметрических данных:

  1. Откройте окно настройки информационной системы, выполнив команду меню IndorInfo/Power| [image] Настройка IndorInfo/Power… или нажав кнопку [image] Настройка IndorInfo/Power… на панели инструментов IndorInfo/Power.
  2. Переключитесь на закладку Телеметрия.

Подключение к серверу рассылки телеметрических данных

  3. Укажите в разделе Источник данных IP-адрес или имя компьютера, где установлен сервер рассылки телеметрических данных, и порт, на котором он ожидает клиентское соединение.
  4. Для установки соединения с сервером нажмите кнопку Старт. Кнопка Стоп разрывает соединение.
  5. Если нужно, чтобы соединение с сервером устанавливалось автоматически при открытии проекта, установите флаг Автоматически запускать клиента.
  6. Далее установите флаг Обновлять телеобъекты, для того чтобы на карте отображались изменения состояния коммутаторов и обновлялись показания измерений и период обновления.

Также в этом разделе:

Задачи интеграции с системой телеметрии

Сопоставление элементов схемы с объектами телеметрии

Способы отображения измеренных значений на схеме

Отображение состояний выключателей

Отображение значений измерительного прибора

Журнал телеметрии


Просмотр телеметрической информации на схеме. Сопоставление элементов схемы с объектами телеметрии

Просмотр телеметрической информации на схеме

Сопоставление элементов схемы с объектами телеметрии

Для отображения на схеме изменений состояний элементов (коммутаторов, оборудования, линий и т.п.) необходимо соотнести визуальные элементы схемы с объектами телеметрии.

В системе телеметрии объекты имеют, как правило, уникальный номер. При этом визуальные элементы схемы (и связанная с ними информация об оборудовании в базе данных) также имеют некоторый уникальный идентификатор. На основе сопоставления номера объекта телеметрии (в системе телеметрии) и идентификатора оборудования (в базе данных) возможно определение, к какому элементу схемы относятся те или иные данные телеметрии.

Схема сопоставления данных телеметрии и элементов схем

В системе IndorInfo/Power с объектами телеметрии могут быть сопоставлены следующие типы объектов: измерительный прибор и все виды выключателей. Измерительный прибор может быть связан с одним из датчиков, который снимает показания с какого-либо устройства, а выключатель - с датчиком, который возвращает состояние выключателя (включен, выключен и т.д.).

Замечание
Описание объекта (выключателя или измерительного прибора) должно быть связано со своим изображением на схеме (см. подробнее).

Для перечисленных типов объектов в окне ввода данных имеется закладка Телеметрия, где можно сопоставить объекту некоторый объект телеметрии:

  1. Установите на закладке Телеметрия флаг Используются телеизмерения. После этого станут доступными поля для установки соответствия с объектом телеметрии.
  2. Укажите, какой объект телеметрии соответствует данному объекту информационной системы. Для этого введите в поле Код в системе MMO FDST уникальный номер объекта в системе телеметрии.

Установка связи выключателя с объектом телеметрии

Установка связи измерительного прибора с объектом телеметрии

Также в этом разделе:

Задачи интеграции с системой телеметрии

Подключение к серверу рассылки телеметрических данных

Способы отображения измеренных значений на схеме

Отображение состояний выключателей

Отображение значений измерительного прибора

Журнал телеметрии


Просмотр телеметрической информации на схеме. Способы отображения измеренных значений на схеме

Просмотр телеметрической информации на схеме

Способы отображения измеренных значений на схеме

Измеренные параметры могут отображаться на схеме одним из двух способов:

  • Отображение условным знаком. Данный способ используется для отображения состояния выключателей (включен, выключен, в ремонте и т.п.). Примеры условных знаков приведены ниже на рисунке.

Примеры условных знаков для отображения состояния коммутаторов

  • Алфавитно-цифровое отображение значения на выноске. Данный способ используется для представления значений тока, напряжения, потока мощности. Выноски представляют собой текстовые блоки с указателем, обозначающим точку, в которой производится данное измерение.

Использование выносок для отображения значений токов и напряжений

Также в этом разделе:

Задачи интеграции с системой телеметрии

Подключение к серверу рассылки телеметрических данных

Сопоставление элементов схемы с объектами телеметрии

Отображение состояний выключателей

Отображение значений измерительного прибора

Журнал телеметрии


Просмотр телеметрической информации на схеме. Отображение состояний выключателей

Просмотр телеметрической информации на схеме

Отображение состояний выключателей

Чтобы на схеме отображалось текущее состояние выключателя, необходимо выполнить следующее:

  1. Создайте в базе данных описание выключателя и свяжите его с соответствующим элементом на схеме.
  2. В окне ввода данных на закладке Телеметрия установите соответствие созданного в базе описания выключателя с датчиком, который снимает показания с данного выключателя.
  3. Далее выберите вид сигнала о состоянии коммутатора.

Выбор вида сигнала о состоянии коммутатора

Возможны следующие варианты:

  • Простой сигнал (1 датчик положения). В этом случае выключатель может иметь 2 состояния: включен или выключен.
  • 4 состояния (2 отдельных датчика положений "ВКЛ" и "ВЫКЛ"). Выбор этого варианта означает, что выключатель может иметь 4 состояния: включен, выключен, неизвестное (или промежуточное) состояние и аварийное состояние.
  • Произвольные значения (настройка пользователя). Этот вариант аналогичен предыдущему. Отличие заключается в том, что пользователь может сам задать числовые значения, которые означают все 4 состояния.

После этого при поступлении данных от сервера телеметрии выключатель будет менять свое положение. В зависимости от настроек при переключении выключатель может подсвечиваться, кроме этого, переключение может сопровождаться звуковым сигналом.

Также в этом разделе:

Задачи интеграции с системой телеметрии

Подключение к серверу рассылки телеметрических данных

Сопоставление элементов схемы с объектами телеметрии

Способы отображения измеренных значений на схеме

Отображение значений измерительного прибора

Журнал телеметрии


Просмотр телеметрической информации на схеме. Отображение значений измерительного прибора

Просмотр телеметрической информации на схеме

Отображение значений измерительного прибора

Показания, снимаемые датчиками (значения напряжений, токов и т.д.), выводятся на схему в виде текстовых надписей (или выносок). В этом случае необходимо сопоставлять выноски и датчики. Это делается так же, как и при сопоставлении изображений оборудования - через уникальные номера объектов. Выноски рассматриваются как самостоятельные объекты схемы - измерительные приборы. Они имеют собственные атрибутивные описания в базе данных.

Чтобы вывести на схему значения, снимаемые датчиком, необходимо выполнить следующее:

  1. Создайте надпись, которая будет содержать измеряемое значение. Для этого следует использовать элемент схемы Маркер.

Группа элементов Надписи в слое электрической схемы

  2. Подведите указатель маркера к точке, где производится данное измерение.

Создание выноски для отображения показаний измерительного прибора

Созданная выноска представляет собой объект информационной системы Измерительный прибор.

  3. Создайте в базе данных атрибутивное описание измерительного прибора и свяжите его с созданной надписью.
Замечание
В настройках соответствия объектов и слоёв должно быть установлено соответствие между элементом схемы Маркер и объектом информационной системы Измерительный прибор.

На закладке Общие данные указывается наименование измерительного прибора, выбирается марка прибора, категория размещения и климатическое исполнение. Ниже выбирается измеряемая величина. Это может быть ток, напряжение и т.п. Для измеряемой величины можно установить нижний и верхний пороги предупреждения.

Параметры измерительного прибора

  4. На закладке Телеметрия установите соответствие созданного в базе описания измерительного прибора с датчиком.

Теперь при поступлении данных от сервера телеметрии в надпись, обозначающую измерительный прибор, будет выводиться значение контролируемого параметра.

Вывод показания измерительного прибора на схему

Если измеренное значение выходит за нижний или верхний порог предупреждения, то надпись выделяется.

Также в этом разделе:

Задачи интеграции с системой телеметрии

Подключение к серверу рассылки телеметрических данных

Сопоставление элементов схемы с объектами телеметрии

Способы отображения измеренных значений на схеме

Отображение состояний выключателей

Журнал телеметрии


Просмотр телеметрической информации на схеме. Журнал телеметрии

Просмотр телеметрической информации на схеме

Журнал телеметрии

Все показания датчиков, поступающие от сервера телеметрии, хранятся в архиве измерений в базе данных. Нажмите кнопку [image] Журнал телеметрии… на панели инструментов IndorInfo/Power или выполните команду меню IndorInfo/Power| [image] Журнал телеметрии…

В верхней части окна Журнал телеметрии отображаются текущее время и имя пользователя, в центре окна - все измерения, поступившие с момента открытия журнала. Каждая строка в журнале соответствует одному измерению, положению выключателя или марке времени.

Журнал телеметрии

Строка содержит следующие поля:

  • Объект. Это наименование объекта информационной системы, для которого проводится измерение.
  • Время. В этом поле отображается время снятия показаний с датчика.
  • Значение. Данное поле содержит значение измеряемого параметра для измерительного прибора или состояние выключателя.

Временной интервал, с которым в журнале телеметрии отображаются марки времени, цвета заливки строк и отображаемые поля задаются в окне настройки журнала телеметрии. Оно открывается при нажатии кнопки [image] Настройка свойств журнала, расположенной в нижней части окна.

Настройки журнала телеметрии

В разделе Столбцы можно отметить галочками поля, отображаемые в журнале. В разделе Строки задаётся временной интервал, с которым в журнале телеметрии отображаются марки времени, а также цвета заливки строк.

Обычные строки в журнале имеют цвет, выбранный в поле Обычные строки. Если значение измерительного прибора выходит за пределы, указанные в окне ввода данных, или выключатель перешёл в состояние, отличное от своего нормального положения, то строки имеют цвет Выход за предел. При выделении обычные строки имеют цвет Выделенные, а строки, выходящие за предел, имеют цвет Выделение предел.

Рассмотрим другие кнопки, расположенные в журнале телеметрии:

Удалить строку журнала. Эта команда удаляет выделенную строку из журнала телеметрии. При этом из архива измерений в базе данных она не удаляется.

Подсветить объект на карте. По этой команде на карте подсвечивается объект, выделенный в журнале.

Параметры объекта. При нажатии этой кнопки открывается окно ввода данных для выделенного в журнале объекта.

Также в этом разделе:

Задачи интеграции с системой телеметрии

Подключение к серверу рассылки телеметрических данных

Сопоставление элементов схемы с объектами телеметрии

Способы отображения измеренных значений на схеме

Отображение состояний выключателей

Отображение значений измерительного прибора


Работа с готовым проектом. Измерение расстояний и площадей по карте

Работа с готовым проектом

Измерение расстояний и площадей по карте

При работе с картами можно проводить измерения расстояний и площадей, например, измерить расстояние между двумя опорами линии электропередачи или вычислить площадь территории, занимаемую опорой.

Включите режим измерения расстояний, нажав кнопку [image] Измерение расстояний на панели инструментов Power Режимы работы. Подведите указатель к первой опоре и щёлкните мышью, затем к следующей опоре и т.д. При этом в строке подсказки отображается общая длина нарисованной линии и длина её последнего сегмента. Для завершения измерения щёлкните правой кнопкой мыши.

Измерение расстояния по карте

Включите режим измерения площадей, нажав на кнопку [image] Измерение площадей. Последовательными щелчками мыши введите вершины полигона. При этом на карте отображается закрашенный полигон, а в строке подсказки - его площадь и периметр. Для завершения измерения щёлкните правой кнопкой мыши.

Измерение площади по карте

Замечание
Измерения проводятся в единицах карты, которые задаются в окне свойств карты (команда меню Карта| [image] Параметры карты…) на закладке Координаты.

Также в этом разделе:

Просмотр краткой и полной информации по объектам

Поиск объектов на карте

Просмотр каталога сетей

Просмотр ведомостей по объектам

Формирование отчётов

Подключение внешних атрибутов к карте

Вывод на карту значений атрибутов отдельных фигур

Коммутация переключателей

Выделение электрически связанной части схемы

Выделение части схемы с одним классом напряжения

Раскрашивание схемы по классам напряжения

Раскрашивание частей схемы, запитанных от разных источников

Раскрашивание фидеров, запитанных от разных подстанций

Просмотр телеметрической информации на схеме

Построение буферных зон

Печать карты


Работа с готовым проектом. Построение буферных зон

Работа с готовым проектом

Построение буферных зон

Буферные зоны определяются как геометрическое место точек, удалённых от заданной группы объектов не более чем на заданное расстояние. Построение буферных зон может использоваться в информационной системе для решения таких распространённых задач, как нахождение всевозможных охранных зон вдоль линий электропередачи, вокруг рек и озёр и т.д.

Для каждого объекта можно построить не одну, а несколько буферных зон. Например, если задана ширина буферной зоны 10 м и указано, что нужно построить 2 зоны, то будут построены 2 области, в первой из которых расстояние от любой точки до исходного объекта будет от 0 до 5 м, во второй - от 5 до 10 м.

  1. Выполните команду меню Фигуры| [image] Операции| [image] Буферные зоны…
  2. Выберите исходные данные для построения буферных зон. Ими могут быть только выделенные на карте фигуры (для этого следовало предварительно выделить нужные фигуры на карте) или все фигуры текущего слоя.
  3. Укажите ширину буферной зоны в единицах карты (поле Расстояние до объектов), а также количество буферных зон (параметр Число зон).

Параметр Число круговых дуг определяет, каким количеством дуг будет представлена буферная зона в крайних точках.

Кнопка По карте… предназначена для того, чтобы отмерить нужное расстояние до объектов по карте.

Параметры построения буферных зон

  4. Если буферные зоны строятся для нескольких фигур, то в разделе Вид построения выберите способ построения зон: Построить отдельные буферные зоны для каждого объекта или Объединить буферные зоны разных объектов.
Отдельно для каждого объекта | Объединение буферных зон
  5. Далее укажите, каким образом необходимо сохранить результат вычислений.

Буферные зоны можно построить временно на карте. Для этого выберите переключатель Нарисовать временно.

Можно выдать результат вычислений на один из слоёв карты. Для этого установите переключатель Выдать на слой и выберите в списке один из слоёв карты. Если установить флаг Очистить перед выдачей, то все фигуры выбранного слоя будут удалены.

Также можно сохранить результаты вычислений в шейп-файл. Для этого выберите переключатель Сохранить в шейп-файл и укажите в поле файл, в который нужно сохранить результат.

При нажатии кнопки ОК для указанных фигур строятся буферные зоны.

Буферная зона линии электропередачи

Если буферная зона нарисована на карте временно, то для её удаления выполните команду меню Фигуры| [image] Удалить результаты расчётов.

Также в этом разделе:

Просмотр краткой и полной информации по объектам

Поиск объектов на карте

Просмотр каталога сетей

Просмотр ведомостей по объектам

Формирование отчётов

Подключение внешних атрибутов к карте

Вывод на карту значений атрибутов отдельных фигур

Коммутация переключателей

Выделение электрически связанной части схемы

Выделение части схемы с одним классом напряжения

Раскрашивание схемы по классам напряжения

Раскрашивание частей схемы, запитанных от разных источников

Раскрашивание фидеров, запитанных от разных подстанций

Просмотр телеметрической информации на схеме

Измерение расстояний и площадей по карте

Печать карты


Работа с готовым проектом. Печать карты

Работа с готовым проектом

Печать карты

Вывод графической информации на печать осуществляется стандартными средствами системы IndorGIS. Для вывода на печать фрагмента карты выполните команду меню Карта| [image] Печать. Откроется окно настройки печати.

  • На закладке Принтер задаются настройки принтера, на который будет производиться печать.
  • На закладке Карта задаются координаты области карты для печати и масштаб печати. Можно указать точные координаты области в полях Слева, Сверху, Справа и Снизу или воспользоваться дополнительными командами. Кнопка [image] По видимому размеру карты устанавливает координаты области печати по размеру, видимому сейчас в окне редактора карты. Кнопка [image] По размеру всей карты устанавливает координаты области по размеру, занимаемому всей картой, кнопка [image] По размеру выделенных слоёв - по размеру, занимаемому выделенными в легенде карты слоями. При нажатии кнопки [image] По размеру слоя появляется меню со списком всех слоёв карты. При выборе любого слоя координаты области устанавливаются равными размеру соответствующего слоя.
  • Печатаемую область можно вписать на некоторое количество страниц или на отпечаток заданного размера в миллиметрах (масштаб будет вычислен автоматически). Можно также задать масштаб вручную. При этом количество страниц, необходимое для размещения карты в указанном масштабе, будет определено автоматически.

Окно настройки печати (закладка Карта)

  • В правой части окна настройки печати находится окно предварительного просмотра, в котором в уменьшенном виде отображается печатаемая область карты. Если карта занимает более одной страницы, то вся печатаемая область разделяется на несколько страниц установленного формата. Чтобы указать те страницы, которые необходимо напечатать или нет (по умолчанию печатаются все), щёлкните мышью на нужных страницах в окне предварительного просмотра.
  • На закладке Страница задаётся порядок печати страниц и поля страницы в миллиметрах.

Окно настройки печати (закладка Страница)

  • На закладке Параметры можно задать особые параметры печати: программная растеризация, настройки смешения цветов и метод вывода надписей.

Также в этом разделе:

Просмотр краткой и полной информации по объектам

Поиск объектов на карте

Просмотр каталога сетей

Просмотр ведомостей по объектам

Формирование отчётов

Подключение внешних атрибутов к карте

Вывод на карту значений атрибутов отдельных фигур

Коммутация переключателей

Выделение электрически связанной части схемы

Выделение части схемы с одним классом напряжения

Раскрашивание схемы по классам напряжения

Раскрашивание частей схемы, запитанных от разных источников

Раскрашивание фидеров, запитанных от разных подстанций

Просмотр телеметрической информации на схеме

Измерение расстояний и площадей по карте

Построение буферных зон


Технические паспорта объектов

В этой главе рассматриваются технические паспорта по всем объектам информационной системы и особенности использования справочников при заполнении паспортов.

Также в этом разделе:

Сети электроснабжения

Электростанции

Склад

Потребители

Линии электропередачи

Подстанции (строительная часть)

Силовые трансформаторы

Коммутаторы

Измерительные трансформаторы

Вводы и масляное хозяйство

Устройства компенсации

Другое оборудование


Технические паспорта объектов. Сети электроснабжения

Справочное руководство

Технические паспорта объектов

Сети электроснабжения

При редактировании сети электроснабжения указывается:

  • Наименование сети.
  • Организация-владелец. Выбирается из списка, формируемого по справочнику Организации, - в список включаются только те организации, которые могут владеть сетями. Для таких организаций в справочнике должен быть установлен флаг Владеет сетями.
  • Диспетчерское управление. Выбирается из списка, содержащего все элементы справочника Диспетчерские управления.
  • Обслуживающая организация. Выбирается из списка, содержащего все значения справочника Организации.

Параметры объекта Сеть электроснабжения

Замечание
При создании в составе некоторой сети электроснабжения новой сети последние 3 параметра (организация-владелец, диспетчерское управление и обслуживающая организация) копируются в новую сеть. Сделано это для удобства ввода данных, поскольку в большинстве случаев эти параметры у родительской и дочерних сетей совпадают. При необходимости их можно изменить, выбрав в списках нужные значения.
  • Поле Главная сеть заполняется автоматически - оно содержит название сети, в составе которой была создана новая сеть. Чтобы изменить главную сеть или, другими словами, владельца данной сети, нажмите кнопку [image] и выберите в появившемся окне другую сеть. После этого сеть будет перемещена в соответствующую ветвь дерева.
Замечание
При создании новой базы данных в ней создаётся один объект с названием Сеть электроснабжения. Это единственный объект в базе данных, который не имеет главного объекта (или владельца), для него поле Главная сеть - пустое. Все остальные объекты создаются в его составе.
  • Классы напряжения сети. Указанные здесь классы напряжения влияют на то, какие объекты могут быть созданы в составе сети. Например, если задать для сети классы напряжения 110 и 35 кВ, то в папке Линии будут созданы две подпапки ЛЭП 110 кВ и ЛЭП 35 кВ для размещения линий соответствующих классов. Кроме этого, если не задать класс напряжения сети, то и все объекты, создаваемые в её составе, также не будут иметь класса напряжения, что не позволит, к примеру, выполнить раскраску схемы по классам напряжения.

Также в этом разделе:

Электростанции

Склад

Потребители

Линии электропередачи

Подстанции (строительная часть)

Силовые трансформаторы

Коммутаторы

Измерительные трансформаторы

Вводы и масляное хозяйство

Устройства компенсации

Другое оборудование


Технические паспорта объектов. Электростанции

Справочное руководство

Технические паспорта объектов

Электростанции

В составе сети электроснабжения может быть создана электростанция и заданы её характеристики.

Также в этом разделе:

Электростанция, гидроэлектростанция, атомная электростанция

Синхронный генератор, синхронный компенсатор


Электростанции. Электростанция, гидроэлектростанция, атомная электростанция

Справочное руководство

Электростанции

Электростанция, гидроэлектростанция, атомная электростанция

Для электростанции указывается:

  • Наименование.
  • Организация-владелец и обслуживающая организация. Эти параметры выбираются из списков, которые содержат все записи справочника Организации.
  • Поле Сети заполняется автоматически - оно содержит название сети, в составе которой была создана электростанция. Чтобы изменить владельца, нажмите кнопку [image] и выберите в появившемся окне другую сеть. После этого электростанция будет перемещена в соответствующую ветвь дерева.

Параметры объекта Электростанция

Также в этом разделе:

Синхронный генератор, синхронный компенсатор


Электростанции. Синхронный генератор, синхронный компенсатор

Справочное руководство

Электростанции

Синхронный генератор, синхронный компенсатор

Характеристики питающей электростанции задаются с помощью объектов Синхронный генератор и Синхронный компенсатор, которые создаются в её составе.

Для синхронного генератора указываются следующие параметры:

  • Наименование.
  • Тип генератора. Выбирается из списка, содержащего все значения справочника Синхронный генератор.

Значения перечисленных ниже параметров устанавливаются автоматически при выборе типа генератора - они соответствуют типовым значениям, заданным в справочнике. При необходимости некоторые из них можно изменить.

  • Полная мощность.
  • Активная мощность.
  • КПД.
  • Номинальная частота вращения.
  • Коэффициент мощности.

Параметры объекта Синхронный генератор (Общие)

На закладке Типовые данные отображаются справочные характеристики выбранного типа генератора.

Параметры объекта Синхронный генератор (Типовые данные)

Для синхронного компенсатора задаются аналогичные параметры, за исключением КПД.

Параметры объекта Синхронный компенсатор (Общие данные)

Также в этом разделе:

Электростанция, гидроэлектростанция, атомная электростанция


Технические паспорта объектов. Склад

Справочное руководство

Технические паспорта объектов

Склад

В составе сети электроснабжения может быть создан объект Склад. На закладке Общие сведения для него указывается:

  • Наименование.
  • Организация-владелец и обслуживающая организация. Эти параметры выбираются из списков, которые содержат все записи справочника Организации.
  • Инвентарный номер.
  • Сеть, в состав которой входит склад.
  • Адрес склада.

Параметры объекта Склад (Общие сведения)

На закладке Оборудование можно составить список всего оборудования, хранящегося на складе.

  • Чтобы занеси информацию о новом оборудовании, поступившем на склад, нажмите кнопку Новое оборудование…, выберите тип создаваемого объекта, а затем введите его характеристики.
  • Чтобы перевести некоторое оборудование со склада в эксплуатацию, выделите его в списке, нажмите кнопку Установить… и в появившемся окне выберите нового владельца объекта.

Список оборудования, хранящегося на складе

  • Чтобы переместить на склад один из описанных в базе данных объектов, откройте для него окно ввода данных, нажмите кнопку [image] Дополнительная информация… и в поле Главный объект выберите складское помещение.

Также в этом разделе:

Сети электроснабжения

Электростанции

Потребители

Линии электропередачи

Подстанции (строительная часть)

Силовые трансформаторы

Коммутаторы

Измерительные трансформаторы

Вводы и масляное хозяйство

Устройства компенсации

Другое оборудование


Технические паспорта объектов. Потребители

Справочное руководство

Технические паспорта объектов

Потребители

В составе сетей могут быть созданы такие виды потребителей, как Насосная станция и Скважина.

Также в этом разделе:

Насосная станция, скважина

Синхронный двигатель, асинхронный двигатель


Потребители. Насосная станция, скважина

Справочное руководство

Потребители

Насосная станция, скважина

Для этих объектов указывается:

  • Наименование.
  • Организация-владелец и обслуживающая организация. Эти параметры выбираются из списков, которые содержат все записи справочника Организации.
  • Поле Сети заполняется автоматически - оно содержит название сети, в составе которой была создана электростанция. Чтобы изменить владельца, нажмите кнопку [image] и выберите в появившемся окне другую сеть. После этого электростанция будет перемещена в соответствующую ветвь дерева.

Параметры объекта Насосная станция

Также в этом разделе:

Синхронный двигатель, асинхронный двигатель


Потребители. Синхронный двигатель, асинхронный двигатель

Справочное руководство

Потребители

Синхронный двигатель, асинхронный двигатель

Чтобы определить состав нагрузки, в насосной станции могут создаваться синхронный и асинхронный двигатели, а в скважине - только синхронный двигатель.

Рассмотрим параметры синхронного двигателя:

  • Наименование.
  • Тип двигателя. Выбирается из списка, содержащего все значения справочника Синхронный двигатель.

Параметры объекта Синхронный двигатель (Общие)

Значения перечисленных ниже параметров устанавливаются автоматически при выборе типа двигателя - они соответствуют типовым значениям, заданным в справочнике. При необходимости некоторые из них можно изменить.

  • Полная мощность.
  • Активная мощность.
  • КПД.
  • Номинальная частота вращения.
  • Коэффициент мощности.

На закладке Типовые данные отображаются справочные характеристики выбранного типа двигателя.

Параметры объекта Синхронный двигатель (Типовые данные)

Для асинхронного двигателя указывается:

  • Наименование.
  • Тип двигателя. Выбирается из списка, содержащего все значения справочника Асинхронный двигатель.

Параметры объекта Асинхронный двигатель (Общие)

Значения перечисленных ниже параметров устанавливаются автоматически при выборе типа двигателя - они соответствуют типовым значениям, заданным в справочнике. При необходимости некоторые из них можно изменить.

  • Активная мощность.
  • КПД.
  • Скольжение.
  • Номинальная частота вращения.
  • Коэффициент мощности.

Также в этом разделе:

Насосная станция, скважина


Линии электропередачи. Модель представления линии электропередачи в базе данных

Справочное руководство

Линии электропередачи

Модель представления линии электропередачи в базе данных

Для описания в базе данных параметров линии электропередачи используются несколько типов объектов: ЛЭП, Участок ЛЭП, Отрезок ВЛЭП, Кабель, а также Опора, Пролёт, Грозозащитный трос и т.д. Рассмотрим один из возможных вариантов использования этих объектов. Для примера возьмём линию электропередачи, показанную ниже на рисунке.

Пример линии электропередачи

  1. В исходной линии создаётся определённое количество новых линий электропередачи. Таким образом выделяются отпайки и происходит деление двухцепной линии электропередачи на отдельные линии. Ниже на рисунке показан пример разбиения исходной линии на несколько линий.

Разбиение исходной линии электропередачи на несколько линий

Отпайка исходной линии "ВЛ-110 Отпайка на Водозабор (1,2)", в свою очередь, также состоит из двух линий.

Разбиение отпайки на две линии

  2. При необходимости в линиях создаётся требуемое количество участков для представления топологического ветвления линии. В таких линиях, как "Отпайка на Водозабор 1", показанная выше на рисунке, участки внутри линии можно не создавать.

Выделение в линии участков

  3. Участки и линии электропередачи моделируются последовательностью отрезков воздушного и/или кабельного исполнения, которые описывают используемые марки проводов и их длины. Для этого в их составе создаются объекты Отрезок ВЛЭП и Кабель.
  4. Кроме этого, в составе линий и участков могут быть созданы опоры и пролёты.

Также в этом разделе:

Линия электропередачи

Участок ЛЭП

Отрезок ВЛЭП

Кабель

Опора

Пролёт

Кабельная муфта

Грозозащитный трос


Линии электропередачи. Линия электропередачи

Справочное руководство

Линии электропередачи

Линия электропередачи

При редактировании линии электропередачи на закладке Общие данные указывается:

  • Наименование линии.
  • Диспетчерское имя.
Совет
Полное наименование линии фигурирует в отчётах, а краткое (или диспетчерское) можно использовать, например, для вывода названий линий на полки атрибутов.
  • Имя фидера. Вводится, как правило, для линий 0,4 кВ и фигурирует в отчётах.
  • Организация-владелец и обслуживающая организация. Эти параметры выбираются из списков, содержащих все значения справочника Организации.

Параметры объекта ЛЭП (Общие данные)

  • Поле Сеть (или Линия) заполняется автоматически - оно содержит название сети (или другой ЛЭП), в составе которой была создана новая линия. Чтобы изменить главный объект или, другими словами, владельца данной линии, нажмите кнопку [image] и выберите в появившемся окне другую сеть или линию. После этого линия будет перемещена в соответствующую ветвь дерева.
  • Кроме этого, можно указать адрес, инвентарный номер и балансовую стоимость линии электропередачи.

При нажатии кнопки Взять данные по отрезкам из IndorElectra вся информация по отрезкам линии электропередачи передаётся из внутренней базы данных системы IndorElectra в базу данных информационной системы IndorInfo/Power.

На закладке Проектные величины можно указать характеристики, прописанные в проекте линии электропередачи. Заданные здесь значения не участвуют в расчётах, но могут выводиться в некоторые отчёты, например инвентарный.

  • Активное сопротивление (R).
  • Реактивное сопротивление (X).
  • Длина линии.
  • Код климатической категории по ветру.
  • Код климатической категории по гололёду.
  • Особые условия.
  • Длины расчётного весового, расчётного ветрового и габаритного пролётов.

Параметры объекта ЛЭП (Проектные величины)

На закладке Интегральные параметры отображаются значения, вычисленные по данным отрезков и кабелей в составе линии. Они недоступны для редактирования.

  • Число отрезков ВЛЭП.
  • Число кабелей.
  • Длина линии (как сумма длин всех отрезков и кабелей в линии).

Параметры объекта ЛЭП (Интегральные параметры)

  • Погонное активное сопротивление (R).
  • Погонное реактивное сопротивление (X).
  • Погонная активная проводимость (g).
  • Погонная ёмкостная проводимость (b).
  • Максимальный ток (Imax).

Кнопка Обновить параметры вычисляет все перечисленные выше характеристики на основе актуальных данных в базе.

При нажатии кнопки УРЗА… открывается окно со списком защит, у которых в качестве защищаемого объекта указана данная линия (см. подробнее).

Расчёт топологии линии электропередачи выполняется для того, чтобы выяснить, на каких опорах висит каждый пролёт, и чтобы сформировать последовательность пролётов в линии. Для расчёта необходимо графическое представление опор и пролётов на карте, т.е. на карте должны быть нарисованы как опоры, так и пролёты.

Кнопка Рассчитать топологию… открывает окно задания параметров расчёта. При расчёте топологии указывается первый пролёт линии и расстояние между соседними пролётами, в результате чего соседними в цепочке считаются пролёты, расстояние между концевыми точками которых меньше, чем указанное значение. Также по карте выявляются опоры, расположенные в точках соединения пролётов.

Параметры расчёта топологии

Полученная в результате расчёта информация используется в отчёте Паспорт ВЛ, содержащем данные о переходных пролётах и опорах, на которых висят эти пролёты.

Также в этом разделе:

Модель представления линии электропередачи в базе данных

Участок ЛЭП

Отрезок ВЛЭП

Кабель

Опора

Пролёт

Кабельная муфта

Грозозащитный трос


Линии электропередачи. Участок ЛЭП

Справочное руководство

Линии электропередачи

Участок ЛЭП

Участок ЛЭП описывается теми же параметрами, что и линия электропередачи. Отличие заключается в том, что для участка не задаётся диспетчерское имя и он может входить только в состав другой линии.

Параметры объекта Участок ЛЭП

Также в этом разделе:

Модель представления линии электропередачи в базе данных

Линия электропередачи

Отрезок ВЛЭП

Кабель

Опора

Пролёт

Кабельная муфта

Грозозащитный трос


Линии электропередачи. Отрезок ВЛЭП

Справочное руководство

Линии электропередачи

Отрезок ВЛЭП

Отрезок воздушной линии характеризует марку провода и его длину на некотором участке линии электропередачи. Для него указывается:

  • Линия или участок линии, где расположен отрезок. Значение параметра устанавливается автоматически при создании отрезка.
  • Наименование отрезка.
  • Марка провода. Выбирается из списка, содержащего все значения справочника Марки проводов.

Параметры объекта Отрезок ВЛЭП (Общие данные)

  • Исполнение провода. Одной маркой провода могут быть выполнены линии электропередачи разных классов напряжения, при этом провод имеет индивидуальные характеристики в зависимости от того, на линии какого класса напряжения он используется. Поэтому следует указать, провод какого исполнения используется на данном отрезке. Список, в котором выбирается исполнение, содержит все исполнения, заданные в справочнике Марки проводов для выбранной марки провода.
  • Длина отрезка.

На закладке Типовые данные отображаются справочные характеристики выбранной марки провода.

Параметры объекта Отрезок ВЛЭП (Типовые данные)

Также в этом разделе:

Модель представления линии электропередачи в базе данных

Линия электропередачи

Участок ЛЭП

Кабель

Опора

Пролёт

Кабельная муфта

Грозозащитный трос


Линии электропередачи. Кабель

Справочное руководство

Линии электропередачи

Кабель

Кабели используются при выполнении линий электропередачи до 35 кВ, поэтому создать объект Кабель возможно только в составе линий электропередачи и участков до 35 кВ. Для него указывается:

  • Линия или участок линии, где расположен кабель. Этот параметр проставляется автоматически при создании кабеля.
  • Номер (или наименование) кабеля.
  • Марка кабеля. Выбирается из списка, содержащего все значения справочника Марки кабелей.

Параметры объекта Кабель

  • Длина кабеля.
  • Допустимый предельный ток (Imax). При выборе марки кабеля это значение устанавливается автоматически и берётся из справочных значений (если оно задано в справочнике). Но если допустимый предельный ток данного кабеля отличается от типового, то его можно изменить, указав в поле нужное значение.
  • Количество параллельных кабелей.

В разделе Типовые данные кабеля отображаются справочные характеристики выбранной марки кабеля.

Также в этом разделе:

Модель представления линии электропередачи в базе данных

Линия электропередачи

Участок ЛЭП

Отрезок ВЛЭП

Опора

Пролёт

Кабельная муфта

Грозозащитный трос


Линии электропередачи. Опора

Справочное руководство

Линии электропередачи

Опора

В составе линий электропередачи и участков имеется папка Опоры, предназначенная для размещения описаний опор в линии.

На закладке Общие данные для опоры задаются:

  • Номер (или наименование) опоры.
  • Вид опоры. Выбирается из списка, формируемого по справочнику Виды опор, - в список включаются только те опоры, для которых в поле Unom задан класс напряжения, совпадающий с классом редактируемой линии электропередачи.

Параметры объекта Опора (Общие данные)

  • Поле Линия 1 заполняется автоматически - оно содержит название линии, в составе которой была создана опора. Если в поле Вид опоры выбрана двухцепная опора, то становится доступным также поле Линия 2, где следует выбрать вторую линию, проходящую по этой опоре.
Замечание
Во второй линии создавать те же самые опоры не нужно.
  • Габарит по высоте и в плане.
  • Признак Угловая показывает назначение выбранного вида опоры, прописанное в справочнике. Он недоступен для редактирования.
  • Является ли опора анкерной.
  • Является ли опора транспозиционной.
  • Наличие у опоры ригеля.

На закладке Характеристики указываются следующие параметры:

  • Если для опоры задан признак наличия ригеля, то можно ввести материал, из которого он изготовлен.
  • Если для выбранного вида опоры в справочнике задано количество оттяжек, то можно выбрать марку троса оттяжек. Соответствующий список содержит все значения справочника Марки тросов.
  • Количество и величину искровых промежутков.
  • Количество и материал приставок.
  • Количество и материал подкосов.

Параметры объекта Опора (Характеристики)

На закладке Изоляторы задаётся список изоляторов и арматуры данной опоры. Кнопки [image] Редактировать описание и [image] Удалить описание предназначены для редактирования параметров и удаления выделенного объекта в списке.

Параметры объекта Опора (Изоляторы)

  • Чтобы добавить новое описание изолятора, нажмите кнопку [image] Добавить описание изолятора и в появившемся диалоговом окне заполните необходимые поля.

Параметры объекта Изолятор

  • Чтобы добавить новое описание арматуры, нажмите кнопку [image] Добавить описание арматуры и в появившемся диалоговом окне заполните необходимые поля.

Параметры объекта Арматура

В разделе Типовые данные отображаются справочные характеристики выбранного вида опоры.

Параметры объекта Опора (Типовые данные)

Также в этом разделе:

Модель представления линии электропередачи в базе данных

Линия электропередачи

Участок ЛЭП

Отрезок ВЛЭП

Кабель

Пролёт

Кабельная муфта

Грозозащитный трос


Линии электропередачи. Пролёт

Справочное руководство

Линии электропередачи

Пролёт

В составе линий электропередачи и участков имеется папка Пролёты, предназначенная для размещения описаний пролётов в линии.

На закладке Общие данные для пролёта задаются:

  • Поле Линия заполняется автоматически - оно содержит название линии, в составе которой был создан пролёт. При необходимости пролёт можно перенести в другую линию, выбрав её в списке.
  • Номер (или наименование) пролёта.

Параметры объекта Пролёт (Общие данные)

  • Провис пролёта.
  • Габарит (или высота) пролёта.
  • Расстояние между проводами в фазе.
  • Расстояние между дистанционными распорками.
  • Если пролёт проходит над каким-либо препятствием (например, над рекой или дорогой), установите флаг Переходный и в поле справа введите описание препятствия.

На закладке Арматура задаётся список арматуры данного пролёта (см. подробнее).

Также в этом разделе:

Модель представления линии электропередачи в базе данных

Линия электропередачи

Участок ЛЭП

Отрезок ВЛЭП

Кабель

Опора

Кабельная муфта

Грозозащитный трос


Линии электропередачи. Кабельная муфта

Справочное руководство

Линии электропередачи

Кабельная муфта

Создать объект Кабельная муфта возможно только в составе линий электропередачи и участков до 35 кВ. Для него указывается:

  • Поле Линия заполняется автоматически - оно содержит название линии, в составе которой был создан пролёт.
  • Номер (или наименование) муфты.
  • Тип муфты.
  • Типоразмер муфты.
  • Материал, из которого изготовлена оболочка муфты.
  • Тип кабельной массы муфты.
  • Тип кабельного соединения.

Перечисленные выше параметры выбираются из справочников, объединённых в группу Муфты в редакторе справочников.

  • Длина муфты.
  • Внутренний диаметр муфты.
  • Толщина стенок муфты.

Параметры объекта Кабельная муфта

Также в этом разделе:

Модель представления линии электропередачи в базе данных

Линия электропередачи

Участок ЛЭП

Отрезок ВЛЭП

Кабель

Опора

Пролёт

Грозозащитный трос


Линии электропередачи. Грозозащитный трос

Справочное руководство

Линии электропередачи

Грозозащитный трос

Грозозащитные тросы объединяются в составе линии в отдельную папку. Для них указывается:

  • Поле Линия заполняется автоматически - оно содержит название линии, в составе которой был создан грозозащитный трос.
  • Номер (или наименование) грозозащитного троса.
  • Марка троса. Выбирается из списка, содержащего все значения справочника Марки тросов.
  • Тип крепления. Выбирается из списка, содержащего все значения справочника Крепления тросов.

Параметры объекта Грозозащитный трос (Общие данные)

На закладке Арматура задаётся список арматуры грозозащитного троса (см. подробнее), а на закладке Типовые данные отображаются справочные характеристики выбранной марки троса.

Также в этом разделе:

Модель представления линии электропередачи в базе данных

Линия электропередачи

Участок ЛЭП

Отрезок ВЛЭП

Кабель

Опора

Пролёт

Кабельная муфта


Подстанции (строительная часть). Подстанция

Справочное руководство

Подстанции (строительная часть)

Подстанция

Для подстанции указываются следующие параметры:

  • Наименование подстанции.
  • Тип подстанции. Выбирается из списка, содержащего все значения справочника Типы подстанций.
  • Организация-владелец и обслуживающая организация. Эти параметры выбираются из списков, содержащих все значения справочника Организации.
  • Диспетчерское управление. Выбирается из списка, содержащего все значения справочника Диспетчерские управления.
  • Инвентарный номер.

Параметры объекта Подстанция

  • Поле Сеть заполняется автоматически - оно содержит название сети, в составе которой была создана подстанция. Чтобы изменить главный объект или, другими словами, владельца данной подстанции, нажмите кнопку [image] и выберите в появившемся окне другую сеть. После этого подстанция будет перемещена в соответствующую ветвь дерева.
  • Также можно указать адрес, вид связи и оперативного обслуживания на подстанции.

Также в этом разделе:

Здание

Распределительное устройство

Секция подвесная и Секция жёсткая

Портал

Ячейка

Контур заземления


Подстанции (строительная часть). Здание

Справочное руководство

Подстанции (строительная часть)

Здание

В составе подстанций имеется папка Здания ТП, предназначенная для размещения описаний зданий в подстанции.

На закладке Общие для здания задаются такие параметры, как:

  • Наименование здания.
  • Тип здания. Выбирается из списка, содержащего все значения справочника Типы сооружений.
  • Организация-владелец. Выбирается из списка, содержащего все значения справочника Организации.
  • Инвентарный номер.

Параметры объекта Здание (Общие)

На закладке Строительная часть указываются строительные характеристики сооружения:

  • Материал стен.
  • Тип фундамента.
  • Тип кровли.
  • Тип перекрытий.
  • Тип окон.

Перечисленные выше параметры выбираются из справочников, которые объединены в группу Строительные части в редакторе справочников.

  • Число этажей в здании.
  • Высота здания.
  • Высотная отметка поверхности в месте расположения здания.
  • Длина и ширина здания.

Параметры объекта Здание (Строительная часть)

Информация о дверных проёмах здания задаётся на закладке Дверные проёмы.

Параметры объекта Здание (Дверные проёмы)

Чтобы добавить описание дверного проёма, нажмите кнопку [image] Добавить дверной проём и введите его наименование и размеры.

Параметры дверного проёма

Кнопки [image] и [image] открывают параметры выделенного дверного проёма или удаляют его соответственно.

На закладке Изоляция можно задать список изоляторов здания (аналогично дверным проёмам).

Также в этом разделе:

Подстанция

Распределительное устройство

Секция подвесная и Секция жёсткая

Портал

Ячейка

Контур заземления


Подстанции (строительная часть). Распределительное устройство

Справочное руководство

Подстанции (строительная часть)

Распределительное устройство

Распределительные устройства создаются в составе подстанций. Для них указывается:

  • Наименование.
  • Тип распределительного устройства. Выбирается из списка, содержащего все значения справочника Типы распределительных устройств.
  • Класс напряжения.

Параметры объекта Распределительное устройство

Также в этом разделе:

Подстанция

Здание

Секция подвесная и Секция жёсткая

Портал

Ячейка

Контур заземления


Подстанции (строительная часть). Секция подвесная и Секция жёсткая

Справочное руководство

Подстанции (строительная часть)

Секция подвесная и Секция жёсткая

Секции могут создаваться либо непосредственно внутри подстанций, либо внутри распределительных устройств.

На закладке Общие для секции задаётся:

  • Наименование секции.
  • Номинальное напряжение секции.
  • Номинальный ток шин.

Параметры объекта Секция (Общие)

Информация о шинах, расположенных внутри секции, вводится на закладке Шины.

Параметры объекта Секция (Шины)

Чтобы добавить описание шины, нажмите кнопку [image] Добавить описание шины и введите её наименование, выберите тип шинопровода (список содержит все записи справочника Типы шин) и марку провода, укажите длину шины, площадь сечения и другие параметры.

Параметры шины

Кнопки [image] и [image] открывают параметры выделенной шины или удаляют её.

На закладке Изоляция можно задать список изоляторов секции (аналогично шинам).

Также в этом разделе:

Подстанция

Здание

Распределительное устройство

Портал

Ячейка

Контур заземления


Подстанции (строительная часть). Портал

Справочное руководство

Подстанции (строительная часть)

Портал

Порталы создаются в составе секций. Для них указывается:

  • Номер (или наименование) портала.
  • Габарит по горизонтали и вертикали.
  • Количество фундаментных стоек.
  • Если задано количество стоек, то можно выбрать их тип. Список содержит все значения справочника Фундаменты опор.

Параметры объекта Портал (Общие данные)

На закладке Изоляция можно задать список изоляторов портала.

Также в этом разделе:

Подстанция

Здание

Распределительное устройство

Секция подвесная и Секция жёсткая

Ячейка

Контур заземления


Подстанции (строительная часть). Ячейка

Справочное руководство

Подстанции (строительная часть)

Ячейка

Ячейки могут быть созданы в составе секции или распределительного устройства.

На закладке Общие для ячейки указывается:

  • Наименование ячейки.
  • Номер ячейки.
  • Тип ячейки. Выбирается из списка, формируемого по справочнику Типы ячеек, - в список включаются только те типы, максимальное номинальное напряжение которых позволяет использовать их в данной ячейке. Максимальное номинальное напряжение задаётся в справочнике в поле Uном.max.
  • Назначение ячейки (например, ввод линии или ввод трансформатора).

В разделе Типовые данные отображаются справочные характеристики выбранного типа ячейки.

Параметры объекта Ячейка (Общие)

Список шин для ячейки задаётся на закладке Ошиновка. Чтобы добавить описание шины, нажмите кнопку [image] и в появившемся диалоговом окне введите необходимые параметры шины.

Параметры объекта Ячейка (Ошиновка)

На закладке Изоляция задаётся список изоляторов ячейки. Чтобы добавить описание изолятора, нажмите кнопку [image] и в появившемся диалоговом окне введите необходимые параметры изолятора.

Параметры объекта Ячейка (Изоляция)

Также в этом разделе:

Подстанция

Здание

Распределительное устройство

Секция подвесная и Секция жёсткая

Портал

Контур заземления


Подстанции (строительная часть). Контур заземления

Справочное руководство

Подстанции (строительная часть)

Контур заземления

На закладке Общие данные для контура заземления указывается:

  • Наименование.
  • Инвентарный номер.
  • Организация-владелец. Выбирается из списка, содержащего все значения справочника Организации.

Параметры объекта Контур заземления (Общие данные)

  • Способ заземления.
  • Тип заземлителя.
  • Тип присоединения.

Три последних параметра выбираются из справочников, объединённых в группу Контур заземления в редакторе справочников.

На закладке Характеристики можно ввести:

  • Расчётное сопротивление.
  • Сечение полос.
  • Глубину прокладки.
  • Длину заземлителя.

Параметры объекта Контур заземления (Характеристики)

Также в этом разделе:

Подстанция

Здание

Распределительное устройство

Секция подвесная и Секция жёсткая

Портал

Ячейка


Силовые трансформаторы. Автотрансформатор

Справочное руководство

Силовые трансформаторы

Автотрансформатор

На закладке Общие данные для автотрансформатора указывается:

  • Наименование.
  • Марка автотрансформатора. Выбирается из списка, формируемого по справочнику Типы автотрансформаторов, - в список попадают только те типы из справочника, у которых параметр Unom равен классу напряжения ячейки, где создаётся автотрансформатор.
  • Значение номинальной мощности Snom берётся из типовых значений, заданных для выбранной марки в справочнике. Если для данного трансформатора реальное значение мощности отлично от типового, то его можно изменить, указав в поле подходящее значение.
  • Категория размещения. Выбирается из списка, содержащего все значения справочника Категории размещения.
  • Климатическое исполнение. Если в справочнике для выбранной марки трансформатора указано климатическое исполнение, то значение этого параметра задаётся автоматически. Его можно изменить, выбрав в списке другое значение. Список формируется по справочнику Климатические исполнения.

Параметры объекта Автотрансформатор (Общие данные)

  • Фундамент. Выбирается из списка, содержащего все значения справочника Типы фундаментов.
  • Марка масла. Выбирается из списка, содержащего все значения справочника Марки масла.
  • Газозащита. Выбирается из списка, содержащего все значения справочника Типы газозащиты.
  • Если данный трансформатор является трансформатором собственных нужд, то следует установить соответствующий флаг.

При нажатии кнопки Защиты… открывается окно со списком защит, у которых в качестве защищаемого объекта указан данный трансформатор (см. подробнее).

На закладке Силовая часть задаются следующие характеристики:

  • Значение номинальной мощности Snom отображается также на этой закладке.
  • Схемы соединения обмоток высокого и низкого напряжения. Схемы соединения обмоток трансформаторов прописаны в справочнике Схемы обмоток и недоступны для редактирования.

После выбора этих параметров в последнем поле отображается Группа соединения обмоток.

  • Сдвиг фаз между обмотками высокого и среднего напряжения и между обмотками высокого и низкого напряжения.

Значения перечисленных ниже параметров устанавливаются автоматически при выборе марки трансформатора - они соответствуют типовым значениям, заданным в справочнике. При необходимости их можно изменить.

  • Потери холостого хода.
  • Потери короткого замыкания между обмотками высокого и среднего напряжения, высокого и низкого напряжения, среднего и низкого напряжения.
  • Напряжение короткого замыкания между обмотками высокого и среднего напряжения, высокого и низкого напряжения, среднего и низкого напряжения.
  • Ток холостого хода.

Параметры объекта Автотрансформатор (Силовая часть)

На закладке Отпайки следует выбрать схему отпаек автотрансформатора. Список содержит все схемы, заданные для выбранного типа автотрансформатора в справочнике Параметры отпаек автотрансформаторов.

После выбора схемы данные о числе переключений и проценте отпайки на высокой стороне и средней стороне трансформатора устанавливаются автоматически по справочным значениям. При необходимости их можно изменить.

Параметры объекта Автотрансформатор (Отпайки)

На закладке Кадастр указывается:

  • Завод-изготовитель автотрансформатора. Он выбирается из списка, содержащего все значения справочника Заводы-изготовители.
  • Заводской номер.
  • Дата изготовления.
  • Инвентарный номер.
  • Владелец автотрансформатора. Выбирается из списка, содержащего все значения справочника Организации.
  • Дополнительную информацию можно указать в поле Примечание.

Параметры объекта Автотрансформатор (Кадастр)

На закладке Типовые данные отображаются справочные характеристики выбранного типа автотрансформатора.

Параметры объекта Автотрансформатор (Типовые данные)

Также в этом разделе:

Трансформатор двухобмоточный

Трансформатор трёхобмоточный

Трансформатор с расщеплённой обмоткой

Линейный регулятор

Регулятор


Силовые трансформаторы. Трансформатор двухобмоточный

Справочное руководство

Силовые трансформаторы

Трансформатор двухобмоточный

На закладке Общие данные для двухобмоточного трансформатора задаются те же параметры, что и для автотрансформатора (см. подробнее). Марка выбирается из справочника Типы двухобмоточных трансформаторов, причём в список выводятся только те типы из справочника, у которых параметр Unom равен классу напряжения ячейки, где создаётся трансформатор.

При нажатии кнопки УРЗА… открывается окно со списком защит, у которых в качестве защищаемого объекта указан данный трансформатор (см. подробнее).

Параметры объекта Тр-р двухобмоточный (Общие данные)

На закладке Силовая часть задаются следующие характеристики:

  • Схемы соединения обмоток высокого и низкого напряжения. Схемы соединения обмоток трансформаторов прописаны в справочнике Схемы обмоток и недоступны для редактирования.

После выбора этих параметров в последнем поле отображается Группа соединения обмоток.

  • Сдвиг фаз между обмотками высокого и низкого напряжения.

Параметры объекта Тр-р двухобмоточный (Силовая часть)

Значения перечисленных ниже параметров устанавливаются автоматически при выборе марки трансформатора - они соответствуют типовым значениям, заданным в справочнике. При необходимости их можно изменить.

  • Потери холостого хода.
  • Потери короткого замыкания.
  • Напряжение короткого замыкания.
  • Ток холостого хода.

На закладке Отпайки следует выбрать схему отпаек трансформатора. Список содержит все схемы, заданные для выбранного типа трансформатора в справочнике Параметры отпаек двухобмоточных трансформаторов.

После выбора схемы данные о числе переключений и проценте отпайки на высокой стороне трансформатора устанавливаются автоматически по справочным значениям. При необходимости их можно изменить.

Параметры объекта Тр-р двухобмоточный (Отпайки)

На закладке Кадастр указывается завод-изготовитель трансформатора, его заводской номер, дата изготовления, инвентарный номер и владелец.

На закладке Типовые данные отображаются справочные характеристики выбранного типа двухобмоточного трансформатора.

Также в этом разделе:

Автотрансформатор

Трансформатор трёхобмоточный

Трансформатор с расщеплённой обмоткой

Линейный регулятор

Регулятор


Силовые трансформаторы. Трансформатор трёхобмоточный

Справочное руководство

Силовые трансформаторы

Трансформатор трёхобмоточный

На закладке Общие данные для трёхобмоточного трансформатора задаются те же параметры, что и для других видов силовых трансформаторов (см. подробнее). Марка выбирается из справочника Типы трёхобмоточных трансформаторов, причём в список выводятся только те типы из справочника, у которых параметр Unom равен классу напряжения ячейки, где создаётся трансформатор.

При нажатии кнопки УРЗА… открывается окно со списком защит, у которых в качестве защищаемого объекта указан данный трансформатор (см. подробнее).

Параметры объекта Тр-р трёхобмоточный (Общие данные)

На закладке Силовая часть задаются следующие характеристики:

  • Схемы соединения обмоток высокого, среднего и низкого напряжения. Схемы соединения обмоток трансформаторов прописаны в справочнике Схемы обмоток и недоступны для редактирования.

После выбора этих параметров в последнем поле отображается Группа соединения обмоток.

  • Сдвиг фаз между обмотками высокого и среднего напряжения и между обмотками высокого и низкого напряжения.

Параметры объекта Тр-р трёхобмоточный (Силовая часть)

Значения перечисленных ниже параметров устанавливаются автоматически при выборе марки трансформатора - они соответствуют типовым значениям, заданным в справочнике. При необходимости их можно изменить.

  • Потери короткого замыкания между обмотками высокого и среднего напряжения, высокого и низкого напряжения, среднего и низкого напряжения.
  • Потери холостого хода.
  • Ток холостого хода.
  • Напряжение короткого замыкания между обмотками высокого и среднего напряжения, высокого и низкого напряжения, среднего и низкого напряжения.

На закладке Отпайки можно выбрать схему отпаек трансформатора (см. подробнее). На закладке Кадастр указывается завод-изготовитель трансформатора, его заводской номер, дата изготовления, инвентарный номер и владелец. На закладке Типовые данные отображаются справочные характеристики выбранного типа трёхобмоточного трансформатора.

Также в этом разделе:

Автотрансформатор

Трансформатор двухобмоточный

Трансформатор с расщеплённой обмоткой

Линейный регулятор

Регулятор


Силовые трансформаторы. Трансформатор с расщеплённой обмоткой

Справочное руководство

Силовые трансформаторы

Трансформатор с расщеплённой обмоткой

На закладке Общие данные для трансформатора с расщеплённой обмоткой задаются те же параметры, что и для других видов силовых трансформаторов (см. подробнее). Марка выбирается из справочника Типы трансформаторов с расщеплённой обмоткой, причём в список выводятся только те типы из справочника, у которых параметр Unom равен классу напряжения ячейки, где создаётся трансформатор.

Параметры объекта Тр-р с расщеплённой обмоткой (Общие данные)

При нажатии кнопки УРЗА… открывается окно со списком защит, у которых в качестве защищаемого объекта указан данный трансформатор (см. подробнее).

На закладке Силовая часть задаются следующие характеристики:

  • Схемы соединения обмоток высокого и низких напряжений. Схемы соединения обмоток трансформаторов прописаны в справочнике Схемы обмоток и недоступны для редактирования.

После выбора этих параметров в последнем поле отображается Группа соединения обмоток.

  • Сдвиг фаз между обмотками высокого и первого низкого напряжения и между обмотками высокого и второго низкого напряжения.

Значения перечисленных ниже параметров устанавливаются автоматически при выборе марки трансформатора - они соответствуют типовым значениям, заданным в справочнике. При необходимости их можно изменить.

  • Потери холостого хода.
  • Потери короткого замыкания между обмотками трансформатора.
  • Напряжение короткого замыкания между обмотками трансформатора.
  • Ток холостого хода.

Параметры объекта Тр-р с расщеплённой обмоткой (Силовая часть)

На закладке Отпайки можно выбрать схему отпаек трансформатора (см. подробнее).

На закладке Кадастр указывается завод-изготовитель трансформатора, его заводской номер, дата изготовления, инвентарный номер и владелец.

На закладке Типовые данные отображаются справочные характеристики выбранного типа трансформатора с расщеплённой обмоткой.

Также в этом разделе:

Автотрансформатор

Трансформатор двухобмоточный

Трансформатор трёхобмоточный

Линейный регулятор

Регулятор


Силовые трансформаторы. Линейный регулятор

Справочное руководство

Силовые трансформаторы

Линейный регулятор

На закладке Общие данные для линейного регулятора задаются те же параметры, что и для других видов силовых трансформаторов (см. подробнее). Марка выбирается из справочника Типы линейных регуляторов, причём в список выводятся только те типы из справочника, у которых параметр Unom равен классу напряжения ячейки, где создаётся линейный регулятор.

При нажатии кнопки Защиты… открывается окно со списком защит, у которых в качестве защищаемого объекта указан данный линейный регулятор (см. подробнее).

Параметры объекта Линейный регулятор (Общие данные)

На закладке Силовая часть задаются следующие характеристики:

  • Схемы соединения обмоток высокого и низкого напряжения. Схемы соединения обмоток трансформаторов прописаны в справочнике Схемы обмоток и недоступны для редактирования.

После выбора этих параметров в последнем поле отображается Группа соединения обмоток.

  • Сдвиг фаз между обмотками высокого и низкого напряжения.

Параметры объекта Линейный регулятор (Силовая часть)

Значения перечисленных ниже параметров устанавливаются автоматически при выборе марки трансформатора - они соответствуют типовым значениям, заданным в справочнике. При необходимости их можно изменить.

  • Значение номинальной мощности Snom.
  • Минимальные и максимальные потери холостого хода.
  • Минимальный и максимальный ток холостого хода.
  • Потери короткого замыкания.

На закладке Кадастр указывается заводизготовитель трансформатора, его заводской номер, дата изготовления, инвентарный номер и владелец.

На закладке Типовые данные отображаются справочные характеристики выбранного типа линейного регулятора.

Также в этом разделе:

Автотрансформатор

Трансформатор двухобмоточный

Трансформатор трёхобмоточный

Трансформатор с расщеплённой обмоткой

Регулятор


Силовые трансформаторы. Регулятор

Справочное руководство

Силовые трансформаторы

Регулятор

В составе силовых трансформаторов может быть создан регулятор.

На закладке Общие данные для регулятора указывается:

  • Наименование.
  • Тип регулятора. Выбирается из списка, содержащего все значения справочника Типы переключателей.
  • Метод и тип регулирования. Выбираются из списков, содержащих все значения справочников Методы регулирования и Типы регулирования.
  • Исполнение регулятора. Выбирается из списка, содержащего все значения справочника Исполнения регуляторов.

Параметры объекта Регулятор (Общие данные)

  • Марка масла. Выбирается из списка, содержащего все значения справочника Марки масла.
  • Категория размещения и климатическое исполнение. Эти параметры выбираются из справочников Категории размещения и Климатические исполнения, объединённых в группу Добавочные в редакторе справочников.

На закладке Характеристики задаются такие параметры, как:

  • Регулируемая обмотка. Выбирается из списка, содержащего все значения справочника Типы регулируемых обмоток.
  • Зона нечувствительности.
  • Выдержка времени.

Параметры объекта Регулятор (Характеристики)

На закладке Рабочее положение указывается число рабочих положений регулятора. Если число рабочих положений регулятора меньше, чем количество отпаек у трансформатора, то нужно установить соответствие между рабочими положениями и отпайками.

Например, чтобы поставить в соответствие отпайке трансформатора "+1" 2-е рабочее положение регулятора, достаточно щёлкнуть мышью в таблице в ячейке (2,+1).

Если количество рабочих положений больше, чем число отпаек, то таблица соответствия будет недоступна.

Текущее рабочее положение регулятора устанавливается с помощью бегунка полосы прокрутки. Оно отображается в таблице красным цветом.

Параметры объекта Регулятор (Раб. положение)

На закладке Кадастр задаются следующие параметры:

  • Завод-изготовитель.
  • Заводской номер.
  • Дата изготовления.
  • Инвентарный номер.
  • Организация-владелец.

Параметры объекта Регулятор (Кадастр)

На закладке Типовые данные отображаются справочные характеристики выбранного типа регулятора.

Также в этом разделе:

Автотрансформатор

Трансформатор двухобмоточный

Трансформатор трёхобмоточный

Трансформатор с расщеплённой обмоткой

Линейный регулятор


Коммутаторы. Выключатели (масляный, вакуумный, воздушный, элегазовый, тиристорный, электромагнитный, автоматический, выключатель нагрузки)

Справочное руководство

Коммутаторы

Выключатели (масляный, вакуумный, воздушный, элегазовый, тиристорный, электромагнитный, автоматический, выключатель нагрузки)

На закладке Общие данные для выключателей указывается:

  • Наименование выключателя.
  • Марка выключателя. Выбирается из списка, формируемого по одному из справочников (Типы масляных выключателей, Типы вакуумных выключателей и т.д.) - в список попадают только те типы из справочника, у которых параметр Unom равен классу напряжения ячейки, где создаётся выключатель.
  • Завод-изготовитель. Выбирается из списка, содержащего все значения справочника Заводы-изготовители.
  • Заводской номер.
  • Дата изготовления.
  • Категория размещения и климатическое исполнение. Эти параметры выбираются из справочников Категории размещения и Климатические исполнения, объединённых в группу Добавочные в редакторе справочников.
  • Марка масла. Выбирается из справочника Марки масла и задаётся только для масляного выключателя.
  • Время включения и отключения.
  • Количество допустимых КЗ. Эта информация используется при определении степени износа выключателя и выводится в отчёт Степень износа выключателей.
  • Текущее положение: Включен или Отключен, показывает, в каком состоянии находится в данный момент выключатель.
  • Нормальное положение.
  • Уставка срабатывания расцепителя в зоне перегрузки.
  • Уставка срабатывания расцепителя в зоне КЗ.
  • Число циклов ВО и число циклов ВО под нагрузкой.

Параметры объекта Выключатель (Общие данные)

На закладке Коммутации отображается история включений и отключений коммутатора, начиная с даты, указанной в поле. По каждой коммутации отображается дата, время, причина и источник переключения. Чтобы отобразить переключения, начиная с другой даты, введите эту дату в поле и нажмите кнопку [image] Обновить историю.

Параметры объекта Выключатель (Коммутации)

На закладке Типовые данные отображаются справочные характеристики выбранной марки выключателя.

Параметры объекта Выключатель (Типовые данные)

Поставить в соответствие выключателю некоторый объект телеметрии можно на закладке Телеметрия (см. подробнее).

Также в этом разделе:

Разъединитель, рубильник, контактор


Коммутаторы. Разъединитель, рубильник, контактор

Справочное руководство

Коммутаторы

Разъединитель, рубильник, контактор

На закладке Общие данные для разъединителя, рубильника и контактора указывается:

  • Наименование.
  • Марка. Выбирается из справочников Типы разъединителей, Типы рубильников, Типы контакторов. В список попадают только те типы из справочника, у которых параметр Unom равен классу напряжения ячейки, где создаётся разъединитель (рубильник или контактор).
  • Завод-изготовитель. Он выбирается из списка, содержащего все значения справочника Заводы-изготовители.
  • Заводской номер.
  • Дата изготовления.
  • Категория размещения.
  • Климатическое исполнение.

Два последних параметра выбираются из справочников Категории размещения и Климатические исполнения, объединённых в группу Добавочные в редакторе справочников.

  • Текущее положение: Включен или Отключен, показывает, в каком состоянии находится в данный момент выключатель.
  • Нормальное положение. Не задаётся для рубильника и контактора.

Параметры объекта Разъединитель (Общие данные)

На закладке Коммутации можно просмотреть архив коммутаций переключателей.

На закладке Типовые данные отображаются справочные характеристики выбранной марки разъединителя (рубильника или контактора).

Для разъединителя на закладке Изоляция можно указать список используемых изоляторов.

Также в этом разделе:

Выключатели (масляный, вакуумный, воздушный, элегазовый, тиристорный, электромагнитный, автоматический, выключатель нагрузки)


Измерительные трансформаторы. Трансформатор тока

Справочное руководство

Измерительные трансформаторы

Трансформатор тока

На закладке Общие данные для трансформатора тока указывается:

  • Наименование.
  • Тип трансформатора тока. Выбирается из списка, содержащего все значения справочника Типы трансформаторов тока.
  • Категория размещения. Если в справочнике для выбранной марки трансформатора указана категория размещения, то значение этого параметра задаётся автоматически. Его можно изменить, выбрав в списке другое значение. Список формируется по справочнику Категории размещения.
  • Климатическое исполнение. Если в справочнике для выбранной марки трансформатора указано климатическое исполнение, то значение этого параметра задаётся автоматически. Его можно изменить, выбрав в списке другое значение. Список формируется по справочнику Климатические исполнения.
  • Фаза установки трансформатор тока.

Параметры объекта Тр-р тока (Общие данные)

На закладке Силовая часть указывается схема соединения нагрузок трансформатора тока и фактические нагрузки на каждой обмотке.

Параметры объекта Тр-р тока (Силовая часть)

На закладке Кадастр задаются следующие параметры:

  • Завод-изготовитель.
  • Заводской номер.
  • Дата изготовления.
  • Инвентарный номер.
  • Владелец трансформатора тока. Выбирается из списка, содержащего все значения справочника Организации.
  • Номер в Госреестре.
  • Номер пломбы.

Параметры объекта Тр-р тока (Кадастр)

На закладке Типовые данные отображаются справочные характеристики выбранного типа трансформатора тока.

Также в этом разделе:

Группа трансформаторов тока

Трансформатор напряжения


Измерительные трансформаторы. Группа трансформаторов тока

Справочное руководство

Измерительные трансформаторы

Группа трансформаторов тока

Для объединения однофазных трансформаторов тока в группу создаётся объект Группа ТТ, характеризуемый следующими параметрами:

  • Наименование.
  • Схемы включения вторичных обмоток трансформаторов группы.
  • В поле Марки ТТ показываются марки трансформаторов тока, входящих в группу.

Параметры объекта Группа ТТ

Также в этом разделе:

Трансформатор тока

Трансформатор напряжения


Измерительные трансформаторы. Трансформатор напряжения

Справочное руководство

Измерительные трансформаторы

Трансформатор напряжения

На закладке Общие данные для трансформатора напряжения указывается:

  • Наименование.
  • Тип трансформатора. Выбирается из списка, формируемого по справочнику Типы трансформаторов напряжения, - в список попадают только те типы из справочника, у которых параметр Unom равен классу напряжения ячейки, где создаётся трансформатор.
  • Категория размещения. Если в справочнике для выбранной марки трансформатора указана категория размещения, то значение этого параметра задаётся автоматически. Его можно изменить, выбрав в списке другое значение. Список формируется по справочнику Категории размещения.
  • Климатическое исполнение. Если в справочнике для выбранной марки трансформатора указано климатическое исполнение, то значение этого параметра задаётся автоматически. Его можно изменить, выбрав в списке другое значение. Список формируется по справочнику Климатические исполнения.
  • Марка масла. Выбирается из справочника Марки масла.

Параметры объекта Тр-р напряжения (Общие данные)

На закладке Силовая часть задаются следующие характеристики:

  • Схемы соединения обмоток высокого, среднего и низкого напряжения. Схемы соединения обмоток трансформаторов прописаны в справочнике Схемы обмоток и недоступны для редактирования.

После выбора этих параметров отображается Группа соединения обмоток.

  • Сдвиг фаз между обмотками высокого и среднего напряжения и между обмотками высокого и низкого напряжения.
  • Фактическая нагрузка.

Параметры объекта Тр-р напряжения (Силовая часть)

На закладке Кадастр задаются такие параметры, как:

  • Завод-изготовитель.
  • Заводской номер.
  • Дата изготовления.
  • Инвентарный номер.
  • Владелец трансформатора тока. Выбирается из списка, содержащего все значения справочника Организации.
  • Номер в Госреестре.
  • Номер пломбы.

Параметры объекта Тр-р напряжения (Кадастр)

На закладке Типовые данные отображаются справочные характеристики выбранной типа трансформатора напряжения.

Параметры объекта Тр-р напряжения (Типовые данные)

Трансформаторы напряжения можно объединять в группы. Для группы указывается только наименование.

Также в этом разделе:

Трансформатор тока

Группа трансформаторов тока


Технические паспорта объектов. Вводы и масляное хозяйство

Справочное руководство

Технические паспорта объектов

Вводы и масляное хозяйство

В составе силовых трансформаторов могут быть созданы масляный и монолитный вводы, устройство охлаждения масла и маслоочистительная установка. Рассмотрим параметры этих объектов.

Также в этом разделе:

Масляный и монолитный вводы

Устройство охлаждения масла

Маслоочистительная установка


Вводы и масляное хозяйство. Масляный и монолитный вводы

Справочное руководство

Вводы и масляное хозяйство

Масляный и монолитный вводы

На закладке Общие данные для вводов указываются:

  • Номер (или наименование) ввода.
  • Фаза установки ввода.
  • Тип ввода. Выбирается из списка, содержащего все значения справочника Типы маслонаполнительных вводов (или Типы монолитных вводов).
  • Тип контактов. Выбирается из списка, содержащего все значения справочника Типы контактов.
  • Марка масла. Выбирается из справочника Марки масла и задаётся только для масляного ввода.
  • Климатическое исполнение и категория размещения. Эти параметры выбираются из справочников Климатические исполнения и Категории размещения, объединённых в группу Добавочные в редакторе справочников.

Параметры объекта Масляный ввод (Общие данные)

На закладке Кадастр указываются следующие параметры:

  • Завод-изготовитель ввода. Он выбирается из списка, содержащего все значения справочника Заводы-изготовители.
  • Заводской номер.
  • Дата изготовления.
  • Инвентарный номер.
  • Владелец ввода. Выбирается из списка, содержащего все значения справочника Организации.

Параметры объекта Масляный ввод (Кадастр)

На закладке Типовые данные отображаются справочные характеристики выбранного типа ввода.

Также в этом разделе:

Устройство охлаждения масла

Маслоочистительная установка


Вводы и масляное хозяйство. Устройство охлаждения масла

Справочное руководство

Вводы и масляное хозяйство

Устройство охлаждения масла

На закладке Общие данные для устройства охлаждения масла указывается:

  • Наименование.
  • Тип устройства охлаждения. Выбирается из списка, содержащего все значения справочника Типы устройств охлаждения.
  • Тип и число маслонасосов.
  • Тип и число вентиляторов.
  • Тип радиатора.

Три последних параметра выбираются из справочников Типы маслонасосов, Типы вентиляторов и Типы радиаторов, объединённых в группу Устройства охлаждения масла в редакторе справочников.

Параметры объекта Устройство охлаждения масла (Общие данные)

  • Категория размещения и климатическое исполнение. Эти параметры выбираются из справочников Категории размещения и Климатические исполнения, объединённых в группу Добавочные в редакторе справочников.

На закладке Кадастр указывается завод-изготовитель устройства, его заводской номер, дата изготовления и инвентарный номер.

На закладке Типовые данные отображаются справочные характеристики выбранного типа устройства охлаждения.

Также в этом разделе:

Масляный и монолитный вводы

Маслоочистительная установка


Вводы и масляное хозяйство. Маслоочистительная установка

Справочное руководство

Вводы и масляное хозяйство

Маслоочистительная установка

На закладке Общие данные для маслоочистительной установки указывается:

  • Наименование.
  • Марка. Выбирается из списка, содержащего все значения справочника Типы маслоочистителей.
  • Категория размещения и климатическое исполнение. Эти параметры выбираются из справочников Категории размещения и Климатические исполнения, объединённых в группу Добавочные в редакторе справочников.
  • Завод-изготовитель.
  • Заводской номер.
  • Дата изготовления установки.

Параметры объекта Маслоочистительная установка (Общие данные)

На закладке Типовые данные отображаются справочные характеристики выбранного типа маслоочистительной установки.

Также в этом разделе:

Масляный и монолитный вводы

Устройство охлаждения масла


Устройства компенсации. Реактор токоограничивающий, шунтирующий, заземляющий дугогасящий

Справочное руководство

Устройства компенсации

Реактор токоограничивающий, шунтирующий, заземляющий дугогасящий

На закладке Общие данные для токоограничивающего реактора указывается:

  • Наименование.
  • Тип реактора. Выбирается из списка, содержащего все значения справочника Типы токоограничивающих реакторов.
  • Категория размещения и климатическое исполнение. Эти параметры выбираются из справочников Категории размещения и Климатические исполнения, объединённых в группу Добавочные в редакторе справочников.

Параметры объекта Реактор токоограничивающий (Общие данные)

На закладке Кадастр выбирается завод-изготовитель реактора (из справочника Заводы-изготовители), указывается заводской номер и дата изготовления.

Параметры объекта Реактор токоограничивающий (Кадастр)

На закладке Типовые данные отображаются справочные характеристики выбранного типа токоограничивающего реактора.

Параметры объекта Реактор токоограничивающий (Типовые данные)

Также в этом разделе:

Батарея статических конденсаторов


Устройства компенсации. Батарея статических конденсаторов

Справочное руководство

Устройства компенсации

Батарея статических конденсаторов

Для батареи статических конденсаторов указывается:

  • Наименование.
  • Тип конденсаторов. Выбирается из списка, содержащего все значения справочника Типы конденсаторов.
  • Число конденсаторов в батарее.
  • Продольная компенсация.
  • Завод-изготовитель.
  • Заводской номер.
  • Дата изготовления установки.
  • Категория размещения и климатическое исполнение. Эти параметры выбираются из справочников Категории размещения и Климатические исполнения, объединённых в группу Добавочные в редакторе справочников.

Параметры объекта Батарея статических конденсаторов

Также в этом разделе:

Реактор токоограничивающий, шунтирующий, заземляющий дугогасящий


Другое оборудование. Измерительный прибор

Справочное руководство

Другое оборудование

Измерительный прибор

На закладке Общие данные для измерительного прибора указывается:

  • Наименование.
  • Марка измерительного прибора. Выбирается из справочника Типы измерительного оборудования.
  • Категория размещения и климатическое исполнение. Эти параметры выбираются из справочников Категории размещения и Климатические исполнения, объединённых в группу Добавочные в редакторе справочников.
  • Измеряемая величина. Выбирается из списка, в который попадают только те измеряемые величины, которые указаны для выбранной марки прибора в справочнике.

Рассмотрим этот момент подробнее. В справочнике Типы измерительного оборудования показываются все измеряемые величины, заданные в справочнике Типы измеряемых характеристик. Для каждого типа оборудования следует выбрать из этого списка те величины, которые он может измерять.

Выбор измеряемых величин для некоторого типа измерительного оборудования

  • Схема включения прибора.
  • После записи информации об измерительном приборе в базу данных (кнопка Записать) становится доступным поле Значение для ввода показаний прибора. Время снятия показаний с прибора устанавливается автоматически при нажатии кнопки Зафиксировать.
  • Параметр Коэффициент поправки необходимо указывать для коррекции измерений (например, в связи с изменением характеристик вследствие износа или брака).
  • Для измеряемой величины можно установить нижний и верхний пороги предупреждения. Если значение выходит за указанные пределы, то в журнале телеметрии выдается соответствующее оповещение.

Параметры объекта Измерительный прибор (Общие данные)

На закладке Кадастр задаются следующие параметры:

  • Завод-изготовитель.
  • Заводской номер.
  • Дата изготовления.
  • Инвентарный номер.
  • Владелец измерительного прибора. Выбирается из списка, содержащего все значения справочника Организации.
  • Номер в Госреестре.
  • Номер пломбы.
  • Можно указать наличие электронной пломбы.

Параметры объекта Измерительный прибор (Кадастр)

На закладке Архив измерений отображаются все зафиксированные показания прибора (вручную или средствами телеметрии).

На закладке Типовые данные отображаются справочные характеристики выбранного типа измерительного прибора.

Параметры объекта Измерительный прибор (Типовые данные)

Поставить в соответствие выключателю некоторый объект телеметрии можно на закладке Телеметрия (см. подробнее).

Также в этом разделе:

ВЧ-заградитель, группа ВЧ-заградителей

Предохранитель

Разрядник


Другое оборудование. ВЧ-заградитель, группа ВЧ-заградителей

Справочное руководство

Другое оборудование

ВЧ-заградитель, группа ВЧ-заградителей

При редактировании ВЧ-заградителя указывается:

  • Наименование.
  • Тип заградителя. Выбирается из списка, содержащего все значения справочника Типы ВЧ-заградителей.
  • Фаза заграждения.
    • Типовые данные отображаются справочные характеристики выбранного типа ВЧ-заградителя.

Параметры объекта ВЧ-заградитель

Однофазные ВЧ-заградители можно объединять в группы. Для группы ВЧ-заградителей указывается только наименование.

Параметры объекта Группа ВЧ-заградителей

Также в этом разделе:

Измерительный прибор

Предохранитель

Разрядник


Другое оборудование. Предохранитель

Справочное руководство

Другое оборудование

Предохранитель

На закладке Общие данные для предохранителя указывается:

  • Номер (или наименование).
  • Тип предохранителя. Выбирается из списка, который содержит все значения справочника Типы предохранителей.
  • Климатическое исполнение и категория размещения. Эти параметры выбираются из справочников Категории размещения и Климатические исполнения, объединённых в группу Добавочные в редакторе справочников.

Параметры объекта Предохранитель (Общие данные)

На закладке Кадастр задаются следующие параметры:

  • Завод-изготовитель.
  • Заводской номер.
  • Дата изготовления.
  • Инвентарный номер.
  • Владелец измерительного прибора. Выбирается из списка, содержащего все значения справочника Организации.

Параметры объекта Предохранитель (Кадастр)

В разделе Типовые данные отображаются справочные характеристики выбранного типа предохранителя.

Параметры объекта Предохранитель (Типовые данные)

Также в этом разделе:

Измерительный прибор

ВЧ-заградитель, группа ВЧ-заградителей

Разрядник


Другое оборудование. Разрядник

Справочное руководство

Другое оборудование

Разрядник

На закладке Общие данные для разрядника указывается:

  • Номер (или наименование).
  • Тип разрядника. Выбирается из списка, который содержит все значения справочника Типы разрядников.
  • Климатическое исполнение и категория размещения. Эти параметры выбираются из справочников Категории размещения и Климатические исполнения, объединённых в группу Добавочные в редакторе справочников.
  • Число срабатываний.

Параметры объекта Разрядник (Общие данные)

На закладке Кадастр задаются следующие параметры:

  • Завод-изготовитель.
  • Заводской номер.
  • Дата изготовления.
  • Инвентарный номер.
  • Владелец измерительного прибора. Выбирается из списка, содержащего все значения справочника Организации.

Параметры объекта Разрядник (Кадастр)

Также в этом разделе:

Измерительный прибор

ВЧ-заградитель, группа ВЧ-заградителей

Предохранитель


Перечень кнопок панелей инструментов

В этой главе перечислены все кнопки панелей инструментов редактора карт. Кратко дано описание назначения каждой кнопки со ссылкой на её подробное описание в Руководстве пользователя. Заметим, что рассматриваются те панели инструментов, которые формируются специально для системы IndorInfo/Power.

Также в этом разделе:

Панель инструментов "Power Проекты"

Панель инструментов "Power Слои"

Панель инструментов "Power Навигация"

Панель инструментов "Power Правка"

Панель инструментов "Power Настройка карты"

Панель инструментов "Power Режимы общие"

Панель инструментов "Power Режимы"

Панель инструментов "IndorInfo/Power"


Перечень кнопок панелей инструментов. Панель инструментов "Power Проекты"

Справочное руководство

Перечень кнопок панелей инструментов

Панель инструментов "Power Проекты"

Эта панель содержит команды для сохранения проекта и переключения в окно менеджера проектов.

Панель инструментов Power Проекты

Сохранить проект. Сохраняет текущий проект под тем же именем.

Менеджер проектов. При нажатии этой кнопки система переключается из редактора карт в окно менеджера проектов (см. подробнее).

Также в этом разделе:

Панель инструментов "Power Слои"

Панель инструментов "Power Навигация"

Панель инструментов "Power Правка"

Панель инструментов "Power Настройка карты"

Панель инструментов "Power Режимы общие"

Панель инструментов "Power Режимы"

Панель инструментов "IndorInfo/Power"


Перечень кнопок панелей инструментов. Панель инструментов "Power Слои"

Справочное руководство

Перечень кнопок панелей инструментов

Панель инструментов "Power Слои"

На этой панели собраны команды для работы со слоями карты.

Панель инструментов Power Слои

Создать новый слой карты. При нажатии этой кнопки появляется список для выбора типа создаваемого слоя (см. подробнее).

Добавить слой карты... Открывает окно, где можно выбрать файл слоя, добавляемый в карту (см. подробнее).

Создать новую пустую папку. При нажатии кнопки создаётся новая пустая папка и сразу открывается окно для ввода её названия (см. подробнее).

Начать/завершить редактирование слоя. Используется при совместной работе нескольких пользователей с одним слоем. Позволяет либо начать редактирование текущего слоя, либо завершить редактирование (см. подробнее).

Сохранить данные текущего слоя. Сохраняет все изменения в текущем слое, произведённые с момента последнего сохранения (см. подробнее).

Свойства слоя... Открывает окно настройки свойств текущего слоя.

Также в этом разделе:

Панель инструментов "Power Проекты"

Панель инструментов "Power Навигация"

Панель инструментов "Power Правка"

Панель инструментов "Power Настройка карты"

Панель инструментов "Power Режимы общие"

Панель инструментов "Power Режимы"

Панель инструментов "IndorInfo/Power"


Перечень кнопок панелей инструментов. Панель инструментов "Power Навигация"

Справочное руководство

Перечень кнопок панелей инструментов

Панель инструментов "Power Навигация"

На этой панели присутствуют команды для осуществления навигации по карте (см. подробнее).

Панель инструментов Power навигация

Вписывает в область просмотра всю карту.

Вписывает в область просмотра все объекты выделенного слоя (или нескольких выделенных слоёв).

Вписывает в область просмотра все выделенные фигуры.

Также в этом разделе:

Панель инструментов "Power Проекты"

Панель инструментов "Power Слои"

Панель инструментов "Power Правка"

Панель инструментов "Power Настройка карты"

Панель инструментов "Power Режимы общие"

Панель инструментов "Power Режимы"

Панель инструментов "IndorInfo/Power"


Перечень кнопок панелей инструментов. Панель инструментов "Power Правка"

Справочное руководство

Перечень кнопок панелей инструментов

Панель инструментов "Power Правка"

Команды этой панели предназначены для работы с буфером обмена и выполнения различных операций с объектами.

Панель инструментов Power Правка

Вырезать. Удаляет выделенный объект из карты и помещает его в буфер обмена.

Копировать. Копирует выделенный объект в буфер обмена.

Вставить точно по координатам. Вставляет объект из буфера обмена точно по координатам исходного объекта.

Вставить в центр окна и переместить. При нажатии этой кнопки рядом с указателем мыши появляется изображение объекта в буфере обмена. Нужно определить положение объекта на карте и щёлкнуть мышью.

Сформатировать элементы по образцу текущего выделенного. Эта кнопка позволяет скопировать значения внутренних атрибутов выделенного объекта в другой объект этого же слоя, который будет указан мышью.

Повернуть налево. Поворачивает выделенную фигуру на 90° против часовой стрелки.

Повернуть направо. Поворачивает выделенную фигуру на 90° по часовой стрелке.

Отразить сверху вниз. Создаёт зеркальную копию выделенной фигуры относительно горизонтальной линии, проходящей через её центр.

Отразить слева направо. Создаёт зеркальную копию выделенной фигуры относительно вертикальной линии, проходящей через её центр (см. подробнее).

Инспектор объектов. Открывает окно инспектора объектов (см. подробнее).

Также в этом разделе:

Панель инструментов "Power Проекты"

Панель инструментов "Power Слои"

Панель инструментов "Power Навигация"

Панель инструментов "Power Настройка карты"

Панель инструментов "Power Режимы общие"

Панель инструментов "Power Режимы"

Панель инструментов "IndorInfo/Power"


Перечень кнопок панелей инструментов. Панель инструментов "Power Настройка карты"

Справочное руководство

Перечень кнопок панелей инструментов

Панель инструментов "Power Настройка карты"

На этой панели собраны команды для настройки сетки карты.

Панель инструментов Power Настройка карты

Свойства карты... Открывает окно настройки свойств карты.

Показывать сетку. Включает/отключает отображение сетки на карте.

Привязывать к сетке. Включает/отключает привязку к сетке фигур при их создании и редактировании (см. подробнее).

Настроить индивидуальную сетку слоя... Открывает окно настройки индивидуального шага сетки для текущего слоя (см. подробнее).

Также в этом разделе:

Панель инструментов "Power Проекты"

Панель инструментов "Power Слои"

Панель инструментов "Power Навигация"

Панель инструментов "Power Правка"

Панель инструментов "Power Режимы общие"

Панель инструментов "Power Режимы"

Панель инструментов "IndorInfo/Power"


Перечень кнопок панелей инструментов. Панель инструментов "Power Режимы общие"

Справочное руководство

Перечень кнопок панелей инструментов

Панель инструментов "Power Режимы общие"

На этой панели собраны режимы работы системы IndorGIS, используемые при работе с системой IndorInfo/Power.

Панель инструментов Power Режимы общие

Увеличение изображения. Включает режим увеличения изображения.

Уменьшение изображения. Включает режим уменьшения изображения.

Панорамирование изображения. Включает режим панорамного просмотра карты (см. подробнее).

Измерение расстояний. Этот режим позволяет выполнять измерение расстояний по карте (см. подробнее).

Редактирование фигур. Этот режим позволяет выделить фигуру и выполнить какие-либо действия: повернуть, переместить, изменить свойства и т.д. (см. подробнее).

Редактирование частей фигур. В этом режиме можно выделить несколько узловых точек фигуры и выполнить с ними некоторые преобразования, например, переместить или повернуть.

Редактирование подписей визуализатора. Позволяет выборочно перемещать подписи у некоторых фигур (см. подробнее).

Создание новых объектов. Предназначен для создания новых фигур на карте. Набор фигур, создаваемых в этом режиме, зависит от того, какой слой в данный момент является активным (т.е. выделен в дереве слоёв). Если в активном слое могут присутствовать фигуры нескольких типов, то кнопка содержит всплывающую панель инструментов (см. подробнее).

Также в этом разделе:

Панель инструментов "Power Проекты"

Панель инструментов "Power Слои"

Панель инструментов "Power Навигация"

Панель инструментов "Power Правка"

Панель инструментов "Power Настройка карты"

Панель инструментов "Power Режимы"

Панель инструментов "IndorInfo/Power"


Перечень кнопок панелей инструментов. Панель инструментов "Power Режимы"

Справочное руководство

Перечень кнопок панелей инструментов

Панель инструментов "Power Режимы"

На этой панели располагаются специфические режимы системы IndorInfo/Power.

Панель инструментов Power Режимы

Краткая информация. Если в этом режиме указать мышью объект, относящийся к электрическим сетям, то появится окно с краткой информацией о нём (см. подробнее).

Ввод данных. В этом режиме при щелчке на фигурах карты, относящихся к электрическим сетям, появляется окно, где можно ввести параметры объекта. Если указанная мышью фигура уже была связана с некоторым объектом в базе данных, то появляется это же окно, но с введёнными параметрами, которые можно изменить (см. подробнее).

Связывание фигур с объектами в базе данных. В этом режиме осуществляется связывание фигур на карте с описаниями объектов в базе данных. Для этого достаточно указать мышью фигуру, а затем выбрать соответствующее ей описание (см. подробнее).

Удаление связей между фигурами и объектами в базе данных. Чтобы разорвать связь между фигурой на карте и описанием в базе данных, достаточно указать в этом режиме фигуру и подтвердить удаление связи (см. подробнее).

Коммутация переключателей с записью в базу данных. В этом режиме производится переключение состояний коммутаторов (включен/выключен). Информация о переключения (дата, время и, возможно, причина) записывается в базу данных (см. подробнее).

Выделение части сети. Режим для выделения электрически связанных частей схемы (см. подробнее).

Выделение класса напряжения. Режим для выделения части схемы с одним классом напряжения (см. подробнее).

Проверка связности без коммутаторов. Этот режим используется для проверки связности графа сети, он не учитывает состояния коммутаторов (см. подробнее).

Выделение фигур, не связанных с объектами в базе данных. Предназначен для выполнения проверки: какие фигуры на карте связаны с объектами в базе данных, а какие - нет. Для этого нужно обвести интересующий фрагмент карты рамкой (см. подробнее).

Также в этом разделе:

Панель инструментов "Power Проекты"

Панель инструментов "Power Слои"

Панель инструментов "Power Навигация"

Панель инструментов "Power Правка"

Панель инструментов "Power Настройка карты"

Панель инструментов "Power Режимы общие"

Панель инструментов "IndorInfo/Power"


Перечень кнопок панелей инструментов. Панель инструментов "IndorInfo/Power"

Справочное руководство

Перечень кнопок панелей инструментов

Панель инструментов "IndorInfo/Power"

На этой панели располагаются команды, предназначенные только для работы с IndorInfo/Power. Эти команды доступны также в подменю IndorInfo/Power главного меню.

Панель инструментов IndorInfo/Power

Каталог сетей... Открывает окно, где представлена иерархия сетей электроснабжения, описанная в базе данных. Можно перейти к содержимому одной из сетей (см. подробнее).

Ведомости… Открывает окно для формирования ведомостей по объектам: сетям, подстанциям, линиям электропередачи, оборудованию подстанции, объектам телеметрии, устройствам РЗА, потребителям и измерительным приборам. Выборка производится на основе заданных критериев. Например, можно сформировать ведомость по оборудованию определённого типа, принадлежащему некоторой подстанции, или по всем линиям электропередачи из заданной сети электроснабжения (см. подробнее).

Журнал работ… Открывает окно, где можно просмотреть в общем списке работы по всем объектам информационной системы (см. подробнее).

Отчёты… Открывает окно, где можно выбрать вид формируемого отчёта и задать его параметры. Система IndorInfo/Power позволяет формировать сводные отчёты по электрическим сетям, линиям электропередачи, подстанциям и оборудованию; инвентарные отчёты, включающие информацию о технических параметрах оборудования, отчёты по эксплуатации и другие виды отчётов (см. подробнее).

Поиск объекта на карте… Выполняет поиск объекта на карте по его описанию в базе данных. Искать можно по наименованию, инвентарному номеру или примечанию (см. подробнее).

Справочники… Открывает окно редактора справочников, где можно добавлять новые справочные значения и редактировать существующие (см. подробнее).

Экспорт параметров в IndorElectra… Выполняет экспорт параметров объектов электрических сетей из базы данных системы IndorInfo/Power во внутреннюю базу данных системы IndorElectra. Эта операция применяется при совместном использовании двух систем (см. подробнее).

Журнал телеметрии… Вызывает окно, где показываются все поступившие от сервера телеметрии показания датчиков с момента открытия окна (см. подробнее).

Обновить состояние коммутаторов из базы. Чтобы обновить состояние коммутаторов на схеме в соответствии с их реальными положениями, записанными в базе данных, следует нажать эту кнопку. Используется, если переключение коммутаторов осуществляется на нескольких рабочих местах (см. подробнее).

Раскрасить части схемы, запитанные от разных источников. Окрашивает в разные цвета те части схемы, которые запитаны от разных источников. Неподключенная часть схемы окрашивается в серый цвет (см. подробнее).

Раскрасить части схемы, запитанные от разных подстанций. Окрашивает в разные цвета фидеры, запитанные от разных подстанций (см. подробнее).

Раскрасить схему по классам напряжения. Окрашивает в один цвет элементы электрической схемы, обладающие одинаковым номинальным напряжением. Кольца трансформаторов окрашиваются в цвет, который соответствует номинальному напряжению стороны трансформатора (см. подробнее).

Выделить фигуры, не связанные с объектами в базе данных. Выделяет на карте все фигуры, которые не связаны с объектами в базе данных (см. подробнее).

Настройка соответствия слоёв… Открывает для выделенного слоя окно, в котором настраивается соответствие с объектами электрических сетей (см. подробнее).

Настройка IndorInfo/Power… Открывает окно настройки системы IndorInfo/Power, где можно настроить подключение к базе данных (см. подробнее), настроить подключение к серверу рассылки телеметрических данных (см. подробнее), просмотреть список функций, допускаемых текущей лицензией (см. подробнее).

Также в этом разделе:

Панель инструментов "Power Проекты"

Панель инструментов "Power Слои"

Панель инструментов "Power Навигация"

Панель инструментов "Power Правка"

Панель инструментов "Power Настройка карты"

Панель инструментов "Power Режимы общие"

Панель инструментов "Power Режимы"


Список "горячих" клавиш

Для повышения эффективности работы в системах IndorGIS и IndorInfo/Power предусмотрены "горячие" клавиши - сочетания одной или нескольких клавиш, при нажатии которых выполняется определённое действие. Горячие клавиши указаны в пунктах меню справа от названия команды, а для инструментов - во всплывающих подсказках.

Также в этом разделе:

Вызов справки

Доступ к меню

Работа в диалоговых окнах

Работа с проектами

Работа с картами

Просмотр карты

Работа со слоями

Создание и удаление фигур

Выделение и редактирование фигур

Ввод и редактирование данных


Список "горячих" клавиш. Вызов справки

Справочное руководство

Список "горячих" клавиш

Вызов справки

F1

Вызов справки (меню ?, команда Помощь по модулю|IndorInfo/Power…). Если при нажатии на эту клавишу активно диалоговое окно, то справка откроется на соответствующем разделе.

Также в этом разделе:

Доступ к меню

Работа в диалоговых окнах

Работа с проектами

Работа с картами

Просмотр карты

Работа со слоями

Создание и удаление фигур

Выделение и редактирование фигур

Ввод и редактирование данных


Список "горячих" клавиш. Доступ к меню

Справочное руководство

Список "горячих" клавиш

Доступ к меню

F10 или Alt

Выбор строки главного меню или закрытие открытого меню (вместе с подменю, если оно открыто).

Alt+подчеркнутая буква в названии меню

Открытие меню: Alt+Ф - меню Файл, Alt+К - меню Карта, Alt+П - меню Просмотр, Alt+Р - меню Режим, Alt+З - меню Запрос, Alt+В - меню Вид, Alt+С - меню Сервис, Alt+? - меню Справка (это сочетание клавиш действует только при английской раскладке клавиатуры), Alt+I - меню IndorInfo/Power (это сочетание клавиш действует только на английской раскладке клавиатуры).

Стрелка влево или Стрелка вправо

Выбор меню слева или справа. При открытом подменю переключение между основным меню и подменю.

Стрелка вверх или Стрелка вниз

Выбор предыдущей или следующей команды после открытия меню или подменю.

Enter

Открытие выбранного меню или выполнение действия, которое назначено выбранной команде.

Esc

Закрытие открытого меню или подменю.

Также в этом разделе:

Вызов справки

Работа в диалоговых окнах

Работа с проектами

Работа с картами

Просмотр карты

Работа со слоями

Создание и удаление фигур

Выделение и редактирование фигур

Ввод и редактирование данных


Список "горячих" клавиш. Работа в диалоговых окнах

Справочное руководство

Список "горячих" клавиш

Работа в диалоговых окнах

Tab

Переход к следующему параметру или группе параметров.

Shift+Tab

Переход к предыдущему параметру или группе параметров.

Ctrl+Tab

Переход к следующей закладке диалогового окна.

Ctrl+Shift+Tab

Переход к предыдущей закладке диалогового окна.

Клавиши управления курсором

Переход к следующему или предыдущему элементу в списке или группе.

Пробел

Установка или снятие выбранного флажка.

F4

Открытие раскрывающегося списка, если фокус установлен в поле со списком. Открытие калькулятора, если фокус установлен в числовом поле. Открытие окна визуального определения угла, если фокус установлен в поле для задания углов.

Стрелка вверх или Стрелка вниз

Увеличение или уменьшение значения числового поля со средним шагом.

Ctrl+Стрелка вверх или Ctrl+Стрелка вниз

Увеличение или уменьшение значения числового поля с большим шагом.

Shift+Стрелка вверх или Shift+Стрелка вниз

Увеличение или уменьшение значения числового поля с мелким шагом.

Стрелка влево или Стрелка вправо

Перемещение курсора на один знак влево или вправо при редактировании значения числового поля.

Enter или Пробел

Выполнение действия, назначенного выбранной кнопке диалогового окна (эта кнопка выделена синей рамкой).

Esc

Отмена команды и закрытие диалогового окна.

Также в этом разделе:

Вызов справки

Доступ к меню

Работа с проектами

Работа с картами

Просмотр карты

Работа со слоями

Создание и удаление фигур

Выделение и редактирование фигур

Ввод и редактирование данных


Список "горячих" клавиш. Работа с проектами

Справочное руководство

Список "горячих" клавиш

Работа с проектами

Shift+Ctrl+N

Создание нового проекта (в менеджере проектов: меню Файл, команда Создать новый проект).

Shift+F2

Сохранение проекта под текущим именем (в менеджере проектов: меню Файл, команда Сохранить проект).

Shift+Ctrl+F2

Сохранение проекта под другим именем (в менеджере проектов: меню Файл, команда Сохранить проект как...).

Alt+F2

Сохранение всех рабочих проектов под текущими именами (в менеджере проектов: меню Файл команда Сохранить все проекты).

Shift+F3

Открытие проекта (в менеджере проектов: меню Файл, команда Открыть проект…).

Alt+Enter

Вызов окна свойств текущего проекта (в менеджере проектов: контекстное меню проекта, команда Свойства…).

Также в этом разделе:

Вызов справки

Доступ к меню

Работа в диалоговых окнах

Работа с картами

Просмотр карты

Работа со слоями

Создание и удаление фигур

Выделение и редактирование фигур

Ввод и редактирование данных


Список "горячих" клавиш. Работа с картами

Справочное руководство

Список "горячих" клавиш

Работа с картами

Alt+Enter

Открытие свойств карты в менеджере проектов (контекстное меню карты, команда Свойства…).

Ctrl+Alt+M

Открытие свойств карты в редакторе карт (меню Карта, команда Параметры карты…).

Ctrl+P

Вызов окна настройки печати карты (меню Карта, команда Печать…).

Shift+Ctrl+P

Печать видимой части карты (меню Карта, команда Печать видимой части…).

Ctrl+F2

Сохранение всех слоёв карты (меню Карта, команда Сохранить все слои карты).

Также в этом разделе:

Вызов справки

Доступ к меню

Работа в диалоговых окнах

Работа с проектами

Просмотр карты

Работа со слоями

Создание и удаление фигур

Выделение и редактирование фигур

Ввод и редактирование данных


Список "горячих" клавиш. Просмотр карты

Справочное руководство

Список "горячих" клавиш

Просмотр карты

Клавиши управления курсором

Прокрутка изображения в редакторе карт.

Ctrl+клавиша управления курсором

Переход к краю текущего изображения в редакторе карт.

I

Переход в режим увеличения изображения (кнопка [image] Увеличение изображения на панели инструментов Power Режимы общие).

O

Переход в режим уменьшения изображения (кнопка [image] Уменьшение изображения на панели инструментов Power Режимы общие).

P

Переход в режим панорамирования карты (кнопка [image] Панорамирование изображения на панели инструментов Power Режимы общие).

Ctrl+0…9

Эти комбинации клавиш можно назначить для масштабов просмотра карты из стандартного ряда, которые задаются в окне свойств карты на закладке Масштабы.

Ctrl+Num+

Увеличение масштаба просмотра карты на 25% (меню Просмотр, команда Увеличить сейчас на 25%).

Ctrl+Num-

Уменьшение масштаба просмотра карты на 25% (меню Просмотр, команда Уменьшить сейчас на 25%).

Ctrl+Num*

Вписывание в рабочую область всей карты (кнопка [image] Вписать в окно всю карту на панели инструментов Power Навигация).

Shift+Num*

Вписывание в рабочую область всех фигур выделенных слоёв (кнопка [image] Вписать в окно все выделенные слои на панели инструментов Power Навигация).

Alt+Num*

Вписывание в рабочую область всех выделенных на карте фигур (кнопка [image] Вписать в окно все выделенные фигуры на панели инструментов Power Навигация).

BackSpace

Предыдущий вид карты.

M

Измерение расстояний по карте (кнопка [image] Измерение расстояний на панели инструментов Power Режимы общие).

Также в этом разделе:

Вызов справки

Доступ к меню

Работа в диалоговых окнах

Работа с проектами

Работа с картами

Работа со слоями

Создание и удаление фигур

Выделение и редактирование фигур

Ввод и редактирование данных


Список "горячих" клавиш. Работа со слоями

Справочное руководство

Список "горячих" клавиш

Работа со слоями

F3

Добавление в карту слоя из файла (кнопка [image] Добавить слой карты на панели инструментов Power Слои).

F2

Сохранение изменений в слое (кнопка [image] Сохранить данные текущего слоя на панели инструментов Power Слои).

Alt+F5

Перезагрузка данных слоя, т.е. возврат слоя в то состояние, которое было при последнем сохранении (меню Слой, команда Перезагрузить).

F5

Обновление визуализации слоя (меню Слой, команда Обновить визуализацию).

Ctrl+Alt+Z

Открытие окна настройки визуализации слоя (меню Слой, команда Визуализация слоя…).

Ctrl+Alt+L

Открытие окна свойств слоя (кнопка [image] Свойства слоя… на панели инструментов Power Слои).

Ctrl+Alt+Стрелка вверх или Ctrl+Alt+Стрелка вниз

Перемещение слоя на одну позицию вверх или вниз в легенде карты (меню Слой, команда Переместить слой|Вверх или Переместить слой|Вниз).

Ctrl+Alt+PageUp

Перемещение слоя вверх в другую папку (меню Слой, команда Переместить слой|Вверх в папку).

Также в этом разделе:

Вызов справки

Доступ к меню

Работа в диалоговых окнах

Работа с проектами

Работа с картами

Просмотр карты

Создание и удаление фигур

Выделение и редактирование фигур

Ввод и редактирование данных


Список "горячих" клавиш. Создание и удаление фигур

Справочное руководство

Список "горячих" клавиш

Создание и удаление фигур

D

Выбор режима создания новых фигур в активном слое.

Alt

При создании и редактировании фигуры с нажатой клавишей Alt указатель мыши притягивается к контурам и узлам фигур в этом же слое.

Alt+Shift

При создании и редактировании фигуры с нажатыми клавишами Alt+Shift указатель мыши притягивается к контурам и узлам фигур во всех слоях.

Ctrl

Если при создании линии удерживать клавишу Ctrl, то сегменты привязываются к углам, кратным 15°.

Ctrl+Del

Удаление выделенных фигур (меню Фигуры, команда Удалить).

Также в этом разделе:

Вызов справки

Доступ к меню

Работа в диалоговых окнах

Работа с проектами

Работа с картами

Просмотр карты

Работа со слоями

Выделение и редактирование фигур

Ввод и редактирование данных


Список "горячих" клавиш. Выделение и редактирование фигур

Справочное руководство

Список "горячих" клавиш

Выделение и редактирование фигур

E

Выбор режима выделения и редактирования фигур на активном слое.

Ctrl+Alt+Shift

Если в режиме редактирования фигур щёлкать мышью на карте, удерживая нажатыми указанные клавиши, то будут последовательно выделяться все фигуры, над которыми находится мышь, и соответствующие им слои будут становиться активными.

Shift

При выделении фигур с нажатой клавишей Shift можно выделить несколько фигур в одном слое, последовательно щёлкая на них мышью, или несколько диапазонов с помощью прямоугольной рамки.

Alt

Эта клавиша позволяет исключить из выделения некоторые фигуры.

Ctrl+A

Выделение всех фигур в активном слое.

Ctrl+D

Снятие выделения со всех фигур слоя.

Ctrl+N

Инвертирование выделения: со всех выделенных фигур снимается выделение, а все невыделенные фигуры становятся выделенными.

Ctrl+Insert или Ctrl+C

Копирование выделенной фигуры в буфер обмена (меню Фигуры, команда Копировать).

Shift+Delete или Ctrl+X

Удаление фигуры и помещение её в буфер обмена (меню Фигуры, команда Вырезать).

Shift+Insert или Ctrl+V

Вставка объекта из буфера обмена (меню Фигуры, команда Вставить).

Ctrl+B

Открытие инспектора объектов (кнопка [image] Инспектор объектов на панели инструментов Power правка или меню Вид, команда Инспектор объектов).

X

Переход в режим редактирования частей фигур (кнопка [image] Редактирование частей фигур на панели инструментов Power Режимы общие).

A

Переход в режим выборочного перемещения подписей визуализатора (кнопка [image] Редактирование подписей визуализатора на панели инструментов Power Режимы общие).

Также в этом разделе:

Вызов справки

Доступ к меню

Работа в диалоговых окнах

Работа с проектами

Работа с картами

Просмотр карты

Работа со слоями

Создание и удаление фигур

Ввод и редактирование данных


Список "горячих" клавиш. Ввод и редактирование данных

Справочное руководство

Список "горячих" клавиш

Ввод и редактирование данных

W

Выбор режима ввода данных по объектам. При щелчке на фигурах карты, относящихся к электрическим сетям, появляется окно для ввода данных (кнопка [image] Ввод данных на панели инструментов Power Режимы).

B

Выбор режима связывания фигур на карте с объектами в базе данных (кнопка [image] Связывание фигур с объектами в базе данных на панели инструментов Power Режимы).

U

Переход в режим удаления связей между фигурами на карте и объектами в базе данных (кнопка [image] Удаление связей между фигурами и объектами в базе данных на панели инструментов Power Режимы).

K

Выбор режима коммутации переключателей с записью в архив переключений (кнопка [image] Коммутация переключателей с записью в базу данных на панели инструментов Power Режимы).

Работа в окне ввода данных

Ctrl+I

Открытие окна с дополнительной информацией по текущему объекту (меню Объект, команда Дополнительная информация…).

Ctrl+E

Открытие окна планировщика работ по текущему объекту (меню Работы, команда План работ…).

Ctrl+D

Открытие окна для формирования списка сопутствующих документов по текущему объекту (меню Документы, команда Общий список…).

Ctrl+F

Подсвечивание фигуры, соответствующей текущему объекту, на карте (меню Карта, команда Подсветить).

Ctrl+W

Открытие окна для поиска объекта на картах проекта (меню Карта, команда Найти на карте…).

Ctrl+A

Переход в режим прокрутки и масштабирования карты из окна ввода данных (меню Карта, команда Прокрутка карты).

Ctrl+Q

Выбор режима связывания текущего объекта с фигурой на карте (меню Карта, команда Связать с изображением).

Также в этом разделе:

Вызов справки

Доступ к меню

Работа в диалоговых окнах

Работа с проектами

Работа с картами

Просмотр карты

Работа со слоями

Создание и удаление фигур

Выделение и редактирование фигур

Наверх [image] Назад Авторское право © 2009 ООО "ИндорСофт"